xubuntu 18.10 daily x86 - suspend, on wake i have no mouse-pointer (nvidia/nouveau)

Bug #1797032 reported by Chris Guiver on 2018-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

-- updated info
I re-booted daily x86 daily on same machine, was able to re-create, but it came good on its own (~15+ seconds after screen appeared)

It only occurs sometimes; more testing & it can occur with `sudo systemctl suspend` but if you wait cursor will re-appear usually so my conclusion it was [fixed] via whisker-menu may be invalid; maybe I'm impatient, or nvidia/nouveau on this card requires time for system to display mouse???

I do think something is wrong, but it's extremely minor, and inconsistent! (would be a pain I suspect to find)

-- original post

hp dx6120mt (desktop, pentium 4 dual-core, 3gb ram, nvidia 7600gt)
xubuntu 18.10 daily ISO x86

QA test - 2018-10-10 00:26 (current timestamp on QA tracker) of daily ISO

on suspend everything is normal, on wake I've lost my mouse-pointer.

I can see icons (drives, panel widgets) react & thus can detect where cursor is if over something, but no mouse-pointer is visible at all.

To get mouse back, I select menu (top left), then move mouse over menu and pointer re-appears.

Selecting anything else does not bring mouse back, also selecting menu but moving mouse up (not on menu but off screen) allows me to de-select menu without pointer being re-drawn. It returns only if I move mouse over the [main] menu when selected.

I've suspended 4 times this 'live-test', same loss-of-pointer each time, each time restored via selection of menu top left (third time I didn't have it return as I coughed causing mouse to never thus cross menu & select something right causing menu to close without return of mouse-pointer; got same reaction on 4th sleep/wake)..

xubuntu@xubuntu:~$ sudo lshw -C video
  *-display
       description: VGA compatible controller
       product: G73 [GeForce 7600 GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:24 memory:f1000000-f1ffffff memory:e0000000-efffffff memory:f2000000-f2ffffff ioport:1000(size=128) memory:c0000-dffff

---
I looked for duplicates - lots for intel graphics, not nvidia
Sorry if duplicate; also I know it's a wrong package assigned (unsure to assign to)

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: xubuntu-desktop 2.227
ProcVersionSignature: Ubuntu 4.18.0-8.9-generic 4.18.7
Uname: Linux 4.18.0-8-generic i686
ApportVersion: 2.20.10-0ubuntu11
Architecture: i386
CasperVersion: 1.396
CurrentDesktop: XFCE
Date: Wed Oct 10 04:30:18 2018
LiveMediaBuild: Xubuntu 18.10 "Cosmic Cuttlefish" - Beta i386 (20181010)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Guiver (guiverc) wrote :
summary: xubuntu 18.10 daily x86 - suspend, on wake i have no mouse-pointer
- (nvidia)
+ (nvidia/nouveau)
tags: added: iso-testing
Chris Guiver (guiverc) wrote :

I've re-ran this test on another system (different video card) & no issue.
re-tested (daily-iso) trying to cause bug on same machine -- yes re-created briefly, but within 30 seconds mouse-pointer appeared (before I worked out where mouse-pointer was)

copying (slightly edited) from QA-report http://iso.qa.ubuntu.com/qatracker/milestones/390/builds/182196/testcases/1303/results/

2018-10-10 02:39

hp dx6120mt (mini-tower, pentium 4 dual core, 3gb, nvidia 7600gt)
re-run of test but focusing only on suspending & mouse-pointer post-wake...
using `sudo systemctl suspend`, waiting briefly & then wake - mouse-pointer was okay
repeated twice more `sudo systemctl suspend`, wait & wake - mouse pointer okay.
put to sleep with menu (like prior test; mouse over terminal), waited then awoke - mouse pointer okay.
put to sleep with menu (again, mouse over nothing but wallpaper), waited then awoke - NO MOUSE POINTER
-- yet this time it came good on its on, before I worked out where pointer was & before I could get to menu...
yes I could re-create bug briefly; but then okay..

Chris Guiver (guiverc) on 2018-10-10
description: updated

This is a new issue in 18.10?

affects: xubuntu-meta (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Chris Guiver (guiverc) wrote :

Thanks Theo.

I can't comment on "new issue in 18.10" as I've only been using the machine for testing [18.10] (Xubu & Lubu), before that it was idle for a couple of years..

In this case I suggest that you test with 18.04.1 also.

Chris Guiver (guiverc) on 2018-10-11
description: updated
Chris Guiver (guiverc) wrote :

i booted lubuntu 18.10 (9-Oct-2018 iso); it has `xserver-xorg-video-nouveau` & started suspending (suspend, few secs, wake, look for pointer, repeat) but couldn't recreate. Lubuntu uses xscreensaver so I was using mouse to wake up screensaver - so `killall xscreensaver`then repeated testing. I get an error on wake ("Error occurred starting screensaver. Action 'activate' failed. Ensure you have xscreensaver installed and running") which I hit <enter> to bypass.

Now I note a 0-2 second delay of mouse-movement before I can see the mouse-pointer drawn on screen, but even the more common 1-2 seconds is minimal compared to xubuntu. Once mouse-pointer appears, it remains visible. This delay was consistent in being slow to appear; usually 1-2 secs but appeared inconsistent in time to appear (user/me inconsistent probably too), though I tried to delay touching mouse to ensure system was ~idle.

// just observation whilst `find` executed looking for 18.04 iso's

Chris Guiver (guiverc) wrote :

booted 18.04.1 x86 iso

numerous suspends; from CLI or menu, dx6120 wakes (I need to get past lock screen), but I've had mouse-pointer each time (at login screen, it'd dead centre of screen; on 18.10 I got the feeling it was trying to be restored to wherever it was pre-suspend!?).

I've left system on, will re-suspend & wake when I notice it ... but looks like I can't re-create in 18.04.1; and won't add another comment on this issue unless I get a difference response.

// `screenfetch -n` & `sudo lshw -C video`

guiverc@d960-ubu:~$ cat /de2900/xubuntu_32/screenfetch_18.04.1_dx6120.txt
 xubuntu@xubuntu
 OS: Ubuntu 18.04 bionic
 Kernel: i686 Linux 4.15.0-29-generic
 Uptime: 17m
 Packages: 1673
 Shell: bash 4.4.19
 Resolution: 1280x1024
 DE: XFCE
 WM: Xfwm4
 WM Theme: Greybird
 GTK Theme: Greybird [GTK2]
 Icon Theme: elementary-xfce-darker
 Font: Noto Sans 9
 CPU: Intel Pentium 4 2.80GHz @ 2x 2.791GHz [55.0°C]
 GPU: NV4B
 RAM: 273MiB / 3025MiB
guiverc@d960-ubu:~$ cat /de2900/xubuntu_32/lshw_dx6120_18.04_vid.txt
  *-display
       description: VGA compatible controller
       product: G73 [GeForce 7600 GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:24 memory:f1000000-f1ffffff memory:e0000000-efffffff memory:f2000000-f2ffffff ioport:1000(size=128) memory:c0000-dffff

Does it change anything if you disable light-locker in 18.04, or enable it in 18.10? Also, can you restore the mouse pointer by switching to another VT and back?

From all the information gathered so far this appears to be a Xfce or Xubuntu specific bug which may have been introduced recently.

Chris Guiver (guiverc) wrote :

I had my (installed) 18.10 system on dx6120 running (for testing lximage-qt elsewhere) so decided to try that (instead of 'live').

After numerous suspends via term & gui, I've had no lost mouse-pointers!

18.10 does not have `light-locker` installed; however it is using xscreensaver; which appeared every time I resumed/woke my system.

I `killall xscreensaver`, and second resume/wake my mouse-pointer was slow to appear (1-2 secs). Third test 1-2secs delay for pointer, Fourth test & it took 4-5 secs for mouse-pointer to appear (my screen had terminal full-screen, so url's on `apt-cache policy` lines had underlines flashing being all I could use to guess where cursor was until it appeared).. Fifth test again ~5+ secs

// It feels longer not knowing where cursor is, but it's hard scanning screen looking
// for cursor (unknown position) to appear, whilst also watch clock bottom right for timing
// I'm going to reduce my OP timings, but if you need accurate I'll have to find a stopwatch

The latest daily-iso is now written to thumb-drive...

description: updated
Chris Guiver (guiverc) wrote :

NOTE: my last comment relates to LUBUNTU - which is not XUBUNTU..
I've been testing the 'live' image & only just worked out why there were so many app changes!
Sorry my mistake !

Chris Guiver (guiverc) wrote :

with Xubuntu 18.10 (yes X) booted (installed image on dx6120); dist-upgrade, 3x suspends using terminal & 3x suspends via menu with mouse-pointer, then noticed I'd not logged out since upgrade. I logged out, back in & repeat 3x suspends using term & 3x menu suspends and mouse-pointer was there each time.

booted LIVE Xubuntu 18.10 (yes X; latest daily image), first suspend & lost my mouse-pointer... I didn't have seconds visible on clock so guess would be 20-30 secs before cursor returned on it's own (& before I found the menu to select it, but I may have swiped across it many times..)

I'll have to continue testing later (pain bad, why my concentration is so poor; however me not seeing this result on installed system is very good I suspect...

Chris Guiver (guiverc) wrote :

Xubuntu 18.10 daily image, last resume from suspend took 59 seconds before mouse-pointer returned. In this case I was mostly just watching the clock (not waving it around; I started waving it around furiously at 56 seconds...)

Next resume was 20 secs - it appears to wake faster if you're more active with the mouse instead of slow careful movements.. (very subjective). I wonder if there is a threshold of movement that causes it to re-draw that i'm not triggering. I do have mildly restricted hand movements with a mouse (to avoid pain...)

--
on 18.10 I `sudo apt install light-locker-settings`, then run it to enable light-locker.

2x suspends & wakes - both times mouse-pointer appears within ~1-2 secs.
disable light-locker in `light-locker-settings` & suspend; mouse-pointer within 2-4 secs
// I can't continue testing at present...

The conclusion seems to be that having light-locker or xscreensaver enabled is a way to prevent this glitch from occurring.

I think it would be best to contact the 'nouveau' driver devs and ask them how to further debug this issue.

https://nouveau.freedesktop.org/wiki/Bugs/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers