Video resolution cannot be changed

Bug #1443989 reported by Wolf Rogner on 2015-04-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
High
Unassigned

Bug Description

Trying to change the video resolution (I tried on a Macbook Pro Retina 15") to something like 1900:1200 or 1920:1080 blackens the screen and does not revert to the previous settings.

Worse, the graphics card heats up rapidly and brings the area close to the screen to a scorging hot temperature.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
ProcVersionSignature: Ubuntu 3.19.0-13.13-generic 3.19.3
Uname: Linux 3.19.0-13-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 2.17-0ubuntu2
Architecture: amd64
CasperVersion: 1.359
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Apr 14 14:39:36 2015
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
DkmsStatus: bcmwl, 6.30.223.248+bdcom, 3.19.0-13-generic, x86_64: installed
ExtraDebuggingInterest: No
GraphicsCard:
 NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition] [10de:0fd5] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Apple Inc. Device [106b:00f2]
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150414)
MachineType: Apple Inc. MacBookPro10,1
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash --- keyboard-configuration/layoutcode=de
SourcePackage: xserver-xorg-video-nouveau
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/21/2012
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP101.88Z.00EE.B03.1212211437
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-C3EC7CD22292981F
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro10,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-C3EC7CD22292981F
dmi.modalias: dmi:bvnAppleInc.:bvrMBP101.88Z.00EE.B03.1212211437:bd12/21/2012:svnAppleInc.:pnMacBookPro10,1:pvr1.0:rvnAppleInc.:rnMac-C3EC7CD22292981F:rvrMacBookPro10,1:cvnAppleInc.:ct10:cvrMac-C3EC7CD22292981F:
dmi.product.name: MacBookPro10,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.12.1+15.04.20150410.1-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.60-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.5.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.5.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.1-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2build1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
xserver.bootTime: Tue Apr 14 14:20:56 2015
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.17.1-0ubuntu3
xserver.video_driver: nouveau

Wolf Rogner (war-rsb) wrote :
Wolf Rogner (war-rsb) wrote :

No come to think of it (and testing).

The graphics card gets very hot even when left in its initial stage (2880x1800).

With the nvidia driver under 14.10 the temperature does not get anywhere as close to this temperature.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Gaele Strootman (gaele) wrote :

Same here, using a Macbook Pro 11,3 with NVIDIA GeForce GT 750M. Changing the resolution and clicking Apply blackens the screen and freezes up the machine. A hard reboot is necessary.

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers