No live DE in Vivid using nouveau w/GeForce 7025/nForce 630a

Bug #1412602 reported by Erick Brunzell on 2015-01-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned
Vivid
Medium
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

I've been testing the Ubuntu GNOME Vivid daily images in anticipation of Alpha 2 and I noticed that with this specific hardware I get no graphics at all other than a blank screen (see attached photo):

AMD Sempron Processor LE-1250 @ 2.2 GHz
nVidia C61 [GeForce 7025 / nForce 630a] (rev a2)
nVidia MCP61 High Definition Audio (rev a2)
nVidia MCP61 Ethernet (rev a2)
2GB DDR2 RAM

In fact I never even get as far as the screen offering to Try or Install, but I can enter the Advanced Boot Options screen and select either Try or Install from there, but with both options I still get the same blank screen.

Further testing reveals the same results with Ubuntu and Ubuntu GNOME but I found that both the Xubuntu and Lubuntu images will boot properly on this box so I installed Lubuntu and then installed the ubuntu-desktop, ubuntu-gnome-desktop, and gnome-session-flashback meta-packages just to try some things.

After doing so I found that the Unity, GNOME Shell, Gnome Classic, and Flashback w/Compiz sessions produce broken graphics just as the Ubuntu GNOME and Ubuntu live images do. So basically Compiz and Mutter both fail to display any usable UI. OTOH both the Lubuntu and Flashback w/Metacity sessions work just fine.

I next opened the Additional drivers UI and chose nvidia-304.125 (current) and all DE's perform quite well with the proprietary drivers so I deduced that nouveau might be the culprit.

The last known working Ubuntu and Ubuntu GNOME live images are 14.04.1. I hadn't tried Utopic on this box yet but it's also a fail. I'll try the proposed 14.04.2 images ASAP (probably after Vivid Alpha 2 is released).

But I see no point in trying to fix this for Utopic (or even 14.04.2 if it's effected) because of the 9 month life-cycle for Utopic and the continued availability of the 14.04.1 images. In fact I'd be cool with this not being fixed until 16.04 as long as it's documented so people know what versions will and will not work.

I'm probably forgetting something but that's all I can think of ATM. Sorry in advance if I did this totally wrong.

### Additional workaround and debug info ###

The focus of this bug report is limited to screen corruption and X-freezes that either prevent the installation of Ubuntu (or other flavors) and/or booting the installed system even long enough to enable the third party nvidia driver. There are almost certainly other instances of screen corruption and hard (or soft) lockups that may also be related to the nouveau driver but those are beyond the scope of this specific bug report.

To workaround this bug, or to see if you're affected by it you can boot using this boot parameter:

nouveau.config=NvMSI=0

You'll find general instructions for using custom boot parameters at these links:

https://help.ubuntu.com/community/BootOptions

https://wiki.ubuntu.com/Kernel/KernelBootParameters

In addition to what's said at the latter link about temporarily adding a kernel boot parameter to an installed system; after using the arrow keys to navigate to the line beginning with "linux /boot" you'll notice that line ends with "quiet splash $vt_handoff". The boot parameter belongs between the "quiet splash" and "$vt_handoff" like this:

quiet splash nouveau.config=NvMSI=0 $vt_handoff

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
ProcVersionSignature: Ubuntu 3.18.0-9.10-generic 3.18.2
Uname: Linux 3.18.0-9-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.15.1-0ubuntu2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: GNOME-Flashback:Unity
Date: Mon Jan 19 17:41:32 2015
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Biostar Microtech Int'l Corp Device [1565:1405]
InstallationDate: Installed on 2015-01-19 (0 days ago)
InstallationMedia: Lubuntu 15.04 "Vivid Vervet" - Alpha i386 (20150118)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 046d:c52e Logitech, Inc.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: BIOSTAR Group N68SB-M2S
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.18.0-9-generic root=UUID=acf0fd65-0d6d-4da6-9532-2adc558bc0a7 ro quiet splash init=/lib/systemd/systemd
SourcePackage: xserver-xorg-video-nouveau
UdevLog:

UpgradeStatus: No upgrade log present (probably fresh install)
XorgLogOld:

dmi.bios.date: 06/24/2010
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: N68SB-M2S
dmi.board.vendor: BIOSTAR Group
dmi.chassis.type: 3
dmi.chassis.vendor: BIOSTAR Group
dmi.chassis.version: N68SB-M2S
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd06/24/2010:svnBIOSTARGroup:pnN68SB-M2S:pvr:rvnBIOSTARGroup:rnN68SB-M2S:rvr:cvnBIOSTARGroup:ct3:cvrN68SB-M2S:
dmi.product.name: N68SB-M2S
dmi.sys.vendor: BIOSTAR Group
version.compiz: compiz 1:0.9.12.0+15.04.20141219-0ubuntu1
version.libdrm2: libdrm2 2.4.58-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.16.2.901-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Mon Jan 19 17:37:11 2015
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Logitech USB Receiver KEYBOARD, id 8
 input Logitech USB Receiver KEYBOARD, id 9
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.16.2.901-1ubuntu3
xserver.video_driver: nouveau

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Here's what Ubuntu GNOME Vivid 20150119 i386 boots to when it should display Try or Install. I was able to enter the advanced boot menu and run check disc for defects so I know it's not just a bad burn.

tags: added: ubuntu-gnome
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1412602

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

Oh, I forgot to mention that I have tried the nomodeset boot parameter to no avail.

Tim (darkxst) wrote :

Looks like this might be https://bugs.freedesktop.org/show_bug.cgi?id=87361

can you try disable MSI As mentioned in that bug report (kernel paramater: nouveau.config=NvMSI=0).

Erick Brunzell (lbsolost) wrote :

I tried the 3.19.0-031900rc5-generic mainline kernel on that installation and both mutter and compiz based DE's work OK with nouveau, but the nvidia module fails to build properly against that kernel. I haven't yet researched what kernel we intend to ship with Vivid.

I started some testing with Ubuntu GNOME 20150125 but it's been bumped to 20150126 now so I'll wait until I've repeated those tests with the latest build before commenting further.

Erick Brunzell (lbsolost) wrote :

The latest two daily builds are failing for what must be a totally unrelated issue because they're also failing with different hardware so I went back to testing the Ubuntu GNOME Alpha 2 live image and it does boot successfully with the boot parameter nouveau.config=NvMSI=0. So do we need to edit the bug tags? I'm thinking we may want to add linux but I'm not sure.

Tim (darkxst) on 2015-01-27
tags: added: kernel-fixed-upstream
Erick Brunzell (lbsolost) wrote :

Trusty 3.13.0-44 was OK but 3.13.0-45 is affected.

tags: added: trusty
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Changed in linux (Ubuntu Vivid):
importance: Undecided → Medium

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
Changed in linux (Ubuntu Utopic):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Commit 4761703 is in mainline as of v3.19-rc4. It was also sent to stable.

Not applicable in upstream 3.13.
It is in upstream 3.16 as of v3.16.7-ckt5.
It is in upstream 3.18 as of v3.18.4.

Can folks affected by this bug test the following kernels to see if this bug is fixed:

 v3.16.7-ckt5: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16.7-ckt5-utopic/
v3.18.5: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.5-vivid/

tags: added: kernel-da-key
Erick Brunzell (lbsolost) wrote :

@ Joseph Salisbury,

I'll be glad to do that but it'll be a couple of days due to prior commitments.

Erick Brunzell (lbsolost) wrote :

@ Joseph Salisbury,

There seemed to be some improvement in Ubuntu GNOME Utopic with the amd64 version of 3.16.7-031607-generic, at least I was able to boot that kernel w/o adding the nouveau.config=NvMSI=0 boot parameter, but then after spending a couple of minutes fiddling around when I attempted to open the System Settings UI the screen tore and X froze. So nouveau is still a failure with that specific GPU.

I doubt it's arch specific so I'll move on to testing the Vivid mainline kernel next.

Erick Brunzell (lbsolost) wrote :

Perhaps oddly (perhaps not oddly at all) I decided to reboot and select GNOME Classic rather than booting into the standard GNOME Shell and it seems to work fine - no screen tearing or X-freezes under fairly heavy use. So maybe nouveau itself is simply not capable of running GNOME Shell.

I find that a bit odd as I'd assumed both use mutter but Tim could probably provide some insight in that regard. I should probably try that same kernel with Ubuntu in a Unity session to see what happens.

ATM I'm inclined to think that kernel fixes this specific issue, but that other underlying issues exist in nouveau itself which may actually be an Xorg issue beyond the scope of this bug ................ or is it???????

Tim (darkxst) wrote :

Lance, gnome-classic is gnome-shell with a bunch of extensions, so for classic to work and Shell not does seem odd. Was the issue in gnome-shell repeatable or a one of crash?

Erick Brunzell (lbsolost) wrote :

I have been able to reproduce that a few times in a gnome-shell session but it's not specific to any one task. It "crashed/froze" twice just looking for logs and once again while launching Firefox. OTOH I can use the classic session w/o a problem - in fact I'm streaming the nightly news right now.

I know that X actually freezes when the screen tears because I'd set Ctrl+Alt+Backspace to kill X and tested it in both sessions. When the screen tears as shown in the attached pic the keyboard is just totally unresponsive causing me to do a hard reset.

There are no .xsession-errors in Home and I don't see anything unusual in /var/log/Xorg.0.log but there is also an /var/log/Xorg.0.log.old that I can't read.

FYI sometime tomorrow I'll add some storage to that box so I can retain 4 or 5 installs at the same time. That way I can dig for logs and/or do some retesting without having to reinstall and update each time.

Tim (darkxst) wrote :

That looks like video corruption, and it is possible that gnome-classic has some of the animations disabled compared to gnome-shell, but I can't think of any other difference.

.xsession-errors is obsolete, logs will by default be in ~/.cache/upstart/gnome-session-GNOME.log under upstart boot or `journalctl -b /usr/bin/gnome-session` under systemd init.

But either way it seems likely that is a bug in Nouveau, so those logs might not be too useful either.

Erick Brunzell (lbsolost) wrote :

Sorry to take so long getting back to this. The affected PC is usually used as my media center but I've now been able to move it into my testing suite so hopefully once 14.04.2 milestone testing is out of the way I'll be able to respond more quickly and efficiently.

Regarding the screen corruption in Utopic I've now found that it does eventually occur even running GNOME Classic but just much less frequently than in a GNOME Shell session. This includes both the stock Utopic kernel as well as the 3.16.7-031607-generic kernel Joseph Salisbury requested I try.

So, moving on to Vivid for the moment - last night I installed Ubuntu GNOME Vivid Alpha 2 and this AM I booted it using the nouveau.config=NvMSI=0 boot parameter, then applied all available updates, and it seems to be running GNOME Shell just fine with the latest Vivid kernel using the nouveau driver:

lance@lance-AMD-desktop:~$ uname -r
3.18.0-13-generic

lance@lance-AMD-desktop:~$ sudo lshw -c video
[sudo] password for lance:
  *-display
       description: VGA compatible controller
       product: C61 [GeForce 7025 / nForce 630a]
       vendor: NVIDIA Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:21 memory:fb000000-fbffffff memory:e0000000-efffffff memory:fc000000-fcffffff memory:80000000-8001ffff

So some recent kernel update in Vivid appears to have fixed this issue. Is there still any point in trying the 3.18.5-031805-generic mainline kernel?

For the next 5 or 6 days I'll be shifting my focus almost totally onto 14.04.2, in fact my next two tests on this hardware will be 14.04.1 with the latest Trusty kernel and then 14.04.2 with the Utopic HWE.

Erick Brunzell (lbsolost) wrote :

I was encountering some issues installing 14.04.1 which I'll get into later, but for now I moved on to testing 14.04.2, this one installed w/Ubuntu-GNOME 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150203), and while 3.16.0-30-generic was affected I pulled 3.16.0-31-generic from trusty-proposed and it appeared to be OK for a while, at least I was not getting the same screen corruption.

In fact I began a forum post from that Trusty install but before I was done the screen became unresponsive, but not entirely frozen because I could move the mouse pointer, then after a minute or two the screen displayed the error in the attached pic.

Erick Brunzell (lbsolost) wrote :

It turns out that both 14.04 and 14.04.1 are affected by this bug. I had to look in the installer log to see what version I'd begun with (and have been running on that box as my stable OS) = Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140129). So I was undoubtedly able to install Trusty at that point but hadn't noticed a problem because I was already using the third-party nvidia driver after that date.

Erick Brunzell (lbsolost) wrote :

@ Tim Lunn,

This is totally unrelated, but to be certain that Vivid is working properly w/3.18.0-13-generic I've been using it to post all of these messages and on the last boot apport presented me with a gdm error so I accepted the automated reporting which is bug #1421991. Poorly written for sure, but I really had no idea what was going on.

Tim (darkxst) wrote :

Lance, this is getting a little confusing to follow, can you file separate bugs for the corruption and lockups above.
The original nouveau.config=NvMSI=0 bug should be fixed in vivid now? is it fixed in trusty 14.04.2?

Erick Brunzell (lbsolost) wrote :

Hi Tim,

As far as I can tell ATM the only difference in most of these crashes/freezes/screen-corruptions is the frequency with which they occur and the screen color depending on what point during boot and/or operation the "freeze" occurs.

Like this is the pic I included with original bug report:

https://launchpadlibrarian.net/195348138/IMG_4796.JPG

And this is a pic from Ubuntu GNOME Utopic with the amd64 version of 3.16.7-031607-generic (mainline kernel):

https://launchpadlibrarian.net/196872607/IMG_4817.JPG

The frequency of crashes/freezes (or the point at which they occur) is sometimes random with the exact same images. Sometimes it may prevent me from even getting to the live desktop or booting to the desktop of an installed OS. Other times it may not happen until I'm performing some random task on the desktop. Or it may occur at any random point during installation.

It seems to affect Unity, GNOME Shell, and Flashback w/Compiz somewhat more frequently that GNOME Classic and I've not been able to reproduce this bug with the same versions of Lubuntu so I assume it's a "load" or "demand" related issue???

The one exception is 14.04.2 with 3.16.0-31-generic from trusty-proposed which may (or may not) fix this issue but results in an unrelated crash (see comment #19) so I'll check the changelogs and see if there is a tracking bug # to refer to. I'll then file a new bug report ASAP.

But yes, this does appear to be fixed in Vivid w/3.18.0-13-generic. I will be glad to try the 3.18.5-031805-generic mainline kernel in Vivid also if desired.

I should also probably test Utopic again and see if I can find the equivalent of trusty-proposed 3.16.0-31-generic since it really is part of the 14.04.2 LTS HWE for Trusty.

Erick Brunzell (lbsolost) wrote :

OK I did some more testing last night and this AM, so here's a quick recap to reduce any confusion (both for others and myself):

Vivid: This is fixed in 3.18.0-13 generic. I verified that this AM by testing the Ubuntu GNOME Vivid 20150215 amd64 iso.

Utopic: This is fixed in 3.16.0-31 generic which is in utopic-proposed. No additional problems were encountered.

Trusty with the Utopic HWE: This is fixed in 3.16.0-31 generic which is in trusty-proposed. The bug I mentioned in comment #19 was observed and I think it may be bug #1291574. I'll follow up on that separate issue appropriately ASAP.

Trusty with the OEM 3.13 series kernel: This remains under investigation. I know that both the 14.04 and 14.04.1 images are affected as well as 3.13.0-45-generic. I'll also follow up on this ASAP.

Erick Brunzell (lbsolost) wrote :

Regarding Trusty with the OEM 3.13 series kernel: This is NOT fixed in 3.13.0-46-generic from trusty-proposed. That can be verified because using the nouveau.config=NvMSI=0 boot parameter gets me past the screen corruption/X freeze. So evidently the upstream fix has not yet trickled down to the 3.13 series kernel.

description: updated
description: updated
Erick Brunzell (lbsolost) wrote :

No surprise but since the 14.04.2 20150217 images still have 3.16.0-30 generic they are affected.

Since it's a hardware specific corner issue I don't know if it's worth mentioning in the release notes or not.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Utopic):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Vivid):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu Trusty):
status: New → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu Utopic):
status: New → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu Vivid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.