nouveau DRM GPU lockup, PFIFO unhandled status 0x00800000

Bug #1291574 reported by Chad Miller on 2014-03-12
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Critical
xserver-xorg-video-nouveau (Ubuntu)
High
Unassigned

Bug Description

Usually seen on large screen transitions, often in browser windows. Display freezes, and processes disappear. klog starts with

nouveau ![ PFIFO][0000:01:00.0] unhandled status 0x00800000
nouveau E[ DRM] GPU lockup - switching to software fbcon

and thereafter fills with

nouveau E[Xorg[1868]] failed to idle channel 0xcccc0001 [Xorg[1868]]
nouveau E[Xorg[1868]] failed to idle channel 0xcccc0001 [Xorg[1868]]
nouveau E[ PFIFO][0000:01:00.0] playlist 0 update timeout
nouveau E[Xorg[1868]] failed to idle channel 0xcccc0000 [Xorg[1868]]
nouveau E[Xorg[1868]] failed to idle channel 0xcccc0000 [Xorg[1868]]
nouveau E[ PFIFO][0000:01:00.0] channel 2 [Xorg[1868]] kick timeout
nouveau E[ PFIFO][0000:01:00.0] channel 2 [Xorg[1868]] kick timeout
nouveau E[ PFIFO][0000:01:00.0] playlist 0 update timeout

repeated about every 150 seconds.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic i686
.tmp.unity.support.test.1:

ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,snap,imgpng,move,animation,mousepoll,compiztoolbox,resize,grid,unitymtgrabhandles,workarounds,gnomecompat,vpswitch,place,expo,wall,fade,ezoom,session,scale,unityshell]
CompositorRunning: None
Date: Wed Mar 12 15:10:37 2014
DistUpgraded: 2010-09-09 17:07:06,366 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 NVIDIA Corporation GK107 [GeForce GTX 650] [10de:0fc6] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:2650]
LightdmGreeterLog:
 (lightdm-gtk-greeter:5159): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed

 (lightdm-gtk-greeter:5159): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed

 (lightdm-gtk-greeter:5159): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed
MachineType: MSI MS-7673
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-16-generic root=UUID=44b47c66-6a6d-465d-a0b6-e03e703616cb ro nomdmonddf nomdmonisw nomdmonddf nomdmonisw
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: Upgraded to trusty on 2010-09-09 (1279 days ago)
dmi.bios.date: 03/31/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.10
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P67A-C43 (MS-7673)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.10:bd03/31/2011:svnMSI:pnMS-7673:pvr1.0:rvnMSI:rnP67A-C43(MS-7673):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7673
dmi.product.version: 1.0
dmi.sys.vendor: MSI
version.compiz: compiz 1:0.9.11+14.04.20140305-0ubuntu1
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc3-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0~rc3-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Wed Mar 12 15:10:05 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input daskeyboard KEYBOARD, id 8
 input daskeyboard KEYBOARD, id 9
 input Logitech USB-PS/2 Optical Mouse MOUSE, id 10
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.0-1ubuntu6
xserver.video_driver: nouveau

Chad Miller (cmiller) wrote :
Anders (eddiedog988) on 2014-03-13
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed

It affects an essential hardware component (disk controller, built-in networking, video card, keyboard, mouse).

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → High
RickB (rick-777) wrote :

I can't find a workaround. The PC locks up. A reboot is necessary.

RickB (rick-777) wrote :

To be more specific, the display appears totally frozen and the mouse and keyboard are unusable. I have to press the hard-reset button.

ejoftheweb (8dward) wrote :

Same or nearly the same bug affects me, with Xubuntu 14.04. Graphics card is GE7300. Thought it might be associated with light-locker switching VT but removing light-locker makes no difference. Only seems to happen when computer is left unattended (thus triggering a screensave situation),

Alexander Voronin (av1024) wrote :

Affects me since ubuntu 12.04 with Intel+nVidia dual card combination where is impossible to use proprietary driver.

2RickB: Try ctrl-alt-F1 to switch to console for login and reboot. This works for me. Note: do not try restart X via ctrl-alt-backspace before

RickB (rick-777) wrote :

Depending on how it crashes, ctrl-alt-F1 may or may not work. Obviously, when it works, a clean reboot is possible. When it doesn't work, the machine is entirely hung and only a hard power reset will recover it.

Maybe is needed to try a temporal or a permanent disabling (deactivation) of nouveau driver, by blacklisting the driver. Temporal is done by using the kernel parameter nouveau.blacklist=yes. Permanent is done by adding the line 'blacklist nouveau' in the end of file /etc/modprobe.d/blacklist.conf.

For more information please read these:
http://askubuntu.com/questions/110341/how-to-blacklist-kernel-modules
http://forums.fedoraforum.org/showthread.php?t=300720

Erick Brunzell (lbsolost) wrote :

I believe I encountered the same issue while working on bug #1412602 which is unrelated to this bug.

In the process of testing the nouveau driver with an nVidia C61 [GeForce 7025 / nForce 630a] chipset on Ubuntu GNOME Trusty with the Utopic HWE and 3.16.0-31-generic from trusty-proposed I experienced what I'd call a soft-lockup (I could still move the mouse pointer but all else was unresponsive) and after a minute or two the screen went basically blank with this message sprawled across the screen:

[ 1206.026900] nouveau E[ DRM] GPU lockup - switching to software fbcon

[ 1305.160013] nouveau E[Xorg[955]] failed to idle channel 0xeeee0000 [Xorg[955]]

[ 1320.160018] nouveau E[Xorg[955]] failed to idle channel 0xeeee0000 [Xorg[955]]

[ 1328.076012] BUG: soft lockup - GPU#0 stuck for 21sf [gnome-shell:1740]

After reboot I found a crash report in /var/log/crash but it was unreportable, the details say:

This problem report is damaged and cannot be processed.

EOF Error('Compressed file ended before the end-of-stream marker was reached',)

I'm attaching a picture of the screen during freeze.

Lex Ross (lross) wrote :

Same problem with Nvidia C67 GeForce 7000M / nForce 610M graphics card on Asus F5N laptop.

Created attachment 114766
Nouveau with Gnome 3.16.0 crash log

Using nouveau drivers, when plays with the new legacy tray in Gnome 3.16.0 (open it, close, and reopen again) the entire system hangs and must to restart Gnome Shell & GDM.

Card: GeForce GTS 250

Versions:
Kernel 3.19.3-1-ARCH
xf86-video-nouveau 1.0.11-3
mesa 10.5.2-1

I attach journal log.

Note: I open related bug in GNOME https://bugzilla.gnome.org/show_bug.cgi?id=747115 They advised me that open bug here too.

Created attachment 114831
Attaching journalctl output after gnome 3.16 freeze. Freeze happened @ ~ 23:06

The gnome team thinks I may be hitting the same issue

NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)

Versions:
Kernel 3.19.3-1-ARCH
xf86-video-nouveau 1.0.11-3
mesa 10.5.2-1

Attached my journal log

Somehow gnome-shell is able to convince nouveau to do something very dumb. I didn't even think this was possible... libdrm is supposed to de-dup these, no?

nouveau E[gnome-shell[1773]] multiple instances of buffer 215 on validation list
nouveau E[gnome-shell[1773]] validate_init
nouveau E[gnome-shell[1773]] validate: -22

I'm also getting the same errors since april 1st:

Apr 01 11:07:08 arjen-imac.office.react.nl kernel: nouveau E[gnome-shell[4997]] multiple instances of buffer 228 on validation list
Apr 01 11:36:47 arjen-imac.office.react.nl kernel: nouveau E[gnome-shell[905]] multiple instances of buffer 255 on validation list
Apr 01 13:51:37 arjen-imac.office.react.nl kernel: nouveau E[gnome-shell[2939]] multiple instances of buffer 146 on validation list
Apr 02 12:20:26 arjen-imac.office.react.nl kernel: nouveau E[gnome-shell[2939]] multiple instances of buffer 415 on validation list
Apr 02 17:00:46 arjen-imac.office.react.nl kernel: nouveau E[gnome-shell[895]] multiple instances of buffer 327 on validation list

Just before the 1st crash I upgrade mesa:

[2015-04-01 09:55] [ALPM] upgraded mesa (10.5.1-2 -> 10.5.2-1)

Versions:
Kernel 3.19.2-1-ARCH
xf86-video-nouveau 1.0.11-3
mesa 10.5.2-1
Gnome 3.14.2

So I think this is mesa related, and not related to Gnome 3.16.

I'm guessing all you guys have libdrm-2.4.60 -- can you try downgrading to libdrm-2.4.59?

I have the same issue and can confirm that downgrading
from libdrm-2.4.60 to libdrm-2.4.59 seems to stop the issue from
happening as there are no more hangs.

Thanks,
Rennie

git bisect puts the first bad commit @
commit 5ea6f1c32628887c9df0c53bc8c199eb12633fec
Author: Maarten Lankhorst <email address hidden>
Date: Thu Feb 26 11:54:03 2015 +0100

    nouveau: make nouveau importing global buffers completely thread-safe, with tests
...

ArchLinux bug report (https://bugs.archlinux.org/task/44680) suggests an additional reproduction method "when I move my mouse over VLC's seekbar and it shows a small tooltip to show the time gnome-shell freezes".

My favourite is "run mplayer with vdpau, then move the window". I arrived at that one by accident, but that repros it 100%. No compositors or anything like that.

*** Bug 90201 has been marked as a duplicate of this bug. ***

b (ben-ekran) wrote :

This seems to be happening to me also on 14.04, GeForce 6600 AGP, Nouveau. I'm now going to try and add "nomodeset" to my kernel options and see if that helps (as suggested here: http://askubuntu.com/questions/205021/how-to-solve-gpu-lockup-switching-to-software-fbcon-on-new-install-of-12-10)

b (ben-ekran) wrote :

Scratch that; turning off modesetting seems to disable Nouveau.

I just push a commit[1] to libdrm which should fix this issue.

[1] http://cgit.freedesktop.org/mesa/drm/commit/?id=812e8fe6ce46d733c30207ee26c788c61f546294

(In reply to Ben Skeggs from comment #10)
> I just push a commit[1] to libdrm which should fix this issue.
>
> [1]
> http://cgit.freedesktop.org/mesa/drm/commit/
> ?id=812e8fe6ce46d733c30207ee26c788c61f546294

I can confirm that this fixes my repro case (move mplayer vdpau window around). I knew it was something relating to named bo's, so good to see that the fix also involved those.

Simon John (sej7278) wrote :

affects me too on debian scratch/sid.

all the "fixes" from google appear to be disable nouveau (nomodeset) and install the proprietary drivers, which isn't helpful.

i can still ssh into the box, but anything that was running a gui has crashed (defunct), here's some output i got in dmesg:

[116651.047961] nouveau E[gnome-shell[1436]] multiple instances of buffer 256 on validation list
[116651.047965] nouveau E[gnome-shell[1436]] validate_init
[116651.047966] nouveau E[gnome-shell[1436]] validate: -22
[116691.791976] nouveau E[ PFIFO][0000:01:00.0] write fault at 0x000a420000 [PAGE_NOT_PRESENT] from PGRAPH/GPC0/PROP on channel 0x007f9ee000 [gnome-shell[1436]]
[116691.791980] nouveau E[ PFIFO][0000:01:00.0] PGRAPH engine fault on channel 5, recovering...
[116758.244902] nouveau E[ DRM] GPU lockup - switching to software fbcon
[116773.237541] nouveau E[Xorg[1023]] failed to idle channel 0xcccc0000 [Xorg[1023]]
[116788.222848] nouveau E[Xorg[1023]] failed to idle channel 0xcccc0000 [Xorg[1023]]
[116788.222899] [sched_delayed] sched: RT throttling activated
[116788.223033] nouveau E[ PFIFO][0000:01:00.0] read fault at 0x000001b000 [PAGE_NOT_PRESENT] from PFIFO/BAR_READ on channel 0x007fb5e000 [unknown]
[116803.328066] nouveau E[gnome-shell[1436]] failed to idle channel 0xcccc0000 [gnome-shell[1436]]
[116818.313425] nouveau E[gnome-shell[1436]] failed to idle channel 0xcccc0000 [gnome-shell[1436]]

things that seem to trigger it are screensaver and google chrome, but that could be coinsidence.

Created attachment 115697
jounralctl events when gnome-shell freezes

Gnome version is 3.14.4-2-fc21. I had reported this event to the gnome team #749128; they referred me here. I had initiated a download in firefox when this freeze occurred but i have experienced it in other applications

In closer review of the thread above I checked on downgrading libdrm from 2.4.60. In my installation yum tells me I need to also downgrade libdrm-devel and apparently the downgrade version is 2.4.58 rather than 2.4.59. Is that what you recommend?

Download full text (6.7 KiB)

I never get it with chromium, but I do with mplayer when the window size is
larger than a quarter of my screen. Not reliable reproduction. Seems to be
a race that happens once every 30 minutes or so at that size.

On Mon, May 11, 2015 at 6:39 AM, Simon John <email address hidden>
wrote:

> affects me too on debian scratch/sid.
>
> all the "fixes" from google appear to be disable nouveau (nomodeset) and
> install the proprietary drivers, which isn't helpful.
>
> i can still ssh into the box, but anything that was running a gui has
> crashed (defunct), here's some output i got in dmesg:
>
> [116651.047961] nouveau E[gnome-shell[1436]] multiple instances of buffer
> 256 on validation list
> [116651.047965] nouveau E[gnome-shell[1436]] validate_init
> [116651.047966] nouveau E[gnome-shell[1436]] validate: -22
> [116691.791976] nouveau E[ PFIFO][0000:01:00.0] write fault at
> 0x000a420000 [PAGE_NOT_PRESENT] from PGRAPH/GPC0/PROP on channel
> 0x007f9ee000 [gnome-shell[1436]]
> [116691.791980] nouveau E[ PFIFO][0000:01:00.0] PGRAPH engine fault on
> channel 5, recovering...
> [116758.244902] nouveau E[ DRM] GPU lockup - switching to software
> fbcon
> [116773.237541] nouveau E[Xorg[1023]] failed to idle channel 0xcccc0000
> [Xorg[1023]]
> [116788.222848] nouveau E[Xorg[1023]] failed to idle channel 0xcccc0000
> [Xorg[1023]]
> [116788.222899] [sched_delayed] sched: RT throttling activated
> [116788.223033] nouveau E[ PFIFO][0000:01:00.0] read fault at
> 0x000001b000 [PAGE_NOT_PRESENT] from PFIFO/BAR_READ on channel 0x007fb5e000
> [unknown]
> [116803.328066] nouveau E[gnome-shell[1436]] failed to idle channel
> 0xcccc0000 [gnome-shell[1436]]
> [116818.313425] nouveau E[gnome-shell[1436]] failed to idle channel
> 0xcccc0000 [gnome-shell[1436]]
>
> things that seem to trigger it are screensaver and google chrome, but
> that could be coinsidence.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1291574
>
> Title:
> nouveau DRM GPU lockup, PFIFO unhandled status 0x00800000
>
> Status in xserver-xorg-video-nouveau package in Ubuntu:
> Confirmed
>
> Bug description:
> Usually seen on large screen transitions, often in browser windows.
> Display freezes, and processes disappear. klog starts with
>
> nouveau ![ PFIFO][0000:01:00.0] unhandled status 0x00800000
> nouveau E[ DRM] GPU lockup - switching to software fbcon
>
> and thereafter fills with
>
> nouveau E[Xorg[1868]] failed to idle channel 0xcccc0001 [Xorg[1868]]
> nouveau E[Xorg[1868]] failed to idle channel 0xcccc0001 [Xorg[1868]]
> nouveau E[ PFIFO][0000:01:00.0] playlist 0 update timeout
> nouveau E[Xorg[1868]] failed to idle channel 0xcccc0000 [Xorg[1868]]
> nouveau E[Xorg[1868]] failed to idle channel 0xcccc0000 [Xorg[1868]]
> nouveau E[ PFIFO][0000:01:00.0] channel 2 [Xorg[1868]] kick timeout
> nouveau E[ PFIFO][0000:01:00.0] channel 2 [Xorg[1868]] kick timeout
> nouveau E[ PFIFO][0000:01:00.0] playlist 0 update timeout
>
> repeated about every 150 seconds.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: xserver-xorg-video-nouveau 1:1.0.10...

Read more...

(In reply to Joe Verreau from comment #13)
> In closer review of the thread above I checked on downgrading libdrm from
> 2.4.60. In my installation yum tells me I need to also downgrade
> libdrm-devel and apparently the downgrade version is 2.4.58 rather than
> 2.4.59. Is that what you recommend?

Joe, are you on the Fedora 22 bet? If so, an update will be going out soon. You can get it immediately from https://admin.fedoraproject.org/updates/FEDORA-2015-7930/libdrm-2.4.61-3.fc22

This is version 2.4.61, which fixes the regression. If you're not on F22, I expect updates will be coming soon. In the meantime, go ahead and downgrade to whatever works.

Matthew, actually I'm on fedora 21 so I will downgrade libdrm, libdrm-devel to 2.4.58 and await the update to 2.4.61 in the normal distribution. thanks.

Simon John (sej7278) wrote :

i can't see the problem is xserver-xorg-video-nouveau 1.0.11-1 though, as the package hasn't been updated in 8 months and i've only had the problem the last few weeks.

i assume its one of the libdrm* userspace packages which seem to have had 3-4 new versions during march/april

Simon John (sej7278) wrote :

kernel 4.0.0 has the same issue, so its not kernel-bound and its not a screensaver issue as it tends to happen to me when using google chrome viewing youtube for some reason (but not every time and not exclusively when using chrome).

According to this post https://bugs.freedesktop.org/show_bug.cgi?id=89842 the libdrm should be downgraded to 2.4.58.

Download full text (4.8 KiB)

I can trigger the bug with docky anytime I want. Just move quickly through Docky icons with the mouse cursor (https://bugs.launchpad.net/ubuntu/+source/docky/+bug/1451379). I a few seconds the screen will freeze. Most of the times I have to wait for about 30 seconds. I can switch to text (Alt + Ctrl + F1) in the meantime and see that gnome-shell occupies the computer 100%. Nouveau driver writes lots of lines into syslog at the same time. But sometimes everything freezes and only hard reset helps.

It starts like that:
May 21 08:35:37 computer gnome-session[8979]: nouveau: kernel rejected pushbuf: Invalid argument
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: krec 0 pushes 1 bufs 19 relocs 0
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000000 00000005 00000004 00000004 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000001 000001b9 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000002 00000007 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000003 0000000a 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000004 0000000b 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000005 00000008 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000006 00000006 00000004 00000000 00000004
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000007 0000019e 00000002 00000000 00000002
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000008 00000013 00000002 00000000 00000002
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000009 0000000d 00000004 00000004 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 0000000a 00000104 00000004 00000004 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 0000000b 00000124 00000002 00000002 00000002
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 0000000c 00000026 00000004 00000004 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 0000000d 00000090 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 0000000e 000001b1 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 0000000f 000001ac 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000010 000001ad 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000011 00000030 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: buf 00000012 000001ba 00000002 00000002 00000000
May 21 08:35:37 computer gnome-session[8979]: nouveau: ch0: psh 00000000 000005e7d4 000006045c
May 21 08:35:37 computer gnome-session[8979]: nouveau: #0110x0004721c
May 21 08:35:37 computer gnome-session[8979]: nouveau: #0110x0fac6881
May 21 08:35:37 computer gnome-session[8979]: nouveau: #0110x00086ff4
May 21 08:35:37 computer gnome-session[8979]: nouveau: #0110x12c00000
May 21 08:35:37 computer gnome-session[8...

Read more...

I too am experiencing the issue described in this ticket. It is affecting 6 machines all running Fedora 21. They generally hang around 2-3 times a day. Is there going to be an update to 2.4.61 pushed for Fedora 21 at some point?

Simon John (sej7278) wrote :

i've seen crashes with iceweasel and mplayer, so its not just chrome (on debian)

[21236.953014] nouveau E[mplayer[20360]] multiple instances of buffer 34 on validation list
[21236.953020] nouveau E[mplayer[20360]] validate_init
[21236.953021] nouveau E[mplayer[20360]] validate: -22
[228512.722648] nouveau W[ PFIFO][0000:01:00.0] INTR 0x01000000: 0x00000005
[405193.284040] nouveau E[mplayer[2277]] multiple instances of buffer 37 on validation list
[405193.284048] nouveau E[mplayer[2277]] validate_init
[405193.284051] nouveau E[mplayer[2277]] validate: -22
[608343.309025] nouveau E[mplayer[6653]] multiple instances of buffer 37 on validation list
[608343.309033] nouveau E[mplayer[6653]] validate_init
[608343.309036] nouveau E[mplayer[6653]] validate: -22
[623180.230876] nouveau W[ PFIFO][0000:01:00.0] INTR 0x01000000: 0x00000005
[663031.221724] nouveau E[gnome-shell[4889]] multiple instances of buffer 469 on validation list
[663031.221729] nouveau E[gnome-shell[4889]] validate_init
[663031.221730] nouveau E[gnome-shell[4889]] validate: -22
[663071.853783] nouveau E[ PFIFO][0000:01:00.0] write fault at 0x0007dc0000 [PAGE_NOT_PRESENT] from PGRAPH/GPC0/PROP on channel 0x007f9ee000 [gnome-shell[4889]]
[663071.853788] nouveau E[ PFIFO][0000:01:00.0] PGRAPH engine fault on channel 5, recovering...
[663158.214504] nouveau E[gnome-shell[4889]] failed to idle channel 0xcccc0000 [gnome-shell[4889]]
[663173.199899] nouveau E[gnome-shell[4889]] failed to idle channel 0xcccc0000 [gnome-shell[4889]]

no longer affects: xserver-xorg-video-nouveau (Debian)

I have a similar bug with

Debian Linux "testing" ("stretch")
GeForce 8400 GS Rev. 3
Linux 3.10-2-amd64
xserver-xorg-video-nouveau 1:1.0.11-1+b1
libdrm-nouveau1a 2.4.40-1~deb7u2
libdrm-nouveau2 2.4.60-3
libgl1-mesa-dri 10.5.7-1
libgl1-mesa-glx 10.5.7-1
Gnome 3.14.0-1

Created attachment 116767
when manipulating Gnome tray

See the error log produced by journalctl when manipulating Gnome tray.

This is fixed by not using libdrm 2.4.60 which was a buggy release on the nouveau end. libdrm 2.4.59 or libdrm 2.4.61 should work fine.

Changed in nouveau:
importance: Unknown → Critical
status: Unknown → Fix Released

... at this point I'm inferring there will not be upgraded versions of libdrm, libdrm-devel for fc21? I did downgrade my laptop from 2.4.60 to 2.4.58 in Jun as noted below. I'm guessing the fix really is to go to fc22. I ask because now my desktop is also experiencing these freeze ups tho not in the frequency that others have reported.

tags: added: bios-outdated-1.j

Chad Miller, as per http://www.msi.com/support/mb/P67AC43.html#down-bios an update to your computer's buggy and outdated BIOS is available (1.J). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. As well, you don't have to create a new bug report.

Once the BIOS is updated, if the problem is still reproducible, and the information above is provided, then please mark this report Status New. Otherwise, please mark this as Invalid.

Thank you for your understanding.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Incomplete

Chad Miller, as per http://www.msi.com/support/mb/P67AC43.html#down-bios an update to your computer's buggy and outdated BIOS is available (1.J). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Once the BIOS is updated, if the problem is still reproducible, and the information above is provided, then please mark this report Status New. Otherwise, please mark this as Invalid.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.