Nvidia: unknown chipset

Bug #1142733 reported by Mattia Migliorini on 2013-03-03
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Invalid
Undecided
Unassigned
xserver-xorg-video-nouveau (Fedora)
New
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Maarten Lankhorst

Bug Description

OS: Ubuntu
OS version: 13.04
Architecture: x84_64

On boot the system shows this message:
[ 10.893362] nouveau I [ DEVICE] [0000:01:00.0] unknown Feral chipset
[ 10.893436] nouveau E [ DEVICE] [0000:01:00.0] unknown chipset, 0x0d7000a2
[ 10.893506] nouveau E [ DRM] failed to create 0x80000080, -22

After that, the system starts apparently without problems. I append some infos about my graphics card from lshw command:

*-display UNCLAIMED
                description: 3D controller
                product: NVIDIA Corporation
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress cap_list
                configuration: latency=0
                resources: memory:f2000000-f2ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:3000(size=128)
---
.tmp.unity.support.test.0:

ApportVersion: 2.9-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
DistUpgraded: Fresh install
DistroCodename: raring
DistroRelease: Ubuntu 13.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:072b]
   Subsystem: Acer Incorporated [ALI] Device [1025:072b]
InstallationDate: Installed on 2013-03-03 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130303)
MachineType: Acer Aspire V5-571G
MarkForUpload: True
Package: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-9-generic root=UUID=90af2353-1568-46fb-8bdd-805f4b92acc7 ro quiet splash
ProcVersionSignature: Ubuntu 3.8.0-9.18-generic 3.8.1
Tags: raring ubuntu single-occurrence reproducible compiz-0.9
Uname: Linux 3.8.0-9-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 06/08/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: V1.10.
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire V5-571G
dmi.board.vendor: Acer
dmi.board.version: V1.10.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.10.
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrV1.10.:bd06/08/2012:svnAcer:pnAspireV5-571G:pvrV1.10.:rvnAcer:rnAspireV5-571G:rvrV1.10.:cvnAcer:ct9:cvrV1.10.:
dmi.product.name: Aspire V5-571G
dmi.product.version: V1.10.
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.9~daily13.03.01-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Mon Mar 4 08:50:22 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1142733/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Please run the following commands to gather more information:
sudo update-pciids
apport-collect 1142733

affects: ubuntu → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected compiz-0.9 raring reproducible single-occurrence ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This is a hybrid/Optimus system with two graphics units:
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116]
01:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:1140]

The Nvidia card is a GT620M

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Confirmed
Mattia Migliorini (deshack) wrote :

You're right, it's Optimus Technology, but it doesn't make any problem in Quantal, even if I didn't install Bumblebee (so I might say it's a regression).

Maarten Lankhorst (mlankhorst) wrote :

can you run with the quantal kernel and post a dmesg? if the kernel from the cd works, it's fine

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → Maarten Lankhorst (mlankhorst)
Mattia Migliorini (deshack) wrote :

dmesg from Quantal

Maarten Lankhorst (mlankhorst) wrote :

Congratulations, you have a chip that wasn't known by the nouveau developers yet. :-)

If you want nouveau to support that chip we need some information from your system.

How comfortable are you with the command line?

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → In Progress
Mattia Migliorini (deshack) wrote :

Great!

I must say I don't have problems (maybe too high battery consumption, but nothing bad with screen resolution or so), but when Raring showed me that error I wanted to share it, 'cause it may help.

After that, I use the command line, but don't know everything :-)

slam (slamhan1987) wrote :

I'm get this message when boot the system when update kernel from 3.5 to 3.8.
[ 2.269144] hub 4-0:1.0: unable to enumerate USB device on port 2

[ 2.101338] usb 4-2: got a wrong device descriptor, warm reset device
[ 4.236484] sd 6:0:0:0: [sdc] No Caching mode page present
[ 4.236489] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[ 4.237371] sd 6:0:0:0: [sdc] No Caching mode page present
[ 4.237377] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[ 4.306197] sd 6:0:0:0: [sdc] No Caching mode page present
[ 4.306204] sd 6:0:0:0: [sdc] Assuming drive cache: write through

[ 19.469816] nouveau ![ DEVICE][0000:01:00.0] unknown Fermi chipset
[ 19.469846] nouveau E[ DEVICE][0000:01:00.0] unknown chipset, 0x0d7000a2
[ 19.469870] nouveau E[ DRM] failed to create 0x80000080, -22
[ 19.470095] nouveau: probe of 0000:01:00.0 failed with error -22

Maarten Lankhorst (mlankhorst) wrote :

Did any of you manage to get the nvidia driver working? It doesn't need to have output to the screen, just xorg needs to start and detect nvidia. The nvd7 is a card we haven't seen before, and it's a surprise it worked at all.

If the binary driver works, it could be made to work on nouveau correctly. Just get on freenode irc, go to the #nouveau channel and ping me there, and I can help you get us the information we need.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: In Progress → Incomplete

Any new updates on this bug?

Maarten Lankhorst (mlankhorst) wrote :

I'm still waiting on a mmiotrace from the nvidia driver.

http://people.freedesktop.org/~mlankhorst/mmiotrace-nvidia.sh is a script that automatically does such a trace if you kill the xserver first. It will set things up and then you have to start xserver in the shell it spawns. After that kill the xserver and exit from the subshell, and it will finish up the trace.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
status: New → Incomplete

I tried to run the sricpt as you asked but I have some issues... After killing lightdm, I ran the script.
First, "modprobe -r nvidia" said: "module nvidia not found", so I installed nvidia-current.
But then, "modprobe nvidia" said: "Error could not insert "nvidia_304": Unknown symbol in module or unknown paramter".

Did I miss something to do?

Maarten Lankhorst (mlankhorst) wrote :

look at dmesg, maybe it will say something.

It only says: nvidia: Unknown symbol mcount (err 0).
Does this information help you...?

Maarten Lankhorst (mlankhorst) wrote :

Are you using a custom kernel?

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
status: New → Incomplete

No, I just upgraded ubuntu from 12.10 to 13.04.

Eric Strebel (eric-strebel22) wrote :

I have the same issue and card and managed to get the latest nvidia (beta) driver 319.17 running, however with no screen output in X.

Maarten, what do I need to do once your script spawns the shell? just startx and kill the process or is there more to it? I would be glad to provide the information necessary.

Maarten Lankhorst (mlankhorst) wrote :

spawning x is good enough, maybe run glxgears for a few seconds but I don't think it's necessary :)

Eric Strebel (eric-strebel22) wrote :

OK, here is what I obtained. Hope this helps :)

Maarten Lankhorst (mlankhorst) wrote :

Thanks for the trace, it helped a bit for testing. I now have some hardware to test with. The fix is a bit more involved it seems. The nvd7 I have has no display engine, so it requires some fixes in the X driver and the kernel to work at all. It now works without acceleration for me, but without acceleration it's completely useless. I'll try to get the 3d engine working.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → In Progress
Maarten Lankhorst (mlankhorst) wrote :

I have made a fix for nvd7, the nouveau maintainer is reworking some of the code this applies to, so this may fail to apply soon. A fix is also required in xserver-xorg-video-nouveau, because it doesn't handle displayless cards correctly right now.

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nouveau - 1:1.0.8-0ubuntu1

---------------
xserver-xorg-video-nouveau (1:1.0.8-0ubuntu1) saucy; urgency=low

  * Sync to unreleased debian experimental git.
  * Remaining differences:
    - Try to enable vblank if available (LP: #1019131)
      - 100-vblank-on.diff
  * Add support for displayless cards. (LP: #1142733)

xserver-xorg-video-nouveau (1:1.0.8-1) UNRELEASED; urgency=low

  * New upstream release.
  * Replace dependency on x11proto-xf86dri-dev with x11proto-dri2-dev.
    - Upstream removed dri1 dependency.
 -- Maarten Lankhorst <email address hidden> Wed, 12 Jun 2013 11:24:18 +0200

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: In Progress → Fix Released

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

Maarten - would it be appropriate for you to add the NVD7 to the nouveau code names wiki page at http://nouveau.freedesktop.org/wiki/CodeNames/

?

bill allen (coolbreez66) on 2013-06-25
Changed in linux (Ubuntu):
assignee: nobody → bill allen (coolbreez66)
status: Confirmed → New
status: New → Fix Committed
status: Fix Committed → Confirmed
tags: removed: nvidia reproducible single-occurrence
affects: linux (Ubuntu) → nouveau
Changed in nouveau:
assignee: bill allen (coolbreez66) → nobody
status: Confirmed → Invalid
Grzegorz Rożniecki (xaerxess) wrote :

Is there a chance that the fix will appear in Raring and Precise via xserver-xorg-video-nouveau-lts-raring?

Maarten Lankhorst (mlankhorst) wrote :

The userspace parts are not the problem, you need a supported kernel, which raring won't provide. So if lucky saucy will support it.

To post a comment you must log in.