Ubuntu

NVidia GPU lock-up on 12.10 Beta-1

Reported by Ben Howard on 2012-09-10

This bug report will be marked for expiration in 22 days if no further activity occurs. (find out why)

96
This bug affects 18 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
High
Unassigned

Bug Description

Whilst happily running for four or five days, my desktop died with:

Sep 10 09:41:33 padfoot kernel: [252339.517419] [drm] nouveau 0000:01:00.0: GPU lockup - switching to software fbcon
Sep 10 09:41:45 padfoot kernel: [252351.446194] [drm] nouveau 0000:01:00.0: Failed to idle channel 1.
Sep 10 09:41:47 padfoot kernel: [252353.443312] [drm] nouveau 0000:01:00.0: PFIFO - playlist update failed
Sep 10 09:41:50 padfoot kernel: [252356.435837] [drm] nouveau 0000:01:00.0: Failed to idle channel 2.
Sep 10 09:41:52 padfoot kernel: [252358.431790] [drm] nouveau 0000:01:00.0: 0x2634 != chid: 0x00100002
Sep 10 09:41:52 padfoot kernel: [252358.431975] [drm] nouveau 0000:01:00.0: PFIFO: unknown status 0x00000100

Then the machine locked up. The machine has also had screen corruption. See attached pictures.

----

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Mon Sep 10 09:46:59 2012
DistUpgraded: 2012-09-06 10:02:40,389 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.18, 3.2.0-29-generic, x86_64: installed
 virtualbox, 4.1.18, 3.5.0-13-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 NVIDIA Corporation GF108 [Quadro 1000M] [10de:0dfa] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21cf]
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64+mac (20120802.1)
MachineType: LENOVO 4270CTO
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=7879b10c-9e30-4a42-a82d-5f3bbe0d6493 ro kvm-intel.nested=1
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: Upgraded to quantal on 2012-09-06 (3 days ago)
dmi.bios.date: 08/16/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8BET50WW (1.30 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4270CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8BET50WW(1.30):bd08/16/2011:svnLENOVO:pn4270CTO:pvrThinkPadW520:rvnLENOVO:rn4270CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4270CTO
dmi.product.version: ThinkPad W520
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.8.0-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120903.e1673d20-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120903.e1673d20-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.6-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Ben Howard (utlemming) wrote :
description: updated
Ben Howard (utlemming) wrote :

Picture of intermittent screen corruption.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
tgelter (timothy-gelter) wrote :

duplicate: 1041851

Bryce Harrington (bryce) wrote :

Maarten, please investigate this when you get the chance. See also the dupe bug.

Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
milestone: ubuntu-12.10-beta-2 → none
status: Confirmed → Triaged

Still is a problem for me in Beta 2!

Still a problem in Beta 2. Will not boot Ubuntu 12.10 x64 Desktop Beta 2 from a USB Flash Drive:

[drm] nouveau 000:01:00.0: GPU lockup - switching to software fbcon
[drm] nouveau 000:01:00.0: Failed to idle channel 2
[drm] nouveau 000:01:00.0: Failed to idle channel 3
[drm] nouveau 000:01:00.0: Failed to idle channel 2
[drm] nouveau 000:01:00.0: Failed to idle channel 3
...and just stays in this loop forever.

Using Lenovo W510 Laptop with NVIDIA Quadro FX 880M

Exactly the same problem as the one reported by David Spoelstra: 12.10 beta 2 will not boot.

Using Acer 6930G laptop with Nvidia gpu.

GonzO (gonzo) wrote :

Same issue here on my ThinkPad W510 (same laptop as David Spoelstra), but also happening with custom-built desktop machine using a MSI Twin Frozr GeForce 560Ti. Is nouveau working for anyone?

I managed to properly boot and install 12.10 by removing the 'quiet splash' option on startup.

Jacek Nykis (jacekn) wrote :

This also affects me on desktop with the following GPU:
"NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1)"

12.10 beta 2 would not start until I removed "quiet splash" options.

GonzO (gonzo) wrote :

Please tell me this is going to be fixed before release. I can't fathom a live USB stick that doesn't boot on (some significant amount of) nVidia cards being release-quality stuff.

Doug McMahon (mc3man) wrote :

For many the issue with booting a live cd/usb on nvidia was fixed here (post beta2
Bug 1043518

(Though with the current 3.5.0-17-generic #27 the "[drm] nouveau 0000:01:00.0: GPU lockup - switching to software fbcon" is now seen on shutdown/restart, only seems to affect how long it takes to do so

GonzO (gonzo) wrote :

For me, on two different machines, it was not. Both have been updated to the very latest as of this morning, both still have this problem, neither can boot from a live USB (even from a daily).

FYI, tested today's live version and it worked perfectly on my Lenovo W510 Laptop with NVIDIA Quadro FX 880M. Thanks for fixing it!

Dag Blakstad (dag-blakstad) wrote :

This problem happens frequently (daily) on my Dell E6510 with Ubuntu 12.10 (release version)

Miguel Barbero (sonfrau) wrote :

I have the same problem on my desktop. I have recently upgraded to Ubuntu 12.10 and my graphics have turned very unstable. How could I help to fix this issue?

Same here, experiencing daily hard restarts because of this.

Hans Nieser (hnsr) wrote :

I was unable to install Ubuntu 12.10 today from USB stick on my PC with a Geforce 580GTX due to this bug. It would happen within a minute or so after Unity coming up. Had to install with a spare radeon. Working better now after installing nvidia closed source drivers (which was quite a challenge for a newbie like me since it wouldn't list it under 'Additional Drivers' without the card actually being in the PC)

Paul O'Riordan (reverselogic) wrote :

I'm also experiencing this issues hourly, since doing a clean install of 12.10 today.

Jacer OMRI (jokerhacker-jacer) wrote :

i'm getting this problem once per 2 hours maybe, can't do anything until i restart, i'm using nvidia GeForce 7000M on Acer Aspire 5520

jlhal (jlhal) wrote :

Getting this problem with GTX590 after trying an update from 12.04 and also when trying to boot/reinstall from CD : NVidia driver not installed and xorg for nvidia not present in packets management (but intel, amd, ati are there)
To be noticed : My GPUGRID work units all suddenly failed 2 days ago under 12.04 : Some software updates may be the cause.

Julian Alarcon (alarconj) wrote :

Guys, with the latest kernel updates, is this bug still happening?

Yes, it's still happening. Here is the error screen: https://www.dropbox.com/s/kv8kodwsbeeiym7/2013-02-16%2008.35.34.jpg

It appears randomly, after using the computer for some time. After the screen appears, my laptop becomes unresponsive and I have to do a hard shutdown. I'm using Ubuntu 12.10 for two days now.

Versions:
Kernel Linux 3.5.0-23-generic
GF108 [GeForce GT 540M]

Maarten Lankhorst (mlankhorst) wrote :

There can be many causes for this specific bug, I would recommend updating to mesa from quantal-proposed, and a current development kernel. The more recent kernels increase fault reporting slightly, and the mesa upload might fix some of the causes of hangs, but no guarantee!

Maarten Lankhorst (mlankhorst) wrote :

If it still happens with those new versions, please attach a new dmesg. xorg-edgers can help you get the latest versions, if you're daring enough. :)

vradovic (vradovic) wrote :

I got same problem here.
- NVIDIA GTX 580
 I tried so far 12.04, 12.10, 13.04.

I got freeze problem during early phase of installation. And can't do much.

Ben Howard, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: Maarten Lankhorst (mlankhorst) → nobody
status: Triaged → Incomplete
tags: added: bios-outdated-1.42
Ben Howard (utlemming) wrote :

I haven't run 12.10 in a long time...so I can't comment on it.

Ivan Larionov (xeron-oskom) wrote :

I have this issue on 14.04 with GTX650Ti:

Mar 5 21:47:08 animeworld kernel: [ 354.357948] audit_printk_skb: 117 callbacks suppressed
Mar 5 21:47:08 animeworld kernel: [ 354.357953] type=1006 audit(1394041628.099:63): pid=3406 uid=0 old auid=4294967295 new auid=1000 old ses=4294967295 new ses=1 res=1
Mar 5 21:47:08 animeworld dbus[988]: [system] Activating service name='org.freedesktop.ConsoleKit' (using servicehelper)
Mar 5 21:47:08 animeworld dbus[988]: [system] Successfully activated service 'org.freedesktop.ConsoleKit'
Mar 5 21:48:17 animeworld kernel: [ 423.976011] nouveau E[compiz[2343]] failed to idle channel 0xcccc0000 [compiz[2343]]
Mar 5 21:48:32 animeworld kernel: [ 438.976010] nouveau E[compiz[2343]] failed to idle channel 0xcccc0000 [compiz[2343]]
Mar 5 21:48:32 animeworld kernel: [ 438.976117] nouveau E[ PFIFO][0000:01:00.0] PFIFO: read fault at 0x0000013000 [PAGE_NOT_PRESENT] from (unknown enum 0x00000007)/(unknown enum 0x00000007) on chann
el 0x003fa62000 [unknown]
Mar 5 21:48:34 animeworld kernel: [ 440.978687] nouveau E[ PFIFO][0000:01:00.0] playlist 0 update timeout
Mar 5 21:48:36 animeworld kernel: [ 443.204676] nouveau E[ DRM] GPU lockup - switching to software fbcon
Mar 5 21:48:37 animeworld kernel: [ 443.273657] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100
Mar 5 21:48:41 animeworld kernel: [ 447.568648] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100
Mar 5 21:48:45 animeworld kernel: [ 451.863641] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100
Mar 5 21:48:49 animeworld kernel: [ 456.158631] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100
Mar 5 21:48:54 animeworld kernel: [ 460.453621] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100
Mar 5 21:48:55 animeworld kernel: [ 462.088008] nouveau E[Xorg[1147]] failed to idle channel 0xcccc0001 [Xorg[1147]]
Mar 5 21:48:58 animeworld kernel: [ 464.748609] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100
Mar 5 21:49:02 animeworld kernel: [ 469.043601] nouveau W[ PFIFO][0000:01:00.0] unknown status 0x00000100

Ivan Larionov, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions