nouveau causes compiz and gnome-shell to use 100% CPU. nvidia-current works.

Bug #1044060 reported by Colin Keenan on 2012-08-30
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned

Bug Description

Every once in a while, usually when I've been reading news and blogs for a couple of hours, the display freezes up and doesn't respond to any mouse clicking. Doing ctrl-alt-backspace works as well as ctrl-alt-f1. I've noticed that if the problem happens a lot in a short period of time, eventually update-notifier will tell me updates are available. When I tried ctrl-alt-f1 and ran tops, that's when I discovered compiz was using 100% cpu so that was what was causing the display to not respond. I don't know many commands, but killall compiz did allow me to continue reading the blog, but of course all window decoration was missing and I had no way to launch other applications through the gui. After doing ctrl-alt-backspace to restore my desktop, Apport reported an update-notifier crash.

Since this problem happens at times I'm not doing anything but reading what's already in the browser and trying to scroll down to read more, I think the problem is caused by something done on a schedule. Since update-notifier always seems to come up eventually on reboot or ctrl-alt-backspace, it would seem like update-notifier is somehow causing compiz to use 100% cpu at times.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: compiz 1:0.9.8+bzr3319-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
ApportVersion: 2.5.1-0ubuntu3
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,move,imgpng,obs,resize,grid,vpswitch,mousepoll,unitymtgrabhandles,snap,regex,wall,gnomecompat,place,animation,workarounds,expo,session,fade,ezoom,scale,unityshell]
Date: Thu Aug 30 15:32:19 2012
DistUpgraded: 2012-08-23 14:30:03,347 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation C61 [GeForce 6150SE nForce 430] [10de:03d0] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ZOTAC International (MCO) Ltd. Device [19da:a127]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 002 Device 002: ID 0451:2046 Texas Instruments, Inc. TUSB2046 Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 003: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
MachineType: Unknow Unknow
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=e92f6f09-fa78-4288-b695-6f763ae4e38d ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to quantal on 2012-08-23 (7 days ago)
dmi.bios.date: 12/10/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: NF-MCP61
dmi.board.vendor: nVIDIA
dmi.chassis.type: 3
dmi.chassis.vendor: nVIDIA
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd12/10/2009:svnUnknow:pnUnknow:pvrUnknow:rvnnVIDIA:rnNF-MCP61:rvr:cvnnVIDIA:ct3:cvr:
dmi.product.name: Unknow
dmi.product.version: Unknow
dmi.sys.vendor: Unknow
version.compiz: compiz 1:0.9.8+bzr3319-0ubuntu3
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Colin Keenan (colinkeenan) wrote :
tags: added: compiz-0.9
Daniel van Vugt (vanvugt) wrote :

We need some stack information to help us determine the cause of the CPU spikes.

1. Download the attached dstack script to your home directory.
2. Log in to a virtual terminal (Ctrl+Alt+F1), and switch back (Ctrl+Alt+F7)
3. When the spike happens, switch to Ctrl+Alt+F1 and run this:
    sudo -s
    sh ./dstack compiz >> compizstack.txt
    sh ./dstack compiz >> compizstack.txt
    sh ./dstack compiz >> compizstack.txt
    sh ./dstack compiz >> compizstack.txt
    sh ./dstack compiz >> compizstack.txt
4. Attach the resulting compizstack.txt to this bug.

Changed in compiz (Ubuntu):
status: New → Incomplete
Colin Keenan (colinkeenan) wrote :

Update-notifier ran and updated my system without issue today. Later, when opening a tab to "spin a wheel" that also had some popup stuff on the bottom of the page, Compiz started using about 98% cpu, but the spike in cpu usage didn't last so long that I needed to reboot or anything.

I don't know if I caught the spike with dstack or not, but I'm attaching compizstack.txt in case I did.

Colin Keenan (colinkeenan) wrote :

I should also mention that the first time I tried to open that tab, there was a gpu lockup and I couldn't switch to the virtual console. I know it was a gpu lockup because the system switched to console mode and started listing everything it was trying to do, but it was taking too long, so I did a hardware re-boot. It was after re-boot when that tab came up again that I got the Compiz 98% cpu usage. It took a while for me to start the dstack commands, so I don't know if any useful info is in compizstack.txt.

Changed in compiz (Ubuntu):
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

Colin,

I suspect the spike was not captured in that stack info. But if it was then it looks like your issue is the the nouveau driver's failure to sync to vblank. That's a known problem and is fixed by adding to /etc/X11/xorg.conf:

Section "Device"
    Identifier "My Graphics"
    Driver "nouveau"
    Option "GLXVBlank" "on"
EndSection

But it's only a theory and you probably did miss the spike, in which case that's not the real problem here.

Since you're using 12.10 however, please try doing a system update because the new version of compiz (0.9.8.0) was finally released just over 24 hours ago. It may help with this issue.

Changed in compiz (Ubuntu):
status: New → Incomplete
Colin Keenan (colinkeenan) wrote :

I've created xorg.conf and put that Section "Device" in there. I've already got compiz 0.9.8.0 which isn't surprising because I did an update this morning. This particular problem hasn't happened today. Hopefully the xorg.conf file will help with all the other graphics issues I've been having. They've been so bad and random that I've started to wonder if the gpu chip on my motherboard is bad or something. I haven't been able to do a proper bug report on the graphics issues.

I'll update this bug in a couple of days and change the status.

Colin Keenan (colinkeenan) wrote :

The problem has not been solved, but I don't think it's compiz that's causing the trouble. Last night I installed gnome: sudo aptitude install gnome. This morning I was running gnome-shell, not compiz/unity, and got gnome-shell using 100% cpu. I ran dstack.sh 5 times for gnome-shell, and definitely got the spike. Every time the spike seemed to have ended, when I started using Google Chrome Browser again, the spike started again.

So, I ran dstack.sh a several more times. Finally, I had to killall gnome-shell and run gnome-shell again. Last night when I was having a different problem with gnome-shell, I tried mutter --replace, but to my surprise, mutter --replace doesn't work with gnome-shell because I didn't have mutter installed! So, does that mean gnome-shell was using compiz? Last night, when I was worried that gnome-shell was running under compiz somehow, I found instructions on the internet to find out what window manager was being used and the result was "Mutter" with a capital "M", but "Mutter --replace" also didn't work since "Mutter" wasn't installed either. So, I installed mutter, but mutter --replace doesn't work because it doesn't load gnome-shell, and same thing happens with compiz --replace.

Anyway, whatever gnome-shell is running under, the 100% CPU problem happens with it just as it did with compiz/unity. I'm attaching gnomestack.txt hoping someone will figure out what package really has a bug in it.

Colin Keenan (colinkeenan) wrote :

As I was writing the note above, tons of disk activity was going on, and I was expecting update-notifier to pop up. It didn't, so I ran update-notifier and it popped up right away with a list of updates. It could just be coincidence, but maybe the process of checking for and downloading updates might have something to do with this because that seems to be what was happening as I was typing the note above. Of course, that was happening after the spike ended by me killing gnome-shell and re-running it, so I don't know, but that's basically the same pattern I noticed when I first reported this bug.

Changed in compiz (Ubuntu):
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

Colin,

As far as I know, gnome-shell is a self-contained window manager now. So that's why it works without mutter. And compiz is not used by Gnome Shell at all (but compiz is used if you log in to "Gnome Classic").

This sounds like an issue with the nouveau driver now. Are you able to install and test the proprietary NVIDIA driver?
  1. Super+A to search applications
  2. Type: Additional Drivers
  3. Does it give you any option to install a proprietary nvidia driver?

Colin Keenan (colinkeenan) wrote :

I was having so much trouble with graphics that the dash was no longer functional. That was why I tried gnome. I was still having graphics problems in gnome-shell, but it was usable except for the 100% cpu problem. Unfortunately, after I did the killall gnome-shell and then restarted gnome-shell, the next time I logged into it, it wouldn't load. I had accidentally killed and restarted gnome-shell while still super-user. I've reported a separate bug about that and hope they will find a way to make gnome-shell work for me again. I had never used it before, but like it alot.

Anyway, I tried Super+A which I see is the same as just clicking the dash icon, but graphics went haywire as usual and I couldn't see anything. After rebooting, I logged into gnome classic no effects. I searched for "Additional Drivers" in the Ubuntu Software Center, and to my surprise, it wasn't even installed. After installing "Additional Drivers", it wasn't on the menus, but from Software Center, I knew the command was jockey-kde, and ran it from a terminal window (I use guake). That worked and it detected 3 apparently identical drivers, all named NVIDIA binary Xorg driver, kernel module and VDPAU library. It wouldn't install saying I had held-back broken packages. After an aptitude update & aptitude full-upgrade, I was able to install the driver.

This proprietary driver has solved all my problems. Their are clearly very serious issues with the nouveau driver being considered for 12.10, and the latest one for 12.04 has problems too. The original one for 12.04 was fine, but in the past couple of months, I started having serious problems, which was why I decided to try the Alpha 3 12.10. Every upgrade just made the graphics worse. This will be a big problem for Ubuntu. I have not been able to do a proper bug report for nouveau or Xorg or anything related. They can't get the information they need to diagnose the problem. But, the proprietary driver works!

The only reason I had stopped using the proprietary driver in 12.04 is that for some reason it made the fonts look horrible, and there were other minor issues as well. Strangely, I could install the proprietary driver, tweak some things like digital vibrance, remove the proprietary driver, and the digital vibrance settings still worked while improving the fonts by using nouveau. Then they upgraded nouveau and it stopped using the settings I had done with the nvidia driver. Then, the graphics went to hell.

This latest nvidia driver still has worse fonts than nouveau, but it's better than before, and I have no choice anymore.

affects: compiz (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
summary: - compiz uses 100% cpu seemingly at random but maybe related to update-
- notifier
+ nouveau causes compiz and gnome-shell to use 100% CPU. nvidia-current
+ works.
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed

Colin Keenan, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Colin Keenan (colinkeenan) wrote :

Someone else affected by this bug will have to test it again.

I can't test it or run the suggested command because I sold that computer and built a new one based on intel HD 4000 graphics. I also switched to Arch Linux.

Colin Keenan, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1044060/comments/13 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Invalid

I think the bug is related to this one https://bugs.freedesktop.org/show_bug.cgi?id=89842

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.