10de:1080 [SABERTOOTH X58] Xorg hangs using GeForce 580 GTX on nouveau

Bug #1039202 reported by Simplehuman on 2012-08-20
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

I can't install and use Ubuntu 12.10-14.04 x64. Installation and attempt to boot leads to a hang. I am getting an recursive error message (see attached screenshot #1).

WORKAROUND: I can install boot with kernel parameter nomodeset and then use nvidia drivers.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xorg 1:7.7+1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic x86_64
ApportVersion: 2.4-0ubuntu8
Architecture: amd64
CasperVersion: 1.321
Date: Mon Aug 20 20:04:58 2012
DistroCodename: quantal
DistroVariant: ubuntu
GpuHangFrequency: Continuously
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120820)
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
---
.tmp.unity.support.test.1:

ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 NVIDIA Corporation GF110 [GeForce GTX 580] [10de:1080] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ZOTAC International (MCO) Ltd. Device [19da:1203]
InstallationDate: Installed on 2013-11-14 (59 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131114)
MachineType: System manufacturer System Product Name
Package: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-2-generic root=UUID=605146b8-b179-4f1a-b137-b7423032b57f ro quiet splash nomodeset vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-2.17-generic 3.13.0-rc7
Tags: trusty third-party-packages ubuntu regression reproducible compiz-0.9
Uname: Linux 3.13.0-2-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: SABERTOOTH X58
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1402:bd08/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnSABERTOOTHX58:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.51+git20140113.8279c8fb-0ubuntu0ricotz
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~git20140113.99abb87c-0ubuntu0ricotz
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0~git20140113.99abb87c-0ubuntu0ricotz
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.99+git20140106.04ef035c-0ubuntu0sarvatt
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.907+git20140109.a2fc9e5f-0ubuntu0ricotz
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Mon Jan 13 18:54:35 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Ruling Technologies Sdn. Bhd. SteelSeries Gaming Device MOUSE, id 8
 input Ruling Technologies Sdn. Bhd. SteelSeries Gaming Device KEYBOARD, id 9
 input AT Translated Set 2 keyboard KEYBOARD, id 10
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.5-1ubuntu2

Simplehuman (simplehuman) wrote :
description: updated
bugbot (bugbot) on 2012-08-23
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Download full text (7.0 KiB)

Hello,

I've compiled linux-nouveau-3.6.0rc4 x86_64 (made a package for Arch). With this, the system is stable for 1 minute. Then, when I run compiz, or cairo-dock, it freezes..

Here are dmesg messages :

[ 0.000000] Linux version 3.6.0-1-nouveau (bioman@pumpkin) (gcc version 4.7.1 20120721 (prerelease) (GCC) ) #1 SMP PREEMPT Sun Sep 2 22:33:28 CEST 2012
[ 1.236259] fb: conflicting fb hw usage nouveaufb vs VESA VGA - removing generic driver
[ 1.237326] nouveau [ DEVICE][0000:01:00.0] BOOT0 : 0x0c8000a1
[ 1.237328] nouveau [ DEVICE][0000:01:00.0] Chipset: GF110 (NVC8)
[ 1.237329] nouveau [ DEVICE][0000:01:00.0] Family : NVC0
[ 1.238288] nouveau [ VBIOS][0000:01:00.0] checking PRAMIN for image...
[ 1.339740] nouveau [ VBIOS][0000:01:00.0] ... appears to be valid
[ 1.339741] nouveau [ VBIOS][0000:01:00.0] using image from PRAMIN
[ 1.339822] nouveau [ VBIOS][0000:01:00.0] BIT signature found
[ 1.339823] nouveau [ VBIOS][0000:01:00.0] version 70.10.17.00
[ 1.340038] nouveau [ MXM][0000:01:00.0] no VBIOS data, nothing to do
[ 1.362195] nouveau [ PFB][0000:01:00.0] RAM type: GDDR5
[ 1.362196] nouveau [ PFB][0000:01:00.0] RAM size: 1536 MiB
[ 1.378219] nouveau [ DRM][0000:01:00.0] VRAM: 1536MiB
[ 1.378221] nouveau [ DRM][0000:01:00.0] GART: 512MiB
[ 1.378224] nouveau [ DRM][0000:01:00.0] BIT BIOS found
[ 1.378226] nouveau [ DRM][0000:01:00.0] Bios version 70.10.17.00
[ 1.378229] nouveau [ DRM][0000:01:00.0] TMDS table version 2.0
[ 1.378231] nouveau [ DRM][0000:01:00.0] DCB version 4.0
[ 1.378233] nouveau [ DRM][0000:01:00.0] DCB outp 00: 02000300 00000000
[ 1.378235] nouveau [ DRM][0000:01:00.0] DCB outp 01: 01000302 00020030
[ 1.378237] nouveau [ DRM][0000:01:00.0] DCB outp 02: 04011380 00000000
[ 1.378239] nouveau [ DRM][0000:01:00.0] DCB outp 03: 08011382 00020030
[ 1.378241] nouveau [ DRM][0000:01:00.0] DCB outp 04: 02022362 00020010
[ 1.378243] nouveau [ DRM][0000:01:00.0] DCB conn 00: 00001030
[ 1.378246] nouveau [ DRM][0000:01:00.0] DCB conn 01: 00010130
[ 1.378248] nouveau [ DRM][0000:01:00.0] DCB conn 02: 00002261
[ 1.406991] nouveau [ DRM][0000:01:00.0] 0 available performance level(s)
[ 1.406993] nouveau [ DRM][0000:01:00.0] c: core 50MHz shader 101MHz memory 135MHz voltage 963mV fanspeed 40%
[ 1.421196] nouveau [ DRM][0000:01:00.0] MM: using COPY0 for buffer copies
[ 1.713751] nouveau [ DRM][0000:01:00.0] allocated 1920x1200 fb: 0x60000, bo ffff88031f77b400
[ 1.713938] fbcon: nouveaufb (fb0) is primary device
[ 1.741008] fb0: nouveaufb frame buffer device
[ 1.741010] [drm] Initialized nouveau 1.1.0 20120801 for 0000:01:00.0 on minor 0
[ 1.741023] nouveau 0000:02:00.0: enabling device (0004 -> 0007)
[ 1.741572] nouveau [ DEVICE][0000:02:00.0] BOOT0 : 0x0c8000a1
[ 1.741574] nouveau [ DEVICE][0000:02:00.0] Chipset: GF110 (NVC8)
[ 1.741576] nouveau [ DEVICE][0000:02:00.0] Family : NVC0
[ 1.742577] nouveau [ VBIOS][0000:02:00.0] checking PRAMIN for image...
[ 1.752297] nouveau [ VBIOS][...

Read more...

Please,

Also fix those bugs for linux-nouveau 3.4.10

Best regards,

Eric

macstevejb (macstevejb) wrote :

2 machines; one laptop with Intel graphics, one desktop with nvidia graphics.

Live cd boots fine in the laptop but displays weird graphical glitches when attempting to boot with nvidia machine.

Conclude that there must be a problem with nvidia graphics right now.

Tried nomodeset but only gets as far as login screen then freezes in low graphics mode.

Have had problems with every new iteration of Ubuntu that comes along where nvidia graphics are concerned.

Sure hope this gets fixed before final release.

Timo Aaltonen (tjaalton) on 2012-09-20
affects: xorg-server (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)

Hello,

Using external GTX 580 firmware helped !

Eric

Blempis (mikko-lempola) wrote :

This bug is probably the same one that prevents installation also in 12.04 and 12.04.1 .

Simplehuman (simplehuman) wrote :

This is actual for 13.04 too. But in 13.04 it happens after 1-2 minute after boot from Live CD .

Simplehuman (simplehuman) wrote :

it is still actual

This bug persists. I consider it to be a pretty serious bug, too. Anyone with an nvc8 card who runs Gnome or Unity will have the card freeze up in seconds, although somewhat less frequently with KDE. Running firefox will immediately freeze the card. Ubuntu and Fedora both ship their liveCDs to enable nouveau by default and people cannot even run the installer for more than a minute, and most will have no idea what went wrong. Note that most nvc0 cards run just fine... I even have a nvc4 on another computer that runs perfectly, it is nvc8 that specifically has this problem, which very few (if any?) devs seem to posess. Feel free to google "nouveau gtx 580" to see that this is hitting a decent amount of people.

The card works just fine if using the extracted firmware, but this is a poor solution. I have been reading the various envytools/hwdocs on the fuc and been trying to investigate this but I have hit a wall, this issue is just too difficult for me to handle. I am pretty sure the solution is to do whatever Ben did to get the nvd7/nvd9 cards working, which looked like adding chipset specific firmware data to the loading code, but I don't know nearly enough to do this myself. If anyone has some advice, please let me know, I would really like to see this bug closed.

Created attachment 84279
kernel log of card freeze

Created attachment 84280
kernel log of card freeze

Another dmesg log of the freeze. Note that the read fault is not always at the same address.

Worth trying 3.11-rc6. A bunch of changes went into 3.11-rc1 related to register setup on nvc0+ cards.

These logs are from the nouveau git after those changes hit. I've been tracking the git changes pretty carefully and they looked promising but alas, didn't work.

*** Bug 45517 has been marked as a duplicate of this bug. ***

(In reply to comment #3)
> The card works just fine if using the extracted firmware

Can you elaborate on how to do that? This sounds like a better solution than using the proprietary nvidia driver.

Simplehuman (simplehuman) wrote :

It is still actual, any attention on this bug?

summary: - Xorg freeze, crashes, hangs on Live CD and installed system
+ Xorg hangs with GeForce 580 GTX on nouveau
summary: - Xorg hangs with GeForce 580 GTX on nouveau
+ Xorg hangs using GeForce 580 GTX on nouveau
description: updated

Dmitriy "Simplehuman" Fedorov, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
description: updated

apport information

tags: added: apport-collected compiz-0.9 regression reproducible third-party-packages trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Yes, it is still actual for Ubuntu 14.04 x64.

Dmitriy "Simplehuman" Fedorov, thank you for providing the requested information. As a potential WORKAROUND, would you be able to utilize nomodeset, and then install the nvidia drivers as outlined in https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia ?

tags: added: latest-bios-1402
tags: added: precise
Simplehuman (simplehuman) wrote :

As I described in bug description: I can boot with "nomodeset" and then install nvidia drivers. But it is not very user-friendly... :)

Dmitriy "Simplehuman" Fedorov, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at http://nouveau.freedesktop.org/wiki/Bugs/ ?

Please provide a direct URL to your bug report once you have made it so that it may be tracked.

Thank you for your understanding.

description: updated
summary: - Xorg hangs using GeForce 580 GTX on nouveau
+ 10de:1080 [SABERTOOTH X58] Xorg hangs using GeForce 580 GTX on nouveau
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Triaged
tags: removed: regression

Created attachment 103199
Kernel log

When using nouveau on Nvidia GeForce 580 GTX PC freezes. No reaction on keyboard only mouse pointer can move. Sometimes mouse pointer is not reacting too. It happens for a random time and in random activity, most often 10 sec - 2 min.
But if I set "nomodeset" option in kernel boot parameters the system is working fine without freezes.
This problem is actual for X.Org and Mir (Ubuntu-Next 14.10 x64) display servers.
Tested on Ubuntu 14.10 x64, kernel 3.16. But problem is actual for all versions of Ubuntu with Nouveau.

Simplehuman (simplehuman) wrote :

Sorry for such delay.
Bug on Bugzilla upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=81614

There's a known issue with NVC8's whereby there's some unknown deficiency in the nouveau ctxsw firmware causes most of those cards to hang. If the issue goes away when you use blob firmware (see http://nouveau.freedesktop.org/wiki/VideoAcceleration/#firmware for an easy way to get that set up -- you'll also need to add nouveau.config=NvGrUseFW=1 to the kernel cmdline) then you have the same issue as bug 54437.

*** Bug 81614 has been marked as a duplicate of this bug. ***

Thank You for an answer, I will try to mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 54437 ***

This bug is affecting me also, see the last duplicated bug. Any progress in fixing this? Maybe some help in testing (for ex.) required?

Simplehuman (simplehuman) wrote :

My bug upstream is a duplicate of this old bug:

https://bugs.freedesktop.org/show_bug.cgi?id=54437

(In reply to comment #12)
> This bug is affecting me also, see the last duplicated bug. Any progress in
> fixing this? Maybe some help in testing (for ex.) required?

It's a bit of a mystery unfortunately. Adding to the annoyance, Ben said that it does work just fine on his NVC8, although he has the less powerful versions. Could be something with high ROP/TPC/GPC counts not being handled. (Or multiple PARTs?)

That might actually be an interesting experiment -- before loading nouveau, mask out a bunch of the units and see if it helps. If it does, find the "breaking" point.

This is the code that computes that stuff:

http://cgit.freedesktop.org/~darktama/nouveau/tree/nvkm/engine/graph/nvc0.c#n1330

 priv->rop_nr = (nv_rd32(priv, 0x409604) & 0x001f0000) >> 16;
 priv->gpc_nr = nv_rd32(priv, 0x409604) & 0x0000001f;
 for (i = 0; i < priv->gpc_nr; i++) {
  priv->tpc_nr[i] = nv_rd32(priv, GPC_UNIT(i, 0x2608));
  priv->tpc_total += priv->tpc_nr[i];
 }

Step 1: Print out the various values (i.e. number of ROPs, GPCs, and the per-GPC TPC counts).
Step 2: Artificially lower them (to, e.g., 1) and see if it helps. If it does, figure out which of the values matter and where the breaking points are.

If it doesn't help, perhaps the units need to be disabled a little harder, e.g. by setting 0x22584/0x22588.

Changed in nouveau:
importance: Unknown → Critical
status: Unknown → Confirmed

Dmitriy "Simplehuman" Fedorov, you would be better served creating a new report, instead of hijacking another person's similar, but different ancient bug report.

Reopening this bug as an advice given by Christopher M. Penalver from Lauchpad

no longer affects: nouveau
Simplehuman (simplehuman) wrote :

May be you are right. At first I created a new bug report, but I thought that it was a duplicate

Have you verified that your issue is fixed by using blob firmware? Once you do, makes sense to close this bug and mark it as a dup of the older issue.

Yes, blob firmware is working fine

Not sure why you were given that advice on launchpad. The bugs are dups of each other (and older one wins). Should the other bug be resolved and you *still* have issues, you can open a new one. Until then...

*** This bug has been marked as a duplicate of bug 54437 ***

Simplehuman (simplehuman) wrote :

On Bugzilla they think that the bug is still a duplicate, because it is the same issue

Changed in nouveau:
importance: Unknown → Critical
status: Unknown → Invalid

Dmitriy "Simplehuman" Fedorov, that's fine. The point remains that if the original reporter of the master bug has their issue fixed, but yours is not, you have that tracked separately, instead of tangled into some unrelated report.

Simplehuman (simplehuman) wrote :

This bug is fixed upstream, so I mark is as "Fix Released"

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Fix Released
Changed in nouveau:
importance: Critical → Unknown
status: Invalid → Unknown

Simplehuman, something being fixed upstream has no bearing on the status of a Ubuntu package. For more on this, please see https://wiki.ubuntu.com/Bugs/Status . Hence, this is not considered Fix Released. If your issue is resolved, or you are no longer pursuing a fix, please feel free to mark this Invalid.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Fix Released → Triaged
Simplehuman (simplehuman) wrote :

Okay, marking it as Invalid. This bug is doesn't affect me anymore

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Invalid
no longer affects: xserver-xorg-video-nouveau (Ubuntu)
affects: nouveau → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.