corrupted graphic on nvidia card

Bug #1029901 reported by Fabio Marconi on 2012-07-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

This is fixed using the proprietary nvidia experimental.

Hallo
Just after the installation of the Edubuntu 20120727 amd64 build, at the restart the graphic is seriously corrupted and the syslog is full of:

Jul 27 13:42:02 njin-K8NF4G-SATA2 kernel: [ 494.895093] [drm] nouveau 0000:00:05.0: PGRAPH - ERROR nsource: FORMAT_EXCEPTION nstatus: INVALID_STATE BAD_ARGUMENT PROTECTION_FAULT
Jul 27 13:42:02 njin-K8NF4G-SATA2 kernel: [ 494.895110] [drm] nouveau 0000:00:05.0: PGRAPH - ch 3 (0x000db000) subc 6 class 0x009f mthd 0x0308 data 0x00180042

This is the first time that I can observe this behavior in an installed system, before it was afflicting only the live session or ubiquity-dm.

Screenshot and syslog attached

Thanks
Fabio

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-video-nouveau 1:1.0.1-1build1
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.4-0ubuntu5
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Fri Jul 27 14:01:22 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, even including gdb or git bisection work if needed
GraphicsCard:
 NVIDIA Corporation C51G [GeForce 6100] [10de:0242] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation Device [1849:0242]
InstallationMedia: Edubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120727)
Lsusb:
 Bus 002 Device 002: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-6-generic root=UUID=43bfe8e0-a60b-405b-b23b-bb269c70bd7b ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/03/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.asset.tag: 00000000
dmi.board.name: K8NF4G-SATA2
dmi.board.version: 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd11/03/2005:svn:pnK8NF4G-SATA2:pvr1.00:rvn:rnK8NF4G-SATA2:rvr1.00:
dmi.product.name: K8NF4G-SATA2
dmi.product.version: 1.00
version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.37-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.1.902-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~really6.14.4-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.19.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-1build1

Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :

another with unity icons corrupted

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1029901

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

dunno where, how but in beta2 it is fixed.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Fix Released → Confirmed
description: updated
Walter Ribeiro (wribeirojr) wrote :

Possible dupe of bug 568492

Fabio Marconi, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1029901/comments/5 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers