vsync is disabled by default in nouveau

Bug #1019131 reported by Doug McMahon on 2012-06-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Undecided
Unassigned
Ubutter
Medium
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Medium
Maarten Lankhorst

Bug Description

Sync-to-vblank support is disabled by default in the nouveau driver. This makes the desktop tear badly, and look ugly, on nvidia systems.

It's also inconsistent, as radeon and intel both have sync-to-vblank enabled by default.

WORKAROUND:
/etc/X11/xorg.conf:

Section "Device"
        Identifier "My Graphics"
        Driver "nouveau"
        Option "GLXVBlank" "on"
EndSection

ORIGINAL DESCRIPTION:
Quite simply because otherwise performance in the default unity/compiz session is awful. There is very visible tearing when moving windows, switching workspaces ect, ect.
Can't see why you'd leave it up to the users to enable thru xorg.conf

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libgl1-mesa-dri 8.0.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
Uname: Linux 3.5.0-2-generic i686
ApportVersion: 2.2.5-0ubuntu1
Architecture: i386
Date: Fri Jun 29 00:27:49 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0209]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120627)
MachineType: Dell Inc. XPS M1330
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-2-generic root=UUID=4f62ae83-2284-48aa-8935-e1b260f3afcc ro quiet splash vt.handoff=7
SourcePackage: mesa
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "My Graphics"
  Option "GLXVBlank" "on"
 EndSection
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu1
version.libdrm2: libdrm2 2.4.33-3
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.1.902-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~really6.14.4-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.19.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-1build1

Doug McMahon (mc3man) wrote :
Robert Hooker (sarvatt) on 2012-06-29
affects: mesa (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Maarten Lankhorst (mlankhorst) wrote :

It's because fermi and later lack support currently, however I will look into adding it as default for earlier chips.

Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → Medium
summary: - vsync should be enabled by default for nvidia
+ vsync should be enabled by default for nouveau

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Changed in ubutter:
status: New → Confirmed
importance: Undecided → Medium
summary: - vsync should be enabled by default for nouveau
+ vsync is disabled by default in nouveau
description: updated
description: updated
Maarten Lankhorst (mlankhorst) wrote :

Fix is committed in upstream kernel and in nouveau ddx for all cards including kepler.
However, due to the drastic changes in upstream kernel it wouldn't be possible to backport to 3.5, unless it's decided to use a backported version of 3.7 drm there. It's not a typo, the changes are too big for 3.6 merge window.

Changed in nouveau:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nouveau - 1:1.0.2-0ubuntu2

---------------
xserver-xorg-video-nouveau (1:1.0.2-0ubuntu2) quantal; urgency=low

  [ Maarten Lankhorst ]
  * Try to enable vblank if available (LP: #1019131)
    - 100-vblank-on.diff
 -- Timo Aaltonen <email address hidden> Wed, 26 Sep 2012 14:59:24 +0300

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

Can report vsync is auto-enabled on nvidia-8400m (dell

Changed in ubutter:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers