Graphics/text corruptions in some applications with nouveau drivers

Bug #1010794 reported by Jan Rathmann on 2012-06-09
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Medium
xorg-server (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
High
Maarten Lankhorst
Precise
High
Maarten Lankhorst
Quantal
High
Maarten Lankhorst
Raring
High
Maarten Lankhorst

Bug Description

For xserver-xorg-video-nouveau sru:

[IMPACT]
 * Enables SolidFill on fermi and kepler cards, increasing performance slightly.

[TESTCASE]
 * start ubuntu software center
 * hover over some urls and icons, likely corruption already occurs at this point,
   the more you mover over the more it shows.
 * This wil not fix it completely, only make it occur less, see xorg-server below for the real fix.

[Regression Potential]
 * This should be a safe fix, since it simply enables some code which was already created specifically for these cards, and with some testing it appears to work just fine.
 * I expect no regressions, but in the worst case this would result in garbage being sent to the card, which may cause it to do an unexplained hang or (more likely) errors in dmesg and worse glitches since nothing is being shown any more.

[Other Info]
 * Doing solid fill in hardware is a pretty nice speedup for those who use valgrind to test code, and also seems to increase responsitivity a little on nouveau without valgrind, since it safes 2 memcpy's on host, 2 memcpy's on gpu, and a memset.

----
For the xorg-server sru:

[IMPACT]
 * Fallback to exa with gradients and solid pictures results in visual corruption,
   because sometimes the source or mark pixmaps from previous operations are used.
   This results in visual corruption when those fallbacks are triggered.
   The xxv-nouveau fix helps slightly because it disables fallback for solid fills,
   but gradients are still not handled so it still triggers it.

[TESTCASE]
 * Start ubuntu software center on a geforce card that has exa acceleration enabled.
 * Highlight mouse over items
 * Notice display corruption.

[Regression Potential]
 * The patch has been reviewed by upstream, but is not yet included (upstream can be slow). The most likely regression would be that suddenly other operations start failing to draw correctly, or worst case cause crashes but I do not think it is likely.

[Other Info]
See also http://<email address hidden>/msg33376.html

[Original bug report]
Hello,

there are several serious graphic and text corruptions on Quantal with nouveau drivers (which are used by default).

To reproduce:
- Boot a Quantal live system or a fresh installation
- Start software-center.
- Move the mouse in its window or click anything.
Result: Text and some graphics become massively corrupted (See also attached screenshots and short demo video).

I have seen this kind of corruption so far in software-center, ubiquity-slideshow (during installation) and one time on filename text field of gtk-filechooser.

Booting the system with "nomodeset" seems to make the problem go away, as well as installing the propritary Nvidia drivers.

Kind regards,
Jan

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-video-nouveau 1:0.0.16+git20120322+ab7291d-1
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CurrentDmesg:
 [ 14.977209] [drm] nouveau 0000:01:00.0: PMFB0_SUBP0: 0x037f0040
 [ 14.977214] [drm] nouveau 0000:01:00.0: PMFB0_SUBP1: 0x037f0000
 [ 22.821303] [drm] nouveau 0000:01:00.0: PFIFO: unknown status 0x40000000
 [ 22.920011] eth0: no IPv6 routers present
Date: Sat Jun 9 09:21:19 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard: NVIDIA Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120606.2)
MachineType: Gigabyte Technology Co., Ltd. P35-DS3
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz root=/dev/dm-5
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/10/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F13
dmi.board.name: P35-DS3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF13:bd07/10/2008:svnGigabyteTechnologyCo.,Ltd.:pnP35-DS3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP35-DS3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P35-DS3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.8-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu11
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.19.0-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20120322+ab7291d-1

Created attachment 58357
Screenshot of corruption

Various Gnome applications regularly have corrupted graphics.
Empathy, Evolution and also Ubuntu Software Center are good examples.

This has happened for a long time and also happens with a 3.2 kernel and git drivers (xorg-edgers).
I have a Radeon 6850, Intel Core i5.
Running Ubuntu 12.04 and it's kernel + xorg-edgers.

Only something being redrawn inside a window is corrupted, so I guess I suspect something EXA-related.

Created attachment 58359
Xorg.0.log

Please attach your dmesg output.

Created attachment 58368
dmesg

(In reply to comment #4)
> Created attachment 58368 [details]
> dmesg

Did you capture this before or after the problem occurred? The EQ overflows in Xorg.0.log indicate the corruption could be due to the GPU locking up repeatedly, but there's no sign of that in dmesg...

That might have been an instance of https://bugs.freedesktop.org/show_bug.cgi?id=45366
But that lockup doesn't happen every time and this happens all the time, on almost every draw operation of some type in these Gnome applications.

So to clarify, no messages of any kind are shown in dmesg och Xorg-log for this graphics corruption.

I have the following in my rc.local:
echo profile > /sys/class/drm/card0/device/power_method
echo auto > /sys/class/drm/card0/device/power_profile

*** Bug 47573 has been marked as a duplicate of this bug. ***

Has anyone tried if this happens with the upstream 6.14.3 release, or possibly even older releases? If it doesn't, can someone bisect? I haven't seen this on any of my machines.

So if I start a bisect it's xorg-driver-ati I should test?

(In reply to comment #11)
> So if I start a bisect it's xorg-driver-ati I should test?

Whichever of that or xserver / kernel you can find a good snapshot for. But the X driver seems most likely at this point.

Created attachment 58906
another screenshot

Created attachment 58907
dmesg

Created attachment 58908
Xorg.log

Hi,

attached some additional resources because i have those artifacts too.
I am using latest 3.3.0 kernel, latest Oneiric + xorg-edgers ppa too (git versions).

It's not ounly in Gnome, but also both KDE, Xfce4, so the name of the topic is wrong.
As I wrote in deleted duplication (47573) last stable version of driver works correctly.
Also I need to mention that bug not always present, it something like time intervals when it always present and time when it absent at all.

126 comments hidden view all 206 comments

...and on a not quite related note: in cairo 1.12.2 release announcement, there's a note about it having a fix for a LibreOfice problem; perhaps it's the same one, that was mentioned in an earlier comment.

Please excuse a n00b question:
Do Gnome 3 shell or Cinnammon menu use Cairo?

Both have no menus unless I xrandr to a lower resolution. The same workaround solves corruption issue noted in this thread for me.

I am in the process of learning how to apply a patch and will see if the one posted for this issue solves the menu problem as well.

Pictures posted here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668828

Is Bug#43764 a duplicate?

Thank you.

That bugs criticity just jumped hugely for me, as libcairo 1.10 is no more available in Debian Testing.

On my configuration, almost all texts are complettly corrupted for Gtk application (firefoxe, gnometerm, thunderbird, eclipse, etc), making my system mostly unusable.

Performance are also awfull, what was not the case with libcairo-1.10.

I don't know if the bug is or not in libcairo, but *clearly*, that's something that appeared with libcairo-1.12, as it is the only modification on my system between yesterday and today.

I don't use a Radeon card but a nvidia one. System info (pur Debian Sid):

* 01:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 9300M GS] (rev a1)
* xserver-xorg: 1:7.6+12
* xserver-xorg-core: 2:1.12.1-2
* xserver-xorg-video-nouveau: 1:0.0.16+git20120322+ab7291d-1
* libcairo2:amd64: 1.12.2-1

Hope it helps,

(In reply to comment #146)
> That bugs criticity just jumped hugely for me, as libcairo 1.10 is no more
> available in Debian Testing.

For your downloading pleasure:
  http://snapshot.debian.org/package/cairo/

KiBi.

(In reply to comment #146)
> On my configuration, almost all texts are complettly corrupted for Gtk
> application (firefoxe, gnometerm, thunderbird, eclipse, etc), making my system
> mostly unusable.

Since the bug is in EXA, I suppose that disabling EXA would be a temporary workaround. Is there an option for that (or can xorg provide one)?

For the nouveau driver,

  Option "NoAccel" "true"

might be useful (see the nouveau(4) man page). I haven't tried.

(In reply to comment #147)
> (In reply to comment #146)
> > That bugs criticity just jumped hugely for me, as libcairo 1.10 is no more
> > available in Debian Testing.
>
> For your downloading pleasure:
> http://snapshot.debian.org/package/cairo/

Thanks, that helped, and so my system is usable again.
I also discovered that libcairo2 1.10 is on squeeze backports.

I have a suspicion that this EXA bug is the same as I reported when testing openchrome driver.

http://wiki.openchrome.org/pipermail/openchrome-devel/2011-September/000573.html

The issue showed up now again with the current stable openchrome driver when they switched to EXA enabled by default.

The v2 patch makes the corruption look different (white box) but does not fix it.

NoAccel fixes it.

I'm pleased to report that recent changes to the Nouveau driver (I'm currently running git revision ace77b6) reduce the display corruption with cairo 1.12 to the point where the machine is usable again. However, it is not perfect: there are still some instances of corruption (for instance, large JPEGs are corrupted when downscaled to fit on the screen by Firefox) and the X server has crashed on me several times since I upgraded (seems to be an unrelated problem to do with suspend/resume).

172 comments hidden view all 206 comments
Jan Rathmann (kaiserclaudius) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
170 comments hidden view all 206 comments

(In reply to comment #151)
> I'm pleased to report that recent changes to the Nouveau driver (I'm currently
> running git revision ace77b6) reduce the display corruption with cairo 1.12 to
> the point where the machine is usable again. However, it is not perfect: there
> are still some instances of corruption (for instance, large JPEGs are corrupted
> when downscaled to fit on the screen by Firefox) and the X server has crashed
> on me several times since I upgraded (seems to be an unrelated problem to do
> with suspend/resume).

I too have this bug. I hope it is being fixed.

Fresh install of 64 bit Debian 7.0, KDE 4.8.3 version.

For me, text corruption is worst - by far - when using Iceweasel 10.0.5 on the gmail site. Text corrupts badly every few seconds. LibreOffice Writer 3.5.4.2 also has frequent problems.

Chromium 18.0.1025.151 works on gmail with only a few corruptions.

I turned off Desktop Effects, but that made no difference.

Nvidia GT 430 card, but not using the Nvida closed driver.

Other hardware:
Dell Inspiron 530
Intel Core2 Quad processor Q8200 Yorkfield
Socket LGA775
North Bridge – Intel G33
South Bridge – ICH9
8 GB RAM

Mainboard:
Foxcon
DG33M03

Monitor:
Samsung SyncMaster 2443bwx
1920x1200

169 comments hidden view all 206 comments
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1010794

tags: added: iso-testing
Maarten Lankhorst (mlankhorst) wrote :

This should be fixed with xf86-video-nouveau 1.0.1, is this still a problem?

Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)

Maarten, yes unfortunately it still happnes with nouveau 1.0.1 .

168 comments hidden view all 206 comments

 I have also corruption with large jpegs wih current radeon on r280, sometimes it laeds to logouting when page is opened with large jpegs in iceweasel(in Xorg.0.log just says eq overflowing), pages for example:

 http://vincentsanders.blogspot.com/2012/07/travels-with-mr-brown.html

(In reply to comment #153)
> I have also corruption with large jpegs wih current radeon on r280, sometimes
> it laeds to logouting when page is opened with large jpegs in iceweasel(in
> Xorg.0.log just says eq overflowing), pages for example:

That doesn't sound like this bug but maybe e.g. bug 44099.

This has also been seen with xf86-video-geode (uses EXA) on OLPC XO-1. I'd be happy to test patches or provide info needed to help with the X problem being exposed. (Also hopeful we might see an accelerated solid picture path being added to geode soon, but that is uncertain.)

Michel, you seem to be the person who edged closest to fixing the X issue; is there anything I can do to help?

(In reply to comment #155)
> Michel, you seem to be the person who edged closest to fixing the X issue; is
> there anything I can do to help?

I haven't actively worked on this in almost half a year, and I hardly remember details of my investigations beyond what's recorded here.

I'm not sure how useful it would be to fix the EXA bug without accelerating solid pictures anyway, as apps triggering the bug would probably be very slow.

170 comments hidden view all 206 comments
Jan Rathmann (kaiserclaudius) wrote :

Still present on current quantal daily image.

Jan Rathmann (kaiserclaudius) wrote :

Still present at current stage.

170 comments hidden view all 206 comments

Comment on attachment 59437
EXA: Fall back earlier and more thoroughly from exaGlyphs. (v2)

Those of you who are still hitting this, please test the patch from bug 55723.

Tried the patch on xserver 1.13... seems to have fixed all corruption for me. Everything else seems to be working fine too.

170 comments hidden view all 206 comments
Hew McLachlan (hew) wrote :

Same problem for me with a clean install of Ubuntu 12.10. Noticed in Ubiquity and Software Centre for me as well.

171 comments hidden view all 206 comments

I also tried the patch on xserver 1.13 and it fixed the graphic corruption problems I was having in Firefox. I appear to still have some graphic corruption problems in LibreOffice, though, but I lack the knowledge to check whether it is due to EXA, Cairo, or LibreOffice itself. In general, as the text is redrawn, it whites out until one clicks somewhere on the page and most of the text becomes visible once again. I recompiled the X server without the patch just to make sure that this wasn't a regression introduced by the patch, and I verified that the bug was present before I applied the patch. One way or another, this patch seems to make the situation better. I am also unable to find any notable regressions introduced by it.
For the record I have an Nvidia GTX 560 and am using Nouveau as the driver.

170 comments hidden view all 206 comments
Maarten Lankhorst (mlankhorst) wrote :

Ok seems solid fill wasn't accelerated and did a fallback, I don't know why the fallback would corrupt things though, but the acceleration will at least make it work again and increase performance slightly.

Maarten Lankhorst (mlankhorst) wrote :

Can you patch your xserver-xorg-video-nouveau with this debdiff and see if it fixes this issue?

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → In Progress

The attachment "debdiff for 1:1.0.2-0ubuntu3+bug1010794~try1" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Jan Rathmann (kaiserclaudius) wrote :

Maarten, yes, your patches helped, I don't see these corruptions anymore with the patched package.

Hew McLachlan (hew) wrote :

The corruption seems to have disappeared on text and mostly on icons, but the software centre "in progress" animated icon still displays corruption as the white arrow image appears warped and detached from the shadow behind.

Hew McLachlan (hew) wrote :

When I suspend and resume I still have full screen corruption. The mouse can move on top while the background flickers.

description: updated
Maarten Lankhorst (mlankhorst) wrote :

suspend/resume corruption is a separate bug, but still looking into why the fallback is failing

Maarten Lankhorst (mlankhorst) wrote :

So one of the sources seem to be nouveau_exa_prepare_access performing operations directly on the bo, which works but screws up due to tiling. The fix would be to do similar to nouveau_exa_download_from_screen and nouveau_exa_upload_to_screen with a scratch bo to fix up tiling. In this case it would be possible without the extra memcpy since the scratch bo could be operated on directly.

Bryce Harrington (bryce) on 2012-10-22
Changed in xserver-xorg-video-nouveau (Ubuntu Raring):
importance: Undecided → High
Changed in xserver-xorg-video-nouveau (Ubuntu Quantal):
importance: Undecided → High
Changed in xserver-xorg-video-nouveau (Ubuntu Precise):
importance: Undecided → High
Changed in xserver-xorg-video-nouveau (Ubuntu Quantal):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in xserver-xorg-video-nouveau (Ubuntu Precise):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in xserver-xorg-video-nouveau (Ubuntu Quantal):
status: New → Triaged
Changed in xserver-xorg-video-nouveau (Ubuntu Precise):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu Precise):
status: New → Confirmed
Changed in xorg-server (Ubuntu Quantal):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
status: New → Confirmed
2 comments hidden view all 206 comments
Maarten Lankhorst (mlankhorst) wrote :

The real bug seems to be in xorg-server, I linked the upstream bug for this, I would still want to have the SolidFill fix in since it provides a nice speedup.

Changed in nouveau:
importance: Unknown → Medium
status: Unknown → Confirmed
description: updated
description: updated
160 comments hidden view all 206 comments

Created attachment 69139
Backported to xserver-1.13.0

The patch wouldn't apply for me, so I reapplied it by hand to xserver-1.13.0, here it is.

Now, testing on OLPC XO-1.5 using the chrome video driver, I no longer see any text corruption in the GNOME fallback applications menu. However, the textual parts of some of the menu items are not appearing.

1 comments hidden view all 206 comments

*** Bug 55723 has been marked as a duplicate of this bug. ***

commit 1ca096d5e07221025c4c4110528772b7d94f15ee
Author: Michel Dänzer <email address hidden>
Date: Mon Oct 29 12:57:54 2012 +0100

    EXA: Track source/mask pixmaps more explicitly for Composite fallback regions.

1 comments hidden view all 206 comments
Hein (hhanssen) wrote :

Happens on my system as well. Ubuntu 12.10 with Nvidia 6400m G (Acer aspire 7520 laptop). Nvidia drivers not working properly (wrong screen resolution/ freezes/ double login (loop?!)) Because of problems with Nvidia 12.10 is only usable with Nouveau drivers, but I need to restart my desktop about 5 to 10 times a day due to artefacts that make programs rather useless. Looks like an old problem that was here before. Found also description of this problem related to Debian. Problem is not reproducable by starting certain programs.

Changed in nouveau:
status: Confirmed → Fix Released
2 comments hidden view all 206 comments
Jonathan Weber (jjm-weber) wrote :

Happens too on Dell Latitude e6530 with NVIDIA NVS 5200M. Ubuntu 12.10 using nouveau drivers.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nouveau - 1:1.0.4-0ubuntu1

---------------
xserver-xorg-video-nouveau (1:1.0.4-0ubuntu1) raring; urgency=low

  * Sync from unreleased debian experimental git.
  * Remaining differences:
    - Try to enable vblank if available (LP: #1019131)
      - 100-vblank-on.diff
 -- Maarten Lankhorst <email address hidden> Thu, 15 Nov 2012 11:02:38 +0100

Changed in xserver-xorg-video-nouveau (Ubuntu Raring):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.0-0ubuntu7

---------------
xorg-server (2:1.13.0-0ubuntu7) raring; urgency=low

  [ Maarten Lankhorst ]
  * Add 233-xf86events-valgrind.patch to fix a xserver corruption
    when acpid is stopped before Xorg is.
    (LP: #1070481)
  * Add 235-composite-tracking.patch to fix exa corruption.
    (LP: #1010794)

  [ Bryce Harrington ]
  * Add 236-use-fbdev-for-poulsbo-oaktrail-medfield.patch: Never use Intel
    driver on Poulsbo/Oaktrail/Medfield. Thanks to Matthias Klumpp.
    (LP: #1069031)
  * Add 237-dix-set-the-device-transformation-matrix.patch: Fix pointer
    jumping with absolute pointing device. Initializes device
    transformation matrix to an identity matrix. Thanks to a7x.
    (LP: #1041063)

  [ Tim Lunn ]
  * 500_pointer_barrier_thresholds.diff: Update to fix gaps above
    barriers at edge of screen
    (LP: #1073724)
 -- Bryce Harrington <email address hidden> Fri, 16 Nov 2012 11:37:26 -0800

Changed in xorg-server (Ubuntu Raring):
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2012-11-17
Changed in xorg-server (Ubuntu Quantal):
status: Confirmed → Fix Committed
Bryce Harrington (bryce) wrote :

I've also uploaded the xserver fix for quantal, but precise still needs done.

mlankhorst, did you already upload the nouveau fix for quantal-proposed and precise-proposed? If not then that still needs done as well.

Hello Jan, or anyone else affected,

Accepted xorg-server into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.13.0-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Bolick (alexey-brodkin) wrote :

I'm on Ubuntu 12.10 32-bit with GF108GLM [Quadro 1000M]
Just updated xorg-server to those latest packets 2:1.13.0-0ubuntu6.1 from proposed updates.
For 30 minutes I didn't get any visible corruptions as I saw before.

tags: added: verification-done
removed: verification-needed
Jan Rathmann (kaiserclaudius) wrote :

I can also confirm that the updated package fixes this issue.

Jonathan Weber (jjm-weber) wrote :

Same for me, bug fixed. Thanks guys.

Changed in xorg-server (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Hello Jan, or anyone else affected,

Accepted xorg-server into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.11.4-0ubuntu10.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Bryce Harrington (bryce) wrote :

No work needs done specifically for nouveau in precise and quantal; this was really an xserver problem.

Changed in xserver-xorg-video-nouveau (Ubuntu Quantal):
status: Triaged → Invalid
Changed in xserver-xorg-video-nouveau (Ubuntu Precise):
status: Triaged → Invalid
Chris Halse Rogers (raof) wrote :

Hello Jan, or anyone else affected,

Accepted xorg-server into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.11.4-0ubuntu10.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jan Rathmann (kaiserclaudius) wrote :

I have run a short test with Precise on a seperate partition (since I'm using Quantal now for daily purpose) and I didn't find any problems so far.

Hello,

I have tested Edubuntu amd64 (e37ee30822fc8ca0697c32bf2035d4ac *raring-desktop-amd64.iso 20130116), on live usb persistent, because this bug (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1009353), I have reported on Lubuntu amd64 (precise).

I have performed these action:
1) enabled the repository proposed;
2) sudo apt-get update.
3) sudo apt-get upgrade.

I confirmed this fix.

I am available for verify this bug on Lubuntu-precise-amd64.

Thank

Giovanni Tornatore

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.11.4-0ubuntu10.11

---------------
xorg-server (2:1.11.4-0ubuntu10.11) precise-proposed; urgency=low

  * Drop 237-dix-set-the-device-transformation-matrix.patch:
    Bug was targeted to precise, but is only confirmed to affect xserver
    1.13 and newer.
    (LP: 1041063)

xorg-server (2:1.11.4-0ubuntu10.10) precise-proposed; urgency=low

  * Add 237-dix-set-the-device-transformation-matrix.patch: Fix pointer
    jumping with absolute pointing device. Initializes device
    transformation matrix to an identity matrix. Thanks to a7x.
    (LP: #1041063)

xorg-server (2:1.11.4-0ubuntu10.9) precise-proposed; urgency=low

  [ Maarten Lankhorst ]
  * add 233-xf86events-valgrind.patch to fix a xserver corruption
    when acpid is stopped before Xorg is. (LP: #1070481)
  * add 235-composite-tracking.diff to fix exa corruption. (LP: #1010794)
 -- Bryce Harrington <email address hidden> Wed, 19 Dec 2012 16:39:23 -0800

Changed in xorg-server (Ubuntu Precise):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Hello Jan, or anyone else affected,

Accepted xserver-xorg-video-nouveau into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/1:1.0.3-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-nouveau (Ubuntu Quantal):
status: Invalid → Fix Committed
tags: added: verification-needed
removed: verification-done
Jan Rathmann (kaiserclaudius) wrote :

Hello Steve,

I'm a bit confused, from my point of view the fix for this bug has been in Quantal since end of last November, and I had verified the fix at that time (see comments 191 - 193).

Also testing again would be a bit hard since I'm on Raring since its release and I currently don't have a partition with Quantal on my system anymore. However, if it is really necessary, I could try to test with booting from an USB stick and selectively installing the respective updates.

Kind regards,
Jan

The fix for this bug has been awaiting testing feedback in the -proposed repository for quantal for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

downgrading xorg-server and xorg-video-nouveau triggers it, only updating nouveau fixes it. verification-done. :P

tags: added: verification-done
removed: removal-candidate verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nouveau - 1:1.0.3-0ubuntu0.2

---------------
xserver-xorg-video-nouveau (1:1.0.3-0ubuntu0.2) quantal-proposed; urgency=low

  * Revert kwin fix, it caused a regression.
    - 101-Revert-nouveau-dri2-fix-pixmap-window-offset-calcs.patch

xserver-xorg-video-nouveau (1:1.0.3-0ubuntu0.1) quantal-proposed; urgency=low

  [ Maarten Lankhorst ]
  * New upstream bugfix release
  * Fix SIBABRT in NVRefreshArea (LP: #1056511)
  * Fix race condition in vblank
  * Add solid fill acceleration (LP: #1010794)
  * Cleanup download/upload screen functions (LP: #1010794)
  * Fix prime rendering with kwin

xserver-xorg-video-nouveau (1:1.0.3-1) UNRELEASED; urgency=low

  [ Maarten Lankhorst ]
  * New upstream release.
  * Drop 02-drm-nouveau-newabi.patch and require libdrm 2.4.34

  [ Timo Aaltonen ]
  * watch: Use the .gz tarball, and update the url.
 -- Maarten Lankhorst <email address hidden> Thu, 28 Feb 2013 12:35:09 +0100

Changed in xserver-xorg-video-nouveau (Ubuntu Quantal):
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 206 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.