Edgy upgrade breaks multiple Matrox cards

Bug #58721 reported by Thomas Kaschwig on 2006-09-03
104
Affects Status Importance Assigned to Milestone
Edgy Backports
Undecided
Unassigned
xserver-xorg-video-mga (Debian)
Fix Released
Unknown
xserver-xorg-video-mga (Ubuntu)
High
Rodrigo Novo

Bug Description

I have a MGA200 (PCI version) and I had no problems with X.org 7.0 on Ubuntu Dapper. Today (2006-09-03), I have updated to Edgy and the `mga' driver doesn't work anymore.

I have noticed the same effects described in this thread:
http://ubuntuforums.org/showthread.php?t=235087

Now, I am only able to use the VESA driver and a resolution of 1024x768, instead of 1600x1200. :-(

If you need more information (e.g. log files), just answer to this bug report or send me an email.

--Thomas

description: updated
David Planella (dpm) wrote :

I can confirm this bug, which also appears in my system.

My graphics card is an MGA G200 AGP, and the behaviour I get is that when GDM starts, my monitor goes into power-saving mode complaining that its maximum frequency has been reached. I double-checked the frequency ranges in /etc/X11/xorg.conf and they seem to be ok. In fact, they did not change from Dapper.

At the moment I am also using the VESA driver, with which I can only get a resolution of 800x600.

Warren Butler (grumpymole) wrote :

I can also confirm this.

I can get the higher resolution, but only at low frequency.

Previously, I have been able to run the MGA200 at 1024x768 at 85Hz. Now, if I try this the monitor shows a message saying not able to sync.

Dell Optiplex PC running Xubuntu Edgy with latest updates. Worked without any problems in Dapper.

Attached to this comment, you find a not working X.org 7.1.1. configuration for a Matrox MGA200 card at 1600x1200@60Hz. The same configuration (created with `dpkg-reconfigure xserver-xorg') worked perfectly with X.org 7.0 on Dapper Drake.

I hope the attached X.org log files helpes to find the bug in the `mga' driver on Edgy. I used the configuration file attached in the former comment, which was created on Edgy with `dpkg-reconfigure xserver-xorg', but with the same specifications I used for this card on Dapper.

Interestingly, X11and my window manager seem to start, when I run `startx', but the monitor becomes black.

I have found a workarround to use the `mga' driver again: I activated the kernel framebuffer interface in the device section of the X.org configuration file /etc/X11/xorg.conf (Option "UseFBDev" "true").

Section "Device"
        Identifier "Matrox Graphics, Inc. MGA G200"
        Driver "mga"
        BusID "PCI:1:6:0"
        Option "UseFBDev" "true"
        Option "OldDmaInit" "True"
EndSection

I haven't tested it with the default ubuntu kernel, but with my self-compiled 2.6.18-rc6, I had to load the `matroxfb_base' before starting the X-Server. If you compile the matrox framebuffer into the kernel, you shouldn't notice any problems. If you have compiled it as a module, you should add `matroxfb_base' to your /etc/modules file.

David Planella (dpm) wrote :

I can confirm that after applying the workaround described by Thomas, I can use the 'mga' driver again.

Many thanks!

Note: I've got a standard kernel and 'matroxfb_base' was compiled as a module.

David Planella (dpm) wrote :

While researching a bit about this, I found this couple of threads on the xorg mailing list, which may be relevant to this bug.

http://thread.gmane.org/gmane.comp.freedesktop.xorg/7169/
http://thread.gmane.org/gmane.comp.freedesktop.xorg/7146/
http://thread.gmane.org/gmane.comp.freedesktop.xorg/10483

BTW, as I said, I've been using mga over the framebuffer now. It is not 100% satisfactory speedwise (no direct rendering?), but still better than using the vesa driver.

Changed in xserver-xorg-video-mga:
status: Unknown → Unconfirmed
Felix Miata (mrmazda) wrote :

Is Bug #64853 a duplicate of this? It looks like anything that should be using the mga driver has the same problem. My G400 works fine except with edgy.

bjoh (jb-5pm) wrote :

Bug +64853 may very well be a duplicate. Before I filed it, I read this bug report and saw the framebuffer workaround, which did not work for me.

I saw a thread in the German Gentoo forum which seems to describe the same problem:
http://forums.gentoo.org/viewtopic-p-3599547.html?sid=609d2e8a4591382ae3dcd029518338a9

The last comment says that after the mga driver was updated to 1.4.2, the problem was resolved. So I forced xserver-xorg-video-mga-1.4.2 from the Debian unstable repositories onto my Edgy installation, and X11 started without problems. I guess the DRI fix mentioned here

http://article.gmane.org/gmane.comp.freedesktop.xorg/11588/

did it.

Pascal (pascaldekloe) wrote :

Mikrorechner seems to be right. It worked for me too.

Please upgrade the package as soon as possible since Edgy is already a release candidate! :@

Fred (frederic-lespez) wrote :

I build xserver-xorg-video-mga-1.4.2 on Edgy from Debian unstable package and it fix the problems I have experienced since my upgrade from Dapper.

I found out that the framebuffer trick improve things further (GoogleEarth doesn't work without it even after upgrading the package).

I am using a MATROX G550 AGP.

I also found out that this bug prevents me for using wine, see :
https://launchpad.net/distros/ubuntu/+source/wine/+bug/64705

Please upgrade the package before Edgy goes out since it causes real regressions from Dapper to Matrox card users.

Regards,
Fred

Paulo J. S. Silva (pjssilva) wrote :

I have the same problem in a system with a g400.

After updating to edgy I had to manually change the resolution in my system to 1152x864 @ 75 Hz (and I see the flickering under this rate).

I have compiled the new Debian package to cleanly install in Ubuntu. Anyone can download it here:

http://www.ime.usp.br/~pjssilva/xserver-xorg-video-mga_1.4.2.dfsg.1-1_i386.deb

and install it as a work around (I hope I don't bring too much trafic to my site...).

If this bug is closed in an update to edgy, the person should manully uninstall the package to get the update, as it is named with a higher version number.

Please fix this... Is is a major regression for Edgy.

Since my update from 6.06 to 6.10 yesterday X is no longer working for me. The graphics adapter is a Matrox G400 which was working without problems with all previous Ubuntu versions. The problem is: X seems to start but the monitor remains black, just the following on screen error message is display:

Monitor IBM P260
-----------------
INPUT 18.3 KHz / 15 Hz
OUT OF SCAN RANGE
CHANGE SIGNAL TIMING

I guess my problem is related to this bug. Unfortunately the update to mga 1.4.2 has not happened before the release of 6.10. :-(

Xorg.0.log:
---------------
(II) LoadModule: "mga"
(II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
(II) Module mga: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.4.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 1.0

Andrew Ash (ash211) wrote :

Manfred makes the 7th(?) time this bug has been confirmed. The others I count from this thread are Paulo, Fred, mikrorechner, Bernat, Warren, and the initial reporter Thomas.

The importance should also clearly be High for an X server crash, (https://wiki.ubuntu.com/Bugs/Importance) though I don't have the privileges to make this change.

Changed in xserver-xorg-video-mga:
status: Unconfirmed → Confirmed
chippy99 (carpenter-john) wrote :

Same problem here. G400 card, get refresh rate out of range error after logging in. All worked fine prior to upgrade to edgy. From the other number of posts about this it definitely is a bug and it would be really nice if it was fixed soon.

BTW I was just telling a guy how he should switch to Ubuntu when this happened ;>{

My Matrox Millenium II (4MB) is also not working with Edgy. In dapper everything was ok.

Andrew Ash (ash211) wrote :

Here are the cards people have mentioned so far that are broken by the edgy upgrade:

Matrox MGA200 (PCI)
Matrox MGA G200 (AGP)
Matrox MGA G400
Matrox MGA G550 (AGP)
Matrox Millenium II (4MB)

I'll change the bug title to reflect this.

Matt Zimmerman (mdz) on 2006-10-28
Changed in xserver-xorg-video-mga:
assignee: nobody → rodarvus
Tim Aretz (t-aretz) wrote :

I can confirm that as well, no update, but fresh installation of xubuntu edgy.
Card is a Millenium G400 (AGP).
highest resolution I can choose is 800x600 and 60Hz refresh rate. It's a pain in the eyes...
Previous install of Kubuntu Dapper worked fine.

Tim Aretz (t-aretz) wrote :

edit:
Just applied Paulo's driver, now everything is as it should be... thanks!
And I agree, it's an important bug!

Todor Todorov (tilkov) wrote :

I can confirm that ( bug #65876 ) with Matrox G200 AGP.

dsurber (dnsurber) wrote :

I just upgraded from Dapper to the release version of Edgy and the mga driver does not work. I am using a G550 AGP. I have tried both the mga driver installed with the upgrade and the mga driver from Matrox which is substantially larger.

I've just switched from Win2k to Ubuntu and thought it was very nice. Hitting this bug and then finding it was known well before the release and yet was not fixed does not increase my happiness.

Terry S (terry-shuttleworths) wrote :

I installed Paulo's deb above (thank you, Paulo).

It got my Matrox G400 Dual-Head working on one screen, but it doesn't seem to include mga_hal:

(from Xorg.0.log)
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Reloading /usr/lib/xorg/modules/libvgahw.so
(--) MGA(1): Chipset: "mgag400" (G400)
(EE) MGA(1): This card requires the "mga_hal" module for dual-head operation
 It can be found at the Matrox web site <http://www.matrox.com>
(II) UnloadModule: "mga"
(II) UnloadModule: "vgahw"

I've tried the workaround at http://www.tuxx-home.at/projects/mga/HOWTO_mga_Xorg7, but that version of mga_hal fails the version-check

(from Xorg.0.log [different run, obviously])
(II) Loading sub module "mga_hal"
(II) LoadModule: "mga_hal"
(II) Loading /usr/lib/xorg/modules/drivers/mga_hal.o
(II) Module mga_hal: vendor="X.Org Foundation"
 compiled for 6.8.1, module version = 4.1.0
 ABI class: X.Org Video Driver, version 0.7
(EE) module ABI major version (0) doesn't match the server's version (1)
(II) UnloadModule: "mga_hal"
(II) Unloading /usr/lib/xorg/modules/drivers/mga_hal.o

I've tried compiling the mga source, but I keep getting an error I don't know how to fix (looks like something about variable types)

Can anyone put together a Paulo-type fix which includes a compilation of mga_hal that won't get rejected ?

Terry

Cory Albrecht (bytor) wrote :

I tried Paulo's compile of xserver-xorg-video-mga-1.4.2 but it did not work for me. :-( All I get is a bunch of squares on the screen as if the driver were writing to video memory in the format for mode <X> but the card is reading its memory for display as if it were formatted for mode <Y>.

The machine is an Asus P2B-D with a Matrox G200 AGP, and the vesa driver with Edgy Eft is refusing to do more than a 60Hz refresh rate. For me this is significant because I have epilepsy and 60Hz literally makes me feel like I am about to have a seizure. :-P Quite disappointing after switching from Dapper where I had it in 1152x864 and 75Hz refresh.

I'm also experiencing this problem with a G550 on amd64 which means I can't use Paulo's deb. I tried to compile from the Debian unstable package but that didn't work (probably because I'm not familiar with the compilation process).

Is anyone else concerned that this critical bug which affects multiple video cards has yet to be given a status by the Ubuntu dev team? The package maintainer hasn't even responded to the bug which was reported nearly 2 months ago. It'd be nice to have the upgrade system warn us about critical bugs like this before installing new packages which break our systems.

tmp (skrald) wrote :

I can indeed confirm this bug on my G550.

As William Mckee says: This bug should have been marked as critical for ages ago.
If I had just known about the bug, I would never have upgraded as my system is now broken. :-(
The upgrade mechanism should have warned about it.

Can anyone (the maintainer?) please provide a status report for this bug and some estimate for when a bugfix will be available?

I had the same problems with my ancient Matrox Mystique (Monitor shows frequency out of range)

I solved it by turning on the ShadowFB option:

Section "Device"
        Identifier "Matrox Graphics, Inc. MGA 1064SG Mystique]"
        Driver "mga"
        BusID "PCI:0:12:0"
        Option "ShadowFB" "true"
        Option "OldDmaInit" "True"
EndSection

(The OldDmaInit options seems not to matter)

I had to specify the HorizSync and VertRefresh options for my monitor.
Now it works with a resolution of "1024x768" and a Depth of 16.

I had the same problem when installing Dapper.

Thank you: I fixed it by setting the "ignoreABI" switch when starting
Gnome. Not the best way, but it works for now

On 11/1/06, Alexander Federlin <email address hidden> wrote:
> I had the same problems with my ancient Matrox Mystique (Monitor shows
> frequency out of range)
>
> I solved it by turning on the ShadowFB option:
>
> Section "Device"
> Identifier "Matrox Graphics, Inc. MGA 1064SG Mystique]"
> Driver "mga"
> BusID "PCI:0:12:0"
> Option "ShadowFB" "true"
> Option "OldDmaInit" "True"
> EndSection
>
> (The OldDmaInit options seems not to matter)
>
> I had to specify the HorizSync and VertRefresh options for my monitor.
> Now it works with a resolution of "1024x768" and a Depth of 16.
>
> I had the same problem when installing Dapper.
>
> --
> Edgy upgrade breaks multiple Matrox cards
> https://launchpad.net/bugs/58721
>

Tim Newsome (nuisance) wrote :

I had a problem running mythtv 0.20, which ended up being solved by installing Paulo's .deb file. (Thank you very much.) The symptom is that you'd run mythtv, it would print out a bunch of stuff ending with:
2006-10-31 19:52:25.252 Using the Qt painter

Then it would sit there and not do anything. Strace reveals it's waiting for an ioctl to complete. Anyway, I just wanted to add that to this incident so maybe people will find it if they search for a mythtv failure. This really should be fixed in edgy asap. The fix is simple, and the problem is fairly bad.

I got an old matrox g400 dualhead (agp 4x) and see the same faults as described above.
I hope that the status of this bug will change soon from undecided.
It should not be a big problem to update a single driver to the next subversion.
What do you need to decide?
The current driver does not work with any gl-application.
Nearly evrything uses gl nowadays - even starting a simple swing application in eclipse...
I think in this situation you can only decide to give the latest driver a chance. It should not be worse as some people already stated that it's working for them.

Andrew Ash (ash211) wrote :

Added a reference to this bug in https://wiki.ubuntu.com/EdgyKnownIssues

I just tried the 1.4.2 with my old mga 400 dualhead (agp4x) but this did not fix the problem. glxinfo did not hang but when starting any gl application (tried glxgears, ppracer) the whole system hang, only hard reset possible. So that's not a [complete] solution - strange...
I also tried that matroxfb_base line in /etc/modules and to use fb but that did not work for me. Vesa is no choice as i only get 800x600 resolution instead of 1280x1024 on a tft...

Michael Vogt (mvo) on 2006-11-04
Changed in xserver-xorg-video-mga:
importance: Undecided → High
Paddy Clark (paddy-clark) wrote :

Same problem on a G400. Strangely logging into xfce doesn't go out of scan range.

gonzolero (hubertlombard) wrote :

Bonjour à tous :)

On my workstation with a Matrox G400 graphic card, Edgy can't start and comes with an error message : "X server can't start..." (or something of the same kind). I'm obliged to change "mga" by "vesa", i'm limited at 800x600 and meet slow performances.
It was fantastic on Dapper, and worked very fine ;)

Andrew Ash (ash211) wrote :

Yes, regressions are alway disappointing :( Let's try to limit further comments to new information relating to the bug.

Thanks for working with us, guys, and I bet the Ubuntu devs are well aware of this problem.

David Sauvage (pariakanet) wrote :

[concerning i386 platform]
Please notice that the Debian testing xserver-xorg-video-mga_1.4.2.dfsg.1-1_i386.deb package does not contain this bug, it could be interesting to backport this package in Ubuntu,

A workaround to get a Matroc card working with the rigth resolution in Ubuntu Edgy is to force the install of this package
$ sudo dpkg -i --force overwrite xserver-xorg-video-mga_1.4.2.dfsg.1-1_i386.deb

Please note that this workaround let the system will unresolve dependencies ...

Is there any estimation about the time it will take to fix this bug?
I don't want a concrete date (even it that would be nice).
Something like 'up to a week' or 'at least a month' would give me a chance to chose whether to buy another graphics card as I don't have the time for debugging device drivers for about 5 years old hardware which worked better before 4 years than about the last 2.

tmp (skrald) wrote :

I agree that some response from the package maintainer(s) would be nice. Currently this bug seems to be ignored. When will it be fixed?

yellow (yellowshark) wrote :

Hi Folks,
just to highlight the importance: Got the Problem on Matrox G550 Dual, too. I'd prefer to have a real fix than the work arounds. Just because I know I'll forget what I've done. And the system gets more and more impure by funny work arrounds. Chees, Seb

PS: Google Earth does not work for me eather.

Matti Nuortio (matti-nuortio) wrote :

This 800x600 workaround starts to be a real pain. In case this bug is not fixed very soon, I'll just give up and purchase a new graphics card. Matrox Parhelia has not thus far been listed among the affected cards. Does this bug exist also on Parhelia? -- M. Nuortio, Oulu, Finland

John Dong (jdong) wrote :

http://buntudot.org/people/~jdong/backports/edgy/58721/xserver-xorg-video-mga_1.4.4.dfsg.1-1~6.10prevu1_i386.deb

I've made a test backport of debian sid's mga driver. Please confirm whether or not this resolves the issue, so we can move forward.

Cory Albrecht (bytor) wrote :

Didn't even install for me. :-)

[cory@fenris] 12:43:57 [7]~> sudo dpkg --install xserver-xorg-video-mga_1.4.4.dfsg.1-1~6.10prevu1_i386.deb
(Reading database ... 107912 files and directories currently installed.)

Preparing to replace xserver-xorg-video-mga 1:1.4.2.dfsg.1-1 (using xserver-xorg-video-mga_1.4.4.dfsg.1-1~6.10prevu1_i386.deb) ...

Unpacking replacement xserver-xorg-video-mga ...

dpkg: dependency problems prevent configuration of xserver-xorg-video-mga:

 xserver-xorg-video-mga depends on xserver-xorg-core (>= 2:1.1.1); however:

  Version of xserver-xorg-core on system is 1:1.1.1-0ubuntu12.

dpkg: error processing xserver-xorg-video-mga (--install):

 dependency problems - leaving unconfigured

Errors were encountered while processing:

 xserver-xorg-video-mga

sorry, I am a moron. i will fix that when i get home .

On 11/18/06, Byor <email address hidden> wrote:
> Didn't even install for me. :-)
>
> [cory@fenris] 12:43:57 [7]~> sudo dpkg --install
> xserver-xorg-video-mga_1.4.4.dfsg.1-1~6.10prevu1_i386.deb
> (Reading database ... 107912 files and directories currently installed.)
>
> Preparing to replace xserver-xorg-video-mga 1:1.4.2.dfsg.1-1 (using
> xserver-xorg-video-mga_1.4.4.dfsg.1-1~6.10prevu1_i386.deb) ...
>
> Unpacking replacement xserver-xorg-video-mga ...
>
> dpkg: dependency problems prevent configuration of xserver-xorg-video-
> mga:
>
> xserver-xorg-video-mga depends on xserver-xorg-core (>= 2:1.1.1);
> however:
>
> Version of xserver-xorg-core on system is 1:1.1.1-0ubuntu12.
>
> dpkg: error processing xserver-xorg-video-mga (--install):
>
> dependency problems - leaving unconfigured
>
> Errors were encountered while processing:
>
> xserver-xorg-video-mga
>
> --
> Edgy upgrade breaks multiple Matrox cards
> https://launchpad.net/bugs/58721
>

John Dong (jdong) wrote :

http://buntudot.org/people/~jdong/backports/edgy/58721/xserver-xorg-video-mga_1.4.4.dfsg.1-1jdong1~6.10prevu1_i386.deb

Please try this package. Had to bump another epoch down to 1 in debian/control.

Cory Albrecht (bytor) wrote :

WOOHOO! It works! Thanks, man!

Hi John Dong,

thank you very much for your work!
It works for me, too :-)
I got an old Matrox g400 (Agp 4x) dualhead.
glxgears now works and I got no artifacts in the right side of
my window, seeing videos and the refresh rates are now ok, too.
(I did not try the second head as i currently have no space for a second device...)

Kind regards,
Peter

tmp (skrald) wrote :

Great! It works perfectly! Thanks!

Matti Nuortio (matti-nuortio) wrote :

Infinitely many thanks, John Dong! At first that update did nothing very much useful: "mga" instead of "vesa" in /etc/X11/xorg.conf started to work, yes, but I still got only maximum resolution 800x600. This however appears to be due to my actual physical screen configurations; now that I added the correct hsync and vertrefresh values, everything works in 1024x768@85Hz MGA mode just fine.

So let's agree that this .deb seems to resolve the bug. Thanks again.

Oh, and for further note: My card is Matrox Millennium G450, five years old, and monitor is LG 99G 19", five years old.

-- Matti Nuortio, Oulu, Finland

John Dong (jdong) wrote :

An authorized developer, please ACK a sync of xserver-xorg-video-mga >=1.4.4 from Debian Sid, as it has been confirmed to fix this bug ... Afterwards, the Backports team will perform a manual upload of this package to edgy-backports.

jdong@jdong-laptop:~/tmp/backports$ madison-lite xserver-xorg-video-mga
xserver-xorg-video-mga | 1:1.4.1-0ubuntu1 | edgy | source, i386
xserver-xorg-video-mga | 1:1.4.1-0ubuntu1 | feisty | source, i386
xserver-xorg-video-mga | 1:1.4.4.dfsg.1-1 | unstable | source, i386

Michal Suchanek (hramrach) wrote :

Yes, I cannot see anything with Matrox G400 AGP with the Edgy driver and cannot install Edgy either (it probably uses X in installer).

I compiled latest drm/mesa/mga, and it works quite well. OpenGL works for me even better than with the Dapper driver.
However, the latest drivers tend to crash on console switching (would probably apply to the 1.4.4 driver as well).

John Dong (jdong) wrote :

Just an update on the fixing situation... I've talked to Roderigo a bit, and he's basically saying that currently Xorg 7.2 is his highest priority and after that gets uploaded to feisty, he'll prepare a fiesty package for Debian Sid's mga driver.

At that point, we can introduce the fix to edgy-backports. Right now without the Feisty package, I'm powerless to do anything officially to remedy this bug....

Sorry for the long wait... :(

e-maj (dannytherocker) wrote :

I had the same trouble on my old pc ! just installed the .deb file and everything seems to be fine but the loading logo: it does not appear, my screen is black! The only way to get it appeared is to add "vga=771" to grub line but logo is out of screen and at the end of loading get an HAL error.....
What can I do ??

clubsoda (clubsoda) wrote :

Hello,
Running Xubuntu Edgy here.

After upgrading to a G550 (AGP, single head DVI), my system suffered:-
1) crash upon display of login window
2) can't even boot the install CD
3) Xfce rodent very dark (black screen) during boot with LCD dropout - "No Signal"
Thank-you Thomas for the FBDev hack which fixed #1.

4) glxgears blank
Thank-you John for the recompiled library which fixed #4.

Somthing is still wrong though:-
5) flickering display
6) MGA reports "VideoRAM: 16384 kByte" but card is 32MB
7) MGA reports "PixClock max 130 MHz" but probe of monitor reports 1200MHz maximum.

Problem #7 prevents 75Hz display, which I thought was the cause of the flickering, but it turns out Windows only runs 60Hz but displays beautifully with the drivers from Matrox. In linux, when fsck runs I can see that even the low-res console text is flickering.

Edgy includes Xorg 7.1.1 but the installation script for the official Matrox drivers crashes (supports up to version 7.0.0 only). According to the readme file, DVI output requires the proprietary "hal" driver, so maybe I'm lucky to be seeing anything at all. I am considering downgrading my Xorg to version 7.0.0 until Matrox upgrade their driver or release their source code.

[On a side note, is it reasonable to expect Matrox to compile so many drivers? New versions of Xorg seem to come out every few months, compared to Windows every few years, so it's like 10 times the work for 10% of the customers.]

chris (christoph-bodner) wrote :

A very easy work-around is to append "vga=795" as a kernel parameter in /boot/grub/menu.lst, e.g. in the line directly after "...ro quiet splash" if you have a 1280x1024 display. Take an appropriate other value for a different screen resolution (773 for 1024x768). This enables the frame buffer mode for the mga driver. Unfortunately, this hack does not activate 3D graphics (mga_hal or something like that).

This has been tested on a Matrox G450 card and allows you a reasonable "xvideo" output in VLC.

I hope that a new, fixed package "xserver-xorg-video-mga" will be available soon.

clubsoda (clubsoda) wrote :

Update: I have discovered that the flickering problems are associated with the framebuffer. (Perhaps because my AGP 1x interface is too slow?) The flickering is subtle but can easily be seen by clicking on the "Quit" icon to exit Ubuntu while you still have a terminal window open, or any other large black spaces on the screen. These will go crazy colours and dance around a bit...

However, if I disable the framebuffer in both xorg.conf and /etc/modules and try what Thomas did in his original post, i.e. replace "mga" with "vesa", it works! Not only pristine 1280x1024 text but glxgears too. (Ahem, please don't ask about the frame rate. :) One small issue: if I go into Display Settings and change the resolution, X crashes.

Someone please reassure me that when the mga driver is working properly I won't need the framebuffer.

Michal Suchanek (hramrach) wrote :

What kind of monitor are you using with the mga card?

There are lots of problems when using dvi digital panels with Matrox cards.

Anyway, if you do see something it is different from original problem.

cyber_rigger (cyber-rigger) wrote :

With a Matrox g400 AGP my 3D acceleration is broken.
I am using the 'mga' driver.

I get this error message when attempting to start a 3D program
such as ppracer.

libGL warning: 3D driver claims to not support visual 0x4b

This card works fine with Dapper and Debian sarge, etch installs.

Fred (frederic-lespez) wrote :

Cyber_rigger :
Have you tried to add Option "UseFBDev" "true" in your xorg.conf as explain by Thomas Kaschwig in one of his comments ?

Mark Lapidge (mlapidge) wrote :

I have a G450 low profile which didn't work with the mga driver and Xorg server 7.1 supplied with edgy eft when using DVI out and a digital flat panel display. My copy of edgy was unmodified except for the application of any recommended updates.

None of the above solutions worked for me ie. attempting to use a FrameBuffer or ShadowFrameBuffer, installing the modified driver from John Dong and tweaking and adding Options and Modelines etc. in /etc/X11/xorg.conf

Those with the same or similar problems as described in this bug report might try installing the modified mga drivers from Alexander Griesser's Unofficial Matrox Technical Support Forum at http://matrox.tuxx-home.at which he has set up in as an alternative to the recently demised Official Matrox forum.

I downloaded the MGA Driver v4.4.2 installation kit from the G-Series Downloads section and rather than running the install script just extracted it to a directory and then replaced the mga driver (mga_drv.so) which in my installation is at /usr/lib/xorg/modules/drivers with the driver from the xserver/7.1.0 sub-directory created during the extraction.

The HAL driver also appears to be required (mga_hal_drv.so) so I put this in the same place and then configured the X server to start with the -ignoreABI option which is a requirement of using these modified drivers.

This can be done in the /etc/gdm.conf-custom file by creating a [standard-Server] entry identical to the one in the gdm.conf file and adding the above option to the X server command line thus:

# Definition of the standard X server.
[server-Standard]
name=Standard server
command=/usr/X11R6/bin/X -ignoreABI -br -audit 0
flexible=true

Thereafter X starts successfully after edgy has booted and I can switch between any of the supported resolutions in DVI out mode.

cyber_rigger (cyber-rigger) wrote :

I got my g400 working WITH 3D acceleration.
I am getting a good frame rate.
I am not using a kernel framebuffer.

I'm using the driver posted above by John Dong, i.e.,
http://buntudot.org/people/~jdong/backports/edgy/58721/xserver-xorg-video-mga_1.4.4.dfsg.1-1jdong1~6.10prevu1_i386.deb
It installed fine for me (once I remembered how to do a local repository).

I do still get this same warning as before:
libGL warning: 3D driver claims to not support visual 0x4b

I do still get a very dark screen at boot time.

cyber_rigger (cyber-rigger) wrote :

I've been using the xserver-xorg-video-mga_1.4.4.dfsg.1-1jdong1~6.10prevu1_i386.deb
driver for a while now with a g400.
I've had some random X crashes, most noticeably with gnome-screensaver. I have also noticed that some of the 3D animations render incorrectly. For example the 'Engine' screensaver appears to render out of order having hidden parts showing where they should not.

The 3D animations in xscreensaver seem to work fine so far.

The initial boot, which I'm assuming is a vesa driver, is still very dark.

cyber_rigger (cyber-rigger) wrote :

I tried the mga driver posted above by Paulo J. S. Silva.
with a g400 agp.
i.e.
http://www.ime.usp.br/~pjssilva/xserver-xorg-video-mga_1.4.2.dfsg.1-1_i386.deb

The installation worked, the 2D display worked
but I would get a total machine lockup when I tried to display 3D
animations from either gnome-screensaver or xscreensaver.
I gave up at this point.

Fred:
I stiil haven't tried the matroxfb_base approach.
Are there some step by step instructions (for the compiling impaired people like me)?

Without matroxfb using a framebuffer just prevents X from starting.

Fred (frederic-lespez) wrote :

Cyber Rigger :
Here is what i have done :
Modify /etc/X11/xorg.conf to add
Option "UseFBDev" "true"
Modify /etc/modprobe.d/blacklist-framebuffer to comment (by adding a leading #) the line about matroxfb_base :
#blacklist matroxfb_base
This way, the matroxfb_base module will be loaded automatically at boot time.
As it is stated in the header of this file, this can "cause suspend failures, kernel panics and general mayhem."
So before doing this check you have an ubuntu live CD by hand in order to reverse this modification if anything goes really bad.
Hope it works for you as it works for me. But as we have different cards, i can warranty you anything.

It's realy annoying. After getting some automatic x-server updates my computer crashes after some minutes logged into kde. I do not look for a solution anymore. As there is nothing done to prevent such things obviously. I don't want to vi in configurations for days...
I hoped ubuntu was a special distribution which really tried to keep such things away from the user. But as my experience now shows that is not the case. I did not have such problems in the days before kde with any slackware-snapshot...
Just go on and support the latest graphics hardware to be able to play the latest shooter-games in linux, too.
But don't claim to be a distribution for the people anymore, please...

As some things never change, I just tried the inofficial kernel modules from
here:
http://matrox.tuxx-home.at/viewtopic.php?t=50

I had to adjust /etc/kde3/kdm/kdmrc:
I added the parameter (-ignoreABI) to enable the usage of hal-drivers not exactly built for that x-version:
ServerArgsLocal=-ignoreABI -nolisten tcp

Hope that helps someone having a g400, too.
I still use the mga-driver of john dong, see above.
This dirver now works again for me.
Hope that the fixes will be included soon, to enable people who are not familar using bash and vi to use their old or new second hand hadware.

cyber_rigger (cyber-rigger) wrote :

Fred:

Here is what I tried (Matrox g400)
using the regular distro packages/modules.

I shut down X (killall gdm)
I used modconf to load matroxfb_base.
I restarted X (gdm).
X works but still no 3D acceleration.

I shut down X again.
I used 'dpkg-reconfigure xserver-xorg' to use the kernel framebuffer
(this adds Option "UseFBDev" "true" to xorg.conf).
The module matroxfb_base is still loaded.
X would not start (gdm).

Fred (frederic-lespez) wrote :

Cyber Rigger :
matroxfb_base must be loaded as soon as possible.
If it is loaded after X has been started once, the behavior is not the same. As least it is like this on my machine.
So after a modification i think you should try to boot the machine to reset the graphic card...
I really don't know if it will work...
Hope it helps.

cyber_rigger (cyber-rigger) wrote :

Fred:

I still couldn't get it to work.

I used modconf to load matroxfb_base.
I edited /etc/modprobe.d/blacklist-framebuffer and commented out 'blacklist matroxfb_base', i.e.
# blacklist matroxfb_base.
I configured xorg.conf with Option "UseFBDev" "true" .

I rebooted. I got the same very dark boot screen with the Ubuntu logo. I'm assuming this is a vesa driver. When gdm should have started I got an X crash.
Here are the X errors:
(EE) Unable to find a valid framebuffer device
(EE) MGA(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons

The module matroxfb_base showed to be loaded.

Val3r10 (vleomporra) wrote :

Thanks for working on this problem, and for all those workarounds.
But, what about such people like me, who's not using i386 architecture ?

Actually I'm having the same problems with both Ubuntu Edgy (FH3 doesn't work at all...) and Debian Etch on my powerpc64 IBM RISC 6000 box.

Any hint or workaround for live/install -powerpc64 ???

Thank you so much

Martin (lodp) wrote :

I've got a Matrox Mystique 220, and I was experiencing the problem described in the original report (monitor gave me "Signal out of Range" when using the mga driver). The package posted by John Dong above fixes that problem, but when I drag around windows etc. I get display errors, as you can see on this screenshot: http://img349.imageshack.us/img349/673/bildschirmphoto1az2.png

It was the same thing when I tried one of the workarounds described above, before John Dongs package was released (comment out the mga part in /etc/modprobe.d/blacklist-framebuffer, and add Option "UseFBDev" "True" to the monitor portion of xorg.conf). I reverted those changes before installing John Dong's package, but the display errors, as seen in the screenshot, are still there... any pointers?

I noticed that when I type "lsmod", the vesafb module (which has something to do with framebuffering) appears loaded, and I can't unload it. Could that have anything to do with it?

rix (focardi) wrote :

I've got a Matrox MGA G550 and I've experienced various kinds of X crashes after upgrading to edgy. I've tried all the solutions proposed above and here is the combination that works for me:

- No framebuffer enabled in xorg.conf and no special kernal module loaded (I'm using standard edgy kernel)

- Added vga=795 (1280x1024 resolution) in kernel parameters (/boot/grub/menu.lst). Without this it was booting with a very dark screen and the monitor was refusing to display anything after gdm started;

- I've upgraded the driver to John's backport above to have 3D (e.g screensaver) working. without this upgrade gnome-screensaver was giving a blank screen before crashing X.

Now it seems to work very well and MUCH faster then VESA.

Thanks for the tips and I hope this combination may help other G550 users.

Riccardo

Timo Aaltonen (tjaalton) wrote :

this should be fixed in feisty which now has 1.4.6-0ubuntu1. If you have other issues please open new bugs, since following this one is becoming difficult.

Now that feisty has a valid version, it can be backported to edgy.

Changed in xserver-xorg-video-mga:
status: Confirmed → Fix Released
Valentin Rocher (bishiboosh) wrote :

-> Considering xserver-xorg-dev (>= 2:1.1.1)
      Tried versions: 1:1.1.1-0ubuntu12.1 1:1.1.1-0ubuntu12

Backporting it to edgy would need to backport this package, is it dangerous ?

Do we really want to backport xorg-server ? :)

Timo Aaltonen (tjaalton) wrote :

hm, maybe the dependancies can be relaxed for the backport. I'm pretty sure it doesn't need a newer xorg-server

Marco Cimmino (cimmo) wrote :

yes Timo please backport it, we are waiting for a long time :)

Timo Aaltonen (tjaalton) wrote :

sorry, that's something you should do if you need it for edgy.. I'm swamped with other work :/

file a backport/SRU report and see if it goes through.

Langly (langly1) wrote :

I've got the same problem on my PWS 600a running au firmware and whatnot. Fresh install of debian using sarge, get xorg nice and configured and then X works fine, but I cant go to any consoles or close out. First monitor was just claiming out of range, but I put it on a very unpicky monitor, it stays on with badly corrupted graphics. so its not exactly an out of sync problem Ill be trying various solutions now.

Tundro Walker (tundrowalker40) wrote :
Download full text (3.6 KiB)

* Card ... Matrox G450 Dual-Head

* OS / Desktop ... Xubuntu XFCE vanilla install from Edgy LiveCD (along with all "update manager" recommended updates afterwards)

* Problem ... libGL error everyone else was getting when trying to do 3d stuff

* Resolution ... Tried the Option "UseFBDev" "true" fix recommended

* Result ... X crashed and wouldn't load GUI, but terminal worked, so I undid the .conf file using Nano. Was able to reboot back to GUI without issue. (Haven't tried the .deb fix yet...was going to try it next)

Didn't see many Matrox G450 Dual-Head folks posting, so wanted to post my experience.

Quick Andecdote...or "why I'm a Linux convert and don't complain about its bugs much".

I originally dual-booted Xubuntu with WinXP, because, like some Linux converts, I was tired of having to check in with MS to verify and activate software I had already paid money obscene amounts of $$$ for. I wanted to see if the Linux grass was greener.

The Xubuntu install was painless, and usage was smooth. I was a little grumbly about having to rely more on command-line to do some things, but remembered how bad it was back in the MS-DOS days (using a command-line with really limited commands and batch functionality), so felt I could suck it up. And, like some Linux'ers, have actually had fun learning about the guts of an OS...been so restricted with WinXP, it's kinda nice to be able to crack open and tweak anything and everything in Linux.

Anyways, while dual-booting, I was still pretty reliant on WinXP (since I was playing Tremulous on it, and couldn't get it to work well in Linux). But, during a day of "routine maintenance" (you know, the 1 hour of reg-cleaning, defragging, temp-file deleting, etc), I decided to give the WinXP Disk Cleaner, which I had never relied upon before, a shot to clean up my temp files on the chance it finds something I had been missing the whole time.

It had an option to "Delete Win 98 Install Files", and I thought that was a good idea, since it was 50mb of wasted space...I was using WinXP afterall, so why keep the old Win98 install files? While Disk Cleaner ran, the WinXP file protector kept popping up periodically asking me if I really, really wanted to delete this or that file. Thought it was odd at the time, but kept clicking "yes". After reboot, I found out the Disk Cleaner had totally wiped out critical boot files and .dll's. I spent 2 days trying recovery, but after I got a message basically saying "so much crap was deleted you should just get your Sys Admin to reinstall", I gave up....literally. I decided to give up on Windows from that point on, seeing as I had Xubuntu already installed.

I spent a few days tweaking Xubuntu, and finally got it to hook to my old Windows NTFS partition to try to salvage mp3's and such. When I got it mounted, I was expecting a good 8 gb or so on it. There was 250 mb (megabytes!) Apparently Disk Cleaner had totally wiped major sections of my Windows partition (mp3's, Program Folders, Key Windows files and folders !!!) I was so surprised by this I could only laugh out-loud. Fortunately, I didn't have anything to irreplaceable on there, so I unmounted the Windows p...

Read more...

Changed in xserver-xorg-video-mga:
status: Unconfirmed → Fix Released
Changed in edgy-backports:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.