Ubuntu

Failed to load module "mga" (loader failed, 7)

Reported by SteVe Cook on 2012-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-mga (Ubuntu)
High
Timo Aaltonen

Bug Description

MGA driver not loading. Section from xorg.log

[ 45.022] (II) LoadModule: "mga"
[ 45.028] (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
[ 45.029] (EE) Failed to load /usr/lib/xorg/modules/drivers/mga_drv.so: /usr/lib/xorg/modules/drivers/mga_drv.so: undefined symbol: MGAStormSync
[ 45.029] (II) UnloadModule: "mga"
[ 45.029] (II) Unloading mga
[ 45.029] (EE) Failed to load module "mga" (loader failed, 7)

Hardware spec:

Matrox Electronics Systems Ltd. MGA G200 AGP (rev 03) (prog-if 00 [VGA controller])

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-video-mga 1:1.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
ApportVersion: 2.5.1-0ubuntu4
Architecture: i386
Date: Sat Sep 1 19:48:08 2012
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120623)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-mga
UpgradeStatus: No upgrade log present (probably fresh install)

SteVe Cook (yorvyk) wrote :
SteVe Cook (yorvyk) wrote :

Works OK in 12.04

Tormod Volden (tormodvolden) wrote :

It looks like mga_dga.c (line 32) references MGAStormSync even if XAA is disabled. But Makefile.am does not add mga_storm.c to mga_drv_la_SOURCES in this case.

Changed in xserver-xorg-video-mga (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2012-09-26
Changed in xserver-xorg-video-mga (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → Medium
status: Confirmed → In Progress
Timo Aaltonen (tjaalton) wrote :

uploaded to the quantal queue

Changed in xserver-xorg-video-mga (Ubuntu):
importance: Medium → High
tags: added: rls-q-incoming
Changed in xserver-xorg-video-mga (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-mga - 1:1.6.1-0ubuntu1

---------------
xserver-xorg-video-mga (1:1.6.1-0ubuntu1) quantal; urgency=low

  * Fix the upstream version, the previous 1.6.0 was really 1.6.1.
  * Added fix-driver-load.diff, fixes loading the driver when the
    xserver it was built against has no support for XAA anymore. (LP:
    #1044797)
 -- Timo Aaltonen <email address hidden> Wed, 26 Sep 2012 11:14:51 +0300

Changed in xserver-xorg-video-mga (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers