MACH64 video driver crashes with Mach 3D Rage Pro

Bug #1077975 reported by Yuri I. Kornilov on 2012-11-12
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux Mint
xserver-xorg-video-mach64 (Ubuntu)

Bug Description

It seems that xserver-xorg-video-mach64 is broken in Lubuntu 12.10.
After the upgrade from 12.04 to 12.10 MACH64 video driver crashes, causing infinite loop at boot:
starting desktop manager, X server crash, restarting desktop manager, X server crash, restarting desktop manager, X server crash, etc.
It is impossible even to switch to text console.
I found a workaround - booting in rescue mode, mounting filesystem read-write and creating the file containing lines
Section "Device"
 Identifier "Default device"
 Option "NoAccel"
in /usr/share/X11/xorg.conf.d stops the crashes of X server and allows to boot desktop environment. But doing without video acceleration on a slow machine is not a good thing.
I hope it will be possible to find the bug (in 12.04 this video driver worked OK).

Some details which may be useful:
CPU Pentium III 500MHz, RAM 512 MB
Video card:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI 3D Rage Pro AGP 1X/2X (rev 5c)
Lubuntu 12.10 (upgraded from 12.04)
xserver-xorg-video-mach64 6.9.3-0ubuntu1

Yuri I. Kornilov (yuqi) wrote :

It looks like that this bug is caused by the fact that mach64 driver depends on XAA, which was removed in xserver 1.13:
http://<email address hidden>/msg33768.html

Maybe the proposed upstream patch will help:

Waiting for the patched version of xserver-xorg-video-mach64 to appear in the Ubuntu repository.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-mach64 (Ubuntu):
status: New → Confirmed
Clara (claracagigal) wrote :

I have experienced the same bug when upgrading my lubuntu 12.04 to 12.10. Impossible to log into the system, there is in an infinite loop and the login screen never appears. Cannot loginto console neither.

My computer is an old pentium III with sis 630/730 graphics card, 512 MB Ram from which 64 MB go for the graphics card. 20 GB HDD. This computer worked well with lubuntu 12.04.

Please Yuri.Kornilov (yuqi) could give step by step instructions in order to get into lubuntu 12.10 system?

Thanks in advance

Yuri I. Kornilov (yuqi) wrote :

Explanations for Clara - how to login to the system affected by this bug.

(Re)boot your system, holding down the "Shift" key - the GRUB menu will appear.
In the GRUB menu select
"Advanced options for Ubuntu"
"Ubuntu, with Linux X.Y.Z-N-generic (recovery mode)"
(X.Y.Z-N is a kernel version number, choose any version, the latest one will be fine).
In the "Recovery menu" choose
"root Drop to root shell prompt"
You get the root shell, but filesystem is mounted read-only. Remount it read-write with the command like
mount -o remount,rw /

Now you can do what you like, for example,
vi /usr/share/X11/xorg.conf.d/91-noaccel.conf
and type the configuration lines I mentioned in my first post.
Instead of
 Option "NoAccel"
you may also try
 Driver "vesa"
- it is not as fast as native drivers, but supposed to work with most graphics cards.

Clara (claracagigal) wrote :

Thankyou very much Yuri l. Kornilov for the step by step instructions.
 I'll try the workaround .

Jaromír Cápík (tavvva) wrote :

Hello guys. It crashes in my case too and the vesa driver doesn't work correctly in my case (broken windows and panel). Mageia 2 runs perfectly with the same driver. Could you please apply the upstream patch and make the package available for testing?

Clara (claracagigal) wrote :

Jaromir Capik, if this bug affects you, please, click on the link: this bug also affects me un the upper left part of the page.
In this way, as many people is affected by the bug, the probability that it will be fixed is bigger.

madbiologist (me-again) on 2015-01-13
tags: added: quantal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.