Ubuntu

Awkward graphic glitches (texture corruption) in Unity/Nux when opening lot of applications (intel video card)

Reported by George Karavasilev on 2012-04-19
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

This bug happens when one has a ... well, crappy video ("Mobile Intel® GM45 Express Chipset" in my case) and a quite a lot of opened windows (at least 10). Sometimes a graphical glitches appear - broken looking windows shadows and glitches in the Active Blurring (when Dash or Alt+Tab is opened).
I've attached a screenie of the bug affecting the Alt+Tab.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.scope.cities: Error: [Errno 21] Is a directory: '/tmp/unity-scope-cities'
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,resize,compiztoolbox,vpswitch,imgpng,regex,mousepoll,gnomecompat,snap,grid,wall,unitymtgrabhandles,place,move,animation,expo,session,fade,workarounds,scale,unityshell]
CompositorRunning: compiz
Date: Thu Apr 19 13:19:10 2012
DistUpgraded: 2012-02-20 23:41:59,931 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3a02]
   Subsystem: Lenovo Device [17aa:3a02]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 20023
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=140042a3-4561-4903-abea-3adf85ee2ae9 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-20 (58 days ago)
dmi.bios.date: 01/18/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 18CN42WW(V2.51)
dmi.board.name: NITU1
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr18CN42WW(V2.51):bd01/18/2010:svnLENOVO:pn20023:pvrLenovoG550:rvnLENOVO:rnNITU1:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 20023
dmi.product.version: Lenovo G550
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

On-The-Fly (onthefly) wrote :

I encounter similar troubles on Lubuntu 12.04 with an also crappy card: ATI Mobility Radeon HD 2400 with the proprietary drivers installed. As LXDE is pretty much without effects, the way to reproduce and see it there, is when I move windows like mad. It will end up looking similar to George's screenshot.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, does it happen every time you get lot of applications running?

Changed in unity (Ubuntu):
importance: Undecided → Low

Well, not every time, but let's say at least on 90% :P

summary: - Awkward graphic glitches in Compiz
+ Awkward graphic glitches (texture corruption) in Unity/Nux

the trigger is to open lot of applications right?

Yes :)

summary: - Awkward graphic glitches (texture corruption) in Unity/Nux
+ Awkward graphic glitches (texture corruption) in Unity/Nux when opening
+ lot of applications (intel video card)

Anyone feeling like working on fixing this, because it's getting pretty damn ugly sometimes. See the screenie I attached :)

Omer Akram (om26er) on 2012-05-29
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Omer Akram (om26er) wrote :

I have seen this thing on a SandyBridge laptop that had. It can make things totally useless sometimes

Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High

For me, the corruption occurs when my machine starts to run out of RAM and beings to swap. compiz --replace fixes all of the corruption issues.

Martin Haynes (martin-haynes) wrote :

I've seen this issue on a Lenovo G550 32bit Core 2 Duo with integrated Intel chipset since 11.10. The problem survived an upgrade to 12.04. I've attached another screen capture. I typically encounter the problem after the machine has been asleep for any length of time.

I can confirm the 'compiz --replace' workaround which is the first progress I've had with the issue.

I'll also note that bug #975306, while seemingly a duplicate, does seem to result in subtly different screen artefacts.

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

This bug is *seriously* getting super annoying.
And no, the recent one or two Compiz updates for P didn't fixed it.

Changed in unity:
status: New → Confirmed

I've had this occur to me on Gnome shell (mutter) recently, so I'd say it's actually an intel driver issue with compositing.

Hi, has anyone upgrade to ubuntu 12.10? It would be great to see if it's been resolved as there have been many updates to the intel driver since then.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Andy Braben (abraben) wrote :

I suffered from this bug with Ubuntu 12.04, intel graphics card and the glitchy buggy screen.

I upgraded to ubuntu 12.10 pre-release some time ago and after an update suffered incorrect screen resolution which made it unusable. About a week ago I updated the system and got the correct resolution back, and have not suffered the glitchy buggy screen, but instead the computer locks out when I hit the dash button, but if I don't hit the dash button I have a fully useable system. (so I won't see the Amazon results!)

I realise this should now be for a different bug report but It would be interesting to see if anyone else has the same results when upgrading.

The bug still exists in 12.10 (granted it appears tons of times more rarely)

That's good that it's more rare - I actually decided to upgrade to 12.10 and am doing it now. I don't doubt you, George, that it's still there but I'll confirm if/when it happens.

Has anyone else been able to reproduce this problem under another environment (e.g. not compiz/Unity)? I posted earlier that I was able to reproduce under gnome-shell. Can anyone else confirm? It would be nice to know for sure if this is an intel bug or a unity/compiz bug.

Thanks a lot for the patience, guys. Hope to see it getting fixed as much as you all are :)

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

I believe saw in once in GS. The issue happens when you open a bunch of windows and with unity resource hungryness the graphical glitches appear. Due to the fact that GS is not that resource hungry, it happens extremely rarely in it.

The worst result in 12.04 occurs when I switch users. All characters
except the ones in the topbar are garbled even the characters of Conky
are garbled beyond any recognition. The desktop picture is garbled too.
I will come back with the result in 12.10

On 10/21/2012 02:18 PM, George Karavasilev wrote:
> I believe saw in once in GS. The issue happens when you open a bunch of
> windows and with unity resource hungryness the graphical glitches
> appear. Due to the fact that GS is not that resource hungry, it happens
> extremely rarely in it.
>

BertN45 (lammert-nijhof) wrote :

The error has been solved in 12.10. Switching user does not cause the
garbling of desktop and menus.

On 10/21/2012 02:18 PM, George Karavasilev wrote:
> I believe saw in once in GS. The issue happens when you open a bunch of
> windows and with unity resource hungryness the graphical glitches
> appear. Due to the fact that GS is not that resource hungry, it happens
> extremely rarely in it.
>

Hi all,

The fixes for these errors were introduced in the upstream kernel version 3.2.32. They were already corrected on the 3.5 kernel, so that should be OK too. If you use a kernel based on that (>= 3.2.32, >=3.5.?? ), these issues should be fixed.

Currently, this appears to be case for the kernels on Precise (12.04), Quantal (12.10) and Raring (13.04).
Please report if you still get these bugs with any of these kernels. Thanks!

The relevant upstream commit:
https://git.kernel.org/?p=linux/kernel/git/bwh/linux-3.2.y-queue.git;a=commit;h=b6e32828805b35efce711f75f95f360770157f32
And the discussion leading to the backport where my newbieness is exposed :-) :
http://<email address hidden>/msg18581.html

Regards,
Luís Picciochi

@Luis, I greatly appreciate your help in the matter. I'm not particularly ready to try out 3.3 and above kernels due to these concerns with EXT4 corruption bugs. I value my data more than my graphics stack!

Regardless, why is it that the patch hasn't been merged for backport? It appears to have been OK'ed but the latest post is from half a month ago.

affects: unity → xserver-xorg-video-intel
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
affects: unity (Ubuntu) → xserver-xorg-video-intel (Ubuntu)

@Luis: Would the x-updates PPA have the fixes you mentioned?

bugbot (bugbot) on 2012-11-15
tags: added: corruption
Chris Wilson (ickle) on 2013-02-14
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released

Hi, Chris. I'm assuming you pushed a commit that fixed that issue. Is it backportable? What version was fixed?

Chris Wilson (ickle) wrote :

The source of this error was a driver leak in the UXA glyph code (at least according to my notes). iirc, somewhen around 2.20.4 had the fix. The DDX will compile against your version of Xorg, and I would strongly recommend you take all the bug fixes in there rather than cherry-picking. Or else poke your friendly package maintainer for a backport of2.21.2...

To post a comment you must log in.