False GPU lockups captured by apport gpu hook unnecessarily

Bug #983640 reported by rakragans on 2012-04-17
114
This bug affects 30 people
Affects Status Importance Assigned to Milestone
xdiagnose (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
High
Bryce Harrington
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Problem]
The GPU lockup detection in the gpu freeze apport hook is a bit too sensitive and flags bug reports in situations where the GPU did not actually lock up. This generates a lot of false-positive bug reports in Ubuntu, of which this one is an example.

We've communicated with upstream (Intel) about this. The false gpu lockup that triggers this really shouldn't be occurring at all, but it's unclear why it does. However, upstream has sufficient information on the problem, so we don't really gain much by continuing to gather these reports. They're a bit annoying to users so quelling them may make running the development version of the distro a little calmer.

[Original Report]
While updating packages this error occurred.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu4
Architecture: i386
Chipset: g41
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Tue Apr 17 09:05:12 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [g41] GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:d000]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
InterpreterPath: /usr/bin/python2.7
MachineType: Gigabyte Technology Co., Ltd. G41MT-ES2L
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=C698D8F998D8E8C7 loop=/hostname/disks/root.disk ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+12ubuntu1
 libdrm2 2.4.32-1ubuntu1
 xserver-xorg-video-intel 2:2.17.0-1ubuntu4
SourcePackage: xserver-xorg-video-intel
Title: [g41] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/01/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: G41MT-ES2L
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd12/01/2009:svnGigabyteTechnologyCo.,Ltd.:pnG41MT-ES2L:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnG41MT-ES2L:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: G41MT-ES2L
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

rakragans (rakragans) wrote :
tags: removed: need-duplicate-check
Bryce Harrington (bryce) on 2012-04-19
summary: - [g41] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001
+ False GPU lockups captured by apport gpu hook unnecessarily
description: updated
Bryce Harrington (bryce) wrote :

The issue is "fixed" for precise in that Apport has been turned off (or rather, switched to "whoopsie-only mode"). Thus, the gpu hook won't be getting triggered any more.

But that is just sweeping the problem under the carpet. It'll still need sorted out when Q-series opens...

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: New → Fix Released
Changed in xdiagnose (Ubuntu Precise):
status: New → Won't Fix
Bryce Harrington (bryce) wrote :

There are two ways this could be addressed. Both require changes to the apport hook (in xdiagnose):

1. Change the udev rule to trigger on a different combination of events. (I have an email somewhere discussing what exactly needs done... I'll have to locate that again.) The possible drawback of this approach may be that it might hide some valid bugs; not sure.

2. Parse the i915_error_state file prior to filing the bug report, and programmatically evaluate whether it's a valid report before trying to send it in. However, I think this might still result in a popup to the user, which would still present an irritant. Yet, it may be a more comprehensive way to deal with invalid gpu error states in general.

Potentially we could do both #1 and #2, which might give the best all around solution. Some experimentation may be needed to get the gpu hook properly tuned.

Since the apport hook is turned off in the release, there's no point to SRUing any changes made for this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdiagnose (Ubuntu):
status: New → Confirmed
Leonardo Torok (leotorok) wrote :

I'm actually getting a lot of false reports of GPU hanging in my fully updated Precise.

I am also getting a lot of false reports, and apparent GPU lockups too.

Bryce Harrington (bryce) wrote :

@Richard and Leonardo, I uploaded a new version of xdiagnose to precise-proposed for that (see bug #997470); it manually switches off the reporting. Please update to xdiagnose 2.5.1 from precise-proposed and confirm on bug #997470 that it has stopped those popups.

Bryce Harrington (bryce) on 2012-06-19
Changed in xdiagnose (Ubuntu Quantal):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.9

---------------
xdiagnose (2.9) quantal; urgency=low

  * xdiagnose.udev: Make the GPU apport hook trigger on RESET=1 rather
    than ERROR=1, as an attempt to prevent capturing bug reports on false
    gpu lockups.
    (LP: #983640)
  * apport/source_xorg.py:
    - Link to all technical support options, not just to Ask Ubuntu.
      Reword recommendation to explain why technical support should be used
      first. Add a 'referred-by-support' tag so we can give those bugs
      priority attention. Provide an option to just file the bug.
      (LP: #991602)
    - Drop question to allow flagging regressions
      following updates, since bug reporters have been using it incorrectly,
      resulting in too many false positives.
      (LP: #1018510)
    - Clarify question about "willing to do whatever it takes" to specify
      that the debugging work may require gdb or git bisection work.
  * xdiagnose.desktop.in: Move xdiagnose to System/Settings menu. Provide
    a GenericName. Set the gettext domain.
  * debian/control: Add runtime dependency on librsvg2, required for
    displaying SVG icons.
    (LP: #969603)
  *
 -- Bryce Harrington <email address hidden> Tue, 19 Jun 2012 14:26:04 -0700

Changed in xdiagnose (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers