Sometimes see vertical bands, artifacts across screen after boot

Bug #980058 reported by Michael Cobb on 2012-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Plymouth
New
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Since updating from 12.04 Beta 1 to 12.04 (Final) (I went from 11.10 to 12.04 Beta 1 before that via a clean install), while booting, GRUB is displayed fine, and Ubuntu begins to boot fine. It's only when Plymouth is displayed (which happens fairly late into boot for me) that I start to experience problems.

Most of the time, Plymouth is shown fine, and everything is great. However, occasionally Plymouth is shown garbled, there's little blobs of colour (Sorry I can't provide much information because Plymouth is only shown for a little while during my boot).

Then I see vertical bands of colour, it kind of looks like my display has been stretched vertically and the whole display is 1px tall. (I have posted some videos showing the behaviour below).

I can log in, log out, switch to TTY's - do whatever, but the screen still has vertical bands on it. Moving the mouse causes the bands to change/update.

Switching to any TTY shows a blinking vertical line, which moves along as I type commands, but it's impossible to see them (you can just see the blinking cursor)

I can SSH into the computer and collect any logs if they are needed.

I then force shut-down the laptop and restart and everything works fine.

The only kernel command I have added is acpi_backlight=vendor (to be able to set the backlight brightness)

lsb_release -rd
===========
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy xorg and apt-cache policy xserver-xorg-video-intel
==========================================================================
xorg:
  Installed: 1:7.6+12ubuntu1
  Candidate: 1:7.6+12ubuntu1
  Version table:
 *** 1:7.6+12ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

xserver-xorg-video-intel:
  Installed: 2:2.17.0-1ubuntu4
  Candidate: 2:2.17.0-1ubuntu4
  Version table:
 *** 2:2.17.0-1ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Below here is information from the original bug report (Before I upgraded from 12.04 Beta 1 to 12.04 (Final)).

=========================

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: None
Date: Thu Apr 12 17:15:47 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.2.0-17-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-21-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-22-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-23-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0504]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 1bcf:288a Sunplus Innovation Technology Inc.
MachineType: Acer Aspire 5750
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=294c451d-e2ed-4cfd-bbfe-9c443dd1a944 ro quiet splash acpi_backlight=vendor vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/24/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.11
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE50_HR
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.11
dmi.modalias: dmi:bvnAcer:bvrV1.11:bd05/24/2011:svnAcer:pnAspire5750:pvrV1.11:rvnAcer:rnJE50_HR:rvrBaseBoardVersion:cvnAcer:ct10:cvrV1.11:
dmi.product.name: Aspire 5750
dmi.product.version: V1.11
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.7.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Michael Cobb (michaelcobb123) wrote :
Michael Cobb (michaelcobb123) wrote :

Attached above ^^^^ in the bug report is a photo of what the display looks like after Plymouth finishes.

This attachment shows the artefacts left behind when moving the mouse around. (no cursor is visible, just the white box)

Michael Cobb (michaelcobb123) wrote :

I just experienced the above bug again, so I decided to take a video after switching to TTY1 and logging in, you can see the blinking horizontal cursor and a squashed version of the display (when holding down return) - I didn't notice this until now.

I ran the command
sudo pkill x
multiple times in the video - to no effect (I just realized i should have ran sudo pkill xorg - not pkill x - I'll take a better video next time and i'll get the command right :P )
and i finally ran
sudo shutdown -h now
to turn off the computer

I also noticed that Plymouth didn't start during the boot (It usually starts pretty late into boot - but it's always done this for me, i get GRUB's background displayed during boot instead) and I saw a glitched, vertical style background briefly. I now think that this may be a Plymouth bug being as this time it didn't start when it normally would, and it was glitched out.

Bryce Harrington (bryce) on 2012-04-16
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Robert Ancell (robert-ancell) wrote :

Not sure if the attached lightdm.log is from after the problem or not but it shows a correct login. I suspect this is an X issue that lightdm isn't involved in though.

Michael Cobb (michaelcobb123) wrote :

I ran 'ubuntu-bug xorg' after I rebooted the machine and logged in through lightdm, so I imagine that the log was from after the issue.
I haven't experienced this bug since the final release of 12.04, however, I experienced this bug just now. I saw a garbled Plymouth which leads me to believe that this is either some bug with either the kernel? or Plymouth starting up the graphics card.

I can still, blindly, access a terminal so if there are any commands that need to be ran whilst the machine is being affected by this bug, like collecting the log from lightdm, then I will be able to run them. I just don't know what logs and stuff to collect.

Michael Cobb (michaelcobb123) wrote :

OK, so sorry for spamming the comments here, but this seems to be happening more and more often, and it's so annoying. I've removed the startup script from my lightdm config in case it was xbacklight screwing up the graphics when I tried to change the backlight level - It happened twice this moring, once after the other. I think this is a Plymouth bug as Plymouth starts garbled too.

no longer affects: lightdm
Michael Cobb (michaelcobb123) wrote :

Okay, so it happened again today, except it's no longer a white box. It's hard to explain but I recorded a video of it.
I also managed to save a copy of dmesg from when this was happening, if it's relevant.

gokul (dotgokul) wrote :

I don't mean to scare you but the last time I saw such a crazy display it was because my laptop cooling had failed. Is there any chance at all that something of this nature has happened with you (coinciding with the upgrade)? On a different occasion on a different system there was bug with a viafb (driver?) and everything froze with not even ctrl+alt+del possible. I had to blacklist it for that particular release and use the default VESA driver [https://bugs.launchpad.net/ubuntu/+source/linux/+bug/518623]

Michael Cobb (michaelcobb123) wrote :

Thanks for the reply. The laptop is only 6 months old, so i'm not sure if that would be a problem. My laptop seems to be running cooler since upgrading to 12.04. But I'll look into it though.

summary: - Sometimes get a white box instead of Lightdm after boot
+ Sometimes see vertical bands, artifacts across screen after boot
description: updated
Michael Cobb (michaelcobb123) wrote :

OK, so I've made a discovery in terms of what could be causing this problem, it appears that when the display is garbled, it's because vesafb is being used, rather than the intel driver. attached it the relevant dmsg that i got by sshing into the computer, note the following lines when the graphics are garbled:

Dmesg when the display is garbled:
...
[ 21.024313] mtrr: type mismatch for b0000000,10000000 old: write-back new: write-combining
[ 21.024320] [drm] MTRR allocation failed. Graphics performance may suffer.
[ 21.025526] i915 0000:00:02.0: irq 42 for MSI/MSI-X
[ 21.025540] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 21.025546] [drm] Driver supports precise vblank timestamp query.
[ 21.025612] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
...
[ 22.471389] vesafb: mode is 1024x768x32, linelength=4096, pages=0
[ 22.471392] vesafb: scrolling: redraw
[ 22.471394] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
...
[ 22.472177] vesafb: framebuffer at 0xb0000000, mapped to 0xffffc90011500000, using 3072k, total 3072k
[ 22.472350] Console: switching to colour frame buffer device 128x48
[ 22.472378] fb0: VESA VGA frame buffer device
...
Xorg.log when the display is garbled (contains loads of lines e.g.):
...
[ 22.579] (II) VESA(0): Total Memory: 2047 64KB banks (131008kB)
[ 22.579] (II) VESA(0): <default monitor>: Using hsync value of 47.05 kHz
[ 22.579] (II) VESA(0): <default monitor>: Using vrefresh value of 60.01 Hz
...

compared to when inteldrmfb is used (the following was taken from this boot, when the display was behaving normally):
Dmesg when the problem isn't present:
...
[ 21.472059] mtrr: type mismatch for b0000000,10000000 old: write-back new: write-combining
[ 21.472064] [drm] MTRR allocation failed. Graphics performance may suffer.
[ 21.472579] i915 0000:00:02.0: irq 42 for MSI/MSI-X
[ 21.472584] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 21.472589] [drm] Driver supports precise vblank timestamp query.
[ 21.472675] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
...
[ 22.091428] fbcon: inteldrmfb (fb0) is primary device
[ 22.091963] Console: switching to colour frame buffer device 170x48
[ 22.091998] fb0: inteldrmfb frame buffer device
[ 22.092000] drm: registered panic notifier
[ 22.095748] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input7
[ 22.095845] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 22.097115] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
...

Xorg.log when the problem isn't present:
...
[ 5137.691] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 5137.691] (==) intel(0): RGB weight 888
[ 5137.691] (==) intel(0): Default visual is TrueColor
[ 5137.691] (II) intel(0): Integrated Graphics Chipset: Intel(R) Sandybridge Mobile (GT2)
[ 5137.691] (--) intel(0): Chipset: "Sandybridge Mobile (GT2)"
...

What would cause vesafb to be used instead of inteldrmfb?

Chris Wilson (ickle) wrote :

Your GPU is extremely unhappy. The fallback to vesa is because it fails even to initialise its command rings, and it looks like it falls over regularly even if it manages to get past that.

I would strongly advise you looks for a BIOS update, and please try a very recent kernel. I would also recommend drm-intel-experimental (from the kernel mainline ppa) as our detection of broken firmware has improved along with our tolerance.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since there has not been a response from the original reporter. However, the issue still exists please feel free to reopen with the requested information. If you're not the original reporter, we'd prefer you file a new bug report.

Some tips:

  * Report X.org bugs via the command: `ubuntu-bug xorg`

  * Test against the latest development Ubuntu. http://cdimage.ubuntu.com/daily-live/
    Bugs marked as affecting the development version tend to get priority attention.

  * The `xdiagnose` utility has functionality for enabling debugging and
    analyzing a few common X problems.

  * Tag your bugs with the Ubuntu versions you have reproduced the issue in.

  * See https://wiki.ubuntu.com/X/Reporting for tips on writing good bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers