8086:2a42 [Tecra M10-S3411] VGA monitor only gets signal on boot (no signal when “hot plugging”)

Bug #979748 reported by Rik Shaw on 2012-04-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

I am able to get an external VGA monitor (or projector) to work if I start my laptop with it connected. However, if I start the laptop with it disconnected there is no signal on the external. The Displays screen shows the external, and thinks that it is active, but there is no signal being sent to it. This has been a persistent problem since 10.04 (I am now on 12.04.... each upgrade hoping something is improved). I should note that even when it works (starting with display connected), Displays still says the monitor is "unknown" (but it sends the signal). For the correct resolution to display, I have had to add a few xrandr lines for my monitor to my .xprofile file... otherwise resolution is limited to default 1024x768. So, resolution issues can be worked around, but the main issue is that the external doesn't get a signal without starting the machine with it connected. I have tried adding i915.modeset=1 to grub, and xorg-edgers.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Thu Apr 12 13:08:21 2012
DistUpgraded: 2012-04-02 03:21:05,114 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-22-generic-pae, i686: installed
 virtualbox, 4.1.12, 3.2.0-23-generic, i686: installed
 virtualbox, 4.1.12, 3.2.0-23-generic-pae, i686: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:0009]
   Subsystem: Toshiba America Info Systems Device [1179:0009]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: TOSHIBA TECRA M10
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=969ec06a-f27d-41db-818a-b9a23fe0009f ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to precise on 2012-04-02 (10 days ago)
dmi.bios.date: 09/08/2009
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 3.00
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion3.00:bd09/08/2009:svnTOSHIBA:pnTECRAM10:pvrPTMB1U-02L01H:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: TECRA M10
dmi.product.version: PTMB1U-02L01H
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.7.4-0ubuntu3
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Rik Shaw (rik-shaw) wrote :
tags: added: external monitor vga
Changed in xorg (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2012-04-12
tags: added: edgers
bugbot (bugbot) on 2012-04-12
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) wrote :

What are the lines you added to your .xprofile?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Rik Shaw (rik-shaw) wrote :

Here is what I have add to my .xprofile:

=======================

xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

xrandr --addmode VGA1 1280x1024_60.00

=======================

Note that the reason for these 2 lines is that Ubuntu doesn't properly recognize my external (just says "Unknown") and only allows a default resolution of 1024 x 768 without the above 2 lines (2 lines give me the resolution option of 1280x1024 for the external monitor). I should probably check to see if there is another bug related to Ubuntu not recognizing the external monitor properly.

Bryce Harrington (bryce) on 2012-04-19
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Chris Wilson (ickle) wrote :

The monitor doesn't have an EDID nor generate hotplug events. Without the hw detection, we fallback to probing the EDID to determine if a display maybe present. Since that is not, we then guess based on whether we can read any values back from the VGA plane in the display (-> unknown connection status). That is a heavy-weight operation and only performed upon explicit request from userspace, i.e. we do not run that check periodically and synthesize hotplug events. This is an issue where improving your experience is to the detriment of everyone else. Instead, you basically need to manually trigger a probe whenever you plug in your monitor (either through xrandr or the display manager).

summary: - Laptop with Intel Graphics: external VGA monitor only gets signal on
- boot (no “hot plugging”)
+ [expected] VGA monitor only gets signal on boot (no “hot plugging”, no
+ EDID)

Thank you for the reply. I think I understand the situation and can appreciate that many others would be negatively affected by my experience being improved!

I do need more advice on how to "manually trigger a probe". In my experience, connecting the monitor (after booted), then opening display manager will have display manager indicate the monitor is connected (and active), but still no signal is sent to it (still black, monitor reporting "no signal"). So, any help on triggering this would be welcomed. If I am able to manually do this without rebooting then I would be accepting of this bug being "resolved".

Thanks again for the reply.

Chris Wilson (ickle) wrote :

Hmm, if the display is being recognised by the display manager and we don't successfully turn it on, then that is a serious issue. After it gets into the "no signal" state, can you please attach the output of xrandr --verbose. It could either be that the modeline is incompatible, or that we are not programming the CRTC correctly. For the latter, grabbing intel-gpu-tools and attaching the output of intel_reg_dumper would be useful.

Also please make sure you have all the updates available (I would like if you could use xorg-edgers or raring), and attach your Xorg.0.log after it exhibits the failure.

Rik Shaw (rik-shaw) wrote :

I will attach 3 files with the output of xrandr --verbose. However, this is with Precise w/o edgers ppa. I'll first update to edgers ppa, do it again, then later try Raring.

First file is xrandr --verbose when booting w/o VGA external connected (and still disconnected). So this is "baseline".

Second file is xrandr --verbose after plugging in VGA external (but having booted w/o it). This is the scenario where the screen is "blank" getting "no signal" even though "Displays" indicates it is connected and "on".

Third file is xrandr --verbose after booting with VGA external connected. In this case (and only in this case), the external works properly.

Rik Shaw, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-intel REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Medium → Wishlist
status: Confirmed → Incomplete
importance: Wishlist → Low
Rik Shaw (rik-shaw) wrote :

I have downloaded and installed trusty 64 daily build (2013-01-07) on a real partition on the Toshiba Tecra M10 machine used to originally report this problem (so no variable to it being a VM or running from a LiveCD).

When connecting an external monitor via VGA (after machine already running), "Displays" in System Settings now shows proper monitor identification, with the option to set correct resolution. From "Displays" it appears as if the monitor is "Active". However, no signal is detected by the external monitor, and it is "black".

If I then restart (so machine boots with the monitor already connected), then all works as expected. Resolution is correct, and both the laptop display and the external monitor are "active". So, the external monitor seems to be identified corrrectly, but when "hot plugged" no signal is sent to the external monitor until a reboot. So, this main component of the original bug report remains unsolved.

Please let me know what tests I can perform to provide any more information.

summary: - [expected] VGA monitor only gets signal on boot (no “hot plugging”, no
- EDID)
+ [expected] VGA monitor only gets signal on boot (no signal when “hot
+ plugging”)
summary: - [expected] VGA monitor only gets signal on boot (no signal when “hot
- plugging”)
+ VGA monitor only gets signal on boot (no signal when “hot plugging”)

Rik Shaw, thank you for performing the requested test. Could you please test the latest xorg stack (may be done in live environment) via https://launchpad.net/~xorg-edgers/+archive/ppa and advise if this is reproducible?

tags: added: latest-bios-3.00
removed: edgers external monitor vga xorg
tags: added: trusty
tags: added: amd64
Rik Shaw (rik-shaw) wrote :

@penalvch I added the edgers PPA, performed a dist-upgrade, rebooted, and still have the same results: "hot plugging" the monitor after already booted without it has it show correctly in "Displays" but there is *no* signal sent to the monitor. Only upon reboot does it receive the signal correctly.

Should the laptop boot with the monitor plugged in, then disconnect the monitor, then later re-connect the monitor, it will behave correctly. So, it is only when booting without the monitor connected that it will not receive the signal after later being connected.

Again, I am happy to perform any debugging or provide any requested logs should you advise on what steps to take for you to get the information you need.

description: updated
tags: added: lucid
summary: - VGA monitor only gets signal on boot (no signal when “hot plugging”)
+ 8086:2a42 [Tecra M10-S3411] VGA monitor only gets signal on boot (no
+ signal when “hot plugging”)

Rik Shaw, thank you for performing the requested test. Hence, the issue you are reporting is an upstream one. Could you please report this problem to https://bugs.freedesktop.org/enter_bug.cgi?product=xorg following https://bugs.freedesktop.org/page.cgi?id=bug-writing.html ?

Component = Driver/intel
Version = 7.7 (2011)

Please provide a direct URL to the new bug report once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
To post a comment you must log in.