Ubuntu

[sandybridge-gt1] GPU lockup with WARNING: at /build/buildd/linux-3.2.0/drivers/gpu/drm/i915/i915_drv.c:413 __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]()

Reported by Matthijs ten Kate on 2012-04-06
132
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Might be similar to bug 902787, but I do have composite enabled so therefore filing a new bug.
I just installed 12.04 beta 2 today (fresh install), updated it and after a reboot I was just working with SC to re-install my apps using the nifty 'Sync Between Computers' option, when suddenly SC exited and the entire UI froze (however, the mouse cursor kept on working). Could not even switch back to terminal using CTRL-Alt-F1.

Only a hard reset remained.

Fortunately, apport has been much improved an promptly asked me to file this bug. So here you go.

[ 468.092437] WARNING: at /build/buildd/linux-3.2.0/drivers/gpu/drm/i915/i915_drv.c:413 __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]()
[ 468.092440] Hardware name: To Be Filled By O.E.M.
[ 468.092442] Modules linked in: bnep snd_hda_codec_hdmi snd_hda_codec_realtek rfcomm bluetooth snd_hda_intel snd_hda_codec snd_usb_audio snd_hwdep snd_usbmidi_lib snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device snd i915 drm_kms_helper drm soundcore i2c_algo_bit snd_page_alloc video joydev mei(C) wacom ppdev pwc videobuf2_core videodev v4l2_compat_ioctl32 videobuf2_vmalloc videobuf2_memops parport_pc mac_hid lp parport usbhid hid floppy r8169 usb_storage
[ 468.092481] Pid: 1103, comm: Xorg Tainted: G C 3.2.0-22-generic #35-Ubuntu
[ 468.092484] Call Trace:
[ 468.092492] [<ffffffff8106712f>] warn_slowpath_common+0x7f/0xc0
[ 468.092496] [<ffffffff8106718a>] warn_slowpath_null+0x1a/0x20
[ 468.092505] [<ffffffffa018b9e4>] __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]
[ 468.092515] [<ffffffffa018c065>] i915_write32+0xe5/0xf0 [i915]
[ 468.092532] [<ffffffffa01c8752>] gen6_ring_put_irq+0xa2/0xc0 [i915]
[ 468.092546] [<ffffffffa01c8788>] blt_ring_put_irq+0x18/0x20 [i915]
[ 468.092557] [<ffffffffa019dba7>] i915_wait_request+0x1b7/0x560 [i915]
[ 468.092563] [<ffffffff8108aeb0>] ? add_wait_queue+0x60/0x60
[ 468.092573] [<ffffffffa019df82>] i915_gem_object_wait_rendering+0x32/0x40 [i915]
[ 468.092584] [<ffffffffa01a2d3d>] i915_gem_execbuffer_sync_rings+0xdd/0x160 [i915]
[ 468.092594] [<ffffffffa01a2f2e>] i915_gem_execbuffer_move_to_gpu+0x16e/0x200 [i915]
[ 468.092604] [<ffffffffa01a365b>] i915_gem_do_execbuffer.isra.8+0x69b/0x940 [i915]
[ 468.092609] [<ffffffff8152854c>] ? do_sock_read.isra.12+0xdc/0xf0
[ 468.092619] [<ffffffffa01a3dc3>] i915_gem_execbuffer2+0xa3/0x270 [i915]
[ 468.092630] [<ffffffffa012a5d4>] drm_ioctl+0x444/0x510 [drm]
[ 468.092633] [<ffffffff8152860d>] ? sock_aio_read+0x2d/0x40
[ 468.092643] [<ffffffffa01a3d20>] ? i915_gem_execbuffer+0x420/0x420 [i915]
[ 468.092649] [<ffffffff81189cfa>] do_vfs_ioctl+0x8a/0x340
[ 468.092653] [<ffffffff81177e0d>] ? vfs_read+0x10d/0x180
[ 468.092657] [<ffffffff8118a041>] sys_ioctl+0x91/0xa0
[ 468.092661] [<ffffffff81664a82>] system_call_fastpath+0x16/0x1b
[ 468.092664] ---[ end trace fbc68137a25c36e1 ]---

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Chipset: sandybridge-gt1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Fri Apr 6 14:01:56 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, if not too technical
GpuHangFrequency: This is the first time
GpuHangReproducibility: I don't know
GpuHangStarted: Immediately after installing this version of Ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-22-generic root=UUID=b8328ab4-d5e1-474a-8d2b-c40789adaaa6 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-gt1] GPU lockup
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 01/17/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.30
dmi.board.name: H67M-GE
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.30:bd01/17/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH67M-GE:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.7.4-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Matthijs ten Kate (igadget) wrote :
Matthijs ten Kate (igadget) wrote :

This just happened again.

Matthijs ten Kate (igadget) wrote :

...and again.

Bryce Harrington (bryce) on 2012-04-06
summary: - [sandybridge-gt1] GPU lockup
+ [sandybridge-gt1] GPU lockup while using 'Sync Between Computers'
description: updated

Thanks for filing this. I see apport correctly captured your i915_error_state, however the error codes are all 0'd out, so I don't think it's revealing what went wrong. However, your dmesg certainly shows the error, it's got several call traces printed.

The good news is you're able to reproduce the failure fairly reliably. If Intel can also reproduce it, I think they'll have good luck at figuring it out. So, a few questions to help ensure they can; the more of these you can answer, the quicker we'll be able to get to the bottom of this:

1. You said you just installed 12.04 today; had you a previous version of ubuntu on the same machine prior to this? If so, was sync working properly then?

2. What was running on the computer you were syncing from? (11.10?) Can you tell more about that other system?

3. You mentioned it happened a couple more times. In all these cases, were you doing the same action? E.g. was it always during a sync attempt?

4. Please outline exactly the steps you took to reproduce the failure. Assume the reader doesn't know software center.

5. When the system is frozen, can you ssh into it from another machine (e.g. through an ethernet cable)? If so, try to manually collect the i915_errors_file. It will be at /sys/kernel/debug/dri/0/i915_error_state file. What we hope to see is a non-zero value for EIR, PGTBL_ER, or one of the IPEHR's.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Matthijs ten Kate (igadget) wrote :

Thanks Bryce for your swift response. I'll try to answer your questions as best as possible:

1. The machine was running 11.10 before, but I completely wiped the root partition (I always do this due to bad past experiences with 'upgrades'). I never had any use for sync in the past, so I never tried.

2. Indeed, it was 11.10. Same machine. I did make a dd copy of the 11.10 root partition, so if it would be helpful I could restore that at some point.

3. Not always, no. The last time it happened I was busy filing a bug report on some other nasty things I ran into (12.04 has been a *very* bad experience on this machine so far)

4. Pfew... that's a hard one. It seems to happen quite randomly, although I do notice the system load is constantly between 0.5 and 1.5 (which, even on a quadcore i5, still seems quite high when just a couple of browser tabs and gedit are open). System monitor somehow is not showing what's causing this load, even when I show the processes of all users and sort by CPU %.

I will keep an eye on the system though and as soon as it happens again I will try to remember exactly what I was doing.

Perhaps I should keep a desktop recorder running... Do you happen to know any which would be suitable for this? GTKrecordmydesktop will probably not do since it encodes the video *after* the user has hit the 'stop' button.

5. Ok, I will install sshd on the machine and try to connect to it from my laptop when it freezes again. Problem is, last time it froze it also automatically rebooted after a few minutes. I hope that was a on-time quirk, otherwise I will have to move very fast.

Matthijs ten Kate (igadget) wrote :

Don't know if this helps, but bug 975315 was reported today and seems to be similar.

It just happened again, after first blanking for a moment (which kicked of apport, see bug 975444). SC was not even running, so I removed it from the bug's description. Now using GTKrecordmydesktop as I'm typing this (found a switch which enabled 'on the fly' encoding), so if it happens again we will at least know what I was doing :-)

summary: - [sandybridge-gt1] GPU lockup while using 'Sync Between Computers'
+ [sandybridge-gt1] GPU lockup
Matthijs ten Kate (igadget) wrote :

Oh and just as in bug 975444, the crash reports always come in pairs.

Matthijs ten Kate (igadget) wrote :

Well... it just happened again while browsing Youtube videos (unfortunately I was not running GTKrecordmydesktop) and when looking at the /sys/kernel/debug/dri/0/i915_error_state file via SSH, both EIR, PGTBL_ER, and all of the IPEHR's where displaying 0x0000000.

However, before this particular lockup I a was able to record a previous lockup which manifested itself a little differently - instead of locking up the entire interface, leaving me with only being able to move the mouse, it looked more as if everything besides the root X server crashed, leaving only the bare windows of the applications visible, without any decorations. I could still interact with the applications (at least those who were on top, switching between applications no longer worked) and could also still use CTRL-Alt-F1. After rebooting the machine from there, Apport prompted me with the same lockup detection as before.

The last thing I did before this happened was dragging an application window to the right.

Anything else I can do to get this sorted out?

Bryce Harrington (bryce) wrote :

Well, ideally we need to have a non-zero'd /sys/kernel/debug/dri/0/i915_error_state as kind of the entry ticket to go upstream.

But tell you what, try once more and snag a copy of whatever file is there and I'll send it up next week, zeros or no.

Matthijs ten Kate (igadget) wrote :

I just filed three more instances of this bug, one with the exact same result as in this bug (bug 978219) and two bugs (one pair) which are related to a single 'almost' crash: bug 978221 and bug 978222.

I hope these shed more light on the matter.

Also, I've attached the i915_error_state which is the result of two 'false' lockups (the first as described in bug 978221 and 978222 and the second occuring while I was entering this comment).

If you also need the i915_error_state of when the machine was 'truly' frozen, let me know.

Matthijs ten Kate (igadget) wrote :

And right after posting the previous comment, my system went one step further into the state of becoming fully unusable. This time it was the 'all-decorations-and-controls-gone' kind of crash. Luckily I still had this browser window open with the terminal on top, so I was able to 'save' the i915_error_state file once more. Please find it attached, I'm curious if it differs from the first.

Matthijs ten Kate (igadget) wrote :

Oh and the bugreport for #12 is bug 978239.

Matthijs ten Kate (igadget) wrote :

And here's a screenshot of what that particular 'crash' results into.

Matthijs ten Kate (igadget) wrote :

And here's a screenshot of what that particular 'crash' results into.

Bryce Harrington (bryce) on 2012-04-10
summary: - [sandybridge-gt1] GPU lockup
+ [sandybridge-gt1] GPU lockup with WARNING: at
+ /build/buildd/linux-3.2.0/drivers/gpu/drm/i915/i915_drv.c:413
+ __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]()
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Bryce Harrington (bryce) wrote :

Thanks for continuing to file the gpu lockup bugs. Reviewing all of them (including your manually collected dumps), it is always the same - zero error codes and the WARNING message above. Thinking the latter may be the most relevant bit.

Next step is probably to forward this upstream. Before we do so, since you're able to reproduce this fairly reliably it seems, could you test the current mainline kernel? .debs are available at http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Matthijs ten Kate (igadget) wrote :

Running this kernel now and was greeted by another Apport popup. Since I suspected this to be a leftover from the previous boot, I ignored it. I will keep working with this kernel and report my findings here.

One thing that has not been solved with this kernel is the load - this is still constantly between 0.5 and 1.5 on an idle system.

Bryce Harrington (bryce) on 2012-04-10
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Matthijs ten Kate (igadget) wrote :

Just filed bug 979367, bug 979368 and bug 979369 while running the 3.4rc22 kernel. However, over 200 megs in updates had not been applied yet, so perhaps this was all in vain :-(

Bryce Harrington (bryce) wrote :

Thanks Matt, let me know how it goes after the update. If the issue is still popping up after that, let's send this upstream and see if they have any wisdom to share.

Matthijs ten Kate (igadget) wrote :

Well after rebooting, the situation seems to be a lot better. With the previous kernel (or perhaps before the updates were applied) I would have experienced several lock ups by now, but right now it has not failed even once. Of course this is after running for less than half an hour, so I guess more extensive testing is need before I can safely say "it's fixed".

Unfortunately I need to get to bed now, but I will boot the (latest version of) the 3.2 kernel tomorrow and see if the lock ups return.

Matthijs ten Kate (igadget) wrote :

Today I experienced a complete lock up of the machine with kernel 3.4rc2, only a few minutes after booting. The only program that was running was Team Viewer 6.

After resetting the machine, the issue did not return and I also was not prompted by Apport to file a bug.
So perhaps it was a one-time issue... I will keep reporting my experiences.

I have not had the time yet to work with 3.2 again but hopefully I will find some time tonight.

I have the same issue here (i5-2500K). With all 3.2 kernel versions. But with mainline kernel 3.4rc1 i do not have the issue. Never. With 3.4rc2 it is back.

Matthijs ten Kate (igadget) wrote :

Well this is interesting. I've just been working for about an hour and a half with kernel 3.2.0-23 without experiencing a single lock up.

The load issue is still there though, but at least now I am able to get some work done. Now let's see how well this kernel deals with suspend/resume... I will keep posting as before.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36
Bryce Harrington (bryce) wrote :

Thanks for the updates Matthijs. Let's give it the weekend (upstream is off until monday anyway). Keep commenting here for each freeze you see.

Several others are seeing this same bug, so I strongly suspect it is not fixed yet.

Matthijs ten Kate (igadget) wrote :

Sure thing. I've reserved today for extensively testing 12.04 so hopefully by tomorrow I will have a fairly good picture of all the issues that are still present.

Bryce Harrington (bryce) on 2012-04-17
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Matthijs ten Kate (igadget) wrote :

Latest news after two more weeks of using 12.04:
- Crashes became less frequent but were indeed not gone both with the 3.4 as well as with the latest 3.2 kernel
- Apport no longer 'detected' any of the crashes so I was unable to send out any reports about them (regression in Apport?)
- Since the situation was unworkable for me and no solution is in sight, I have installed a separate video card. I don't expect the crashes to return now. If they do, I will of course let this know.

One funny detail is my laptop - it's running rock-solid with 12.04 even though it also has an i5 (m520 instead of 2500) with an i915 integrated GPU. Googling around suggests that this CPU is of the 'old' Nehalem architecture instead of Sandy Bridge, which would really pin-point the problem to Sandy Bridge CPU's. It's also running a lower res though. I will notice next week if this makes a difference when I get back to work (it's connected to an external 1920x1200 monitor there).

roko (rok-ostrovrsnik) wrote :

I have the same issue here (i5-2500) in final release of 12.04 . With all 3.2 kernel versions. I haven't tested 3.4 or 3.3 kernels. System crashes randomly when using firefox or libre office . First it starts to show black screen then it freezes totally.

zmago (zmago-fluks) wrote :

I also have same problem. I have Lenovo G570 also with sandy bridge. I even cannot use computer normally because it crashes randomly. Is so bad that soon I will start to hate Ubuntu. I'm sorry but is true. How can I help to fix this problem? I'm not a programmer but I can help other ways.
For sure I wont change my computer because of that but in the worst scenario I will change operating system.

zmago (zmago-fluks) wrote :

Ah sorry.. i forgot..
I have Ubuntu 12.04 64 bit all updates installed.

zmago (zmago-fluks) wrote :

At same time is happening in many cases that fonts are not readable anymore and pictures have some glitches... for example this page for me looks like this (attachment) ... and problem persist until computer freeze... if i restart everything is normal again... in log files is nothing special about this problem... but i have to admit that computer is barely usable with this problem because you never know when it will freeze and when fonts will get unreadable again...

what can we do about it?

Thanks

zmago (zmago-fluks) wrote :

Really nobody is interested in fixing this issue? I would like to help but I dont know where to begin. I've already submited issue many times by apport... I would like to help. My new laptop is in the bag most of the time because I can't use it...
Please can somebody respond that we begin somewhere?
Thanks

themacmeister (themacmeister) wrote :

This is the state of Linux at the moment. Complete hard-lockups on multiple computers/cpus completely ignored.

Thanks Intel and kernel developers, back to Windows 7 yet again.

zmago (zmago-fluks) wrote :

I would like to help with much as I can... but nobody is really interested about that. I know that there are lot of bugs. But this one makes computer unusable! Some of us are discussing it here and want to help... but we dont know yet how many other people already swithed to Windows or other linux distribution because of that.
My laptop always freeze at least once per day! There is no receipe for reproduction... it happens random but for sure.

Is it possible to start somewhere that we fix this bug? Or we should wait for the autumn that ubuntu 12.10 comes out?

zmago (zmago-fluks) wrote :

i'm getting suspicious about this issue... i've upgraded memory on my laptop and i feel that it works better now... i wonder how much memory do you guys have... i think that issue always come to the surface when the system starts to swap memory to the hard disk.
I'm gonna investigate this more in the future.

Before i've had 2gb of ram. Now i have 6gb so the system really never swaps.

zmago (zmago-fluks) wrote :

Okay, i'm using my laptop with 6 GB of ram for some time now. No issues at all.. my computer also never swaps now... i guess that this issue comes only when computer starts to swap memory to the hard disk .. i have similar problem on my desktop with totally different intel chipset but there happens only screen corruption like some fonts are hard to read etc and nothing else...

so i hope that with new drivers in ubuntu 12.10 this issue will be solved.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
Matthijs ten Kate (igadget) wrote :

This bug is still very much present, even with all the latest updates installed. I just ran into it several times after re-installing my system from scratch and trying again for a moment without the separate videocard. It's even become worse since the system just drops (locks) to a shell (see attached picture I took ) The only way out is a hard reset / power cycle. And after rebooting, Apport doesn't even notice the system has miserably failed.

I tried installing kernel 3.5 from linux-generic-lts-quantal (now at 3.5.0.22.29) and the situation is much better there, even though I did experience one lock-up as well. This lock-up was a bit different though, since the system didn't drop to a shell and I could still move the mouse cursor. Still had to hard reset my machine though.

What can I do to get this issue sorted out?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Expired → New
Changed in linux (Ubuntu):
status: Expired → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Matthijs ten Kate (igadget) wrote :

Here are two syslog snippets from the last time my machine crashed.
A lot of repeating stuff is going on at 14:11:41 (first file).

Matthijs ten Kate (igadget) wrote :

Then 6 seconds later, again (second file). The GUI is completely frozen at that point, but I can still move the mouse cursor.

I should point out that only the GUI breaks down - I can still SSH into the machine and do stuff from there.

In the mean time I've upgraded to kernel 3.7.4 to see if that fixes anything.

Matthijs ten Kate (igadget) wrote :

Just got a complete lock-up on kernel 3.7.4, I could not even ping the machine anymore. Syslog shows this as the last entry before I shut down the machine by pressing the power button for > 3 seconds (even the reset button did not work anymore!):

Jan 28 11:28:39 simba kernel: [ 7659.927292] [drm:__gen6_gt_force_wake_get] *ERROR* Timed out waiting for forcewake to ack request.
Jan 28 11:28:39 simba kernel: [ 7659.935289] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Jan 28 11:28:39 simba kernel: [ 7659.951879] ------------[ cut here ]------------
Jan 28 11:28:39 simba kernel: [ 7659.951911] WARNING: at /home/apw/COD/linux/drivers/gpu/drm/i915/intel_pm.c:4112 __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]()
Jan 28 11:28:39 simba kernel: [ 7659.951914] Hardware name: To Be Filled By O.E.M.
Jan 28 11:28:39 simba kernel: [ 7659.951915] Modules linked in: nls_iso8859_1 serpent_avx_x86_64 serpent_sse2_x86_64 serpent_generic twofish_generic twofish_avx_x86_64 twofish_x86_64_3way glue_helper twofish_x86_64 twofish_common dm_crypt nfsv3 snd_usb_audio coretemp snd_pcm kvm_intel kvm snd_page_alloc snd_hwdep snd_usbmidi_lib ghash_clmulni_intel snd_seq_midi snd_rawmidi aesni_intel ablk_helper cryptd lrw aes_x86_64 snd_seq_midi_event xts gf128mul snd_seq snd_timer snd_seq_device snd soundcore wacom bnep joydev microcode rfcomm nfsd i915 nfs_acl bluetooth drm_kms_helper parport_pc ppdev drm mac_hid i2c_algo_bit serio_raw video mei lpc_ich nfsv4 auth_rpcgss nfs fscache lockd sunrpc lp parport hid_logitech ff_memless firewire_ohci firewire_core crc_itu_t usbhid r8169 usb_storage hid
Jan 28 11:28:39 simba kernel: [ 7659.951972] Pid: 2033, comm: Xorg Tainted: G W 3.7.4-030704-generic #201301211706
Jan 28 11:28:39 simba kernel: [ 7659.951974] Call Trace:
Jan 28 11:28:39 simba kernel: [ 7659.951985] [<ffffffff8105872f>] warn_slowpath_common+0x7f/0xc0
Jan 28 11:28:39 simba kernel: [ 7659.951990] [<ffffffff8105878a>] warn_slowpath_null+0x1a/0x20
Jan 28 11:28:39 simba kernel: [ 7659.952006] [<ffffffffa02ef36e>] __gen6_gt_wait_for_fifo+0x9e/0xb0 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952017] [<ffffffffa02a84a0>] i915_write32+0xc0/0x1a0 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952032] [<ffffffffa02f2a41>] ring_write_tail+0x21/0x30 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952046] [<ffffffffa02f4379>] intel_ring_advance+0x49/0x50 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952060] [<ffffffffa02f4671>] blt_ring_flush+0x91/0xa0 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952073] [<ffffffffa02f5bb1>] intel_ring_invalidate_all_caches+0x41/0xe0 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952086] [<ffffffffa02c2173>] i915_gem_execbuffer_move_to_gpu+0x133/0x150 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952097] [<ffffffffa02c27f0>] i915_gem_do_execbuffer.isra.12+0x660/0x940 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952109] [<ffffffffa02c2fde>] i915_gem_execbuffer2+0xae/0x290 [i915]
Jan 28 11:28:39 simba kernel: [ 7659.952121] [<ffffffffa014e58c>] drm_ioctl+0x47c/0x540Jan 28 11:33:16 simba kernel: imklog 5.8.6, log source = /proc/kmsg started.

Matthijs ten Kate (igadget) wrote :

Also worth mentioning is that I'm also getting i915 related errors in syslog which actually did not cause any problems in the UI. All entries mentioned in the attached file for example - I just happened to see them because I had the Log File Viewer open at that moment, but the machine and UI just kept going without any noticeable problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
mmu2s (ykpmusicstudio) wrote :
Download full text (4.7 KiB)

I'm also struggling with this issue for a while now. I had the random crash during 2012, it stopped as soon as i stopped using Unity3D / compiz.

I'm not sure that it's completely related to this, but configuring VAAPI HW decoding in many applications (I've tried both mythtv and xmbc) triggers the gpu hang event quite quickly. The side effect is the crash of the related program as well...

I had some success with the latest xorg-edgers + kernel 3.5 for some time but it was not stable overall.

My HW configuration is quite plain (Asus P8H67-PRO / Intel i3 + integrated HD2000), the only specificites are a HauppageTV card (my configuration is a HTPC) and the HDMI output used as the main screen. This may not play a major role, though.

--- config ---
Linux MediaHTPC 3.5.0-18-generic #29~precise1-Ubuntu SMP Mon Oct 22 16:31:46 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
xorg-server 2:1.11.4-0ubuntu10.11
  libdri module version = 1.0.0
  libglx module version = 1.0.0
  libdri2 module version = 1.2.0 (i965)
  intel_drv module version = 2.17.0
i965_va_driver = 1.0.15-1ubuntu2
Intel(R) Core(TM) i3-2100T CPU @ 2.50GHz
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 2040:8400 Hauppauge WinTV Nova-T-500
-----

--- dmesg ---
[ 661.658237] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[ 661.658242] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 661.662557] [drm] Enabling RC6 states: RC6 off, RC6p off, RC6pp off
[ 663.093515] ------------[ cut here ]------------
[ 663.093524] WARNING: at /build/buildd/linux-lts-quantal-3.5.0/mm/page_alloc.c:2298 __alloc_pages_nodemask+0x2f2/0x930()
[ 663.093525] Hardware name: System Product Name
[ 663.093526] Modules linked in: snd_hda_codec_hdmi snd_hda_codec_realtek bnep rfcomm bluetooth coretemp dvb_usb_dib0700 dib0090 dib7000p kvm_intel dib7000m dib0070 dvb_usb kvm ppdev dib8000 eeepc_wmi dvb_core snd_hda_intel asus_wmi nfsd ghash_clmulni_intel snd_hda_codec dib3000mc nfs cryptd dibx000_common lockd snd_hwdep fscache binfmt_misc auth_rpcgss sparse_keymap nfs_acl rc_imon_pad psmouse snd_pcm sunrpc imon rc_core joydev snd_seq_midi microcode serio_raw lpc_ich snd_rawmidi snd_seq_midi_event parport_pc i915 snd_seq drm_kms_helper snd_timer drm snd_seq_device i2c_algo_bit video snd wmi soundcore mac_hid snd_page_alloc mei lp parport hid_logitech_dj r8169 pata_via usbhid hid usb_storage
[ 663.093568] Pid: 3217, comm: apport-gpu-erro Not tainted ...

Read more...

Chris Wilson (ickle) wrote :

The original incarnation of this bug will be avoided by using semaphores.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
zmago (zmago-fluks) wrote :

Ok what does this mean? Ive thought my problem is solved with upgrading ram. Im having same issue. What does mean that original incarnation of this bug will be avoided using semaphores? We are waiting for fix for this bug almost one year. Its serious bug as whole computer freezes and you cannot recover lost data anymore. Ive always thought that linux is something stable and reliable and that community has interest of fixing bugs especially if behind of that is some company which is in this case called Canonical. After 4 years of using Ubuntu im slowly giving up. My life is too short for waiting when critical bugs are going to be fixed. In this case is much 'cheaper' to pay for operating system. Nobody will give me back time of my life lost in frustration with operating system which should work in the first place.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers