Ubuntu

[regression] Xorg freeze

Reported by Eugene San on 2012-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Xorgs started to freeze frequently, once a day or so.
Mostly screen freeze, mouse cursor continue to move, no reaction to mouse clicks nor keyboard presses.

At least once, system managed to restore. After few seconds of screen freeze screen blanked and returned to normally working state.

Probably unrelated but chrome segfaulted on first attempt to start it after freeze/restore and started normally on second attempt.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Tue Mar 13 20:05:13 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.112+bdcom, 3.2.0-17-generic, i686: installed (WARNING! Diff between built and installed module!)
 bcmwl, 5.100.82.112+bdcom, 3.2.0-18-generic, i686: installed
 bcmwl, 5.100.82.112+bdcom, 3.2.0-18-generic-pae, i686: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Several times a week
GpuHangReproducibility: Seems to happen randomly
GpuHangStarted: Within the last week or two
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Apple Inc. Device [106b:00ea]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120101)
MachineType: Apple Inc. MacBookAir4,1
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic-pae root=UUID=c4aa6f13-6bc0-4f99-9f12-bb6cbb3e81cb ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/24/2012
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA41.88Z.0077.B0F.1201241549
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-C08A6BB70A942AC2
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir4,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-C08A6BB70A942AC2
dmi.modalias: dmi:bvnAppleInc.:bvrMBA41.88Z.0077.B0F.1201241549:bd01/24/2012:svnAppleInc.:pnMacBookAir4,1:pvr1.0:rvnAppleInc.:rnMac-C08A6BB70A942AC2:rvrMacBookAir4,1:cvnAppleInc.:ct10:cvrMac-C08A6BB70A942AC2:
dmi.product.name: MacBookAir4,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Eugene San (eugenesan) wrote :
Eugene San (eugenesan) wrote :
Eugene San (eugenesan) wrote :

One more hang.
This time I've managed to chvt/pm-suspend/resume (not sure which one actually helped) via SSH.

I'am uploading corresponding Xorg.log and i915_error_state.

Eugene San (eugenesan) wrote :
description: updated
bugbot (bugbot) on 2012-03-15
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Eugene San (eugenesan) wrote :

Yesterday I had very unpleasant incident due to this bug, my Laptop got overheated.
Video driver hang also blocks power control, therefore bug severity should be raised.

Bryce Harrington (bryce) wrote :

Interesting, you're definitely getting a GPU lockup:

Xorg.0.log
[ 339.944] [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
[ 339.944]
Backtrace:
[ 339.944] 0: /usr/bin/X (xorg_backtrace+0x37) [0xb7795007]
[ 339.944] 1: /usr/bin/X (mieqEnqueue+0x223) [0xb7773353]

dmesg:
[ 107.897744] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 107.897804] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 107.901347] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 17410 at 17406, next 17411)
[ 243.583933] cfg80211: All devices are disconnected, going to restore regulatory settings

That means X.org couldn't write to the GPU's memory, which is a symptom of a hung GPU.

However:

Time: 1331732836 s 509176 us
PCI ID: 0x0116
EIR: 0x00000000
PGTBL_ER: 0x00000000
ERROR: 0x00000000

I assume you gathered these by ssh'ing in when the system was hung?

In both your i915_error_state files, there are no errors registered, just 0's which indicate the GPU isn't hung on a software error. Any chance it could be a hardware error? Try booting an older ubuntu livecd from before you started noticing the error, like alpha2, and see if it reproduces there. If so, a hardware problem might be a good guess, so keep an eye on the cpu temperature and see if you have a bad fan or some such.

If it doesn't reproduce on the older ubuntu, then the kernel would be the next thing to look at.

Bryce Harrington (bryce) on 2012-03-16
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since there has not been a response from the original reporter. However, the issue still exists please feel free to reopen with the requested information. If you're not the original reporter, we'd prefer you file a new bug report.

Some tips:

  * Report X.org bugs via the command: `ubuntu-bug xorg`

  * Test against the latest development Ubuntu. http://cdimage.ubuntu.com/daily-live/
    Bugs marked as affecting the development version tend to get priority attention.

  * The `xdiagnose` utility has functionality for enabling debugging and
    analyzing a few common X problems.

  * Tag your bugs with the Ubuntu versions you have reproduced the issue in.

  * See https://wiki.ubuntu.com/X/Reporting for tips on writing good bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 960005, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers