i8xx: catch-all for terrible VBE implementations

Bug #9525 reported by Jan Groenewald on 2004-10-28
104
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

The above card in a dell laptop is not supported, so X freezes on a green (in my
case :) screen after the entire install was successful. Perhaps the more severe
bug is that failure is not detected, and the system doe snot drop to a shell or tty.

This might just be a hardware detection bug?

Previously I easily solved this by using the 855wrap utility from this url
http://www.chzsoft.com.ar/855patch.html
This was after a Debian install. I downloaded the source, compiled it and added
it to init.d to run during boot time before X starts. It works fine. I'm not
sure what the licence is (perhaps it cannot be included with ubuntu).

Daniel Stone (daniels) wrote :

I am writing this from a laptop with an i855 chipset, and it's working fine.
What resolution do you run?

Daniel Stone (daniels) wrote :

Having looked at the 855wrap code, there is absolutely no way we can ship this.
 It also doesn't detect which BIOS revisions are buggy; it just overwrites it
regardless. I think the best solution here is to get the upstream author to
co-ordinate with X.Org, so it can automatically detect buggy BIOS revisions, and
patch (or avoid the buggy call altogether) as needed. This goes for 855patch,
865patch, whatever, also; they are all far too unclean to put into an Ubuntu
release. Sorry.

This problem also occurs on ASUS M5000N notebooks which use the i855GM graphics chipset. I have
just installed Ubuntu 4.10 "Warty Warthog" Release, but when it starts X I get a blank green
screen.

To fix this problem put the following line in the "Device" section of your /etc/X11/XF86Config-4

Option "DisplayInfo" "FALSE"

The 855patch or 855wrap hacks are not needed with the above line. Also, I thought that these
hacks were intended to fix problems with the chipset when it comes out of the various suspend
modes and has the incorrect memory allocated.

Daniel Stone (daniels) wrote :

You're experiencing a different problem with a different fix, that's equally
undetectable. There's a large suite of 8?5* programs that are all working
around terrible VBE implementations in different BIOSes -- the symptoms are all
different. Until we can get docs for the >40 vendor video BIOSes attached to
i855 cards, there's nothing we can do about this. Sorry.

Daniel Stone (daniels) wrote :

*** Bug 10179 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

*** Bug 10854 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

So, as a rather exciting aside:
CVSROOT: /cvs/xorg
Module name: xc
Changes by: <email address hidden> 05/01/06 06:43:14

Log message:
  2005-01-06 Alan Hourihane <email address hidden>
        [...]
   Add:
   - Intel i915GM support to 2D DDX and 3D Mesa drivers.
   - PanelID identification
   - DRI suspend/resume support
   - Detection of monitor changes on VT switches
   - Support custom video modes if available in the Video BIOS
   - 3D enhancements:
    * GL_ARB_texture_cube_map
    * GL_EXT_blend_equation_separate
    * GL_ATI_blend_equation_separate
    * GL_ARB_point_parameters
    * GL_NV_blend_square
    * GL_EXT_cull_vertex
    * GL_ARB_depth_texture
    * GL_SGIX_depth_texture
    * GL_ARB_shadow
    * GL_EXT_shadow_funcs
    * GL_3DFX_texture_compression_FXT1
   By Tungsten Graphics, Keith Whitwell & Alan Hourihane.

I plan to merge this patch into 6.8.1-1ubuntu10, so we'll see to what extent it
fixes our problems.

Daniel Stone (daniels) wrote :

*** Bug 13030 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

*** Bug 13689 has been marked as a duplicate of this bug. ***

Gregory P Smith (gpshead) wrote :

I have a Dell Inspiron 700m with the i855 UMA video chipset. Its flat panel is
1280x800 but the BIOS does not properly list that resolution in its VESA tables
so the X server (Xorg, i'm running hoary) won't try the video mode. Using <a
href="http://perso.wanadoo.fr/apoirier/">855resolution by Alain Poirier</a> i
can patch the bios video mode table to list the mode which allows the X server
to actually use that resolution. I agree, this is something that should really
be dealt with in the X server and not with ad-hoc random bios patching
workarounds like this. It sounds like lots of laptops suffer these bad bioses
and will continue to in the future.

I just wanted to let you know that 855resolution/915resolution is being
integrated into the i810 driver.

This might open new options of Ubuntu setting sensible defaults for Notebooks
with bad BIOSes.

For example, the Dell X1 (with the A01 or A02 BIOS) would benefit from the
following option in the device section:

Option "ForceBIOS" "1920x1440=1280x768"

Daniel Stone (daniels) wrote :

*** Bug 17569 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

*** Bug 18682 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

*** Bug 16121 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

*** Bug 20859 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

*** Bug 20209 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) on 2006-03-10
Changed in xorg:
assignee: daniels → nobody
Matt Zimmerman (mdz) on 2006-03-31
Changed in xorg:
status: Unconfirmed → Confirmed

For your information, there is now a modesetting branch of the Intel driver(s) for native modesetting without the video BIOS.

See: http://wiki.x.org/wiki/IntelGraphicsDriver

Perhaps that could be used to solve this issue for Edgy?

Joseph Piché (josephpiche) wrote :

I believe this bug is now fixed. Can someone confirm this?

trollord (trollenlord) wrote :

Actual fixes missed Edgy and Feisty.

Fix has been released on Gutsy. It ships with updated display driver that is able to work with wide-screen modes out of the box, and should fix all if not most green syncing issues for older hardware.

Changed in xserver-xorg-video-i810:
status: Confirmed → Fix Committed

Hi

I have the same problem, I'm on gutsy

My video card is a Intel 82815 CGC [Chipset Graphics Controller]

Regards,

It's fine now :)

Regards

unggnu (unggnu) wrote :

Problem seems to be fixed in Gutsy so I close this bug report. I guess that the new Intel driver wouldn't be available for Dapper and Edgy but Feisty already has it xserver-xorg-video-intel.
Feel free to open it again if it still happens under Gutsy and with the new Intel driver.

Changed in xserver-xorg-video-i810:
status: Fix Committed → Fix Released

Hi

On Sun, Oct 28, 2007 at 11:54:52AM -0000, unggnu wrote:
> Problem seems to be fixed in Gutsy so I close this bug report. I guess that the new Intel driver wouldn't be available for Dapper and Edgy but Feisty already has it xserver-xorg-video-intel.
> Feel free to open it again if it still happens under Gutsy and with the new Intel driver.
>
> ** Changed in: xserver-xorg-video-i810 (Ubuntu)
> Status: Fix Committed => Fix Released

I did an Gutsy Beta alternate CD install on the same dell
latitude which originally gave me this problem, and the
graphics did not work until I booted a command line system,
installed 915 resolution, dpkg-reconfigured xserver-xorg.

cheers,
Jan

--
   .~.
   /V\ Jan Groenewald
  /( )\ www.aims.ac.za
  ^^-^^

unggnu (unggnu) wrote :

@Jan Groenewald
Could you please recheck it with the Gutsy Final Live CD? Especially Intel driver was updated several times after Gutsy Beta.
If It doesn't work with Live CD and the new Intel driver please attach the files '/var/log/Xorg.0.log', '/var/log/Xorg.0.log.old' and '~/.xsession-errors' and the output of 'of
lspci -vvnn '?

Changed in xserver-xorg-video-i810:
status: Fix Released → Incomplete
Jan Groenewald (jan-aims) wrote :

Hi

On Mon, Oct 29, 2007 at 08:21:10AM -0000, unggnu wrote:
> @Jan Groenewald
> Could you please recheck it with the Gutsy Final Live CD? Especially Intel driver was updated several times after Gutsy Beta.
> If It doesn't work with Live CD and the new Intel driver please attach the files '/var/log/Xorg.0.log', '/var/log/Xorg.0.log.old' and '~/.xsession-errors' and the output of 'of
> lspci -vvnn '?
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Sourcepackagename: xserver-xorg-video-i810 => xserver-xorg-video-intel
> Status: Fix Released => Incomplete

I can unfortunately not reinstall that laptop from CD now.

Dell Latitude D505:
   jan@osprey:~$lspci -vvnn|grep -A8 855GM
   00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA])
    Subsystem: Dell Latitude D505 [1028:0163]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 0
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
    Region 1: Memory at faf80000 (32-bit, non-prefetchable) [size=512K]
    Region 2: I/O ports at c000 [size=8]
   --
   00:02.1 Display controller [0380]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
    Subsystem: Dell Latitude D505 [1028:0163]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 0
    Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
    Region 1: Memory at faf00000 (32-bit, non-prefetchable) [size=512K]
    Capabilities: <access denied>
   jan@osprey:~$grep -C3 855GM /etc/X11/xorg.conf
   EndSection

   Section "Device"
    Identifier "Intel Corporation 82852/855GM Integrated Graphics Device"
    Driver "intel"
    BusID "PCI:0:2:0"
   EndSection
   --

   Section "Screen"
    Identifier "Default Screen"
    Device "Intel Corporation 82852/855GM Integrated Graphics Device"
    Monitor "Generic Monitor"
    DefaultDepth 24
   EndSection

But I did
 $ sudo update-rc.d -f 915resolution remove
 $ sudo shutdown -r now
and it came up just fine, no problems...

   jan@osprey:~$apt-cache show 915resolution |grep -A3 obsolete
    The 915resolution package becomes obsolete with the newer xorg,
    especially if you have the xserver-xorg-video-intel package installed.
    Newer xorg brings modesetting support by default.
    .

Perhaps someone else can check an actual install from desktop/alternate CD.

regards,
Jan

--
   .~.
   /V\ Jan Groenewald
  /( )\ www.aims.ac.za
  ^^-^^

unggnu (unggnu) wrote :

You don't need to reinstall. Only boot the Gutsy Final desktop CD and check if resolution and everything else works fine. 915resolution isn't needed anymore for new Intel driver which is default in Gutsy.
But afaik Intel driver has still some problems with i855 card (Bug #108056).
At least attach the informations I asked for.

Jan Groenewald (jan-aims) wrote :

Hi

On Tue, Oct 30, 2007 at 10:12:05AM -0000, unggnu wrote:
> You don't need to reinstall. Only boot the Gutsy Final desktop CD and check if resolution and everything else works fine. 915resolution isn't needed anymore for new Intel driver which is default in Gutsy.
> But afaik Intel driver has still some problems with i855 card (Bug #108056).
> At least attach the informations I asked for.

The live CD boots fine.

The problem previously was not the liveCD, but the graphics after
an alternate CD install and reboot. In previous releases I have had
liveCDs boot and show graphics, but the intel driver fail after an
install and reboot. So I am not sure the current test of booting
a liveCD proves anything.

The lspci output was in the previous email. There are no X logs
with a failure, since I cannot reinstall now. Perhaps it is fixed,
or perhaps someone else can test this.

Thanks,
Jan

--
   .~.
   /V\ Jan Groenewald
  /( )\ www.aims.ac.za
  ^^-^^

Joseph Piché (josephpiche) wrote :

Can this bug be confirmed as fixed? If so, it should be marked accordingly.

Jan Groenewald (jan-aims) wrote :

Hi

On Tue, Dec 11, 2007 at 04:09:33PM -0000, Joseph Piche wrote:
> Can this bug be confirmed as fixed? If so, it should be marked
> accordingly.

My Dell Latitude D505 with 82852/855GM is now running hardy (dev).

I did a "update-rc.d -f 915resolution remove" and "reboot" and
the graphics came up OK so it seems to be fixed yes.

regards,
Jan

--
   .~.
   /V\ Jan Groenewald
  /( )\ www.aims.ac.za
  ^^-^^

Timo Aaltonen (tjaalton) wrote :

Ok, marking as fixed, thanks!

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.