Ubuntu

gnome-terminal and terminator slow under moderate load

Reported by Bayle Shanks on 2012-01-21
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Under Unity-2D 11.10, when running a program which rapidly outputs a lot of text to the terminal, both gnome-terminal and terminator respond sluggishly; keyboard input into the terminal takes a long time to be accepted, switching workspaces to or from the workspace displaying the offending terminal window takes a few seconds.

Also, dragging the scrollbar to scroll takes forever in both gnome-terminal and terminator; the scrollbar does not jump to the desired location but slowly moves towards it; during this time the terminal is unresponsive.

This did not occur in Natty under Gnome 2.

This does not occur in xterm.

See also
https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/850649 . I am not positive that this bug lies in xorg, but it is more general that gnome-terminal, and also a comment in that thread requested that someone do a "ubuntu-bug xorg" in order to capture graphics config info.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,imgpng,unitymtgrabhandles,grid,mousepoll,resize,place,move,workarounds,regex,session,snap,gnomecompat,compiztoolbox,scale,wall,unityshell]
CompositorRunning: None
Date: Fri Jan 20 16:45:38 2012
DistUpgraded: Log time: 2012-01-20 00:09:28.333348
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 hid, 1.1.2, 2.6.38-13-generic, x86_64: installed
 hid-ntrig, 1.1.5, 2.6.38-13-generic, x86_64: installed
 hid-ntrig, 1.1.5, 3.0.0-14-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Limited. Device [10cf:150e]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: FUJITSU T580
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=943d58a7-438a-48a0-81ab-321ebc8a09b2 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to oneiric on 2012-01-20 (0 days ago)
dmi.bios.date: 12/24/2010
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.04
dmi.board.name: FJNB21E
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: AI40110911BA1023
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.04:bd12/24/2010:svnFUJITSU:pnT580:pvr:rvnFUJITSU:rnFJNB21E:rvr:cvnAI40110911BA1023:ct10:cvr:
dmi.product.name: T580
dmi.sys.vendor: FUJITSU
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Bayle Shanks (bshanks) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2012-02-08
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Chris Wilson (ickle) wrote :

Lack of acceleration in UXA, fixed in raring by switching to SNA.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.