eog logs me out when I try to turn right or left an image

Bug #889068 reported by G J on 2011-11-11
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington
Oneiric
High
Unassigned
Precise
High
Bryce Harrington

Bug Description

[Impact]
X server crash which can occur when loading or interacting with large pixmap images.

[Development Fix]
Upstream fixed the issue in the upstream git tree for the -intel driver. It reworks the code that calculates pixmap size limits and ensures properly sized fallback mappings for source, destination, and masking pixmaps. Backporting the patches to the version of -intel we currently have in Precise was straightforward, and have been verified to fix the issue.

[Stable Fix]
The same patch applied to Precise's -intel applies without modification to Oneiric. A visual inspection of the code shows the surrounding code hasn't really changed so it's expected this patch will work as well in Oneiric as in Precise.

[Text Case]
0. watch dmesg and /var/log/Xorg.0.log
1. Obtain a large jpg file, such as a photo scaled up in gimp to >16M in file size.
2. Load the photo using eog
3. If eog successfully loads it, try rotating the image several times
Broken Behavior: Errors will emit to dmesg and X logs, then GPU will lockup and/or the X server will crash
Fixed Behavior: The image will load and rotate without crashes or lockups.

[Regression Potential]
Things to watch for include X crashes or odd behaviors relating to large image rotation or interaction. Indeed, upstream thinks there might be some secondary issues (haven't seen any so far myself), but presumably less severe than crashing.

Since the patch is the same for both oneiric and precise, I think we'll get an ample amount of testing just from folks running Precise. And the chance of there being regressions from this patch affecting oneiric, that don't affect precise, should be very low.

[Original Report]
When I turn left or right an image, system logs out and I have to log again on my count

(gdb) backtrace full
#0 __memcpy_ssse3_rep () at ../sysdeps/i386/i686/multiarch/memcpy-ssse3-rep.S:191
No locals.
#1 0xb739788c in intel_uxa_pixmap_put_image (pixmap=<optimized out>, src=0x9c6e420 "",
    src_pitch=32000, x=0, y=0, w=8000, h=8) at /usr/include/i386-linux-gnu/bits/string3.h:52
        dst = 0xa41ee000 <Address 0xa41ee000 out of bounds>
        row_length = 32000
        num_rows = 8
        priv = 0x9ba3298
        stride = 32256
        cpp = <optimized out>
        ret = 0
#2 0xb739968c in intel_uxa_put_image (pixmap=0x9ba3250, x=0, y=0, w=8000, h=8, src=0x9c6e420 "",
    src_pitch=32000) at ../../src/intel_uxa.c:769
        priv = 0x9ba3298
#3 0xb73b0553 in uxa_do_put_image (src_stride=32000, bits=0x9c6e420 "", format=2, h=8, w=8000, y=0,
    x=0, pGC=0x9c399d0, pDrawable=0x9ba3250, depth=<optimized out>) at ../../uxa/uxa-accel.c:164
        y1 = 0
        x2 = 159692224
        ok = <optimized out>
        x1 = <optimized out>
        y2 = <optimized out>
        src = 0x9c6e420 ""
        yoff = 0
        uxa_screen = 0x0
        pPix = 0x9ba3250
        pClip = <optimized out>
        pbox = 0x9c1c590
        nbox = <optimized out>
        xoff = 0
        bpp = <optimized out>
#4 uxa_put_image (pDrawable=0x9ba3250, pGC=0x9c399d0, depth=24, x=0, y=0, w=8000, h=8, leftPad=0,
    format=2, bits=0x9c6e420 "") at ../../uxa/uxa-accel.c:202
No locals.

From dmesg:
[ 41787.607] (EE) intel(0): Couldn't create pixmap for fbcon
...
[ 52602.993] (EE) intel(0): Couldn't create pixmap for fbcon
...
[ 88171.985] (EE) intel(0): Couldn't create pixmap for fbcon
...
[ 88172.435] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.438] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88172.440] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.440] (WW) intel(0): first get vblank counter failed: Invalid argument
[ 88172.903] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.905] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88172.959] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.970] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88173.143] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88173.177] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88173.363] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88174.698] (WW) intel(0): first get vblank counter failed: Invalid argument
[ 88175.457] (WW) intel(0): first get vblank counter failed: Invalid argument
<repeats for a while>
[100285.751] (WW) intel(0): first get vblank counter failed: Invalid argument
[100314.429]
Backtrace:
[100314.770] 0: /usr/bin/X (xorg_backtrace+0x37) [0x80a66f7]
[100314.770] 1: /usr/bin/X (0x8048000+0x62b3a) [0x80aab3a]
[100314.770] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x1c340c]
[100314.770] 3: /lib/i386-linux-gnu/libc.so.6 (0x276000+0x117771) [0x38d771]
[100314.770] 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x52a000+0xe85c) [0x53885c]
[100314.770] 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x52a000+0x1066c) [0x53a66c]
[100314.770] 6: /usr/lib/xorg/modules/drivers/intel_drv.so (0x52a000+0x27873) [0x551873]
[100314.770] 7: /usr/bin/X (0x8048000+0xe643a) [0x812e43a]
[100314.771] 8: /usr/bin/X (0x8048000+0x26997) [0x806e997]
[100314.771] 9: /usr/bin/X (0x8048000+0x2a117) [0x8072117]
[100314.771] 10: /usr/bin/X (0x8048000+0x1c70c) [0x806470c]
[100314.771] 11: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0x28f113]
[100314.771] 12: /usr/bin/X (0x8048000+0x1ca21) [0x8064a21]
[100314.771] Bus error at address 0xa38ba008
[100314.800]
Caught signal 7 (Bus error). Server aborting

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: eog 3.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Fri Nov 11 12:42:15 2011
ExecutablePath: /usr/bin/eog
InstallationMedia: Ubuntu 11.10 "Oneiric" - Build i386 LIVE Binary 20111013-11:02
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: eog
UpgradeStatus: Upgraded to oneiric on 2011-11-05 (6 days ago)

G J (g-jarnot) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you add your /var/log/Xorg.0.log.old to the bug after getting the issue? Does it happen every time? Is that specific to one image?

Changed in eog (Ubuntu):
importance: Undecided → High
status: New → Incomplete
G J (g-jarnot) wrote :

It only happens with an 1.6M image (.jpeg)
When system logs out, it indicates : "could not write bytes : broken pipe"

Sebastien Bacher (seb128) wrote :

The log shows that xorg is hitting an issue there:

Backtrace:
[100314.770] 0: /usr/bin/X (xorg_backtrace+0x37) [0x80a66f7]
[100314.770] 1: /usr/bin/X (0x8048000+0x62b3a) [0x80aab3a]
[100314.770] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x1c340c]
[100314.770] 3: /lib/i386-linux-gnu/libc.so.6 (0x276000+0x117771) [0x38d771]
[100314.770] 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x52a000+0xe85c) [0x53885c]
[100314.770] 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x52a000+0x1066c) [0x53a66c]
[100314.770] 6: /usr/lib/xorg/modules/drivers/intel_drv.so (0x52a000+0x27873) [0x551873]
[100314.770] 7: /usr/bin/X (0x8048000+0xe643a) [0x812e43a]
[100314.771] 8: /usr/bin/X (0x8048000+0x26997) [0x806e997]
[100314.771] 9: /usr/bin/X (0x8048000+0x2a117) [0x8072117]
[100314.771] 10: /usr/bin/X (0x8048000+0x1c70c) [0x806470c]
[100314.771] 11: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0x28f113]
[100314.771] 12: /usr/bin/X (0x8048000+0x1ca21) [0x8064a21]
[100314.771] Bus error at address 0xa38ba008

affects: eog (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
Papamatti2 (papamatti2) wrote :

Could this be a duplicate of bug #877731 ?

G J (g-jarnot) wrote :

No, system logs out, restarts itself

Kai Krueger (kakrueger) wrote :

I think I might also be seeing this (or a similar) bug

I also occasionally get logged out because Xorg crashes and then automatically restarts.

Most of the time so far it has been when coming out of suspend-to-ram, but today it has also happened after trying to start an image with eog. I haven't found a way to reproduce it yet.

I am running Ubuntu 10.10 64bit on a Macbook 4.1, graphics card is a Mobile GM965/GL960.

I am using gnome-classic as the window manager.

form Xorg.0.log.old I got:

[597577.340]
Backtrace:
[597577.392] 0: /usr/bin/X (xorg_backtrace+0x26) [0x460566]
[597577.392] 1: /usr/bin/X (0x400000+0x64b7a) [0x464b7a]
[597577.392] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fe3dd97f000+0x10060) [0x7fe3dd98f060]
[597577.392] 3: /lib/x86_64-linux-gnu/libc.so.6 (0x7fe3dc89a000+0x12fe51) [0x7fe3dc9c9e51]
[597577.392] 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fe3daabf000+0x11346) [0x7fe3daad0346]
[597577.392] 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fe3daabf000+0x12f27) [0x7fe3daad1f27]
[597577.392] 6: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fe3daabf000+0x28e24) [0x7fe3daae7e24]
[597577.392] 7: /usr/bin/X (0x400000+0xe082c) [0x4e082c]
[597577.392] 8: /usr/bin/X (0x400000+0x2c87e) [0x42c87e]
[597577.392] 9: /usr/bin/X (0x400000+0x2fb89) [0x42fb89]
[597577.392] 10: /usr/bin/X (0x400000+0x232fe) [0x4232fe]
[597577.392] 11: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fe3dc8bb30d]
[597577.392] 12: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
[597577.392] Bus error at address 0x7fe3c5189010
[597577.392]
Caught signal 7 (Bus error). Server aborting

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
anakha (keryilmaz) wrote :

I also have a similar problem with X deciding to restart itself every now and again. Notice that although the log is almost identical, there is something about a failed attempt at submitting batch buffer. I don't know if it is relevant but I included it just in case.

Using 64-bit version of Ubuntu 11.10. The problem persists in both 3D and 2D sessions.

[859350.908] (EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: No space left on device.
[859350.951]
Backtrace:
[859351.108] 0: /usr/bin/X (xorg_backtrace+0x26) [0x460566]
[859351.108] 1: /usr/bin/X (0x400000+0x64b7a) [0x464b7a]
[859351.108] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fcc98072000+0x10060) [0x7fcc98082060]
[859351.108] 3: /lib/x86_64-linux-gnu/libc.so.6 (0x7fcc96f8d000+0x12fef7) [0x7fcc970bcef7]
[859351.108] 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fcc951b2000+0x11346) [0x7fcc951c3346]
[859351.108] 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fcc951b2000+0x12f27) [0x7fcc951c4f27]
[859351.108] 6: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fcc951b2000+0x28e24) [0x7fcc951dae24]
[859351.108] 7: /usr/bin/X (0x400000+0xe082c) [0x4e082c]
[859351.108] 8: /usr/bin/X (0x400000+0x2c87e) [0x42c87e]
[859351.108] 9: /usr/bin/X (0x400000+0x2fb89) [0x42fb89]
[859351.108] 10: /usr/bin/X (0x400000+0x232fe) [0x4232fe]
[859351.108] 11: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fcc96fae30d]
[859351.108] 12: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
[859351.108] Bus error at address 0x7fcc80c9d010
[859351.108]
Caught signal 7 (Bus error). Server aborting
[859351.108]
Please consult the The X.Org Foundation support

Timo Aaltonen (tjaalton) wrote :

Could you post the output of 'lspci -nn | grep VGA' here, so we'd know if it's specific to a certain chipset.

Also, testing on 12.04 alpha2 livecd would be great.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
anakha (keryilmaz) wrote :

here's the output for lspci -nn | grep VGA for me:

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series] [1002:9552]

marw (marw) wrote :

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)

G J (g-jarnot) wrote :

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

Bryce Harrington (bryce) on 2012-02-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
description: updated
description: updated
Bryce Harrington (bryce) wrote :

If #9 is indeed the same bug, sounds like it could have something to do with resource exhaustion. Interesting. Probably a pixmap buffer that's not being dynamically resized properly.

Everyone experiencing this bug, please collect a full backtrace on this crash - see http://wiki.ubuntu.com/X/Backtracing for guidance. Post your full traces here.

The abbreviated traces people have posted are somewhat different from the OP. Please indicate if you see these crashes also after rotating an image left or right in eog.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
marw (marw) wrote :

I hope I got this "gdb backtrace" correctly (attached).

marw (marw) wrote :

Backtrace again, but with libc6-dbg and xserver-xorg-video-intel-dbg installed.

Btw, this crash happens on my computer once loading of a 16 MB JPG reaches 100% in eog.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
importance: Undecided → High
Bryce Harrington (bryce) wrote :

        dst = 0xa41ee000 <Address 0xa41ee000 out of bounds>

Bingo, good work.

description: updated
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: New → Triaged
Download full text (4.7 KiB)

Forwarding this bug from Ubuntu reporter Gatan Jarnot:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/889068

[Problem]
When rotating a large image (e.g. 16M), the X server crashes with the stacktrace shown below.

It appears something's trying to copy a pixmap to an invalid address.

[Original Description]
When I turn left or right an image, system logs out and I have to log again on my count

(gdb) backtrace full
#0 __memcpy_ssse3_rep () at ../sysdeps/i386/i686/multiarch/memcpy-ssse3-rep.S:191
No locals.
#1 0xb739788c in intel_uxa_pixmap_put_image (pixmap=<optimized out>, src=0x9c6e420 "",
    src_pitch=32000, x=0, y=0, w=8000, h=8) at /usr/include/i386-linux-gnu/bits/string3.h:52
        dst = 0xa41ee000 <Address 0xa41ee000 out of bounds>
        row_length = 32000
        num_rows = 8
        priv = 0x9ba3298
        stride = 32256
        cpp = <optimized out>
        ret = 0
#2 0xb739968c in intel_uxa_put_image (pixmap=0x9ba3250, x=0, y=0, w=8000, h=8, src=0x9c6e420 "",
    src_pitch=32000) at ../../src/intel_uxa.c:769
        priv = 0x9ba3298
#3 0xb73b0553 in uxa_do_put_image (src_stride=32000, bits=0x9c6e420 "", format=2, h=8, w=8000, y=0,
    x=0, pGC=0x9c399d0, pDrawable=0x9ba3250, depth=<optimized out>) at ../../uxa/uxa-accel.c:164
        y1 = 0
        x2 = 159692224
        ok = <optimized out>
        x1 = <optimized out>
        y2 = <optimized out>
        src = 0x9c6e420 ""
        yoff = 0
        uxa_screen = 0x0
        pPix = 0x9ba3250
        pClip = <optimized out>
        pbox = 0x9c1c590
        nbox = <optimized out>
        xoff = 0
        bpp = <optimized out>
#4 uxa_put_image (pDrawable=0x9ba3250, pGC=0x9c399d0, depth=24, x=0, y=0, w=8000, h=8, leftPad=0,
    format=2, bits=0x9c6e420 "") at ../../uxa/uxa-accel.c:202
No locals.

From dmesg:
[ 41787.607] (EE) intel(0): Couldn't create pixmap for fbcon
...
[ 52602.993] (EE) intel(0): Couldn't create pixmap for fbcon
...
[ 88171.985] (EE) intel(0): Couldn't create pixmap for fbcon
...
[ 88172.435] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.438] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88172.440] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.440] (WW) intel(0): first get vblank counter failed: Invalid argument
[ 88172.903] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.905] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88172.959] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88172.970] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88173.143] (WW) intel(0): I830DRI2GetMSC:1297 get vblank counter failed: Invalid argument
[ 88173.177] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88173.363] (WW) intel(0): I830DRI2ScheduleWaitMSC:1364 get vblank counter failed: Invalid argument
[ 88174.698] (WW) intel(0): first get vblank counter failed: Invalid argument
[ 88175.457] (WW) intel(0): first get vblank coun...

Read more...

Bryce Harrington (bryce) wrote :

I'm able to reproduce a crash when loading a 20M image into eog, but not quite the same stacktrace as posted in the above comments.

So, for now I'll forward this upstream in case they have some insights.

Created attachment 57059
Xorg.0.log.old

Created attachment 57060
gdb-Xorg.txt

        dst = 0xa41ee000 <Address 0xa41ee000 out of bounds>

Failing in this chunk of code in intel_uxa.c:

                char *dst = priv->bo->virtual;
                int row_length = w * cpp;
                int num_rows = h;
                if (row_length == src_pitch && src_pitch == stride)
                        num_rows = 1, row_length *= h;
                dst += y * stride + x * cpp;
                do {
                        memcpy (dst, src, row_length);
                        src += src_pitch;
                        dst += stride;
                } while (--num_rows);

I've been able to reproduce an X server crash (rather, an EQ overflow) by loading a large (20M) image into eog, but so far haven't been able to get the reporter's same backtrace.

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Confirmed

The SIGBUS is fixed with

commit 85d3dc5910a2eea3a10b822e01443e11eaae9291
Author: Chris Wilson <email address hidden>
Date: Fri Dec 2 10:22:51 2011 +0000

    uxa: Reset size limits based on AGP size

    The basis for the constraints are what we can map into the aperture for
    direct writing with the CPU, so use the size of the mappable region as
    opposed to the size of the total GTT.

    Signed-off-by: Chris Wilson <email address hidden>

commit f6c82c73b673ec3c9cce432fe38d5e0076234efd
Author: Chris Wilson <email address hidden>
Date: Fri Dec 2 10:34:10 2011 +0000

    uxa: Fix runtime linking of previous commit

    So much for relying on compiler warnings.

    Signed-off-by: Chris Wilson <email address hidden>

commit 735219cd59e6184a6622d3d429a704ca3f58b9cd
Author: Chris Wilson <email address hidden>
Date: Fri Dec 2 10:42:00 2011 +0000

    uxa: Ensure that we can fallback with all of (src, mask, dst) as GTT mappings

    Signed-off-by: Chris Wilson <email address hidden>

However, the original reporter has a lot of collateral damage which would be useful to follow up separately after getting the obvious bugs fixed.

Thanks, confirmed this appears to have resolved it on my own hardware too.
Will file a new bug report for any secondary issues the original reporter still has.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.17.0-1ubuntu4

---------------
xserver-xorg-video-intel (2:2.17.0-1ubuntu4) precise; urgency=low

  * Add 104_uxa_fix_gtt_mapping_limits.patch: Fix SIGBUS errors
    encountered with loading/manipulating large pixmap images.
    Backport of three upstream commits.
    (LP: #889068)
 -- Bryce Harrington <email address hidden> Wed, 15 Feb 2012 17:16:19 -0800

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Triaged → Fix Released
Bryce Harrington (bryce) wrote :

The patches upstream pointed out resolved the crash I see on my hardware.

Update to this version and re-test. It should improve things, but potentially you may still have some secondary issues; if so please file a new bug report and we'll take it from there. (Make reference to this bug #889068 for context.)

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Fix Released → Triaged
Bryce Harrington (bryce) on 2012-02-16
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Triaged → Fix Released
assignee: nobody → Bryce Harrington (bryce)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Posted to oneiric for SRU.

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2012-02-16
description: updated
description: updated
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released

Hello Gaëtan, or anyone else affected,

Accepted xserver-xorg-video-intel into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
manes (neschmuel) wrote :

I still have the same problem on the latest Ubuntu 12.04 using an ATI X2300 graphics card with the open source driver. Opening a JPG with eog crashes X.

Bryce Harrington (bryce) wrote :

@manes, if you check, the fix was for -intel, which is not the driver you're using.

Chris Halse Rogers (raof) wrote :

Ping! Is anyone able to confirm this fix on Oneiric? It's now holding up another -intel fix we'd like to SRU.

Johannes H. Jensen (joh) wrote :

@raof: I just tested the fix from oneiric-proposed and can confirm that the crashes no longer happen when opening large images in eog.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.15.901-1ubuntu2.2

---------------
xserver-xorg-video-intel (2:2.15.901-1ubuntu2.2) oneiric-proposed; urgency=low

  * Add 104_uxa_fix_gtt_mapping_limits.patch: Fix SIGBUS errors
    encountered with loading/manipulating large pixmap images.
    Backport of three upstream commits.
    (LP: #889068)
 -- Bryce Harrington <email address hidden> Thu, 16 Feb 2012 11:22:55 -0800

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.