libreoffice: graphical corruption with welcome screen, after closing application

Bug #874559 reported by Alan Jenkins on 2011-10-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

1. Open LibreOffice (any component).
2. File->Close

As expected, LibreOffice remains open, allowing you to e.g. create a new document. Unfortunately, the window becomes corrupted. Portions of the closed document are left in the window background.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 20:34:34 2011
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (0 days ago)
---
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DistUpgraded: Log time: 2011-10-14 08:10:00.800161
DistroCodename: oneiric
DistroRelease: Ubuntu 11.10
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 82946GZ/GL Integrated Graphics Controller [8086:2972] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Foxconn International, Inc. Device [105b:0cc5]
MachineType: OEM OEM
Package: xorg 1:7.6+7ubuntu7
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=/dev/mapper/alan--desktop.Linux-karmic ro
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Tags: oneiric ubuntu
Uname: Linux 2.6.38-11-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (0 days ago)
UserGroups:

dmi.bios.date: 07/26/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: 946 7MA Series
dmi.board.vendor: Foxconn
dmi.chassis.type: 3
dmi.chassis.vendor: OEM
dmi.chassis.version: OEM
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd07/26/2007:svnOEM:pnOEM:pvrOEM:rvnFoxconn:rn9467MASeries:rvr:cvnOEM:ct3:cvrOEM:
dmi.product.name: OEM
dmi.product.version: OEM
dmi.sys.vendor: OEM
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Alan Jenkins (aj504) wrote :

Alan Jenkins, thank you for reporting this bug and helping make Ubuntu better. Please run the command: apport-collect 874559
which will attach necessary information for debugging this as an Xorg problem. Thanks in advance.

affects: libreoffice (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Probably is an X problem; it doesn't happen under the VESA driver. (I was a bit surprised by how "clean" the corruption was).

Please attach all relevant information noted in https://wiki.ubuntu.com/X/Debugging

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Alan Jenkins (aj504) wrote :

Huh?

I've said how I reproduce this error, and you've got the Apport information. If it's not clear from my description, this happens 100% of the time. I had already attached a screenshot, which shows the corruption exactly as I saw it on the monitor.

I can add that I haven't noticed this in LibreOffice prior to upgrading to 11.10 - but I haven't used the Office programs very often at all, so I can't say it's a regression.

I think that covers everything on that page. I've missed something, please can you point it out?

Alan Jenkins (aj504) wrote :

Apologies, that was not as polite as it should have been.

It does seem to be asking me to "run the xserver through gdb to identify the line or lines immediately prior to the corruption."

My concern is that, if we're talking more than a few 2D driver ops to draw that window, I'm going to be completely lost. I'll see what I can do.

bugbot (bugbot) on 2011-10-16
tags: added: corruption
Bryce Harrington (bryce) wrote :

Don't worry about running it through gdb; it's actually a bit of an art to get useful info that way.

I think all necessary information is provided. This probably should be forwarded upstream as well.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Probably needs the same fix as bug 901959 which was fixed in precise.

Bryce Harrington (bryce) on 2012-02-22
summary: - libreoffice: graphical corruption after closing all documents
+ libreoffice: graphical corruption in welcome screen
Bryce Harrington (bryce) wrote :

I *think* this is probably a dupe of #901959, however that appears at startup whereas this appears at close.

I'll SRU the fix for 901959 in that bug; when that goes through, please add oneiric-proposed to your sources, update, and verify the issue is gone.

summary: - libreoffice: graphical corruption in welcome screen
+ libreoffice: graphical corruption with welcome screen, after closing
+ application
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed

Hello Alan, or anyone else affected,

Accepted xserver-xorg-video-intel into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Alan Jenkins (aj504) wrote :

Sorry, my oneiric install is no more. (KVM with direct HD access to host partition... oops). Precise certainly looks fixed.

bugbot (bugbot) on 2012-05-31
tags: added: natty

The fix for this bug has been awaiting testing feedback in the -proposed repository for oneiric for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Chris Wilson (ickle) on 2013-02-11
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) on 2013-02-11
tags: added: verification-failed
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers