External monitor switch flashes all the time

Bug #873718 reported by Renne on 2011-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Notebook: Amilo Si2636, Intel GMA 3100
ATEN CS1784 KVM switch
HP LP2475w monitor
Cables: Si2636 -> HDMI-DVI-D -> ATEN CS1784 -> DVI-I/DVI-I -> HP LP2475w

The external monitor flashes between black screen (1-15 seconds) and desktop (500 ms - 2 seconds). The problem started with Ubuntu 11.04, prior versions (9.04 - 10.10) worked fine.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CasperVersion: 1.287
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgpng,mousepoll,move,place,regex,resize,session,snap,unitymtgrabhandles,vpswitch,wall,animation,expo,ezoom,fade,scale,unityshell,workarounds]
CompositorRunning: compiz
Date: Thu Oct 13 21:44:05 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Technology Solutions Device [1734:111f]
   Subsystem: Fujitsu Technology Solutions Device [1734:111f]
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: FUJITSU SIEMENS AMILO Si 2636
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/08/2009
dmi.bios.vendor: Phoenix
dmi.bios.version: 1.0H-1471-0012
dmi.board.name: MR030___
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: 8r7b19507
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnPhoenix:bvr1.0H-1471-0012:bd05/08/2009:svnFUJITSUSIEMENS:pnAMILOSi2636:pvrREFERENCE:rvnFUJITSUSIEMENS:rnMR030___:rvr8r7b19507:cvnFUJITSUSIEMENS:ct10:cvrVersion1.0:
dmi.product.name: AMILO Si 2636
dmi.product.version: REFERENCE
dmi.sys.vendor: FUJITSU SIEMENS
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Renne (renne) wrote :
Renne (renne) wrote :

Probably still the same bug as reported in #821043 for 11.04.

bugbot (bugbot) on 2011-10-16
tags: added: dual-head
Bryce Harrington (bryce) wrote :

Hi ml,

Does this also occur in Ubuntu Precise (12.04)?

If you don't want to install Ubuntu Precise, it should be sufficient to boot a Live USB session, configure the monitors, and see if it is working properly now. You can get the current Live USB desktop image at http://cdimage.ubuntu.com/daily-live/current/ and create a USB boot drive using usb-creator.

I take it that with the monitor directly connected, without the KVM, that it works fine?

This bug sounds familiar, I think we had one where the KVM was blocking some/all of the EDID in such a way that the kernel kept re-probing to determine the resolution. Something like that. But your log files don't give any indication whether or not that's what's going on here.

In addition to testing on precise, one other thing that might help reveal some clues would be to turn on drm debugging. Run `sudo xdiagnose`, mark the first checkbox, Apply, and reboot. Now after reproducing the issue collect the output of `dmesg`, which will have more detailed debugging info for us. If my theory is correct, there should be a repeating output in there relating to monitor probing, with the same periodicity as you're noting with the effect.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Renne (renne) wrote :

Currently I'm running the monitor directly attached via HP-HDMI-cable. HDMI-DVI-cables make things worse (also tried cables with gold-plated plugs). Mainboard (most current BIOS) and HDD of the Notebook have been replaced in April, RAM (3GB -> 4GB) at installation of Oneiric (64 bit) in November (I skipped 11.04 for permanent usage because of the video problems).

The Login-Screen is flickering and expanded to four tiles. Lower resolutions work stable for the Desktop, but about every third boot the Desktop is viewable but flickers maybe every 10 - 30 seconds until reboot. After screen lock, the monitor cannot sync anymore and displays "check cable".

The KVM-Switch stores the EDID of the monitor permanently (pressing "Numlock - d") and emulates monitor + USB in case K +V+M are switched to another port.

I'll run the tests + precise this weekend.

Renne (renne) wrote :

I tried Precise with no difference.

At 1680x1050 everything works fine, but at monitor-native FullHD-resolution (1920x1200) the HP LP2475w flickers. And there's no difference between direct HDMI-HDMI connection and KVM-Switch. The dmesg of Oneiric is attached, see 17:45 to 17:47 where I switched from 1680x1050 to 1920x1200 and back.

Bryce Harrington (bryce) on 2011-12-20
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
tags: added: precise
Bryce Harrington (bryce) on 2012-01-11
summary: - External monitor via KVM switch flashes all the time
+ External monitor switch flashes all the time
Download full text (4.4 KiB)

Forwarding this bug from Ubuntu reporter (ml-bartschnet:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/873718

[Problem]
The external monitor flashes between black screen (1-15 seconds) and desktop (500 ms - 2 seconds). The problem started with Ubuntu 11.04, prior versions (9.04 - 10.10) worked fine. Still occurs in Precise as of 12/17.

[Original Description]
Notebook: Amilo Si2636, Intel GMA 3100
ATEN CS1784 KVM switch
HP LP2475w monitor
Cables: Si2636 -> HDMI-DVI-D -> ATEN CS1784 -> DVI-I/DVI-I -> HP LP2475w

The external monitor flashes between black screen (1-15 seconds) and desktop (500 ms - 2 seconds). The problem started with Ubuntu 11.04, prior versions (9.04 - 10.10) worked fine.

Currently I'm running the monitor directly attached via HP-HDMI-cable. HDMI-DVI-cables make things worse (also tried cables with gold-plated plugs). Mainboard (most current BIOS) and HDD of the Notebook have been replaced in April, RAM (3GB -> 4GB) at installation of Oneiric (64 bit) in November (I skipped 11.04 for permanent usage because of the video problems).

The Login-Screen is flickering and expanded to four tiles. Lower resolutions work stable for the Desktop, but about every third boot the Desktop is viewable but flickers maybe every 10 - 30 seconds until reboot. After screen lock, the monitor cannot sync anymore and displays "check cable".

The KVM-Switch stores the EDID of the monitor permanently (pressing "Numlock - d") and emulates monitor + USB in case K +V+M are switched to another port.

I tried Precise with no difference.

At 1680x1050 everything works fine, but at monitor-native FullHD-resolution (1920x1200) the HP LP2475w flickers. And there's no difference between direct HDMI-HDMI connection and KVM-Switch. The dmesg of Oneiric is attached, see 17:45 to 17:47 where I switched from 1680x1050 to 1920x1200 and back.

DistroRelease: Ubuntu 11.10
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CasperVersion: 1.287
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgpng,mousepoll,move,place,regex,resize,session,snap,unitymtgrabhandles,vpswitch,wall,animation,expo,ezoom,fade,scale,unityshell,workarounds]
CompositorRunning: compiz
Date: Thu Oct 13 21:44:05 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Technology Solutions Device [1734:111f]
   Subsystem: Fujitsu Technology Solutions Device [1734:111f]
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: FUJITSU SIEMENS AMILO Si 2636
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: xserver-xorg-video-intel
UpgradeS...

Read more...

Created attachment 55497
dmesg

Bryce Harrington (bryce) wrote :

ml - I've forwarded this bug report upstream to https://bugs.freedesktop.org//show_bug.cgi?id=44728 - please subscribe to that report in case upstream needs you to test something or has further questions. Thanks ahead of time!

I have the same issue, see: https://bugs.freedesktop.org/show_bug.cgi?id=44697 but with Nouveau driver.

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Confirmed

I think Paulo was working on some KVM-related issues, so reassigning for him to take a look.

Bryce Harrington (bryce) wrote :

Hi ml,

I notice there hasn't been much activity on the upstream bug report. Before I re-ping them can I ask if you're still reproducing this bug on latest Precise?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Renne (renne) wrote :

And it rock's - finally! :)

1920x1200@60Hz, even with KVM-switch! :)

Distro is Precise Pangolin Beta 1 (AMD64 Desktop). Tested via Live-USB-System.

:)

Bryce Harrington (bryce) wrote :

Excellent, so issue is solved? I'll close out the bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released

User reports as of 12.04 beta 1 the issue is resolved.

Closing bug then... But I would love to know which commit fixed it :)

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.