Xrandr probing slow

Bug #855133 reported by Hernando Torque on 2011-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Invalid
High
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Starting with Ubuntu's kernel 2.6.39-0.5, xrandr probing takes a couple of seconds with only one output connected (internal LCD of ThinkPad T510).

This probing also negatively influences lightdm (see bug 828112).

Comment #11 in that bug report suggests to ignore HDMI outputs via xorg.conf, which actually restores the behavior of older kernels and running 'xrandr' becomes a lot faster (in my case it's sufficient to just ignore HDMI1).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Sep 21 00:19:18 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.2, 2.6.38-11-generic, x86_64: installed
 virtualbox, 4.1.2, 2.6.38-8-generic, x86_64: installed
 virtualbox, 4.1.2, 3.0.0-11-generic, x86_64: installed
 virtualbox, 4.1.2, 3.1.0-999-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110112)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 046d:c048 Logitech, Inc. G9 Laser Mouse
MachineType: LENOVO 4349WK7
PlymouthDebug: Error: [Errno 13] Permission denied: '/var/log/plymouth-debug.log'
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=755daaa3-ddf9-4451-ad6d-2b5354cee2c2 ro quiet splash elevator=deadline bootchart=disable vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/29/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET75WW (1.35 )
dmi.board.name: 4349WK7
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET75WW(1.35):bd09/29/2010:svnLENOVO:pn4349WK7:pvrThinkPadT510:rvnLENOVO:rn4349WK7:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4349WK7
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr20110919-0ubuntu1~ppa1
version.ia32-libs: ia32-libs 20090808ubuntu22
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Hernando Torque (htorque) wrote :
description: updated
Bryce Harrington (bryce) wrote :

Hernando Torque - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=41061 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Triaged
Brad Figg (brad-figg) on 2011-09-20
Changed in linux (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2011-09-20
tags: added: kernel-handoff-graphics
Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Confirmed
Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.