Ubuntu

No HDMI support.

Reported by Daniel Holm on 2011-09-07
160
This bug affects 34 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Flávio Alberto Lopes Soares

Bug Description

When I connect my external monitor to my laptop using HDMI, the scrren on the laptop flickers, and then nothing. Gnome Monitor doesnt detect the external monitor, nor does Disper.

Using VGA to the same monitor works fine. But if HDMI doesnt work to that monitor, it also wont work to my LCD TV..

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xserver-xorg 1:7.6+7ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
.tmp.unity.support.test.0:

Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,place,regex,animation,resize,gnomecompat,grid,expo,workarounds,wall,move,session,compiztoolbox,imgpng,unitymtgrabhandles,snap,vpswitch,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Wed Sep 7 14:31:33 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:16f2]
 nVidia Corporation Device [10de:1050] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: ASUSTeK Computer Inc. U31SD
ProcEnviron:
 PATH=(custom, no user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic root=UUID=5d307181-42b6-4337-be52-df1f5fecc84c ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 03/07/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: U31SD.202
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U31SD
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrU31SD.202:bd03/07/2011:svnASUSTeKComputerInc.:pnU31SD:pvr1.0:rvnASUSTeKComputerInc.:rnU31SD:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U31SD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu20
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Daniel Holm (danielholm) wrote :
Robert Hooker (sarvatt) wrote :

On sandybridge optimus laptops the digital outputs are always routed to the nvidia gpu only, but the logs here show the intel gpu being used even though nvidia kernel module loads so this is to be expected unfortunately. Do you have a way to force the discrete gpu to be used in the bios which would fix this?

Timo Aaltonen (tjaalton) wrote :

And are you perhaps using bumblebee or ironhide?

Changed in xorg (Ubuntu):
status: New → Incomplete
bugbot (bugbot) on 2011-09-08
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Daniel Holm (danielholm) wrote :

Yes, I am using Ironhide.

I will have a look in the bios.

Daniel Holm (danielholm) wrote :

I've looked in the BIOS and there is not settings for anything video-like.

What more info can I provide?

I also cant use nvidia-settings due a missing X.org-file.

Daniel Holm (danielholm) on 2011-09-17
summary: - monitor isnt detected using hdmi
+ No HDMI support.
bugbot (bugbot) on 2011-09-18
tags: added: tv-out
Bryce Harrington (bryce) on 2011-09-21
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Daniel Holm (danielholm) wrote :

This turns the HDMI screen on:
$ optirun nvidia-settings -c :8

And then I can watch ie video on the screen using:
DISPLAY=:8.0 vlc $file

Bryce Harrington (bryce) wrote :

Hey danielholm,

Hi, thanks for reporting this issue during the development period of
Ubuntu.

I notice there's not been further comments to the bug report since the
release came out, would you mind updating us on the status of it in the
release?

Are you still able to reproduce the issue? If not, do you think the bug
report can be closed, or do you think we should continue tracking it?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Daniel Holm (danielholm) wrote :

Hi Bryce,

It's still there.
No signal by just connecting a external display, nor is the connected display in the display settings.

By running: $ optirun nvidia-settings -c :8
The display turns on and I can start applications using DISPLAY=:8.0

I am also still using Ironhide.

So, I'm changing it back to confirmed.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Hanine HAMZIOUI (hanynowsky) wrote :

Daniel, when you run DISPLAY=:8.0 someapplication , what resolution do you get in your HDMI external monitor, the native resolution or 640X480 like me?

----------------------------------------

I confirm the same issue using a DELL XPS 15 L502X using a discrete Nvidia GT 525M.

- System : Ubuntu 11.10
- Latest Bumblebee installed

Running the following:
 optirun nvidia-settings -c :8 then DISPLAY=:8.0 someapplication

activates the HDMI external monitor and displays the application in this latter using a resolution of 640X480 that cannot be changed.

Daniel Holm (danielholm) wrote :

Hanine, No I think I get the full screen resolution of the external display. I'm unable to try it just now.

Daniel Holm (danielholm) wrote :

Hanine, actually I got the same error on my girlfriends tv.

Hanine HAMZIOUI (hanynowsky) wrote :

Actually, I managed to get the full resolution of my External Monitor which is 1920X1080 through HDMI (Ubuntu 11.10 on a DELL XPS 15) by editing bumblebee nvidia.xorg.config file (/etc/bumblebee). This file has an option (readEdid = false). Switching it to true enables Nvidia card to read the external monitor EDID information and then use its native modes and refreshing rates. you have to reboot after changes are committed.
If you run: optirun nvidia-settings -c :8 and select your HDMI monitor, you will see it is recognized with native resolution.
Besides, by installing a windows manager (OpenBox) along with Synergy, I was able to have a pseudo extended desktop.

See the last posts here:

https://github.com/MrMEEE/bumblebee/issues/75#issuecomment-2798937

the user: Camelcase managed to have a working Desktop using external monitor through HDMI on his Dell Alienware.

Daniel Holm (danielholm) wrote :

readEdid worked for me too.

Trying out Windump: https://github.com/harp1n/hybrid-windump

And also your tips.

mediterran81 (kyoshuu) wrote :

Glad to hear that!
Gosh! I never knew about Windump. Actually it might solve my remaining problem which is to have only one root W and get rid of OpenBox. I just hope it works fine with Bumblebee.

Thanks for the infos ;)

Daniel Holm (danielholm) wrote :

Glad to help.

But on my laptop Windump fails to work. But I will give it another go tonight.

Sorinello (sorinello) wrote :

I hope this will be fixed in the next version, I really need HDMI. Don't really care about Optimus and optimizations, but I need Full HD HDMI on my monitor. Too bad I have to switch to windows untill this is fixed :(((

mediterran81 (kyoshuu) wrote :

reported from Luis de Costa:

"There is a way to get the HDMI working perfectly, and use the Nvidia at is highest speed with the nvidia drivers without the use of bumblebee...

The problem is that it is a very simple method, that requires to not use the laptopt monitor when using the HDMI.

You just need to create the file /etc/X11/xorg.conf

and introduce this :

Section "Device"
   Identifier "Device1"
   Driver "nouveau"
   BusID "PCI:05:00:0"
EndSection

This one uses the nouveau drivers, you need to "sudo modprobe nouveau" before using this...

For the nvidia drivers :

Section "Device"
   Identifier "Device1"
   Driver "nvidia"
   VendorName "NVIDIA Corporation"
   BusID "PCI:05:00:0"
   Option "NoLogo" "true"
   Option "UseEDID" "false"
   Option "ConnectedMonitor" "DFP"
EndSection

I hope this helps somewone... With this tecnique I was able to play a flash video in 1080p in full screen on my TV using the HDMI !

Now I think that a little tweak with bumblebee, and we can have the booth working at the same time ^^ "

---
https://github.com/Bumblebee-Project/Bumblebee/issues/40#issuecomment-3441375

no longer affects: xserver-xorg-video-intel
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Flávio Alberto Lopes Soares (flavioalsoares)
Bryce Harrington (bryce) wrote :

Ah, this is a hybrid graphics system. The HDMI is likely hard wired only to the nvidia card, not intel, so it'd only work if you blacklist i915. In any case, we don't support hybrid switching yet. Bumblebee may be an option but we're not providing support for it in the distro.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Won't Fix
Rael (rael-gc) wrote :

Just to help some is trying use an external HDMI monitor on Dell XPS (l502x): use a miniport > HDMI adapter. The miniport is wired to the intel graphics card, and the monitor will be recognized.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers