Ubuntu

The screen gets garbled after a few hours of use

Reported by Mynk on 2011-08-04
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I have noticed this problem on my desktop (hoping details were picked by apport) on Ubuntu 10.10 also and was expecting it to be fixed on 11.04 but I still see the issue. It gets really annoying as I can't do much with the screen in this state - A Ctrl-A and Esc usually clears up some of the mess.

I don't see this issue on any other machine so I am sure it is a problem specific to the hardware. I am attaching the screen capture along with. Kindly let know if any other details are needed and apport didn't pick up.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Thu Aug 4 18:35:22 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 82915G/GV/910GL Integrated Graphics Controller [8086:2582] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company DC7100 SFF(DX878AV) [103c:3006]
   Subsystem: Hewlett-Packard Company Device [103c:3006]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: Hewlett-Packard HP Compaq dc7100 SFF(DX878AV)
ProcEnviron:
 LANGUAGE=en_IN:en
 LANG=en_IN
 LC_MESSAGES=en_IN.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=111d490a-27e8-407b-a256-a9f47ccca44b ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/16/2004
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786C1 v01.05
dmi.board.name: 097Ch
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: INI45203WK
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786C1v01.05:bd06/16/2004:svnHewlett-Packard:pnHPCompaqdc7100SFF(DX878AV):pvr:rvnHewlett-Packard:rn097Ch:rvr:cvnHewlett-Packard:ct4:cvr:
dmi.product.name: HP Compaq dc7100 SFF(DX878AV)
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Mynk (mr-mynk) wrote :
Mynk (mr-mynk) wrote :

I have looked up the web for reports on this type of issue but couldn't narrow down my search. I have noticed a considerable slow down in the system when this happens.

Thanks,
Mayank

bugbot (bugbot) on 2011-09-08
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Mynk (mr-mynk) wrote :

I upgraded to Ubuntu 11.10 Beta and I see the problem is still present. I see an improvement as in the screen garbles lesser. I am not sure about this as the issue worsens after some time. As of now at least the text is not garbling which means I can read it. Earlier it used to get really bad.

Mynk (mr-mynk) wrote :

I tried KDE today on Ubuntu 11.10 on my desktop. I see the garbling happening much sooner - so it is not specific to the desktop manager. If I refresh the screen somehow like say minimize and maximize a window the garbling disappears.

Sitsofe Wheeler (sitsofe) wrote :

This looks similar to the screenshots in Bug #820881 ...

Bryce Harrington (bryce) wrote :

Hey mr-mynk,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Mynk (mr-mynk) wrote :

In post #3 I mentioned I was on 11.10 beta. Now I am synced to the latest on Oneiric (11.10) and I still see the issue. I notice that the problem shows up earlier on a resource intensive desktop. I have now moved to stumpwm and I am finding the problem show much slower. But the problem is not gone.

I wish I could provide more useful info to crack the problem. But do keep the bug open - hoping to see it closed sometime! :)

thx,
mynk

myq (myqlarson) wrote :

I have been seeing this off and on since 10.10 as well. Doesn't matter which desktop environment, but I think it happens more with compiz.

Bryce Harrington (bryce) on 2012-02-04
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Mynk (mr-mynk) wrote :

This problem may not be the same but I have noticed very recently that the screen gets garbled after hibernate on my laptop. This problem wasn't there earlier - it is very recent change. It could be after the recent kernel update I did -

$ uname -a
Linux <email address hidden> 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Andy Braben (abraben) wrote :

I suffer the same garbled text after a period of activity. Then pressing the dash (via keyboard or mouse) will lock the screen out completely. Holding the power button in is the only way round the screen freeze.

Chris Wilson (ickle) wrote :

915g swizzling bug fixed in kernel v3.4

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.