Intel driver incorrectly renders some UI elements

Bug #803012 reported by Sameer Morar on 2011-06-28
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Natty
Medium
Unassigned

Bug Description

[Impact]
Widespread occurrences of rendering corruption with -intel. It is cosmetic but looks very ugly.

The issue is caused by a buggy optimization added in upstream commit 3055d401, "uxa: Use Composite rather than solid blitter for PolyRect" added in 2.12.0 (i.e. Maverick).

[Development Fix]
Upstream simply dropped the optimization entirely; their longer term plans are to provide better performance via the new SNA acceleration architecture (which we might ship in oneiric).

[Stable Fix]
See attached debdiff. It is a backport of the upstream patch to natty.

[Test Case]
The bug exhibits itself in different ways for different people, and has different steps for reproducing. For example, tabbing between windows, closing windows, selecting text, etc. Generally you'll see corruption, blackness, or lines surrounding or related to text or dropdown windows.

But in general, booting on affected hardware and using for a period of time will eventually trigger creation of the artifacts.

[Regression Potential]
Probably low. In theory, removal of an optimization path would risk some performance loss, however in practice we're not seeing anyone reporting that the performance got noticeably worse. In any case, it is not expected that the performance loss would be very large, and small performance impacts to resolve a screen corruption issue would probably be a fair trade.

[Original Report]
Some UI elements from wine and fvwm don't render correctly when using the Intel driver. This can be observed in screenshots shown in the following links:

https://bugs.freedesktop.org/show_bug.cgi?id=28798
https://bugs.freedesktop.org/show_bug.cgi?id=29401
http://askubuntu.com/questions/29642/black-or-corrupt-ui-artifacts-under-wine/

These issues have been attributed to errors in UXA utilising the 3D pipeline for core rendering.
Upstream has disabled this to resolve this issue for now.

I have applied their patch (commit: 855ced5a4eb67e287001ae22cb6489639c548cfa) to test this fix, which works for me here:
https://launchpad.net/~smorar/+archive/bugfixes

Sameer Morar (smorar) on 2011-06-28
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Sameer Morar (smorar)
Sameer Morar (smorar) wrote :
Sameer Morar (smorar) wrote :
tags: added: patch patch-accepted-upstream
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Sameer Morar (smorar) on 2011-06-28
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Sameer Morar (smorar) → nobody
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.15.0-3ubuntu2

---------------
xserver-xorg-video-intel (2:2.15.0-3ubuntu2) oneiric; urgency=low

  [ Sameer Morar ]
  * Add 121_fdo-28798-fix.patch: Remove the use of the 3D pipeline for
    UXA core rendering. This fixes incorrect rendering in some UI
    elements (LP: #803012).
 -- Timo Aaltonen <email address hidden> Wed, 29 Jun 2011 14:53:37 +0300

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
chreko (chreko) wrote :

Installing this package on natty (amd64) did solve the issue. Thanks!

Bryce Harrington (bryce) on 2011-07-19
Changed in xserver-xorg-video-intel (Ubuntu Natty):
importance: Undecided → High
milestone: none → natty-updates
status: New → Triaged
importance: High → Medium
Bryce Harrington (bryce) on 2011-07-19
description: updated
Chris Halse Rogers (raof) wrote :

SRU team ack. Please accept into natty-proposed.

Hello Sameer, or anyone else affected,

Accepted xserver-xorg-video-intel into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Sitsofe Wheeler (sitsofe) wrote :

I've unduplicated bug 745608. While it looked like it was a dup, I've installed xserver-xorg-video-intel 2:2.14.0-4ubuntu7.2 from natty-proposed and the glyph corruption described in 745608 is still present. If you read the upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=36326 (and more explicitly https://bugs.freedesktop.org/attachment.cgi?id=47560 ) , it talks about the need for a kernel patch to force unfenced buffers to be aligned to powers of two. Supposedly this is due to hardware tiling bugs on old chipsets...

Sameer Morar (smorar) wrote :

@Martin and Bryce - thanks for getting the patch into -proposed.

This package solves the issue for me.

Given the nature of this bug, I would like others to verify the fix too.

Marc Deslauriers (mdeslaur) wrote :

There may be a regression in the current package in -proposed. See #814325 for the issue.

Martin Pitt (pitti) wrote :

Thanks, marking as verification-failed.

tags: added: verification-failed
removed: verification-needed
Marc Deslauriers (mdeslaur) wrote :

OK, false alert, the package in proposed wasn't causing the regression after all.
Re setting to verification-needed.

tags: added: verification-needed
removed: verification-failed

SRU verification for Natty:
I have reproduced the problem with xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1 in natty-updates and have verified that the version of xserver-xorg-video-intel 2:2.14.0-4ubuntu7.2 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.14.0-4ubuntu7.2

---------------
xserver-xorg-video-intel (2:2.14.0-4ubuntu7.2) natty-proposed; urgency=low

  * Add 121_fdo-28798-fix.patch: Remove the use of the 3D pipeline for
    UXA core rendering. This fixes incorrect rendering in some UI
    elements.
    (LP: #803012)
 -- Sameer Morar <email address hidden> Tue, 28 Jun 2011 16:17:40 +0200

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.