transparency not working with intel driver and LTSP

Bug #785280 reported by Marc Gariépy on 2011-05-19
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Confirmed
High
Gentoo Linux
Unknown
Medium
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] transparency problem on ltsp in natty

When using LTSP the transparency doesn't work.

the easiest way to reproduce the bug is using the edubuntu live and starting the ltsp server. see the following link for more info: http://edubuntu.org/documentation/ltsp-live and boot a laptop or a thin client with the same graphic card.

when using xorg-edgers driver the problem is still present but then isntalling the pacakge from maverick it's working

# lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

# apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.14.0-4ubuntu7.1
  Candidate: 2:2.14.0-4ubuntu7.1
  Version table:
 *** 2:2.14.0-4ubuntu7.1 0
        500 http://archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     2:2.14.0-4ubuntu7 0

I have an issue with icons with transparent backgrounds. The backgrounds show black instead of transparent "see attachment". This seems to happen when connecting to remote hosts (via XDMCP). The transparency looks fine however when the client is local to the server and even (I think) when the client is accessed through ssh X11 forwarding.

I did a little bit of deduction and discovered that the issue is not present if i downgrade to xf86-video-intel-2.13.0.

So far I've tried this when the remote machine is Gentoo (xfce) and Ubuntu (gnome).

Created attachment 260261
screenshot when connected to an xfce-4.8 session via XDMCP

Notice though in the screenshot that the firefox icons look fine.. weird.

In , Remi (remi) wrote :

In theory, you should be able to reproduce the issue locally if you connect to your X server via a tcp/unix-socket only connection and/or disable SHM. Add the following to your xorg.conf if you want to try disabling SHM.

Section "Extensions"
    Option "MIT-SHM" "Disable"
EndSection

Thanks

Yes, I was able to reproduce locally with SHM disabled. Screenshot to be attached.

Created attachment 260512
local (:0) display with xf86-video-intel-2.14.0 driver

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Marc Gariépy (mgariepy) wrote :

I also have the same issue on an intel laptop:

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c)
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) [8086:2a03] (rev 0c)

FYI here is the lspci for the graphic on the other machine:

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 09)

summary: - Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42]
- transparency problem on ltsp
+ transparency not working with intel driver and LTSP
bugbot (bugbot) on 2011-05-20
tags: added: edgers
Changed in gentoo:
importance: Unknown → Medium
Marc Gariépy (mgariepy) wrote :
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Confirmed
cyf221 (cyf221) wrote :

work only with nomodeset
 description: VGA compatible controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation

Jonathan Carter (jonathan) wrote :

nomodeset gets rid of the transparency problem, but my resolution falls back to 1024x768 when I do that. Is there a way around that or do I just need to configure X manually on these machines?

I did a git bisect on the intel driver to attempt to find where this was introduced. I ended up using pretty much the whole old intel driver as is that worked before and the problem was still present. My guess is that this isn't an intel driver specific issue and might have been introduced somewhere else in the X stack. Any suggestions at where I should look first? I'll probably try the mesa libraries next.

Jonathan Carter (jonathan) wrote :

Sorry, I must have done something wrong before. Just did a forward port of the 2.12 driver and it works fine.

Thank you for the response.

What do you mean "2.12 driver"? Sinaptic did't find it.

2011/6/20 Jonathan Carter <email address hidden>

> Sorry, I must have done something wrong before. Just did a forward port
> of the 2.12 driver and it works fine.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/785280
>
> Title:
> transparency not working with intel driver and LTSP
>
> Status in X.org xf86-video-intel:
> Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu:
> Confirmed
> Status in Gentoo Linux:
> Unknown
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42]
> transparency problem on ltsp in natty
>
> When using LTSP the transparency doesn't work.
>
> the easiest way to reproduce the bug is using the edubuntu live and
> starting the ltsp server. see the following link for more info:
> http://edubuntu.org/documentation/ltsp-live and boot a laptop or a
> thin client with the same graphic card.
>
> when using xorg-edgers driver the problem is still present but then
> isntalling the pacakge from maverick it's working
>
> # lsb_release -rd
> Description: Ubuntu 11.04
> Release: 11.04
>
>
> # apt-cache policy xserver-xorg-video-intel
> xserver-xorg-video-intel:
> Installed: 2:2.14.0-4ubuntu7.1
> Candidate: 2:2.14.0-4ubuntu7.1
> Version table:
> *** 2:2.14.0-4ubuntu7.1 0
> 500 http://archive.ubuntu.com/ubuntu/ natty-updates/main i386
> Packages
> 100 /var/lib/dpkg/status
> 2:2.14.0-4ubuntu7 0
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/785280/+subscriptions
>

Jonathan Carter (jonathan) wrote :

@cyf221 I added it to the RLNX ppa: https://launchpad.net/~revolution-linux/+archive/xorg

I also tested the latest drivers under Oneiric and Unstable. It's better now, but not completely fixed. Many icons (notably the panel and menu icons) now have transparency. Some icons, like context-sensitive icons and also the title bar menu's icons are not transparent.

Changed in xserver-xorg-video-intel:
importance: Medium → High
Marc Gariépy (mgariepy) wrote :

Hello, Martin in freedesktop bug tracker updated this issue with this:

>I discovered git bisect ...
>f3a47d7f235d18e4529e3898a48673c7c3cbd489 is the first bad commit
>commit f3a47d7f235d18e4529e3898a48673c7c3cbd489
>Author: Chris Wilson <email address hidden>
>Date: Mon Dec 6 14:11:05 2010 +0000
>
> snb: Cache pixmap binding locations
>
> Signed-off-by: Chris Wilson <email address hidden>
>
>:040000 040000 4a1eb83e6831bceb66e6f6641d2314785abda5c6
>6cb1c7448c1f9513a4f49951a08d554d5ee60faa M src
>
>Hope that helps.

here is the link to the commit:
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=f3a47d7f235d18e4529e3898a48673c7c3cbd489

Thanks

Marc Gariépy (mgariepy) on 2011-11-03
Changed in xserver-xorg-video-intel (Ubuntu):
milestone: none → natty-updates
Marc Gariépy (mgariepy) wrote :

 Here is the debdiff that fixes the issue in natty

Marc Gariépy (mgariepy) wrote :

this is the fix for oneiric

Stéphane Graber (stgraber) wrote :

These two debdiffs should be targeted to -proposed, otherwise they look good. Would still be great to have someone from the X team to have a quick look at them, then I'm happy to sponsor them if nobody else does.

Changed in xserver-xorg-video-intel (Ubuntu):
milestone: natty-updates → none
Stéphane Graber (stgraber) wrote :

Adding tasks for both natty and oneiric (debdiffs provided above) and also adding precise as it's the same version as oneiric and so is also affected by this bug.

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: New → Triaged
Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: New → Triaged
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel (Ubuntu Natty):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel (Ubuntu Precise):
importance: Undecided → Medium
Robert Hooker (sarvatt) wrote :

The patch in the debdiffs here were NAKed by the intel maintainer, and he fixed it differently in the upstream driver. I have prepared oneiric and natty SRU packages with the fix but have to run tonight and will follow up on it in the morning as well as get it uploaded to precise and pushed to git.

http://sarvatt.com/downloads/sru/

The attachment "fix for natty" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Robert Hooker (sarvatt) on 2011-11-04
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.15.901-1ubuntu3

---------------
xserver-xorg-video-intel (2:2.15.901-1ubuntu3) precise; urgency=low

  * Add 102_remove_surface_binding_cache.patch:
    Backport of upstream commit 2174f8401 to fix transparency on
    LTSP. (LP: #785280)
 -- Robert Hooker <email address hidden> Thu, 03 Nov 2011 19:01:44 -0400

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Fix Committed → Fix Released

Hello Marc, or anyone else affected,

Accepted xserver-xorg-video-intel into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello Marc, or anyone else affected,

Accepted xserver-xorg-video-intel into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Triaged → Fix Committed
Marc Gariépy (mgariepy) wrote :

Just tested version 2:2.1.15.901-1ubuntu2.1 on oneiric and version 2:2.14.0-4ubuntu7.3 on natty.
Both are working as expected.

Thanks a lot for this upload.

Martin Pitt (pitti) on 2011-11-10
tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.14.0-4ubuntu7.3

---------------
xserver-xorg-video-intel (2:2.14.0-4ubuntu7.3) natty-proposed; urgency=low

  * Add 103_remove_surface_binding_cache.patch:
    Backport of upstream commit 2174f8401 to fix transparency on
    LTSP. (LP: #785280)
 -- Robert Hooker <email address hidden> Thu, 03 Nov 2011 19:10:25 -0400

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.15.901-1ubuntu2.1

---------------
xserver-xorg-video-intel (2:2.15.901-1ubuntu2.1) oneiric-proposed; urgency=low

  * Add 102_remove_surface_binding_cache.patch:
    Backport of upstream commit 2174f8401 to fix transparency on
    LTSP. (LP: #785280)
 -- Robert Hooker <email address hidden> Thu, 03 Nov 2011 19:01:44 -0400

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.