missing pixels (horizontal lines) in font rendering

Bug #782855 reported by Akkana Peck on 2011-05-15
130
This bug affects 24 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Fedora)
New
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Since upgrading from Lucid to Natty, font rendering in firefox and some other apps is buggy. Certain letters in certain fonts will be missing pixels from horizontal lines through certain letters. For instance, in the screenshot I'm about to attach from this bug report, all the 'o' characters are missing a line through the center, and 'n' are missing a line a little below center. It's different every time: if I restart firefox, different letters will be affected.

Graphics is Intel 915GM (on a Sony Vaio TX650). I don't know that it's the X driver at fault, but most people who see the problem seem to think that it's related to the video driver rather than the font rendering libraries. Changing my set of installed fonts or changing to a different default browser font can make the problem better or worse, but never makes it go away entirely.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Sat May 14 18:16:31 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:81e2]
   Subsystem: Sony Corporation Device [104d:81e2]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
MachineType: Sony Corporation VGN-TX650P
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
ProcKernelCmdLine: root=/dev/sda5 ro noplymouth
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/05/2005
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R0031V1
dmi.chassis.type: 10
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0031V1:bd08/05/2005:svnSonyCorporation:pnVGN-TX650P:pvrJ0017EPV:cvn:ct10:cvr:
dmi.product.name: VGN-TX650P
dmi.product.version: J0017EPV
dmi.sys.vendor: Sony Corporation
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Akkana Peck (akkzilla) wrote :
rix (focardi) wrote :

I have the very same problem, after upgrading to 11.04 from lts, on a Toshiba Portege with the following controller:

> lspci | grep Display
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I don't know if this can help: when zooming in or out the problem usually disappears (it seems to be related to font size)

kaliffo (7repip) wrote :

I have the same problem with ubuntu 11.04 fresh install. Don't know if it's a display controller issue, but symptoms are the sames as described by rix.

My display controller:
Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

James Haigh (james.r.haigh) wrote :

Same problem.

Natty.

james@james-ThinkPad-X60-Tablet:~$ lspci | grep Display
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Marking as confirmed.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Akkana Peck (akkzilla) wrote :

I have a theory that this may be related to heat. I almost never see bad fonts immediately after booting, but after a long session where the fan has been on a lot, the fonts will get worse and worse. If I suspend for a while, sometimes they get better, but I have seen corrupted fonts immediately upon resuming from suspend, so I'm not entirely convinced.

I should stress that this doesn't happen in Lucid, so even if it's heat releated, it's definitely caused by a software change.

Akkana Peck (akkzilla) wrote :

Ignore that comment about heat. After more experimentation, I do occasionally see the problem right after booting, and it almost always persists through a suspend cycle. Exiting/restarting X doesn't cure it, but rebooting (even with no appreciable time for cooldown) does.

John Klug (ski-brimson) wrote :

This is bizarre. I have the same problem with the nouveau driver. I got around it by installing the experimental open source 3D driver. It seems odd that two drivers have the same problem. I am also using 11.04.

Bryce Harrington (bryce) wrote :

Hey akkzilla,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
rix (focardi) wrote :

In the meanwhile I've changed my laptop so I'm afraid I won't be of much help on this. I imagine this kind of bugs are pretty complex to spot but unfortunately push people moving to different OS's, at least for laptops (I've moved to OS X myself, even if I'm still fully-Ubuntu on the desktop). This is just a note and not a criticism on your great job, guys!

Erik Wool (astro-q) wrote :

I had the symptoms described above with Natty running on a Panasonic Toughbook W4 with the display goodies below (from lspci) :

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

After the Oneiric upgrade, I could've sworn I saw it happen again once or twice, but if I did, it's totally cleared up now -- not a line missing for over a week -- and yes, I've been deliberately trying to provoke it by switching up fonts in applications, changing sizes, visiting "99 more annoying fonts", etc.

So I'd say the bug is gone.

btw I notice that I'm currently using a kernel module labelled i915, and I believe Natty's autoselected kernel module was labelled i815. Could be wrong about that, but maybe this is relevant?

Akkana Peck (akkzilla) wrote :

Not fixed here. I upgraded the Vaio to Oneiric yesterday and am seeing font corruption after running it for about 2.5 hours this morning with several suspends.

I'm also seeing the i915 module loaded in oneiric. I can't test what module it used in natty (replaced that partition in the upgrade) but Debian Squeeze, which also shows the problem, loads i915 just like oneiric does.

I'm not convinced using lots of fonts makes a difference -- I've seen it when I wasn't doing much more than rehearsing/presenting a talk, with only a few fonts on the slides. I think running for a while is more important (usually several hours, though once or twice I've seen it sooner than that). Suspending may be relevant; I've never seen corruption in a run where I didn't suspend at least once, but it's rare that I have my laptop running that long without suspending.

Erik Wool (astro-q) wrote :

Ha! Sure enough, the quickest way to get a bug to manifest is to deny its existence. It is NOT fixed globally in Oneiric. I made 2 useage changes in the past few weeks that contributed to my not noticing any flaws: 1) switched primary browser from Firefox to Chrome, and 2) switched terminator shell's font from "Monospace 8pt" to "Ubuntu Mono 8pt". I just changed the terminator font back a day or two ago and yep, it's wrecked again.

Observations:

- bug manifests in terminator shell with "Monospace 8pt" font, but not with "Ubuntu Mono" at any size. After changing font sizes and faces for a while, the bug is completely gone from the font chooser, and does not appear in the shell after closing prefs --- buuuuut, after switching to another app for a while the font is once again damaged in a novel way. This happens with "Monospace" only, as far as I can see.

- bug does not manifest in Chrome 14.0.835.186 at all. (see zooming note below)

- bug manifests in Firefox 7.0.1 -- nb. compared same page [ http://getfirebug.com/firstrun#Firebug%201.8.4] in both firefox and chrome.

- bug manifests in Thunderbird 7.0.1 in html emails, but NOT in message lists, menus, etc.

- browser view zooming causes what? font re-rendering? In Firefox, zooming in and out repeatedly with ctl+, ctl- caused the bug to appear *almost* at random. Sometimes the fonts were damaged in the same way, but after a few passes the damage changed location, moving from letter to letter and line to line. No *pattern* of change was observed, per se. The same actions in Chrome did not provoke any damaged fonts to appear, even using the same page as with Firefox.

Akkana Peck (akkzilla) wrote :

I see the problem almost (but not quite) exclusively in browsers (both firefox and webkit-based, though I don't run chrome on that machine); never in simple apps like xterm or emacs, or in gimp.

Once it starts manifesting, its form will persist (e.g. if two lines of pixels are missing from lowercase b, then that will always be the case) through zooming, moving the browser window, reloading, opening new tabs, etc. However, if I quit firefox and restart it, I'll see a different pattern (e.g. it might be G and x mis-drawn now, rather than b) and that will persist through that run of firefox (but new letters might eventually start being affected as well). Once it starts, there's no chance of quitting and restarting to get a browser that has NO damaged letters; but sometimes I can get one where the bad letters are less common ones so I can still read pages for a while and can postpone rebooting.

Chris (fabricator4) wrote :

Confirmed in Oneiric on, amongst other things, my Eee PC 901SD which has an Intel 915 graphics controller and does not require any proprietary drivers. I see it mostly in Firefox but it affects terminal windows and title bars as well.

I'm sure this problem is much more prevalent than than the meager number of "affects me" flags suggested on this bug report. It would be a shame if this were not fixed for the LTS release.

Chris

I'm on 11.10 on a Dell Inspiron 6400 and have the same issue.

Cosmin Saveanu (csaveanu) wrote :

It is really a strange bug and probably very hard to solve since there is no clear way to reproduce it. I had exactly the same problem (mostly on "e"s missing a line of pixels) but during the time needed to search google, get to this page and log in to post a comment, the display problem just vanished. Now everything looks normal. Happened several times on my system.

The only thing I did previous to the display problem appearing, was to launch DoubleCommander (a GTK2 program) and gedit (Gnome 3) at the same time. If I do it again, no problem is apparent though...

Using Ubuntu 11.10 with Gnome Shell on a Fujitsu Amilo laptop.

This is affecting also Oneiric on Asus EeePC 900.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Jochen Fahrner (jofa) wrote :

Same here on Natty with 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03).
Bug only in Firefox, not in Chromium.

Screenshot attached.
Ubuntu 11.10, EeePC 900
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

Jochen Fahrner (jofa) wrote :

I found that it has something to do with font caching. I tried some fonts for fixed font in Thunderbird. First I had "Andale mono" which was very ugly. Then I siwtched to "Deja vu mono" which is perfect. When I siwtched back to Andale mono this was also without problems.

Confirmed in lubuntu precise today's build, notice the "d" in the attached screenshot.

Erik Wool (astro-q) wrote :

just tried

fc-cache -f -v

... ran normally, but it did nothing to change the currently manifesting missing lines. eg: '3' was mangled in the same way in the "terminator" terminal emulator before and after.

Jane Atkinson (irihapeti) wrote :

Still noticing this in an up-to-date Openbox install on an EeePC 900.

Jane Atkinson (irihapeti) wrote :

Somewhere - and I can't find the reference now - I read that an effective workaround is to create /etc/X11/xorg.conf with the following content.

Section "Device"
 Identifier "Intel"
 Driver "intel"
 Option "DebugWait" "True"
EndSection

I've found that this works on my EeePC 900. I had to reboot, not just log out, before it took effect. Maybe just restarting the xserver would work as well.

Jochen Fahrner (jofa) wrote :

Thank you Jane. I can confirm this workaround is working on my Toshiba Satellite Pro 700.

jacobbrett (jacobbrett) wrote :

Strange, I'm having a similar issue, though using an AMD video card (Intel graphics on-board, though. Occasionally, I'll have grey lines through text. Similar lines appear occasionally through window decoration.

lspci output:

01:00.0 VGA compatible controller: ATI Technologies Inc Barts XT [ATI Radeon HD 6800 Series]
01:00.1 Audio device: ATI Technologies Inc Barts HDMI Audio [Radeon HD 6800 Series]
02:00.0 VGA compatible controller: ATI Technologies Inc Barts XT [ATI Radeon HD 6800 Series]
02:00.1 Audio device: ATI Technologies Inc Barts HDMI Audio [Radeon HD 6800 Series]

I have fglrx-updates (2:8.911-0ubuntu0.1) installed.

jacobbrett (jacobbrett) wrote :

An example of above described issue.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/782855

tags: added: iso-testing
piccobello (piccobello) wrote :

I have this bug at least since upgrade to oneiric (kubuntu), maybe earlier.
It comes and goes. I'll post a pic next time it happens. Can I do something else?
$ lspci -nn|grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

using i915

Jane Atkinson (irihapeti) wrote :

@piccobello

You could try the fix in comment #24 and see if it helps. Yours is a different graphics chip from mine, so it may not work the same.

Ville Jouppi (vjouppi) wrote :

I've experienced the same bug in several releases, including 12.04.

The machine is a Dell Latitude D430

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Adding the xorg.conf snippet in #24 seems to help, based on the short testing I've done so far.

Kenneth Heal (kheal) wrote :

The fix in #24 solved the issue for me on an eeepc 701 4G running lubuntu 12.04

Jane Atkinson (irihapeti) wrote :

This bug is still appearing in Quantal. I haven't applied the fix yet but I expect it to work.

piccobello (piccobello) wrote :

@irihapeti: fix #24 works for me, problem solved for this video card
$ lspci -nn|grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

module i915, Kubuntu oneiric (11.10)

Thanks to all!

Steve Langasek (vorlon) on 2012-06-23
tags: removed: regression-update
mtvoid (mtvoid) wrote :

I'm now using the intel xorg driver with the SNA backend enabled (available since version 2.20 onwards, currently in several PPAs) instead of UXA; it does not suffer from this problem.

Chris (fabricator4) wrote :

Confirmed for 12.04 Precise

Jan Varchola (varchola) wrote :

Problem still exists in Ubuntu 12.04 LTS with the following configuration:

00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)

graphic driver: Intel® 945G x86/MMX/SSE2

I used fix from #24 comment. But after using of hibernation instead of turning off the system this problem occured again.

I have a Dell D420. The problem still exists in 12.10 although the fix from comment #24 has fixed the problem after I logged out and back in.
tim@bach:~$ lspci -nn|grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
tim@bach:~$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers