When using external monitor top part of screen doesn't draw

Bug #781536 reported by Ante Blaskovic on 2011-05-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

When I enable only external monitor and switch off LCD panel top part of screen is not being drawn for application windows (see picture), strange is that Unity Search bar draws OK, only regular application windows and desktop are not drawn.

I didn't have this issue with 10.04 and 10.10

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.3:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBBDEEIAgsAABERAQOAJh54Ku/ApFdKmiQSUFS/74BxT4FAgYABAQEBAQEBAQEBMCoAmFEAKkAwcBMAeC0RAAAeAAAA/wBBVTMwNzE3MDAyODE4AAAA/ABQaGlsaXBzIDE5MFAKAAAA/QA4TB5TDgAKICAgICAgAAQ=
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1600x900
 edid-base64: AP///////wAw5AACAAAAAAATAQOAIxN46hvlnllQmCYOUFQAAAABAQEBAQEBAQEBAQEBAQEBYipAQGGEKjAwIDUAWcIQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/gBMUDE1NldEMS1UTEIyANI=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu May 12 10:06:58 2011
DistUpgraded: Log time: 2011-04-29 01:44:12.491509
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.0.6, 2.6.38-8-generic, x86_64: installed
 vboxhost, 4.0.6, 2.6.35-28-generic, x86_64: installed
 vboxhost, 4.0.6, 2.6.32-31-generic, x86_64: built
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:146d]
InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
MachineType: Hewlett-Packard HP ProBook 6550b
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=UUID=9bfafe34-38c8-4800-bd1e-6fadb7b881ff ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to natty on 2011-04-29 (13 days ago)
dmi.bios.date: 10/27/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CDE Ver. F.04
dmi.board.name: 146D
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 73.12
dmi.chassis.asset.tag: CNU1050TSH
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CDEVer.F.04:bd10/27/2010:svnHewlett-Packard:pnHPProBook6550b:pvr:rvnHewlett-Packard:rn146D:rvrKBCVersion73.12:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 6550b
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Ante Blaskovic (ante-blaskovic) wrote :
summary: - When using external monitor upper part of screen is missing
+ When using external monitor upper part of screen doesn't draw
summary: - When using external monitor upper part of screen doesn't draw
+ When using external monitor top part of screen doesn't draw
description: updated

I am affected by this too. I found the following in my dmesg when my computer woke with the external monitor plugged in:

[19519.662971] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 68
[19519.662978] [drm:drm_edid_block_valid] *ERROR* Raw EDID:
[19519.662983] <3>00 ff ff ff ff ff ff 00 5a 63 1c ad 01 01 01 01 ........Zc......
[19519.662986] <3>1b 10 01 03 0e 26 1e 78 2e c5 c6 a3 57 4a 9c 23 .....&.x....WJ.#
[19519.662990] <3>12 4f 54 bf ef 80 81 80 81 40 71 4f 01 01 01 01 .OT......@qO....
[19519.662993] <3>01 01 01 01 01 01 30 2a 00 98 51 00 2a 40 30 70 ......0*..Q.*@0p
[19519.662997] <3>13 00 78 2d 11 00 00 1e 00 00 00 ff 00 50 58 55 ..x-.........PXU
[19519.663000] <3>30 36 32 37 33 31 34 32 30 0a 00 00 00 fd 00 32 062731420......2
[19519.663003] <3>4b 1e 52 0e 00 0a 20 20 20 20 20 20 00 00 00 fc K.R... ....
[19519.663007] <3>00 56 58 39 ff ff ff ff ff ff ff ff ff ff ff ff .VX9............
[19519.663009]
[20030.294769] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id

bugbot (bugbot) on 2011-05-15
tags: added: dual-head

A screenshot of the bug, if it helps.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Hey ante-blaskovic,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints