Ubuntu 11.04 randomly logs out

Bug #776654 reported by Nekhelesh Ramananthan on 2011-05-03
This bug affects 19 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)

Bug Description

Binary package hint: xorg

I am running Ubuntu 11.04 and it randomly logs out while I am working on anything. This does not happen at a specific interval or anythings...Entirely random. The xorg version installed is 1:7.6+4ubuntu3. Hope this helps.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,text,grid,imgpng,vpswitch,gnomecompat,snap,resize,move,mousepoll,regex,place,unitymtgrabhandles,animation,session,workarounds,wall,expo,ezoom,staticswitcher,fade,scale,unityshell,scaleaddon]
CompositorRunning: compiz
 status: disconnected
 enabled: disabled
 dpms: Off
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 status: disconnected
 enabled: disabled
 dpms: Off
Date: Tue May 3 21:19:42 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:022f]
   Subsystem: Dell Device [1028:022f]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
MachineType: Dell Inc. Inspiron 1525
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=50b3ce12-dbe3-4d20-b5a0-a69b2a29811a ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/10/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0U990C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd03/10/2008:svnDellInc.:pnInspiron1525:pvr:rvnDellInc.:rn0U990C:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1525
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Nekhelesh Ramananthan (nik90) wrote :
bugbot (bugbot) on 2011-05-04
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Jared Amos (rrusciguy) wrote :

I also am affected by this.
HP Compaq 6730s, 3GB RAM, dual-core 2GHz.
Using the Classic Ubuntu interface

Jan Mees (jmees001) wrote :

I am also affected by this bug. I am currently using an Asus n61 with intel core i5.

 As stated above there is no discernible pattern.
I am quite new to Ubuntu but, nonetheless I have a question. Since few people seem to have this problem may it be that something in the update of the ubuntu version went wrong and by reinstalling it it may be solved?

djjuhasz (david-artefactual) wrote :

Posting .xsession-errors, hope it helps diagnose the problem.

Anas El Abboud (anasabboud) wrote :

i am affected too, ubuntu 11.04 - classical GNOME - Toshiba sattelite A200-11c - intel core2due Centrino + 3G Ram

JC (nothingness) wrote :

I had this problem trying to install virtualbox guest additions for a while. Hasn't happened in 4.0.8
However, it just happened my laptop after saving changes to one of my videos on youtube. I clicked sign out right after and ubuntu logged me out.
ubuntu 11.04 64bit

Eugene San (eugenesan) wrote :

Try to use sessions without compiz ("no effects") or simply uninstall compiz.
In my case this solved all stability issues.

Albert Damen (albrt) wrote :

[ 8481.477] 3: /usr/bin/X (_CallCallbacks+0x3e) [0x8074e1e]
[ 8481.477] 4: /usr/bin/X (WriteToClient+0x267) [0x80a7607]
[ 8481.477] 5: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x62) [0x302bf2]
[ 8481.477] 6: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x75) [0x300fc5]

This is a duplicate of bug 774978, which has a fix for testing in comment 25.

Ahmose Solomon (rasa-ahmose) wrote :

this effects me also, and its getting rather annoying.
totally random times.

Is there any kind of fix for this yet?

@ Eugene Swan~ You say "Try to use sessions without compiz ("no effects") or simply uninstall compiz.
In my case this solved all stability issues."

That is wrong.
We are talking about 11.04 here.. with Unity..
which depends on compiz.
There is also no longer a "visual effects" tab in appearance window.
Therefore, no disabling them.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

Having this problem on an Asus K55DR running Xubuntu 13.04.

Gonna need to have this fixed... arrh.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers