[i865G] Upgrade should warn user about lack of support for old 8xx intel hardware

Bug #774999 reported by Olivier Mengué on 2011-05-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
update-manager (Ubuntu)
High
Michael Vogt
xserver-xorg-video-intel (Ubuntu)
Wishlist
Unassigned

Bug Description

[Problem]
Support for 8xx chipsets is dodgy at best, due to insufficient upstream testing/development/priorities. Users frequently experience regressions and problems, which they find annoying.

For distro maintenance, we typically prioritize development work around 915 and higher, and recommend owners of older hardware work directly with upstream filing bugs at bugzilla.freedesktop.org rather than launchpad.

This bug report requests a warning be presented to users on 8xx intel chips that they may be on their own if they run into problems unique to 8xx, and so should do ample testing on their own using livecds and whatnot before risking an upgrade.

10.04 LTS was the last release where we gave priority to 8xx issues and did development/fixup work on it, and so 8xx owners must be cautious upgrading beyond that. Upstream still does some limited maintenance work for 8xx, so Ubuntu may well work fine (so blacklisting 8xx is not suitable) but if it doesn't, we are not open to backporting upstream fixes or introducing tweaks to fix 8xx issues. Our experience has been that when we do this, we risk fixing it for one system but breaking several others...

[Original Report]
Posted from the X11 recovery session.

None of the sessions works (except the recovery session, but that doesn't count) after upgrade from Maverick to Natty:
- Ubuntu : a dialog box says the hadware is does not accept Unity, then screen is garbled (reboot from linux console)
- Ubuntu Classic : screen is garbled (reboot from linux console)
- Ubuntu Classic (no effects) : system freeze

Why the upgrade did not warn me about the lack of support for this hardware? I would not have upgraded. Or tested with the live CD.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1680x1050 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBMLQwDMjJFTQgSAQMOLx54KtUVpFVJmicUUFS/74CzAIGAgUBxTwEBAQEBAQEBfC6QoGAaHkAwIDYA2igRAAAaAAAA/QA4Sx5RDgAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBIUzNRMjEyOTE1CiAgAEY=
Date: Sun May 1 18:54:42 2011
DistUpgraded: Log time: 2011-05-01 15:06:44.795705
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox-ose, 4.0.4, 2.6.38-8-generic, i686: installed
 virtualbox-ose, 4.0.4, 2.6.35-28-generic, i686: installed
GraphicsCard:
 Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company D530 sff(dc578av) [103c:12bc]
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hewlett-Packard HP d530 SFF(DG059T)
ProcEnviron:
 LANGUAGE=fr_FR:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=5f7f6055-15cd-4412-bf5e-a49fcf303fe7 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: Upgraded to natty on 2011-05-01 (0 days ago)
dmi.bios.date: 07/10/2003
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786B2 v1.11
dmi.board.name: 085Ch
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: CZC4161ZSK
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786B2v1.11:bd07/10/2003:svnHewlett-Packard:pnHPd530SFF(DG059T):pvr:rvnHewlett-Packard:rn085Ch:rvr:cvnHewlett-Packard:ct4:cvr:
dmi.product.name: HP d530 SFF(DG059T)
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Olivier Mengué (dolmen) wrote :
Olivier Mengué (dolmen) wrote :

From the Ubuntu web site:

"Ubuntu 11.04 is built to take advantage of the very latest technologies, but it should work on a most desktops, laptops and netbooks too. If you don’t have the required hardware, Ubuntu will automatically start the classic desktop experience so you won’t have to worry about a thing."

Thank you for the Ubuntu experience!

description: updated

Workaround: use Xubuntu which does not trigger the video driver bugs
  sudo aptitude install xubuntu-desktop

summary: - X11 unusable after Natty upgrade
+ Intel 82865G: X11 unusable after Natty upgrade
bugbot (bugbot) on 2011-05-02
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) on 2011-05-02
summary: - Intel 82865G: X11 unusable after Natty upgrade
+ [i865G] X11 unusable after Natty upgrade
summary: - [i865G] X11 unusable after Natty upgrade
+ [i865G] Upgrade should warn user about lack of support for old 8xx intel
+ hardware
Bryce Harrington (bryce) wrote :

Despite the sarcasm, a warning message is not a bad idea. Would save us maintainers from having to continually WONTFIX these types of bug reports.

description: updated
Bryce Harrington (bryce) on 2011-05-02
description: updated
Bryce Harrington (bryce) wrote :

Anyway, I don't know whether the update-manager folks might consider 8xx checks to just be cluttering things up; I'll leave it to them to decide.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in update-manager (Ubuntu):
importance: Undecided → High
milestone: none → oneiric-alpha-1
Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Won't Fix
Colin Watson (cjwatson) on 2011-05-27
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Changed in update-manager (Ubuntu):
milestone: oneiric-alpha-1 → oneiric-alpha-2
Michael Vogt (mvo) wrote :

How about a text like this:

"""
[WARNING]
Your graphics hardware may not be fully supported in Ubuntu 11.04.

The support for your graphics hardware is limited and you may encounter
problems after the upgrade. Do you want to continue with the upgrade? [yes] [no]

"""

Michael Vogt (mvo) wrote :

Btw, this makes me wonder why we did not keep the old i810 driver around. Given that we have support for xserver-xorg-video-s3 with cards like Trio64 it seems like keeping old drivers working is possible without too much maintenance work (but I may be totally wrong here ;). And the old i810 driver did work reasonable on the old cards at least in my experience.

Michael Vogt (mvo) wrote :

From the intel_driver.h it appears the relevant PCIIDs are (8086 for the vendor):

#ifndef PCI_CHIP_I810
#define PCI_CHIP_I810 0x7121
#define PCI_CHIP_I810_DC100 0x7123
#define PCI_CHIP_I810_E 0x7125
#define PCI_CHIP_I815 0x1132
#define PCI_CHIP_I810_BRIDGE 0x7120
#define PCI_CHIP_I810_DC100_BRIDGE 0x7122
#define PCI_CHIP_I810_E_BRIDGE 0x7124
#define PCI_CHIP_I815_BRIDGE 0x1130
#endif

#ifndef PCI_CHIP_I830_M
#define PCI_CHIP_I830_M 0x3577
#define PCI_CHIP_I830_M_BRIDGE 0x3575
#endif

#ifndef PCI_CHIP_845_G
#define PCI_CHIP_845_G 0x2562
#define PCI_CHIP_845_G_BRIDGE 0x2560
#endif

#ifndef PCI_CHIP_I854
#define PCI_CHIP_I854 0x358E
#define PCI_CHIP_I854_BRIDGE 0x358C
#endif

#ifndef PCI_CHIP_I855_GM
#define PCI_CHIP_I855_GM 0x3582
#define PCI_CHIP_I855_GM_BRIDGE 0x3580
#endif

#ifndef PCI_CHIP_I865_G
#define PCI_CHIP_I865_G 0x2572
#define PCI_CHIP_I865_G_BRIDGE 0x2570
#endif

Michael Vogt (mvo) on 2011-06-17
Changed in update-manager (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.151.5

---------------
update-manager (1:0.151.5) oneiric; urgency=low

  * DistUpgrade/DistUpgradeQuirks.py:
    - warn intel i8xx user that the upgrade to oneiric may cause
      issues with their particular graphics hardware (LP: #774999)
  * merge patch from "eapache" to fix the unity progress bars
    (LP: #796311)
 -- Michael Vogt <email address hidden> Fri, 17 Jun 2011 18:04:27 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
Andrew (fromlaunchpad-ziltro) wrote :

The upgrade warning message still says "Your graphics hardware may not be fully supported in Ubuntu 11.04." when upgrading to Ubuntu 11.10.

piccobello (piccobello) wrote :

I have an old machine with this intel graphics card:
 $ lspci -v|grep -i vga
 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
 I am using Kubuntu natty since a while now, and I never had a problem whatsoever.
 I only learned about this bug as I got the scary warning while trying to upgrade to oneiric.
 Should I be worried? Is there something useful I can do?
 I have arrived to natty via an upgrade, and I always kept all desktop effects deactivated, I guess that may be why I never had any issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions