[i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)

Bug #761632 reported by giginux on 2011-04-15
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Nominated for Oneiric by Clint Byrum
Natty
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

after log in it crash before any other activities

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Chipset: i915gm
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64: AP///////wAOFJITAAAAAAoPAQOAIRV4Co4tnVVQjycgUFQAAAABAQEBAQEBAQEBAQEBAQEB6hoAgFAgDTAVIBMAS88QAAAZAAAADwAgICAgICAgICBuBQ8AAAAA/gBDUFQKICAgICAgICAgAAAA/gBDTEFBMTU0V0EwMgogABo=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Fri Apr 15 10:06:42 2011
DistUpgraded: Log time: 2011-04-01 13:21:49.757154
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox-ose, 4.0.4, 2.6.38-8-generic, i686: installed
 virtualbox-ose, 4.0.4, 2.6.38-7-generic, i686: installed
DuplicateSignature: (ESR: 0x00000001 IPEHR: 0x7d8e0001)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Uniwill Computer Corp Device [1584:9800]
   Subsystem: Uniwill Computer Corp Device [1584:9800]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.7
MachineType: American Megatrends Inc 255/259 Series
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=0ec04a32-ae2b-4bfe-aeb1-4893c632c38b ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=0ec04a32-ae2b-4bfe-aeb1-4893c632c38b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+4ubuntu3
 libdrm2 2.4.23-1ubuntu6
 xserver-xorg-video-intel 2:2.14.0-4ubuntu7
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
Title: [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)
UpgradeStatus: Upgraded to natty on 2011-04-01 (13 days ago)
UserGroups:

dmi.bios.date: 06/06/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.00
dmi.board.name: 255/259 Series
dmi.board.vendor: American Megatrends Inc
dmi.chassis.type: 10
dmi.chassis.vendor: American Megatrends Inc
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.00:bd06/06/2005:svnAmericanMegatrendsInc:pn255/259Series:pvr:rvnAmericanMegatrendsInc:rn255/259Series:rvr:cvnAmericanMegatrendsInc:ct10:cvr:
dmi.product.name: 255/259 Series
dmi.sys.vendor: American Megatrends Inc
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 04)
     Subsystem: Uniwill Computer Corp Device [1584:9800]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04) (prog-if 00 [VGA controller])
     Subsystem: Uniwill Computer Corp Device [1584:9800]

giginux (gigidipri) wrote :
tags: removed: need-duplicate-check
bugbot (bugbot) on 2011-04-17
tags: added: crash
Oier Mees (oier) on 2011-04-17
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Bryce Harrington (bryce) wrote :

Have you encountered other system freezes like this one since upgrading to natty? Did you experience freezes like this on maverick? Are you able to reproduce this freeze reliably?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
summary: - crash on startup before any activities
+ [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Please also test this PPA which has a fix to the X driver I think might help. Dunno if there's time to get it into natty, but maybe if enough people test it soon and find it helps: https://launchpad.net/~bryce/+archive/fig

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete

When I first installed Natty I got this error message on every boot up,
however the machine did not totally lock up. When I installed the
updates the next day, it booted normally without error messages and has
had no problems since. It looks like something in the updates fixed the
problem. Also, this laptop has had a hardware problem with the video
card, probably thermally related as it seems to work fine until you load
up the video card with say a full screen movie. When the video card
works hard and heats up I will get a video tear or vertical strips and a
HARD lock up requiring a hard shutdown and reboot. This problem on boot
did not cause a hard lockup and occurred on the boot when the video card
had not yet been doing much, so I did not think it a high probability it
was the same problem. Working fine after the daily Update Manager run.

Did not have similar error messages with Maverick, but did have the
occasional video lockup in both Maverick and Windows XP, which is what
led me to believe I have a thermal problem with the video card and not a
software driver issue. Those never threw an error code because they hard
locked the computer. Interestingly have not had a hard video lockup
since installing Natty, even when trying to push it with full screen
videos. May have to try Passmark or some similar video test in Linux.

Thanks,

Don

On 4/20/2011 8:44 PM, Bryce Harrington wrote:
> Have you encountered other system freezes like this one since upgrading
> to natty? Did you experience freezes like this on maverick? Are you able
> to reproduce this freeze reliably?
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Summary changed:
>
> - crash on startup before any activities
> + [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Incomplete => New
>

Bryce Harrington (bryce) wrote :

@Don, your issue is probably unrelated to this reporter's issue.

But yeah, thermal effects on gfx cards can be bad.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Paul W (dp-wilkinson) wrote :

Hi Bryce,

Freezes seem to be video related. No freezes like this prior to natty. It seems
fixed now after various updates, previously it would happen randomly- unable to
reproduce reliably.

Regards,
Paul

________________________________
From: Bryce Harrington <email address hidden>
To: <email address hidden>
Sent: Thursday, 21 April, 2011 3:44:48
Subject: [Bug 761632] Re: crash on startup before any activities

Have you encountered other system freezes like this one since upgrading
to natty? Did you experience freezes like this on maverick? Are you able
to reproduce this freeze reliably?

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Confirmed => Incomplete

** Summary changed:

- crash on startup before any activities
+ [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Incomplete => New

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (766551).
https://bugs.launchpad.net/bugs/761632

Title:
  [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/761632/+subscribe

Paul W (dp-wilkinson) wrote :

I take the last sentence back ... I've just had a crash

________________________________
From: Paul W <email address hidden>
To: <email address hidden>
Sent: Friday, 22 April, 2011 9:02:16
Subject: Re: [Bug 761632] Re: crash on startup before any activities

Hi Bryce,

Freezes seem to be video related. No freezes like this prior to natty. It seems
fixed now after various updates, previously it would happen randomly- unable to
reproduce reliably.

Regards,
Paul

________________________________
From: Bryce Harrington <email address hidden>
To: <email address hidden>
Sent: Thursday, 21 April, 2011 3:44:48
Subject: [Bug 761632] Re: crash on startup before any activities

Have you encountered other system freezes like this one since upgrading
to natty? Did you experience freezes like this on maverick? Are you able
to reproduce this freeze reliably?

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Confirmed => Incomplete

** Summary changed:

- crash on startup before any activities
+ [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Incomplete => New

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (766551).
https://bugs.launchpad.net/bugs/761632

Title:
  [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/761632/+subscribe

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (766551).
https://bugs.launchpad.net/bugs/761632

Title:
  [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7d8e0001)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/761632/+subscribe

Bryce Harrington (bryce) wrote :

Has anyone on the dupes of this bug found that the fig ppa helps?

(On another i915 gpu lockup bug report similar to this one, we're getting reports that the ppa makes the hangs go away; I need a few more yes votes to justify getting the fix in.)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

This is a dupe of #727594; testing the above fig ppa would prove it but going by the error codes and chipset this is basically the same bug.

Launchpad won't let me mark it as a dupe though (times out).

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Committed
importance: Undecided → High
Alberto Lo Ricco (alby1729) wrote :

This fixed for me:

"Please also test this PPA which has a fix to the X driver I think might help. Dunno if there's time to get it into natty, but maybe if enough people test it soon and find it helps: https://launchpad.net/~bryce/+archive/fig"

:) If that bug comes back i'll alert you, but now is fine!

Accepted xserver-xorg-video-intel into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
bugbot (bugbot) on 2011-04-27
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.14.0-4ubuntu7.1

---------------
xserver-xorg-video-intel (2:2.14.0-4ubuntu7.1) natty-proposed; urgency=low

  * Add 119_disable_relaxed_fencing.patch: The relaxed fencing
    optimization is suspected as the cause for various i915/945 gpu lockup
    issues. This disables the optimization by default but adds an
    xorg.conf parameter to let people experiment with it turned on.
    (LP: #727594, #761143, #761632, #755693)
 -- Bryce Harrington <email address hidden> Fri, 22 Apr 2011 19:12:55 -0700

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) wrote :

This patch is included in oneiric too

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.