GPU lockup (IPEHR: 0xf9b7b7b7) prior to gdm greeter

Bug #742425 reported by Merelin on 2011-03-25
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
xf86-video-intel
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

The system hangs before the gdm greeter due to a GPU lockup (*ERROR* Hangcheck timer elapsed... GPU hung).

/var/log/gdm/:0.log:
(EE) intel(0): Detected a hung GPU, disabling acceleration.

/var/log/kern.log:
Mar 25 15:16:01 localhost kernel: [ 41.860009] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Mar 25 15:16:01 localhost kernel: [ 41.862085] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 372 at 345, next 390)
Mar 25 15:16:01 localhost kernel: [ 41.862185] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 00000000 head 00000000 tail 00000000 start 00000000
Mar 25 15:16:01 localhost kernel: [ 42.005338] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling
Mar 25 15:16:01 localhost kernel: [ 42.025341] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling
Mar 25 15:16:01 localhost kernel: [ 42.045321] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling

Description: Ubuntu Natty (development branch)
Release: 11.04

xserver-xorg-video-intel:
  Installed: 2:2.14.0-4ubuntu4
  Candidate: 2:2.14.0-4ubuntu4
  Version table:
 *** 2:2.14.0-4ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Chipset: i946gz
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1280x1024 1280x1024 1280x1024 1440x900 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAwriBpAQEBAQsRAQNsKBl4KtOQollKliQUUFSv7wBxT4GAgYqVAJUPAQEBAQEBmimg0FGEIjBQmDYAmP8QAAAcAAAA/wBWMUQyNjE2CiAgICAgAAAA/QAySx5QDgAKICAgICAgAAAA/ABMMTkyIFdpZGUKICAgADQ=
Date: Fri Mar 18 14:14:43 2011
DistUpgraded: Log time: 2009-03-03 10:04:20.805534
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: vboxhost, 4.0.4, 2.6.38-7-generic, x86_64: installed
DumpSignature: (ESR: 0x00000001 IPEHR: 0xf7ffffdf)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Intel Corporation 82946GZ/GL Integrated Graphics Controller [8086:2972] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:300b]
MachineType: LENOVO 9645Y8E
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=2c3d749d-3eae-4db4-8841-84d96773306f ro single
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to natty on 2009-03-03 (752 days ago)
dmi.bios.date: 04/17/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 2QKT20AUS
dmi.board.name: LENOVO
dmi.board.vendor: LENOVO
dmi.chassis.asset.tag: �������������������������
dmi.chassis.type: 6
dmi.chassis.vendor: LENOVO
dmi.modalias: dmi:bvnLENOVO:bvr2QKT20AUS:bd04/17/2007:svnLENOVO:pn9645Y8E:pvrThinkCentreM55e:rvnLENOVO:rnLENOVO:rvr:cvnLENOVO:ct6:cvr:
dmi.product.name: 9645Y8E
dmi.product.version: ThinkCentre M55e
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Merelin (merelin) wrote :
Bryce Harrington (bryce) wrote :

Hi Merelin, unfortunately there are a variety of ways a system can lock up with this error message, but we need to get the dmesg and /sys/kernel/debug/dri/0/i915_error_state from point of failure (while system is locked up).

Easiest way is to let apport capture it directly, which it does automatically much of the time. I'll close this bug in hopes that next time it happens apport will catch it and you can file a new bug that way. If not, please manually collect the info and reopen this bug report.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Merelin (merelin) wrote :
Merelin (merelin) wrote :
Changed in xserver-xorg-video-intel (Ubuntu):
status: Invalid → New
Merelin (merelin) wrote :

Bryce,

The info is attached hence I re-open the bug.

Bryce Harrington (bryce) on 2011-04-01
summary: - The system hangs before the gdm greeter due to a GPU lockup (*ERROR*
- Hangcheck timer elapsed... GPU hung)
+ GPU lockup (IPEHR: 0xf9b7b7b7) prior to gdm greeter
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Triaged
importance: Undecided → High
Bryce Harrington (bryce) wrote :

Merelin - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=35854 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in linux:
importance: Unknown → Undecided
status: Unknown → New
Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.14.0-4ubuntu6

---------------
xserver-xorg-video-intel (2:2.14.0-4ubuntu6) natty; urgency=low

  * Add 117_946gz_isreally_965g.patch: 946gz was listed as a 915-family
    chip but it's actually just a marketing name for 965g. Fixes a GPU
    lockup that occurs with this hardware during boot.
    (LP: #742425)
 -- Bryce Harrington <email address hidden> Fri, 01 Apr 2011 13:20:38 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Brad Figg (brad-figg) on 2011-05-03
Changed in linux (Ubuntu):
status: New → Confirmed

Merelin, thank you for reporting this bug and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue using the new xserver-xorg-video-intel 2:2.14.0-4ubuntu6 package? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Merelin (merelin) wrote :

Christopher,

It was been resolved quite a while ago. I don't remember the exact version but can say for sure in xserver-xorg-video-intel 2:2.17.0-1ubuntu4 (precise) it is OK.
Suppose the bug can be closed.

Thank you!

Merelin, the bug task for linux is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.