[gm45] GPU lockup dbe8d52d (EIR: 0x00000010 ESR: 0x00000010 PGTBL_ER: 0x00000001 IPEHR: 0x01000000)

Bug #732089 reported by Robbie Williamson on 2011-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Wasn't doing anything in particular, the message just popped up telling me I had a system error...it's been happening everytime I log in, I just finally decided to report it. I don't notice any odd behavior, just the message.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Chipset: gm45
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1440x900
 edid-base64: AP///////wAwrnRAAAAAACASAQOAHRJ46tCjlltXlCYjUlkAAAABAQEBAQEBAQEBAQEBAQEB2CegjFGEGjAwIDYAH7QQAAAYNCGgjFGEGjAwIDYAH7QQAAAYAAAADwCVCjKVCigeAQAwZABVAAAA/gBMVEQxMzNFUTFCCiAgAHM=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Fri Mar 4 17:16:38 2011
DistUpgraded: Log time: 2010-06-03 15:16:15.473132
DistroCodename: natty
DistroVariant: ubuntu
DumpSignature: dbe8d52d (EIR: 0x00000010 ESR: 0x00000010 PGTBL_ER: 0x00000001 IPEHR: 0x01000000)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:20e4]
   Subsystem: Lenovo Device [17aa:20e4]
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 2777CTO
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=185050f9-b1be-4215-889f-803f2bacff21 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=185050f9-b1be-4215-889f-803f2bacff21 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6~3ubuntu11
 libdrm2 2.4.23-1ubuntu3
 xserver-xorg-video-intel 2:2.14.0-4ubuntu1
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
Title: [gm45] GPU lockup dbe8d52d (EIR: 0x00000010 ESR: 0x00000010 PGTBL_ER: 0x00000001 IPEHR: 0x01000000)
UpgradeStatus: Upgraded to natty on 2010-06-03 (278 days ago)
UserGroups:

dmi.bios.date: 05/15/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET41WW (3.01 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET41WW(3.01):bd05/15/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Robbie Williamson (robbiew) wrote :

On Wed, Mar 09, 2011 at 04:33:35PM -0000, Robbie Williamson wrote:
> Public bug reported:
>
> Binary package hint: xserver-xorg-video-intel
>
> Wasn't doing anything in particular, the message just popped up telling
> me I had a system error...it's been happening everytime I log in, I just
> finally decided to report it. I don't notice any odd behavior, just the
> message.

Hi Robbie,

Believe it or not I love hearing what you just said...

(And I think we may have a fix!)

This is an extremely commonly reported bug (there's gobs of dupes),
however it seems difficult to locate someone who can reproduce it
reliably, as it sounds like you can.

Basically, because of wanting fast/pretty boot with plymouth and all
that, the kernel loads up the generic vesafb framebuffer driver early
on, then switches to a better driver later (the intel kernel drm driver
in this case). I gather that the plumbing layer bits can try to bring
up this intel driver before vesafb has been unloaded. And that makes
the GPU unhappy and it locks up briefly; however it's able to reset the
GPU and keep on chugging (at least, most of the time).

Or something like that.

Anyway, the good news is the kernel team has posted a possible fix for
this, which adds checks throughout the plumbing layer to prevent the
kernel drivers from colliding during boot. This patches gdm, linux,
module-init-tools, plymouth, and udev (no X packages are involved in
this bug afaik).

When the PPA's kernel has finished building, I'll post a note to the
master bug (#702090). I would really appreciate it if you could load
that PPA on your machine and do whatever you normally do to see the bug,
and verify that it no longer occurs with this PPA.

To post a comment you must log in.