Ubuntu

xrandr reports incorrect max resolution from displayport in laptop dock i915

Reported by Richard Harding on 2011-03-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I am using a X201 on the dock with DVI/Displayport outputs to matched Dell 22" lcds doing 1920x1080. It was working correctly, but I redid my install and updated my laptop bios. After the new install xrandr reports the displayport monitor to only be able to do 1280x1024 resolution (vs 1920).

I've tried to manaully force it:

    % xrandr --addmode DP1 1920x1080
    % xrandr --output LVDS1 --off --output DP1 --mode 1920x1080

    # /var/log/syslog output
    kernel: [44206.334502] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff8802322a0800

and get the crtc error and no display pops up.

I've loaded the xorg-edgers ppa with no difference. I've also tested the natty alpha3 live usb to see if an updated package/kernel combo might help.

I've run across a lot of posts like this, most having to do with nouveau-drm, so not sure where this falls exactly.

Richard Harding (rharding) wrote :
Jorge O. Castro (jorge) on 2011-03-05
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2011-03-06
tags: added: resolution
bugbot (bugbot) on 2011-03-07
tags: added: edgers
madbiologist (me-again) wrote :

This could be a duplicate of bug 899598 which was reported in Oneiric. There is a fix in kernel 3.0.0-15.25 in oneiric-proposed which has been verified and therefore will soon make it's way to updates.

Chris Wilson (ickle) on 2013-02-15
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments