With HybridGraphics Xorg assert failure: X: ../../dix/pixmap.c:118: AllocatePixmap: Assertion `pScreen->totalPixmapSize > 0' failed.

Bug #718620 reported by Linuxrider on 2011-02-14
208
This bug affects 20 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Chris Halse Rogers

Bug Description

Simply crashed a few moments after login

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-core 2:1.9.99.901+git20110131.be3be758-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
AssertionMessage: X: ../../dix/pixmap.c:118: AllocatePixmap: Assertion `pScreen->totalPixmapSize > 0' failed.
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CrashCounter: 1
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card1.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card1.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card1.LVDS.2:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAGrzwxAAAAAAAUAQOAHxF4CsilnldUkiaZUFQAAAABAQEBAQEBAQEBAQEBAQEBEhtWRlAAIzAmFjYANa0QAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTQwWFcwMyBWMSAKAAM=
DRM.card1.VGA.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Mon Feb 14 10:11:16 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-3-generic, x86_64: installed
 virtualbox-ose-guest, 4.0.2, 2.6.38-3-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Subsystem: Acer Incorporated [ALI] Device [1025:0414]
   Subsystem: Acer Incorporated [ALI] Device [1025:0414]
MachineType: Acer TravelMate8472TG
ProcCmdline: /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-YzVGVv/database -nolisten tcp vt7
ProcEnviron:
 LANG=de_DE.UTF-8
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=f8c1b1b2-5ea7-45fd-9785-74a1edcf91cd ro splash quiet vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=f8c1b1b2-5ea7-45fd-9785-74a1edcf91cd ro splash quiet vt.handoff=7
Renderer: Hardware acceleration
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 __assert_fail () from /lib/libc.so.6
 AllocatePixmap ()
 fbCreatePixmapBpp () from /usr/lib/xorg/modules/libfb.so
Title: Xorg assert failure: X: ../../dix/pixmap.c:118: AllocatePixmap: Assertion `pScreen->totalPixmapSize > 0' failed.
UserGroups:

dmi.bios.date: 12/13/2010
dmi.bios.vendor: Phoenix
dmi.bios.version: V1.20
dmi.board.name: BAP40-CP
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrV1.20:bd12/13/2010:svnAcer:pnTravelMate8472TG:pvrNotApplicable:rvnAcer:rnBAP40-CP:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: TravelMate8472TG
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu4
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Linuxrider (linuxrider) wrote :

StacktraceTop:
 *__GI_raise (sig=6)
 *__GI_abort () at abort.c:59

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Bryce Harrington (bryce) on 2011-02-18
visibility: private → public
tags: added: bugpattern-needed

If anyone can reproduce this easily, could they please install the xserver-xorg-video-intel-dbg package and attach the /var/log/Xorg.0.log from a failed start? This file will become /var/log/Xorg.0.log.old if the *current* start worked and the previous one didn't.

Changed in xorg-server (Ubuntu):
status: New → Incomplete
assignee: nobody → Chris Halse Rogers (raof)
affects: xorg-server (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Chris Halse Rogers (raof) → nobody
GodNobody (godnobody) wrote :

I'm happy to do that, since this problem occurs to me on my daily startup or reboot.

But it would be great if I could get a method to boot natty "for sure" since it could happen that I need 5-10 boots till I finally made it.

Bryce Harrington (bryce) wrote :

Thanks; we'll follow up once someone has posted a full backtrace for this issue.

Fwiw, while there are bunches of dupes to this bug, I haven't reproduced it on my systems. I wonder if there is something particular on the machines/installs of all the people seeing this?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Pete Goodall (pgoodall) wrote :

Attaching my /var/log/Xorg.0.log file as I just reproduced the crash. It doesn't happen every time on login, but it does happen frequently.

Pete Goodall (pgoodall) wrote :

Oh, and I installed xserver-xorg-video-intel-dbg earlier today.

GodNobody (godnobody) wrote :

In my case I have two GPU's one discrete ati and an integrated intel.

Maybe there is an issue with that

gerbalblaste (gerbalblaste) wrote :

I have only an Intel Atom chipset. For me this bug occurs synchronously with other applications crashing, weather-indicator and GettingThingsGnome are two major culprits.

Mark Poulsen (markypoulsen) wrote :

I have intel HD and ATI graphics as well. I think at some point during boot it sort of decides randomly which GPU it will use because some times it will boot and other times I just get a black screen. I'm assuming it boots with intel HD as this worked in 10.10 but the screen turns off completely if it goes with the ATI. Xorg and Compiz continuously crash when I am able to get it to boot. :/

Vangel Ajanovski (ajanovski) wrote :

If it has something to do with that I also have a hybrid laptop - Intel HD (i5 cpu) and ATI 5470. It is not possible to switch off either in the bios since HP has blocked the switching option.

I too experience random crashes from various indicators, screensaver etc. The setup is much more stable when I use Classic Desktop (Gnome) instead of Unity. In fact nothing has crashed for more than 10 hours now. Unity was not usable at all.

Bryce Harrington (bryce) wrote :

Ah, yes the original bug reporter appears to also have hybrid graphics. Seems like a very strong clue.

summary: - Xorg assert failure: X: ../../dix/pixmap.c:118: AllocatePixmap:
- Assertion `pScreen->totalPixmapSize > 0' failed.
+ With HybridGraphics Xorg assert failure: X: ../../dix/pixmap.c:118:
+ AllocatePixmap: Assertion `pScreen->totalPixmapSize > 0' failed.
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Medium → High
status: Incomplete → Triaged
Bryce Harrington (bryce) wrote :

Looking in other distro bug trackers, I see this assertion has been hit by others, however I've a feeling that there are multiple ways to trigger this assert.

This email makes me wonder if it has something to do with the BGNone patch we carry:
http://archives.mandrivalinux.org/cooker/2010-10/msg00174.php

Chris Halse Rogers (raof) wrote :

Yeah; I also suspect that this is a broken fallback path in our BGNone patch. Intel doesn't appear to own the framebuffer before X, so the framebuffer copy fails - something that doesn't otherwise happen - and the server scratch pixmap state doesn't get set up.

However, I couldn't easily see why it *wasn't* getting set up. Although I don't have a hybrid system I'll try making the framebuffer copy fail on my system to see if I can reproduce.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
status: Triaged → In Progress
Bryce Harrington (bryce) wrote :

To isolate whether it is the no root background patch you could try manually running X without that switch. Something like:

 $ sudo service gdm stop
 $ sudo /usr/bin/X :0 --verbose -nolisten tcp vt7

If the bug can't be reproduced in that situation (which omits the -nr flag) then that'd pinpoint it to the BGNone patch I think.

Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package xserver-xorg-video-intel - 2:2.14.0-4ubuntu1

---------------
xserver-xorg-video-intel (2:2.14.0-4ubuntu1) natty; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - debian/apport-gpu-error-intel.py:
    - debian/control:
    - debian/rules:
    - debian/xserver-xorg-video-intel.install:
    - debian/xserver-xorg-video-intel.udev
      + Add apport hook, triggered on udev GPU error event
    - debian/control:
      + Drop [linux-any] qualifier on libudev-dev build-dep to work around
        pbuilder bug.
    - debian/patches/101_copy-fb.patch:
      + Plymouth integration patch
    - debian/patches/107_solid_nullptr_check.patch:
      + Check null return from uxa_acquire_solid()
    - debian/patches/109_dont_reconstruct_glyph_cache_on_rotate.patch:
      + Fix font corruption (missing glyphs) on rotated screens.
    - debian/patches/110_warnings_cleanup.patch:
    - debian/patches/114_warnings_cleanup_part_2.patch:
      + Cherry picks to fix a large number of build warnings.
    - debian/patches/111_fix_clipped_window_plane_offset.patch:
    - 112_fix_error_in_4c4ad555.patch:
      + Fix issue where vertical green line and strange colors shows up when
        playing gstreamer with certain videos, when dragged. (LP 460677)
    - debian/patches/113_remove_broken_max_base_addresses.patch:
      + Fixes GPU lockup during login with
         "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]" error messages
     listed in the gpu dump text. (LP 710321)
    - debian/patches/115_quell_vblank_counter_failed.patch:
      + Don't fill up Xorg.0.log with
         "get vblank counter failed: Invalid argument" warnings.
    5 is enough. (LP 710594)
    - debian/xserver-xorg-video-intel.preinst.in:
    - debian/xserver-xorg-video-intel.postinst.in:
      + Remove obsolete /etc/modprobe.d/i915-kms.conf file on upgrades. KMS
        is the kernel default.
  * Pull prerequisite commit into
    109_dont_reconstruct_glyph_cache_on_rotate.patch. We mostly didn't notice
    because the copy-fb codepath initialises the resources itself. Fixes
    Pixmap assert on Xserver startup when copy-fb fails, such as on hybrid
    graphics systems. (LP: #718620)
  * debian/control:
    - Dropped Ubuntu change: remove a bunch of Conflicts/Replaces against
      packages last seen in Hardy.

xserver-xorg-video-intel (2:2.14.0-4) unstable; urgency=low

  * Cherry-pick from upstream:
    - uxa: Fallback if the temporary is too large
  * This fixes a null pointer dereference with some rendering operations
    involving large pictures (Closes: #613830). Thanks, Enrico!

xserver-xorg-video-intel (2:2.14.0-3) unstable; urgency=low

  * Switch to dh:
    - Use debhelper 8.
    - Use dh-autoreconf.
    - Bump xserver-xorg-dev build-dep for dh_xsf_substvars and xsf
      debhelper sequence.
    - Specify usr/share/man in .install, remove .manpages accordingly.
    - Specify NEWS and README in .docs file.
  * Get rid of maintainer scripts, since they were only used to handle
    switching between versions with or without KMS. Starting with squeeze,
    KMS is mandatory, so stop worrying about that.
  * Remove xsfbs acco...

Read more...

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.