ubuntu desktop from usb stick freezes when the display switch from plymouth to X

Bug #712173 reported by Jean-Baptiste Lallement on 2011-02-02
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Unassigned
Natty
High
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

ISO Testing Ubuntu Desktop i386/AMD64 20110202

On an Asus eeepc 1015PE, the system freezes at boot when the display switch from plymouth to X.
If I remove quiet/splash from the boot command it boots correctly.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600 1024x600
 edid-base64: AP///////wAiZOkDZUECABoUAQOAFg14CoYmlFdRkCchT1QAAAABAQEBAQEBAQEBAQEBAQEBlBEAsEBYGSA1I0UA3IEAAAAZFhQA2EBYJiBdIxUE3IEAAAAAAAAA/gAAAAAAAAAAAAAAAAAAAAAA/gAAAAAAAAAAAAEAAAAAABY=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Feb 2 22:52:43 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GdmLog1: Not present
GdmLog2: Not present
GraphicsCard:
 Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: ASUSTeK Computer INC. 1015PE
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz --
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 05/31/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1015PE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0402:bd05/31/2010:svnASUSTeKComputerINC.:pn1015PE:pvrx.x:rvnASUSTeKComputerINC.:rn1015PE:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1015PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu5
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
summary: - ubuntu desktop boot from usb stick freezes when the display switch to X
+ ubuntu desktop from usb stick freezes when the display switch from
+ plymouth to X
Changed in xserver-xorg-video-intel (Ubuntu Natty):
milestone: none → natty-alpha-3
importance: Undecided → High
Jean-Baptiste Lallement (jibel) wrote :

confirmed by marjo on another eeepc

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: New → Confirmed
bp0 (bullet-proof-0) wrote :

I also have this issue, with a HP dv6700 series laptop. A workaround which successfully gets me to the desktop is to hit shift as soon as the live-usb starts to load, select my language, hit F6 to get to advanced configuration, and manually edit the boot parameters to remove the word 'quiet'. I presume this means that plymouth isn't loaded.

bugbot (bugbot) on 2011-02-06
tags: added: freeze
Bryce Harrington (bryce) wrote :

Hmm, usually if it was an X issue it would be immaterial whether plymouth is loaded or whether quiet/splash is on the boot prompt. That this issue only appears when plymouth is loaded seems to indicate that plymouth may be futzing up the GPU resulting in X failing when it tries to access it.

Please ssh into the box and reproduce the freeze, and then gather the output of dmesg as well as your /var/log/Xorg.0.log and /var/log/gdm/:0.log files while it is frozen, and attach those files here. These may have error message(s) that better pinpoint where the fault is occurring.

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Confirmed → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

I don't know how to ssh to a frozen livecd, the box doesn't even shows up on the network. Can you please give specific directives? Thanks.

Changed in plymouth (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
Changed in plymouth (Ubuntu Natty):
milestone: none → natty-alpha-3
Evan (ev) wrote :

Adding the following to the kernel command line from the CD bootloader should do the trick (assuming you have an ethernet connection):

d-i preseed/early_command string chroot root apt-get -y install openssh-server

Alternatively, you can add break=bottom to the kernel command line, then:
(initramfs)
chroot root bash
mount -t proc proc /proc
mount -t devpts devpts /dev/pts
dhclient eth0
screen apt-get -y install openssh-server
exit
exit

Bryce Harrington (bryce) on 2011-02-18
Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Incomplete → New
status: New → Incomplete
Martin Pitt (pitti) wrote :

Too late for alpha-3, and it doesn't block the alpha-3 release.

Changed in xserver-xorg-video-intel (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Changed in plymouth (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Bryce Harrington (bryce) wrote :

Alright, well so far it isn't sounding like an X bug. Perhaps an error in plymouth, or even could be kernel issues. Closing the X task, and leaving the plymouth task open for further investigation.

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Incomplete → Invalid
Phil Thompson (phil-yarwell) wrote :

Same issue here with an Acer Aspire One netbook. Trying to install from USB stick it appeared to stall after selecting third party add-ins and live downloads. However via Ctrl-Alt-F1 I could get to command prompt and do stuff.

Rebooted and tried to get to Live CD mode but appeared to freeze, although after a *long* time got a "Compiz has crashed" error then just a wallpapered screen.

Files requested in #4 attached

Phil Thompson (phil-yarwell) wrote :

Other two files concatentated into attached, couldn't see how to upload multiple attachments, sorry !

@Phil, thanks but what you are describing is completely different from the issue I was facing. Could you please file a new report.

I'm closing this report, because a recent update fixed it and I'm not able to reproduce it with the latest desktop ISO (20110307) on i386 and AMD64

Changed in plymouth (Ubuntu Natty):
status: Confirmed → Fix Released
bp0 (bullet-proof-0) wrote :

Just to confirm that this bug should be closed, I've re-tested with a daily build (20110312) on my laptop (i386) and the issue appears to have been resolved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers