[gm45] garbled fonts

Bug #667737 reported by David Monniaux on 2010-10-28
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Sometimes, display fonts become garbled (see attached image). This affects all applications, including those not yet launched, until X is restarted.

The problem seems to occur particularly when using Firefox, but I was not able to identify a sequence of actions leading to it.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic i686
NonfreeKernelModules: wl
Architecture: i386
CurrentDmesg:
 [ 20.945756] ppdev: user-space parallel port driver
 [ 131.897090] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
 [ 131.897610] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 142.016068] eth0: no IPv6 routers present
Date: Thu Oct 28 13:37:26 2010
DkmsStatus:
 bcmwl, 5.60.48.36+bdcom, 2.6.32-24-generic, i686: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.32-22-generic, i686: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.32-25-generic, i686: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.32-23-generic, i686: installed
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Dell Inc. Latitude E4200
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-25-generic root=UUID=238c0805-e3d7-41bb-bcc2-ee866f5734f3 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 05/06/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A16
dmi.board.name: 02GMRH
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA16:bd05/06/2010:svnDellInc.:pnLatitudeE4200:pvr:rvnDellInc.:rn02GMRH:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E4200
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-25-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
     Subsystem: Dell Device [1028:0277]

David Monniaux (david-monniaux) wrote :
bugbot (bugbot) on 2010-11-23
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
bugbot (bugbot) on 2011-04-27
description: updated
bugbot (bugbot) on 2011-04-28
summary: - garbled fonts
+ [gm45] garbled fonts
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
WheelDweller (wheeldweller) wrote :

I have several, Ubuntu Precise (12.04) on built-in Intel machines with this same corruption. It also effects the wallpaper over time, somehow. It's pretty debilitating across an entire day...

Thanks guys!

Chris Wilson (ickle) wrote :

Broken glyph cache. Which is not the same bug as #3, WheelDweller you have a swizzling bug.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers