System freeze when i'am not moving the mouse or typing.

Bug #657990 reported by Tetsuo6995
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Hi !

Just installed Ubuntu 10.10 Netbook Edition.

First boot was completly frozen. So i moved the mouse a little and suddenly the boot continued.
But every 5 seconds or so, the system completly hangs out until i move the mouse again.
Once i finally reached the desktop, i tryed opening a terminal... but again as long as i don't move the mouse, the terminal won't initiate correcly and show the prompt.

Same issue reading a video. As long as i frenetically move the mouse the video will be smooth but if i dare stop, it just freeze and the sound goes in loop.

I tried getting in normal desktop mode (not unity) but it didn't changed a thing.

Then i deactivated all power management options like "deactivating hard drive when iddle" or switch the screen off when idle etc.
Once i did that it went a little better. Now i can let the computer untouched for an incredible duration of ... 1mn or so then it starts again to freeze.

Hardware :
Toshiba NB200
processor:
Atom N280

Graphic processor:
manufacturer : Intel®
type : Mobile Intel® GMA 950
memory : up to 224 MB total available graphics memory with 512 MB system memory
memory type : shared

Thanks !

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAw5LkBAAAAAAASAQOAFg14Cr+1llhUiycgUFQAAAABAQEBAQEBAQEBAQEBAQEB2BMAQEFYHiAwIDYA4H4AAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/ABMUDEwMVdTMS1UTEExAK0=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Mon Oct 11 01:16:07 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: TOSHIBA TOSHIBA NB200
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=a63838e6-a88c-4232-aabc-0e199066c82e ro quiet splash
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
dmi.bios.date: 04/07/2009
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V1.20
dmi.board.name: KAVAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV1.20:bd04/07/2009:svnTOSHIBA:pnTOSHIBANB200:pvrPLL20E-00200MFR:rvnTOSHIBA:rnKAVAA:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: TOSHIBA NB200
dmi.product.version: PLL20E-00200MFR
dmi.sys.vendor: TOSHIBA
glxinfo: Error: [Errno 2] Aucun fichier ou dossier de ce type
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :
Revision history for this message
Sunner Sun (sunner) wrote :

I meet the same problem after upgrade to 10.10 i386 desktop edition from 10.04.

I have a self-compiled kernel installed which is based on 10.04's generic kernel and use the same .config with 10.04. I boot with it and everything is fine. So I believe it is a problem about the kernel.

In fact, at least in 10.04 and 9.10, the Atom CPU is always freezed if no keyboard/mice input for around 5 mins. When be freezing, even the clock is stopped. I 10.10, the freezing happens immediately after the keystoke up. Totally can't afford.

Hardware:
Lenovo Ideapad S12
CPU:
Atom N270
RAM:
2G

Revision history for this message
Sunner Sun (sunner) wrote :

I manually download these files:

linux-headers-2.6.32-25_2.6.32-25.44_all.deb
linux-headers-2.6.32-25-generic_2.6.32-25.44_i386.deb
linux-image-2.6.32-25-generic_2.6.32-25.44_i386.deb

And install them with "sudo dpkg -i *.deb". Reboot with this kernel and the Atom N270 works like before.

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Ok thanks !
I tried the different fix proposed for the lenovo bug #634702 but it didn't work...

I will try your self-compiled kernel to see how it goes !

Revision history for this message
Paul Hirst (paul-hirst) wrote :

I don't find the kernel release for bug #634702 fixes the problem. I believe the duplicate status is wrong. This bug is actually a duplicate of bug #638434.

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Paul Hist is probably right.
Description of symptoms is far more similar on bug #638434.
If someone can change the duplicate status it would be great. We would regroup NB200 and NB300 issues.

Revision history for this message
Sunner Sun (sunner) wrote :

Yes, the latest updated kernel () does not fix this problem. But the "intel_idle.max_cstate=0" solution mentioned in bug #634702 works. So I mark them duplicated.

Although the two bugs have different description, I think they are the same inside. Since if we doesn't touch the keyboard and mouse during boot, the system will always hang.

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

I disagree :/

Sure the fix for Lenovo fix the boot of the NB200.
But only the boot problem.

I'am 99% sure that the freeze will persist from time to time even when the system is totally ON.
So this is mostly a duplicate of bug #638434 as it's a more similar hardware and it concerns freeze on boot AND after boot too.

If you did the "intel_idle.max_cstate=0" on a NB200 and confirm me that you get absolutely 0 freeze once the system is loaded, then i did something wrong. Otherwise the lenovo fix isn't enough.

Revision history for this message
Sunner Sun (sunner) wrote :

Since I don't have a NB200, I must agree with you, :-)

Revision history for this message
Daniel Dräs (g-kar) wrote :

Do we really think xorg is the correct project? I would consider this more a kernel issue.

Revision history for this message
PaoloV (paolo-visnoviz) wrote :

I can confirm that "intel_idle.max_cstate=0" kernel option works fine for my Toshiba NB200-110 with Maverick Meerkat 10.10.
This works fine after boot.

I can't confirm it works during install steps too, 'cause I used (trough F6 option) the "nohz=off". I did not know "intel_idle.max_cstate=0" option yet. :-)

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Well looks like the intel_idle.max_cstate=0 worked for me too !

@Sunner Sun: Well i'm deeply sorry. Looks like you were right in the end. That lenovo fix do work on that issue too.
I wonder why the fix didn't work on the first boot i made with it :/

Revision history for this message
Sunner Sun (sunner) wrote :

@Tetsuo6995 Never mind, :-) So we can begin to wait some ubuntu guys fix this in an updated kernel image. Read through all the related bug reports, I think the bug affects Atom CPU only. But it is urgent since it makes the atom users can't boot/operate their computers.

Revision history for this message
Daniel Dräs (g-kar) wrote :

When I get this right, this option would disable some power management features resulting in shorter battery run-times. correct?

Revision history for this message
Marcos Oliveira (mainzer-sapo) wrote :

Same here, after upgrading from 10.04 to 10.10, system hangs everytime if I do not move the mouse or type anything.

My system:

Magalhães PC (Portuguese version of intel's Classmate)
CPU: Atom N270
Ram: 1G

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

@Daniel Dräs:
As far as i know, this bug comes from an optimization attempt of the kernel.
So yes, if that worked it would have improved maybe a little the battery life.

But on 10.04, i already managed to reach something like 7 hours of battery life.
So it's not really a big concern. I prefer a kernel that works straight out of the box that an optimized kernel that hangs on boot :D

Revision history for this message
Daniel Dräs (g-kar) wrote :

I added the max_idle part and it works at least for booting. All other I don't know yet, but I will see what happens.

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Hmmm finally the problem is partially solved.
When the wifi is not connected, i still get some freeze.

Maybe that's why i had the feeling the issue was fixed when it wasn't ?

Revision history for this message
Rodnox (rodnox) wrote :

Solution.

Add the following to your command line in the boot up script:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nohz=off"

Will turn off the CPU Effects. Not the prettiest solution, your laptop will get hotter, the battery life will b shorter ... but at least, the system runs without interruption.

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Ok thanks. I will try that tonight.

I still hope for a real fix to come out :(
It's really sad to get more hardware problem when updating Ubuntu (10.04 was very stable on that netbook).

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Please don't tell me we will have to wait until the next release to get that bug fixed ?

I really can't stand "patching" the kernel with nohz=off at the cost of performance...

Why isn't that bug even triaged :'(

Revision history for this message
scotty (sfranzyshen-hotmail) wrote :

try adding "clocksource=jiffies nolapic_timers" to the kernel command line
parameter.

sudo pico /etc/default/grub

change

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapci_timer clocksource=jiffies"

save changes

sudo update-grub

reboot

sfranzyshen

bugbot (bugbot)
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Revision history for this message
Conor Anderson (conor.anderson) wrote :

I can contradict previous reports.
The intel_idle.max_cstate=0 option decreases freezes, but they still exist, as evidenced by loops occuring in video or music playback when a user does not move the mouse. Noted in Bug #638434.

Revision history for this message
Conor Anderson (conor.anderson) wrote :

Oops, forgot the important part: Toshiba NB200.
Ubuntu 10.10 - clean install
Kubuntu 10.10 - clean install

Revision history for this message
Len Brown (len-brown) wrote :

if "nolapic_timer" makes this issue go away, then it is probably this issue:

https://bugzilla.kernel.org/show_bug.cgi?id=21032

Which is fixed in 2.6.37-rc1, 2.6.36.1, 2.6.35.9 by this upstream patch

commit c25d29952b2a8c9aaf00e081c9162a0e383030cd
Author: Len Brown <email address hidden>
Date: Sat Oct 23 23:25:53 2010 -0400

    intel_idle: do not use the LAPIC timer for ATOM C2

Revision history for this message
Conor Anderson (conor.anderson) wrote :

In my case 'nolapci_timer' alone did not fix the issue.
It boots as quickly as 'intle_idle.max_cstate=0' but has more frequent pauses once it has started.

Using 'nolapci_timer clocksource=jiffies' does seem to have resolved the problem, however I will test it out some more and report back if problems persist.

Toshiba NB200
Ubuntu 10.10

Revision history for this message
fourcultures (fourcultures) wrote :

This also affects my NB200 running Ubuntu 10.10 netbook edition, updated from 10.04.

I'm testing the 'nolapci_timer clocksource=jiffies' suggestion. So far it has completely fixed the problem of constant hanging. And I can now listen to music on Rhythmbox with no glitches at all (an improvement over my previous 10.04 install, which occasionally stuttered!). This seems to suggest the hanging isn't happening any more.

But now I'm going to test the battery life. Don't see why this particular fix should increase battery use, but it might. Will report.

[later] Update:

Running on battery, still no hangs at all and music running smoothly. As for battery life, it appears to be as good as or better than previously with Ubuntu 10.04 (ie a bit over 2 hours with a 3-cell battery, max charge 22.7Wh, currently at 12Wh or 53% after 1 hour use, according to Gnome-power-statistics). [Can someone please point to instructions for getting better battery life out of NB200 that have worked for them?]

It may be that the bug we're experiencing is one of these (which may be the same bug):
https://bugzilla.kernel.org/show_bug.cgi?id=21032
https://bugzilla.kernel.org/show_bug.cgi?id=20172
If so, it may be fixed in the next release of the kernel.

If this keeps working - hat tip to sfranzyshen.

Revision history for this message
Bryce Harrington (bryce) wrote :

More likely to be a kernel problem than X. I see this already has a kernel task, so closing the X one.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Revision history for this message
rpr nospam (rpr-nospam) wrote :

I'd like to confirm that this bug exists in Ubuntu 11.04 with
Linux 2.6.38-9.43 on a Toshiba nb300.

As a workaround I set
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic_timer clocksource=jiffies"
in /etc/default/grub and then run
sudo update-grub
sudo reboot

Note that the right option name is nolapic_timer, not nolapci_timer as
mentioned above.

Revision history for this message
Adam Ziaja (adamziaja) wrote :

Same on Debian. Thx Robert Premuz, you save my life :).

rpr nospam (rpr-nospam)
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Prajna (prajna.pranab) wrote :

I'd like to report that this bug still persists in 12.04 and 14.04 on a Toshiba NB200.

I have worked round it on 14.04 with the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic_timer clocksource=jiffies"
line in /etc/default/grub as mentioned above.

Revision history for this message
rpr nospam (rpr-nospam) wrote :

Prajna, what version is your linux kernel? (Run "uname -a")

Revision history for this message
Prajna (prajna.pranab) wrote :

@rpr 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 i686 i686 GNU/Linux

Revision history for this message
Romain (ramerica) wrote :

Hi,

I have the same issue on Ubuntu 14.04.
I tried setting GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic_timer clocksource=jiffies"

I works, but, when I open Gnome System Monitor, I see that my first Core is always between 95 et 100% and the other one seems to work normally.

Revision history for this message
rpr nospam (rpr-nospam) wrote :

Romain, could you install htop and run the htop command from command line to see what process is causing high CPU usage?

Maximize the terminal window, start htop and sort processes by CPU% (F6, then choose PERCENT_CPU).

-- rpr.

Revision history for this message
Romain (ramerica) wrote :

Here it is.

As you can see in details, none of the process takes more than 1.9% but the 1rst core line is red and full.

Revision history for this message
rpr nospam (rpr-nospam) wrote :

Romain, red CPU time is related to kernel. In htop you can press F2 and set display options as shown on the attached screenshot in order to get more details on kernel threads. (Press Esc to go back to process list.)

Revision history for this message
Romain (ramerica) wrote :

I've set Htop as you said.
Here is the new screenshot. Nothing is different.
That's strange it's like the system thinks my computer just has a one core CPU.

Revision history for this message
rpr nospam (rpr-nospam) wrote :

Romain, I'd sas that for additional troubleshooting the issue the following article may give you some hints:
http://linoxide.com/how-tos/cpu-bottleneck-linux/

You should have the following packages installed: procps and sysstat.

First, maximize the terminal window. Then run vmstat and mpstat for a while to see CPU usage, e.g.:

$ vmstat 2 5

$ mpstat 2 5

If you see high %irq you can use the following command to find out which interrupt number is the culprit:

$ sar -I XALL 2 1 | less

And the following command shows the recorded number of interrupts per CPU per IO device:

$ cat /proc/interrupts

which is useful to find out which IO device uses the interrupt (see more in proc(5) man page).

-- rpr.

Revision history for this message
Romain (ramerica) wrote :

OK, I've done what you said but I don't understand anything.

$ sar -I XALL 2 1 | less
Shows that 0 interrupt is the problem (if I understood well).

$ cat /proc/interrupts
Show that the 0 interrupt refers to timer. (See screenshot)

What can I do ?
I had to disable lapic timer to prevent system from freezing everytime I don't use mouse or keyboard.

Revision history for this message
Romain (ramerica) wrote :

The bug of the full processor core has been fixed by the new kernel.

Revision history for this message
Kostis Leledakis (koleygr) wrote :

I want to confirm that the bug still exist for the TOSHIBA NB200.
I tried with Ubuntu 12.04 and 14.04 but i could work.. it was freezing even if I had the option "quiet splash nohz=off"
for the grub (this option worked with older versions of kernel)
Then I tried lubuntu 12.04 and 14.04 but it was the same

Now I am runing Debian:
uname -a:
Linux dhcppc4 3.2.0-4-686-pae #1 SMP Debian 3.2.63-2+deb7u2 i686 GNU/Linux

I tried setting GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic_timer clocksource=jiffies"
but the first core of my system is always at 100% usage just as Romain refered before and
it is not fixed.

I turned it back to "quiet" to protect the cpu....

I would like to know if my cpu is safe at 100 usage so that if i use the above settings for the kernel
I will not afraid for system damage

Revision history for this message
François Tissandier (baloo) wrote :

It affects me from time to time. On an Asus UX305F, on Ubuntu Gnome 16.10.
Very very very slow screen refresh, unless I move the mouse.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.