Beta i845G no screens found

Bug #633593 reported by jerrylamos on 2010-09-08
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Chris Halse Rogers
Maverick
High
Chris Halse Rogers

Bug Description

Binary package hint: xorg

Bug #541492 Brian Rogers asked for a separate bug if the 2.6.35-20 kernel isn't defaulting to vesa properly.

If I specify i915.modeset=1 boots fine, with KMS. O.K. That's how 2.6.35-19 worked O.K.

If I have xorg.conf specifying "vesa" runs fine, no KMS as expected. O.K.

With i845G I get "no screens found" see attached Xorg.0.log. No Good.
Conclusion default should wind up with "vesa" but doesn't.
Relevant section (I think) of Xorg.0.log
[ 17.647] (==) Matched intel as autoconfigured driver 0
[ 17.647] (==) Matched vesa as autoconfigured driver 1
[ 17.647] (==) Matched fbdev as autoconfigured driver 2
[ 17.647] (==) Assigned the driver to the xf86ConfigLayout
[ 17.647] (II) LoadModule: "intel"
[ 17.648] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 17.672] (II) Module intel: vendor="X.Org Foundation"
[ 17.672] compiled for 1.8.99.905, module version = 2.12.0
[ 17.672] Module class: X.Org Video Driver
[ 17.672] ABI class: X.Org Video Driver, version 8.0
[ 17.672] (II) LoadModule: "vesa"
[ 17.673] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 17.673] (II) Module vesa: vendor="X.Org Foundation"
[ 17.673] compiled for 1.8.99.905, module version = 2.3.0
[ 17.673] Module class: X.Org Video Driver
[ 17.673] ABI class: X.Org Video Driver, version 8.0
[ 17.673] (II) LoadModule: "fbdev"
[ 17.674] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 17.677] (II) Module fbdev: vendor="X.Org Foundation"
[ 17.677] compiled for 1.8.99.905, module version = 0.4.2
[ 17.677] ABI class: X.Org Video Driver, version 8.0
[ 17.677] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
 i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
 E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
 4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale
[ 17.679] (II) VESA: driver for VESA chipsets: vesa
[ 17.679] (II) FBDEV: driver for framebuffer: fbdev
[ 17.679] (++) using VT number 7

[ 17.683] (WW) Falling back to old probe method for vesa
[ 17.683] (WW) Falling back to old probe method for fbdev
[ 17.684] (II) Loading sub module "fbdevhw"
[ 17.684] (II) LoadModule: "fbdevhw"
[ 17.684] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 17.693] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 17.693] compiled for 1.9.0, module version = 0.0.2
[ 17.693] ABI class: X.Org Video Driver, version 8.0
[ 17.694] (EE) open /dev/fb0: No such file or directory
[ 17.707] (EE) intel(0): No kernel modesetting driver detected.
[ 17.707] (II) UnloadModule: "intel"
[ 17.708] (EE) Screen(s) found, but none have a usable configuration.
[ 17.708]
Fatal server error:
[ 17.708] no screens found

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBBDAMI+rUjBCYLAQIuHheq6sHlo1dOnCMdUFS/7gABAQEBAQEBAQEBAQEBAQEBZBkAQEEAJjAYiDYAM+YQAAAYAAAA/wAgVFkgIDY5NDQ5MjEwAAAA/ABQaGlsaXBzIDE1MFAKAAAA/QA4TB49CAAKICAgICAgANU=
Date: Wed Sep 8 17:54:32 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 002: ID 04b3:310c IBM Corp. Wheel Mouse
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 819911U
ProcCmdLine: BOOT_IMAGE=/vmlinuz root=/dev/sda13 ro quiet i915.modeset=1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 06/03/2003
dmi.bios.vendor: IBM
dmi.bios.version: 24KT45AUS
dmi.board.name: IBM
dmi.board.vendor: IBM
dmi.chassis.asset.tag: �������������������������
dmi.chassis.type: 2
dmi.chassis.vendor: IBM
dmi.modalias: dmi:bvnIBM:bvr24KT45AUS:bd06/03/2003:svnIBM:pn819911U:pvr:rvnIBM:rnIBM:rvr:cvnIBM:ct2:cvr:
dmi.product.name: 819911U
dmi.sys.vendor: IBM
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-20-generic

jerrylamos (jerrylamos) wrote :
useResa (rdrijsen) wrote :

As the OP I have ran into the same issue with the upgrade to kernel 2.6.35-20.
I have added, for now, i915.modeset=1 to the boot options in /etc/default/grub which gives me no crashes or black screens on boot up.

I will attach the Xorg.0.log from when I encountered the issue.

Additionally:
$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
plus (partial):
$ aptitude show xserver-xorg-video-intel
Package: xserver-xorg-video-intel
State: installed
Automatically installed: no
Version: 2:2.12.0-1ubuntu3

If more information is required, please let me know.

useResa (rdrijsen) wrote :
Bryce Harrington (bryce) on 2010-09-09
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
jerrylamos (jerrylamos) wrote :

i830 gets same problem with' Beta 2.6.35-20. That level of Beta is supposed to default to "vesa" according to Brian Rogers but does not, skips the intel driver on purpose, skips vesa by mistake, then fbdevhw gets "Screen(s) found, but none have a usable configuration".

So I specified i915.modeset=1 which bypasses the "KMS blacklist", gets the default intel driver, KMS is up and running, and for ordinary use even internet videos running O.K.

Frankly, Maverick Beta you tube videos running better than any previous Ubuntu on this 1 gHz Celeron IBM Thinkpad R31. HD rather jerky of course.

For my i830 and my i845G running the default beta intel driver Version: 2:2.12.0-1ubuntu3 running fine for ordinary use. "vesa" also runs O.K. on this i830.

I'll be testing Beta updates to see if the bug of not defaulting to "vesa" gets fixed.

Jerry

Bryce Harrington (bryce) on 2010-09-12
tags: added: no-screens

I'm getting the same problem, though when I first install Maverick beta it works okay apart from not being able to see the mouse cursor. When I ran the updates hoping that the cursor problem would go, I get this instead. I don't know if the two bugs are linked in any way?

I am a bit of a newbie so I'm not sure when to put the i915.modeset=1 - can anyone help?

Thanks

Keiron

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
assignee: nobody → Chris Halse Rogers (raof)
status: New → Confirmed
jerrylamos (jerrylamos) wrote :

I am a bit of a newbie so I'm not sure when to put the i915.modeset=1 - can anyone help?

You can test it by booting up and at the first boot manager Grub screen enter:
e
then go down to the line that ends with quiet splash and add
i915.modeset=1
then do Ctrl-X

If it works successfully, then in Applications Terminal do
sudo gedit /etc/default/grub
enter your password
at the end of the line that ends quiet splash insert
i915.modeset=1
save & quit
sudo update-grub
which makes an new boot manager list which should include the i915.modeset=1.

Worked perfectly, thanks for your help!

Chris Halse Rogers (raof) wrote :

This should be fixed in xorg-server (2:1.9.0-0ubuntu6), but Launchpad apparently isn't closing bugs properly. Please re-open if it's still a problem.

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: Confirmed → Fix Released
axion (bugzilla-axion) wrote :

Hi Chris,

I915 kms has been working just fine on my i855 chipset for quite some time now, however since the chipset got unblacklisted in the kernel/startup scripts, I have not been able to bypass your blacklisting of i855 in xorg, could you please tell me how to bypass your blacklisting ?

axion

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: Fix Released → Incomplete
Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: Incomplete → Fix Released
Dave Hope (dave-davehope) wrote :

installed 10.10 on my macbook today (via do-release-upgrade -d) and had the problem described here.

Adding i915.modeset=1 to grub helped.

To post a comment you must log in.