[i945GME] Kwin compositing fail on maverick

Bug #630632 reported by Scott Kitterman on 2010-09-05
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Kubuntu 10.10 Beta

Compositing is off at start. Enabling it (and even removing blur from the list of effects) resulted in compositing being enabled, but no affects that I tried in the short time before the screen locked up (mouse would move, but that was it) worked. This is a regression from 10.04.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-intel 2:2.12.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x576
 edid-base64: AP///////wBMo1IzAAAAAAASAQOAFg14CoWVmVdPjyYhUFQAAAABAQEBAQEBAQEBAQEBAQEBLBUAdkFARiAQMBMA330AAAAZAAAADwAAAAAAAAAAACOHAmQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gAxMDFYVDAxLTEwMQogAKM=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Sun Sep 5 04:13:19 2010
GdmLog: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log'] failed with exit code 1: cat: /var/log/gdm/:0.log: No such file or directory
GdmLog1: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
LiveMediaBuild: Kubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100902.1)
MachineType: Hewlett-Packard HP Mini 110-1000
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/khostname.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 09/16/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 308F0 Ver. F.17
dmi.board.name: 308F
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 02.10
dmi.chassis.asset.tag: CNU94162PP
dmi.chassis.type: 10
dmi.chassis.vendor: Inventec
dmi.modalias: dmi:bvnHewlett-Packard:bvr308F0Ver.F.17:bd09/16/2009:svnHewlett-Packard:pnHPMini110-1000:pvr03A8100000000000100300000:rvnHewlett-Packard:rn308F:rvrKBCVersion02.10:cvnInventec:ct10:cvr:
dmi.product.name: HP Mini 110-1000
dmi.product.version: 03A8100000000000100300000
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
peripherals: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-19-generic

Scott Kitterman (kitterman) wrote :
tags: added: kubuntu regression-potential
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Changed in xserver-xorg-video-intel (Ubuntu Maverick):
milestone: none → ubuntu-10.10
summary: - Kwin compositing fail on maverick
+ [i945GME] Kwin compositing fail on maverick
Scott Kitterman (kitterman) wrote :

Using the mesa from the sarvatt/mesa PPA is signifcantly better. Still effects disabled by default (I guess blacklisted), but once manually enabled, all I tried work just fine, including blur.

Thomas Kluyver (takluyver) wrote :

Seeing something similar with a GMA 3100 chipset (I think: lspci says: VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10) ). Compositing in Google Earth works fine, however. Is it worth my testing the ppa version of mesa? If I sit it out, will mesa be updated in the main repositories soon?

The release team is currently evaluating the freeze exception. The more positive feedback the get the more likely it is to get in.

Thomas Kluyver (takluyver) wrote :

Alright, I've installed the PPA version, and I think it improves matters, although after a while, I still hit a situation where applications weren't accepting mouse input (I could still move and resize the top window with the mouse). I don't know if that's part of the same issue, or something different. Is there a more systematic way to test than wildly clicking around a load of applications?

Chris Halse Rogers (raof) wrote :

Based on your previous comment, I'd guess that this is now fixed in Maverick.

The lack of mouse input is going to be a separate issue. If the windows are being repainted - and given that you can resize them, it seems that they are - then mesa's job is finished :).

Please feel free to file another bug about the mouse input issue - particularly if you can find a way to make it happen regularly.

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: New → Incomplete
Scott Kitterman (kitterman) wrote :

Yes.

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers