[82G965] No compositing with kwin (and doesn't work well if enabled)

Bug #630580 reported by Scott Kitterman on 2010-09-05
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Kubuntu 10.10 Beta

This system currently runs 10.04 LTS with kwin compositing with no problem.

Live CD starts with compositing disabled. When manually enabled effects mostly work OK (blur is a little slow), except present windows has serious problems (see attached screenshot).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-intel 2:2.12.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBaYx4RAQEBASMRAQMYJh54LsVUpFRKnSQUT1e/74CBgIFAcU9hWUVZMVkBAQEBMCoAmFEAKkAwcBMAeC0RAAAeAAAA/wBRODcwNzM1MjQ5NDUKAAAA/QAyVR5SDgAKICAgICAgAAAA/ABWQTkwMyBTRVJJRVMKAKw=
Date: Sun Sep 5 01:39:25 2010
GdmLog: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log'] failed with exit code 1: cat: /var/log/gdm/:0.log: No such file or directory
GdmLog1: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
LiveMediaBuild: Kubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901)
ProcCmdLine: file=/cdrom/preseed/khostname.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 05/10/2007
dmi.bios.vendor: Intel Corp.
dmi.bios.version: MQ96510J.86A.1687.2007.0510.0258
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DG965WH
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD41692-308
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrMQ96510J.86A.1687.2007.0510.0258:bd05/10/2007:svn:pn:pvr:rvnIntelCorporation:rnDG965WH:rvrAAD41692-308:cvn:ct3:cvr:
glxinfo: Error: [Errno 2] No such file or directory
peripherals: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-19-generic

Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :

Updated to KDE 4.5.1 and restarted the session and got the same error.

Attempted to upgrade to the mesa in the sarvatt/mesa PPA. With that mesa (and KDE 4.5.1) the screen froze when desktop effects were activate.

tags: added: kubuntu regression-potential
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Changed in xserver-xorg-video-intel (Ubuntu Maverick):
milestone: none → ubuntu-10.10
E.T. Anderson (firebringer11) wrote :

I can get effects to work by disabling functionality checks manually in kwinrc, all except wobbly windows. It is still quite crash-prone though; even changing window border styles will crash KWin for me.

summary: - No compositing with kwin (and doesn't work well if enabled)
+ [82G965] No compositing with kwin (and doesn't work well if enabled)
E.T. Anderson (firebringer11) wrote :

I've got Intel HD Graphics on a Core i5 laptop. If I remember correctly, that's a GMA4500 stuck onto the processor die, more or less.

E.T. Anderson (firebringer11) wrote :

Here's the output of glxinfo.

Definitely should be tracked in it's own bug since these are usually very hardware specific.

E.T. Anderson (firebringer11) wrote :

You don't think the three kwin compositing bugs ought to be combined?

Scott Kitterman (kitterman) wrote :

No.

E.T. Anderson (firebringer11) wrote :

With the latest packages, compositing seems to be working fine for me. I can do wobbly windows now, and Kwin doesn't crash as much. I don't think I'd call it stable yet.

Chris Halse Rogers (raof) wrote :

Scott, did this get fixed with the newer 2010/09/24 mesa packages in the archive now?

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: New → Incomplete
Scott Kitterman (kitterman) wrote :

I need to test this system again to know for sure, but I believe so.

Scott Kitterman (kitterman) wrote :

Still no blur and the logout effect is problematic, but once enabled, most effects work well. I think the experience is comparable to Lucid now, so I'll mark this fixed.

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: Incomplete → Fix Released
omni-vi (catcher) wrote :

Don't know wether it's the same bug, but when start kde effects are always disabled, and when I enable them, the screen freezes after some time. Effects work up to that moment, though.

syslog error is:
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 251495 at 251463)

The system is a corei5 with integrated graphics. I have all the updates available.
This did not happen with Lucid.

IndustryShocker (guernon) wrote :

I have an IBM Thinkpad R52 with Intel 915GM/GMS/910 GML Express Graphics. It just works like a dream of dubai with Kubuntu 10.04.Now with 10.10 i have the Desktop effects on but it only works with direct rendering not without anymore. My kwin has strange lines everywhere arround when i move my windows. I use low graphics for my windows (dont see windows when resizing, moving etc.). One time i startet Konqueror and kwin and plasma just crashed...i think the intel driver needs fixes!!! I love my Kubuntu IBM:) i dont want miss it

Scott Kitterman (kitterman) wrote :

Different video card, so please file a new bug.

IndustryShocker (guernon) wrote :
Scott Kitterman (kitterman) wrote :

This bug is fixed. If you are having similar issues, please file a new bug

Changed in ubuntu-release-notes:
status: New → In Progress
Scott Kitterman (kitterman) wrote :

There's nothing to release note since this bug is fixed.

Changed in ubuntu-release-notes:
status: In Progress → Invalid
Eric Lacombe (goretux) wrote :

I've got some issues that seems related under kubuntu 10.10.

With my integrated Intel Chips i915 (core i7 on a sony vaio VPCZ11), compositing is disabled at when kwin start.
When I enable it, some screen refresh problems occur.

Indeed, I see regularly artifacts under emacs or Yakuake (certainly with other apps, don't have check yet):
when I play with my text buffers (select text, remove text, move up and down, etc.), the windows do not refresh correctly, some text that should not be displayed persist on the screen.

It looks like the framebuffer got corrupted.

With kubuntu 10.04 there was no problem (and also with a kernel 2.6.35.7). So there is a regression somewhere.
It seems that this bug need to be reopen.

Scott Kitterman (kitterman) wrote :

You have a different video care. Please file a new bug.

molecule-eye (niburu1) wrote :

I'm observing the same thing. With compositing enabled I'm seeing all sorts of graphical glitches such as menus not rendering. I've also noticed that I can no longer use the Shared Memory option under OpenGL Options without serious rendering issues. I'm using an Intel 945GM chipset.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers