Ubuntu

Maverick screen freeze with "shadow" intel driver

Reported by jerrylamos on 2010-09-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Maverick 20100831 with Bug #541492 "shadow-intel" fix on screen froze so I ran ubuntu-bug on next boot. I could try running ubuntu-bug when it happens from the Ctrl-Alt-F1 login if it would give a better report.
Version: 2:2.12.0+shadow+77.gb933ead-maverick

It gets a crash on every bootup as well, then goes on to run. The (!) applet wouldn't process the report.

Let me post this before it crashes again.

Jerry

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBBDAMI+rUjBCYLAQIuHheq6sHlo1dOnCMdUFS/7gABAQEBAQEBAQEBAQEBAQEBZBkAQEEAJjAYiDYAM+YQAAAYAAAA/wAgVFkgIDY5NDQ5MjEwAAAA/ABQaGlsaXBzIDE1MFAKAAAA/QA4TB49CAAKICAgICAgANU=
Date: Wed Sep 1 20:36:13 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 002: ID 04b3:310c IBM Corp. Wheel Mouse
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 819911U
ProcCmdLine: BOOT_IMAGE=/vmlinuz root=/dev/sda16 ro quiet
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
XorgConf:
 Section "Device"
     Identifier "GPU"
     Option "Shadow" "True"
 EndSection
dmi.bios.date: 06/03/2003
dmi.bios.vendor: IBM
dmi.bios.version: 24KT45AUS
dmi.board.name: IBM
dmi.board.vendor: IBM
dmi.chassis.asset.tag: �������������������������
dmi.chassis.type: 2
dmi.chassis.vendor: IBM
dmi.modalias: dmi:bvnIBM:bvr24KT45AUS:bd06/03/2003:svnIBM:pn819911U:pvr:rvnIBM:rnIBM:rvr:cvnIBM:ct2:cvr:
dmi.product.name: 819911U
dmi.sys.vendor: IBM
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-19-generic

jerrylamos (jerrylamos) wrote :
Bryce Harrington (bryce) on 2010-09-02
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Brian Rogers (brian-rogers) wrote :

Can you get a dmesg from after the screen freezes? You might have to ssh in from another computer to do it.

Bryce Harrington (bryce) on 2010-09-05
tags: added: freeze
jerrylamos (jerrylamos) wrote :

Brian,

here's a dmesg from a "GPU hung" on 9/1 with the "shadow". I've been running a Beta lately but I can switch to the Alpha3 with "shadow" on in xorg.conf to see if I get another.

Jerry

jerrylamos (jerrylamos) wrote :

Brian, I'm back from holiday. Running with "shadow" screen froze after about 10 minutes. Also, there was a crash on booting, and another crash 10 minutes later at about the time of the freeze.

I had an ssh running just in case and used it to create a dump.tar including dmesg, i915_error_state, Xorg.0.log, uname -a, intel driver version, xsession-errors. I also saved the two crash reports one on booting and one when the screen froze and can provide them if they are of interest.

Booting now with "shadow" commented out.

I could try the "Shadow" fix on Beta if anyone thinks it is applicable and would be of interest. Do note that on my i845G and my i830 Beta is running default intel driver with KMS on specifying only "quiet".

Jerry

bugbot (bugbot) wrote :

Hey jerrylamos,

Thanks for testing maverick during its development period. Unfortunately it looks like this bug report didn't get attention during the maverick development period. But I see there's not been more comments on the bug since the release, which makes me wonder if this is still an issue for you?

If you've not seen this issue since maverick's release yourself, it may have been solved by kernel or X or other updates that occurred late in the release; if so, would you mind please closing the bug for us? Go to the URL mentioned in this bug report, click the yellow icon(s) in the status column and set to 'Fix Released'.

If you no longer have the hardware needed to reproduce the problem, or otherwise feel the bug no longer needs tracked in Launchpad, you can set the status to 'Invalid'.

If you are the original reporter and still have this issue, just reply to this email saying so. (Or set the bug status to Confirmed.) If you are able to re-test this against 11.04 Natty Narwhal (our current development focus) and find the issue still affects Natty, please also run 'apport-collect <bug-number>' while running natty, which will add fresh logs and debug data, and flag it for the Ubuntu-X development team to look at.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers