[i865] Crash on logout with KDM

Bug #628077 reported by Scott Kitterman on 2010-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Chris Halse Rogers
Maverick
High
Chris Halse Rogers

Bug Description

Binary package hint: xserver-xorg-video-intel

Kubuntu i386 live CD (live session) 20100901 (10.10 beta candidate)

X is generally working well with this i865 (lucid did as well), but when I logged out of KDE, X crashed. Startx got me back to kdm and logged in again.

---
[ 2166.539867] render error detected, EIR: 0x00000010
[ 2166.539876] [drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
[ 2166.539897] render error detected, EIR: 0x00000010
---

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-intel 2:2.12.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1440 1856x1392 1792x1344 1920x1200 1920x1200 1600x1200 1600x1200 1600x1200 1600x1200 1680x1050 1680x1050 1680x1050 1400x1050 1400x1050 1400x1050 1280x1024 1280x1024 1280x1024 1440x900 1440x900 1440x900 1280x960 1280x960 1360x768 1280x800 1280x800 1280x800 1152x864 1152x864 1280x768 1280x768 1280x768 1024x768 1024x768 1024x768 1024x768 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 800x600 848x480 640x480 640x480 640x480 640x480 640x480 640x480 640x480 640x480 720x400 720x400 720x400 640x400 640x350
 edid-base64: AP///////wBN2ZEAs0xrAB0JAQIOJRuW6Q7JoFdHmScSSEz//4AxWUVZYVlxT3FZgZmpQKlP1gmAoCDgLRAQYKIAYAERAAAYAAAA/QAweB5g/wAKICAgICAgAAAA/ABDUEQtNDIwR1MKICAgAAAA/wA3MDMxOTg3CiAgICAgABU=
Date: Wed Sep 1 13:25:16 2010
GdmLog: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log'] failed with exit code 1: cat: /var/log/gdm/:0.log: No such file or directory
GdmLog1: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
LiveMediaBuild: Kubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901)
ProcCmdLine: file=/cdrom/preseed/khostname.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 03/07/2005
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BF86510A.86A.0075.P24.0503071605
dmi.board.name: D865GBF
dmi.board.vendor: Intel Corporation
dmi.board.version: AAC25843-402
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrBF86510A.86A.0075.P24.0503071605:bd03/07/2005:svn:pn:pvr:rvnIntelCorporation:rnD865GBF:rvrAAC25843-402:cvn:ct2:cvr:
glxinfo: Error: [Errno 2] No such file or directory
peripherals: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-19-generic

Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e83bb]
1: /usr/bin/X (0x8048000+0x5da8d) [0x80a5a8d]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xa9640c]
3: /usr/bin/X (FreeClientResources+0xed) [0x808f04d]
4: /usr/bin/X (FreeAllResources+0x60) [0x808f120]
5: /usr/bin/X (0x8048000+0x1a5e6) [0x80625e6]
6: /lib/libc.so.6 (__libc_start_main+0xe7) [0x2a5ce7]
7: /usr/bin/X (0x8048000+0x1a191) [0x8062191]
Segmentation fault at address 0x4

Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :

Backtrace:
[ 2120.009] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e83bb]
[ 2120.009] 1: /usr/bin/X (0x8048000+0x5da8d) [0x80a5a8d]
[ 2120.009] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xa9640c]
[ 2120.009] 3: /usr/bin/X (FreeClientResources+0xed) [0x808f04d]
[ 2120.009] 4: /usr/bin/X (FreeAllResources+0x60) [0x808f120]
[ 2120.009] 5: /usr/bin/X (0x8048000+0x1a5e6) [0x80625e6]
[ 2120.010] 6: /lib/libc.so.6 (__libc_start_main+0xe7) [0x2a5ce7]
[ 2120.010] 7: /usr/bin/X (0x8048000+0x1a191) [0x8062191]
[ 2120.010] Segmentation fault at address 0x4
[ 2120.010]
Caught signal 11 (Segmentation fault). Server aborting
[ 2120.010]

tags: added: iso-testing
Robert Hooker (sarvatt) on 2010-09-01
description: updated
summary: - Intel i865 crash on logout with KDM
+ [i865] Crash on logout with KDM
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-09-01
tags: added: kubuntu
Robert Hooker (sarvatt) wrote :

Hey there Scott, if you have the chance could you give the packages in these two PPA's a shot and see if either one fixes this problem?

https://edge.launchpad.net/~sarvatt/+archive/sarvatt-graphics

https://launchpad.net/~sarvatt/+archive/yellow

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Robert Hooker (sarvatt) wrote :

Scott has tried the packages and we've verified that 101_copy-fb.patch is the culprit here which is also breaking sandybridge at the moment. In the second ppa I asked him to try it included a newer version of the copy-fb patch with slightly changed logic and it did work as well, so hopefully bringing back the changes to the patch we are using will fix it up here.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Medium → High
milestone: none → ubuntu-10.10
Scott Kitterman (kitterman) wrote :

I've since seen this on several other machines (mostly i945). This is a very significant issue.

Scott Kitterman (kitterman) wrote :

Still an issue on current maverick.

Robert Hooker (sarvatt) wrote :

The problems I was chasing with the copy-fb patch on sandybridge were unrelated in the end and even though it was shown that this fault lies in the patch I have not been able to determine the problem in this case. Chris, do you have any more insight into this?

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
assignee: Robert Hooker (sarvatt) → Chris Halse Rogers (raof)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.12.0-1ubuntu5

---------------
xserver-xorg-video-intel (2:2.12.0-1ubuntu5) maverick; urgency=low

  [ Robert Hooker ]
  * Disable DRI on Sandybridge chipsets. Support for them will not be released
    until the Q42010 Intel releases, which will not be pulled into maverick.
    Without this change, all 3D apps on these devices cause hangs.
    (LP: #639667)
  * Add 102_b43_pciid_update.patch. Fixes detection of a new b43
    chipset revision that is being shipped. Without this the drivers
    will not attempt to load even though this chipset is the same as
    the previous b43 ones. Backport of upstream commit 55b5fe8880.
    (LP: #640214)

  [ Christopher James Halse Rogers ]
  * debian/patches/101_copy-fb.patch: Move scratch pixmap creation to the
    drmmode_copy_fb function, and clean up after we've used it. Fixes the
    SIGSEGV in FreeClientResources when logging out of KDE (LP: #628077)
  * debian/patches/106_backport_vblank_on_server_regenerate_fix.patch:
    Backport fix for SwapBuffers hang after server regenerate. LP 628077
    was hiding this by crashing the server. Fixes kwin desktop effects hanging
    on second and subsequent logins.
  * Cherry-pick e30f0338 to free the Screen pixmap on close. Fixes a memory
    leak on server regeneration, and another crash on KDE log out hidden by
    LP 628077.
 -- Christopher James Halse Rogers <email address hidden> Mon, 27 Sep 2010 14:34:27 +1000

Changed in xserver-xorg-video-intel (Ubuntu Maverick):
status: Confirmed → Fix Released
molecule-eye (niburu1) wrote :

I'm not sure if I'm having this particular issues but Maverick RC shows only the boot screen after logging out and no keyboard input appears on-screen. When I ctr+alt+del the it shows it shutting down and the computer restarts as expected. I'm running the stock Intel driver powering a 945GM integrated mobile chipset.

molecule-eye (niburu1) wrote :

I should further mention that I'm using xserver-xorg-video-intel version 2.12.0-1ubuntu5.

Scott Kitterman (kitterman) wrote :

Have a look at bug 651294 and see if the work around for that solves your problem.

To post a comment you must log in.