[Intel Arrandale] Screen flickers

Bug #599360 reported by Stefan Friesel on 2010-06-28
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

After upgrading from lucid the laptop screen flickers similar to a CRT with a low refresh rate, i.e. fast, small changes in lightness especially visible in gradients. The flickering occurs independently from the chosen display resolution or brightness.

Other observations:
- when I connect an external display via VGA the flickering disappears on both displays
- gnome-display-properties lists the native resolution twice, of which one additionally introduces a pattern of blurred vertical stripes

Hardware:
Thinkpad Edge 15

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-6.7-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic x86_64
Architecture: amd64
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAwrrBAAAAAAAETAQOAIhN46rAln1lWkyYNUFQAAAABAQEBAQEBAQEBAQEBAQEBLBpWRVAACjAgGDQAWMEQAAAYzhVWRVAACjAgGDQAWMEQAAAYAAAADwCLCTKLCSgWCQAGr1YzAAAA/gBCMTU2WFcwMiBWMyAKAPE=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1280x1024 1280x1024 1280x960 1152x864 1152x720 1024x768 1024x768 832x624 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAi8KImAQEBAQkSAQNoKRp47t6Vo1RMmSYPUFSla4CVAHEAgUCBgAEBAQEBAQEBmimg0FGEIjBQmDYAmP8QAAAcAAAA/QAyTBhTDgAKICAgICAgAAAA/ABIUCB3MTkwNwogICAgAAAA/wAzQ1E4MDkxWDc5CiAgAEc=
Date: Mon Jun 28 15:15:47 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: LENOVO 03017VG
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-6-generic root=UUID=a1faef82-1d31-43b2-b12b-19a8db529847 ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 03/24/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 80ET29WW (1.06 )
dmi.board.name: 03017VG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr80ET29WW(1.06):bd03/24/2010:svnLENOVO:pn03017VG:pvrThinkPadEdge:rvnLENOVO:rn03017VG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 03017VG
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-6-generic

Stefan Friesel (stefan-friesel) wrote :
description: updated
Bryce Harrington (bryce) on 2010-06-29
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Geir Ove Myhr (gomyhr) on 2010-06-29
tags: added: arrandale
tags: added: flicker
Bryce Harrington (bryce) on 2010-07-02
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

Forwarding this bug from Ubuntu reporter :
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/599360

[Problem]
After upgrading from lucid to maverick the laptop screen flickers similar to a CRT with a low refresh rate, i.e. fast, small changes in lightness especially visible in gradients. The flickering occurs independently from the chosen display resolution or brightness.

Other observations:
- when I connect an external display via VGA the flickering disappears on both displays
- gnome-display-properties lists the native resolution twice, of which one additionally introduces a pattern of blurred vertical stripes

Hardware:
Thinkpad Edge 15

DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-6.7-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic x86_64
Architecture: amd64
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAwrrBAAAAAAAETAQOAIhN46rAln1lWkyYNUFQAAAABAQEBAQEBAQEBAQEBAQEBLBpWRVAACjAgGDQAWMEQAAAYzhVWRVAACjAgGDQAWMEQAAAYAAAADwCLCTKLCSgWCQAGr1YzAAAA/gBCMTU2WFcwMiBWMyAKAPE=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1280x1024 1280x1024 1280x960 1152x864 1152x720 1024x768 1024x768 832x624 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAi8KImAQEBAQkSAQNoKRp47t6Vo1RMmSYPUFSla4CVAHEAgUCBgAEBAQEBAQEBmimg0FGEIjBQmDYAmP8QAAAcAAAA/QAyTBhTDgAKICAgICAgAAAA/ABIUCB3MTkwNwogICAgAAAA/wAzQ1E4MDkxWDc5CiAgAEc=
Date: Mon Jun 28 15:15:47 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: LENOVO 03017VG
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-6-generic root=UUID=a1faef82-1d31-43b2-b12b-19a8db529847 ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SourcePackage: xorg
Symptom: display
dmi.bios.date: 03/24/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 80ET29WW (1.06 )
dmi.board.name: 03017VG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr80ET29WW(1.06):bd03/24/2010:svnLENOVO:pn03017VG:pvrThinkPadEdge:rvnLENOVO:rn03017VG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 03017VG
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO
system:
  codename: maverick
 architecture: x86_64
 kernel: 2.6.35-6-generic

Created an attachment (id=36893)
BootDmesg.txt

Created an attachment (id=36894)
CurrentDmesg.txt

Created an attachment (id=36895)
Dependencies.txt

Created an attachment (id=36896)
GdmLog.txt

Created an attachment (id=36897)
GdmLog1.txt

Created an attachment (id=36898)
GdmLog2.txt

Created an attachment (id=36899)
Lspci.txt

Created an attachment (id=36900)
Lsusb.txt

Created an attachment (id=36901)
PciDisplay.txt

Created an attachment (id=36902)
ProcCpuinfo.txt

Created an attachment (id=36903)
ProcInterrupts.txt

Created an attachment (id=36904)
ProcModules.txt

Created an attachment (id=36905)
RelatedPackageVersions.txt

Created an attachment (id=36906)
UdevDb.txt

Created an attachment (id=36907)
UdevLog.txt

Created an attachment (id=36908)
XorgLog.txt

Created an attachment (id=36909)
XorgLogOld.txt

Created an attachment (id=36910)
Xrandr.txt

Created an attachment (id=36911)
monitors.xml.txt

Created an attachment (id=36912)
setxkbmap.txt

Created an attachment (id=36913)
xdpyinfo.txt

Created an attachment (id=36914)
xkbcomp.txt

Bryce Harrington (bryce) on 2010-07-09
description: updated
description: updated
description: updated
Bryce Harrington (bryce) wrote :

Stefan Friesel - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=28969 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
rCX (rcx) wrote :

Kernel: 2.6.35-020635rc5-generic
Hardware: Thinkpad Edge 14
Architecture: x386

I had the same experience on similar hardware. Also adjusting brightness from keyboard is buggy. When decreasing brightness, the indicator bar reaches the bottom before the brightness is minimum. Likewise when increasing brightness, the indicator bar reaches the top before brightness is maximum. I downgraded to an earlier kernel which does not have these problems (2.6.32-23-generic-pae). Therefore this may be a regression.

rCX (rcx) on 2010-07-22
tags: added: regression-potential

I can confirm the bug. It's happen when I upgrade to maverick (before Alpha 1) and still happens.
Suspend and then resume fixed the flicker problem

Funnnny (ntcong-it) wrote :

Suspend and resume also fix the problem

Funnnny (ntcong-it) wrote :

I can confirm that with the recent update (maverick).. The problem was solved

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released

The description sounds very much like a Self-Refresh issue.

Created an attachment (id=37620)
Update SR after dpms changes.

We've disabled self-refresh [bug 30125].

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium

Hi, I am Lesya (23 y.o.)
I wish to chat with you now.
Here you can look through my personal data:

http://rugirlsz.ru

yours Lesya

N.B. to unsubscribe, please use the link also.
(Lesya 23 yo).I search for boy-friend (on-line now)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.