[arrandale] maverick alpha 1 live doesn't display desktop

Bug #589940 reported by Glen Ditchfield on 2010-06-04
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Image maverick-desktop-i386.iso, md5sum d3d2cce04cd8fc4a75138f93cd1bf3e3

I made a USB key and booted an HP Elitebook 8440p model WH255UT#ABA. (Chipset: Mobile Intel QM57 Express, graphics: Intel Graphics Media Accelerator HD.) I selected "Try Kubuntu without installing". The screen flashed repeatedly, then showed a blinking underscore cursor, then turned black. After some seconds I heard the KDE start-up sound, but the screen stayed black. Ctrl-Alt-F1 did nthing.

With "splash" removed from the boot options, the result was the same.

In short, this is just like Lucid bug 557744.
---
Architecture: i386
DistroRelease: Ubuntu 10.10
DkmsStatus: Error: [Errno 2] No such file or directory
GdmLog2: Error: command ['gksu', '-D', 'Apport', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100616)
MachineType: Hewlett-Packard HP EliteBook 8440p
Package: xserver-xorg-video-intel 2:2.11.0-1ubuntu2
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   product info: "RICOH", "Bay8Controller", "", ""
   manfid: 0x0000, 0x0000
   function: 254 (unknown)
PccardctlStatus:
 Socket 0:
   3.3V 16-bit PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz -- nomodeset
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-2.3-generic 2.6.35-rc2
Tags: maverick maverick
Uname: Linux 2.6.35-2-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CCU Ver. F.02
dmi.board.name: 172A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 30.29
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CCUVer.F.02:bd12/22/2009:svnHewlett-Packard:pnHPEliteBook8440p:pvr:rvnHewlett-Packard:rn172A:rvrKBCVersion30.29:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8440p
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-2-generic

tags: added: iso-testing
Bryce Harrington (bryce) on 2010-06-05
tags: added: kubuntu
tags: added: maverick
Geir Ove Myhr (gomyhr) on 2010-06-07
tags: added: arrandale black-screen
Geir Ove Myhr (gomyhr) wrote :

Thank you for testing Maverick this early in the development cycle. It really helps that we get bug reports in early so that there is a better chance of getting things fixed before the release.

The xorg stack in Maverick is due to receive a major update in the next couple of days [1]. I think it would make sense to wait until that is done before we proceed with this so that we don't troubleshoot things that are changing now anyway. From the email, I would guess you can test a daily live next week and start troubleshooting then.

The nomodeset option will for sure stop working (or rather continue not working for you) after the update (it is not supported by the driver anymore), so you don't need to try that.
Also, at that point, we would need the data that apport-collect provides. I know this can be difficult to get at times, but I see you were able to run it at bug 557744.

[1]: https://lists.ubuntu.com/archives/ubuntu-x/2010-June/000897.html

summary: - maverick alpha 1 live doesn't display desktop
+ [arrandale] maverick alpha 1 live doesn't display desktop
Geir Ove Myhr (gomyhr) wrote :

The Maverick xorg update is now complete and has made I can see [1] that it has made it into the daily-live CDs [2].

[1]: http://cdimage.ubuntu.com/daily-live/current/maverick-desktop-amd64.manifest
[2]: http://cdimage.ubuntu.com/daily-live/

Glen Ditchfield (gjditchfield) wrote :

Daily live image maverick-desktop-i386.iso of June 16 (IIRC), md5sum 07e0f66b07f996d1479855cbc7052be3.
(Ubuntu this time, instead of Kubuntu.)

"Try Ubuntu without installing", with no options changed: I hear the Ubuntu start-up sound, but the screen is still black.

 Again, with "quiet splash" removed from the boot options: boot messages scroll across the screen before it goes black. The screen stays black after the Ubuntu start-up sound.

Again, with "quiet splash" removed and with "nomodeset" selected: boot messages, then many other messages, and color splashes across the screen. Then a dialog!
  Ubuntu is running in low-graphics mode
  Your screen, graphics card, and input device settings
  could not be detected correctly. You will need to
  configure these yourself. [OK]

  What would you like to do? - Troubleshoot the error
  What information would you like to review? - Review the xserver log file

Some messages that caught my eye:
(--) PCI:*(0:0:2:0) 8086:0046:103c:172a Intel Corporation Core Processor Integrated Graphics Controller rev 18, Mem @ 0x90000000/4194304, 0x80000000/268435456, I/O @ 0x00005058/8
(==) Matched intel as autoconfigured driver 0
(==) Matched vesa as autoconfigured driver 1
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810, ..., Arrandale
(II)UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error: no screens found.

"Review the startup errors" shows an empty dialog box.

"Archive configuration and logs" brings up an amusing dialog:
  Relevant configuration and log files have been saved to:
  $xorg_backup_file
  Bug reports can be submitted at http://www.launchpad.net/ubuntu.
So where is $xorg_backup_file?

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Glen Ditchfield (gjditchfield) wrote :

Guessing that $xorg_backup_file is /var/log/failsafeX-backup-100619201009.tar ...

Geir Ove Myhr (gomyhr) wrote :

Glen, as I said in comment #1, it is expected behaviour that things go wrong if you use the nomodeset kernel option. The intel driver in Maverick needs modeset support in the kernel and nomodeset turns that support off. All the files you uploaded contains logs from this expected failure and is therefore not useful.

There are many ways to extract log files from a computer with a black screen. Some of them require some trial-and-error in front of the computer, but one that is easy to explain is:
1. Install the package openssh-server to allow remote login into the computer.
2. (LiveCD-specific) Set a password for the ubuntu user using the command `sudo passwd`
3. ssh in from another computer (using ubuntu as username on a LiveCD system)
4. Save /var/log/Xorg.0.log, dmesg.txt created from `dmesg >dmesg.txt`, and the xrandr.txt created from `xrandr > xrandr.txt` on a usb-stick or copy them to the other computer with scp.

That failsafe X does not show the filename of the tarball is an unrelated issue. I have reported it as bug 596819 and subscribed you to the bug report. You may add any information that I failed to include.

Glen Ditchfield (gjditchfield) wrote :
Geir Ove Myhr (gomyhr) wrote :

Good, these files are what we were looking for (except I forgot the --verbose option to xrandr, but it is still useful). From the xrandr output (and Xorg.0.log) it seems that the monitor is connected using DisplayPort. I assume that the black monitor is the laptop-internal one. Traditionally this has been connected via a LVDS interface, but I think some new models have started using DisplayPort instead. Since this is fairly new and not widely tested, there are probably still some bugs like this that needs to be sorted out. Can you confirm that this is the laptop's monitor we're talking about?

I would like to send this upstream to the intel developers. For that I would like some the three files you uploaded with some more details. Could you boot with the kernel parameter drm.debug=0x04 (and still without quiet and boot)? This will add more debug information to the dmesg output. Then run the same commands as before, only with --verbose option to xrandr: `xrandr --verbose > xrandr.txt`, `dmesg > dmesg.txt`, and also upload Xorg.0.log at the same time so that all the files come from the same session?

Geir Ove Myhr (gomyhr) wrote :

I found this bug report upstream which is probably the same issue: https://bugs.freedesktop.org/show_bug.cgi?id=28070 . It is probably the same problem as this. They're happy to receive duplicate bug reports upstream (since it may turn out later to not be a duplicate), though, so we can still forward it.

From that bug report, it looks like they also need the file produced by `sudo intel_reg_dumper >intel_reg_dumper.txt` and the video bios dump that you can get by following the instructions at https://wiki.ubuntu.com/DebuggingXorg#Obtaining%20the%20video%20BIOS .

Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :

Yes, it is the laptop's built-in screen that is black. I haven't tried the external DisplayPort or VGA port.

Forwarding a bug report from Ubuntu user Glen Ditchfield:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/589940

This is possibly a duplicate of fdo bug #28070.

Problem:
Laptop monitor shows boot messages but turns black when gdm/kdm is started.

It seems that the laptop monitor is connected on DP1:
DP1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1366x768 60.1*+ 40.1

From intel_reg_dumper: PCH_eDP_A: 0xb0854004

This is with Ubuntu 10.10 kernel 2.6.35-2.3-generic based on 2.6.35-rc2.

Original bug report:

I made a USB key and booted an HP Elitebook 8440p model WH255UT#ABA. (Chipset: Mobile Intel QM57 Express, graphics: Intel Graphics Media Accelerator HD.) I selected "Try Kubuntu without installing". The screen flashed repeatedly, then showed a blinking underscore cursor, then turned black. After some seconds I heard the KDE start-up sound, but the screen stayed black. Ctrl-Alt-F1 did nthing.

With "splash" removed from the boot options, the result was the same.

Architecture: i386
DistroRelease: Ubuntu 10.10
MachineType: Hewlett-Packard HP EliteBook 8440p
Package: xserver-xorg-video-intel 2:2.11.0-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-2.3-generic 2.6.35-rc2
Uname: Linux 2.6.35-2-generic i686
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CCU Ver. F.02
dmi.board.name: 172A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 30.29
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CCUVer.F.02:bd12/22/2009:svnHewlett-Packard:pnHPEliteBook8440p:pvr:rvnHewlett-Packard:rn172A:rvrKBCVersion30.29:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8440p
dmi.sys.vendor: Hewlett-Packard
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-2-generic

Created an attachment (id=36448)
video bios dump

Created an attachment (id=36449)
dmesg with drm.debug=0x04

Created an attachment (id=36450)
output of intel_reg_dumper

Created an attachment (id=36451)
output of xrandr --verbose

Created an attachment (id=36452)
Xorg.0.log

Created an attachment (id=36453)
lspci -vvnn

Geir Ove Myhr (gomyhr) on 2010-06-24
description: updated
Geir Ove Myhr (gomyhr) wrote :

I have forwared the bug upstream at https://bugs.freedesktop.org/show_bug.cgi?id=28713 . Please register at http://bugs.freedesktop.org and add yourself to the CC field of that bug report so that you may answer any questions that the developers might have.

here is a new patch on the intel-gfx mailing list today that may fix this.
http://lists.freedesktop.org/archives/intel-gfx/2010-June/007216.html

Geir Ove Myhr (gomyhr) wrote :

There is a kernel patch on the intel-gfx mailing list that may fix this. http://lists.freedesktop.org/archives/intel-gfx/2010-June/007216.html . Unfortunately, it is quite involved to patch the kernel and respin a new iso-image in order to test it. Would you have the possibility to install Maverick on a test partition? Then it is possible to install different kernels in parallel.

Glen Ditchfield (gjditchfield) wrote :

I will try to have a Maverick test partition ready Wednesday.

Geir Ove Myhr (gomyhr) wrote :

The initial kernel patch broke another laptop with eDP panel, so there is still some discussion on the mailing list about how to fix this. There is a version 2 of the patch out, but that didn't fix it on another computer which was fixed by version 1. I hope they sort it out soon, and then we can get a kernel with the final patch built for testing. Or if you feel like building kernels and testing, you can try both versions of the patch and report your findings on the mailing list (assuming it works with at least one of them).

Bryce Harrington (bryce) on 2010-07-02
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Geir Ove Myhr (gomyhr) wrote :

I thought I would have to get a patched kernel image built for you to test this, but v4 of the patch is now commited and has found its way to the latest daily ubuntu mainline build already [1] (see [2] for more information about the mainline builds). It will also be included when 2.6.35-rc4 is released. So when you get your test partition up and running, you can test the latest daily mainline ubild or the mainline build of 2.6.35-rc4 where hopefully this problem is fixed (it is reported on the mailing list that it does not solve the problem for at least one eDP laptop).

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2010-07-02-maverick/
[2]: https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Glen Ditchfield (gjditchfield) wrote :

Kubuntu Maverick alpha 2: as before, the Live CD boots to a black screen. A small regression: when booted with "nomodeset", X does not come up in a low-graphics mode. Instead, after two attempts the computer drops to a command line. I assume the log files are of no particular interest.

Glen Ditchfield (gjditchfield) wrote :

I installed Kubuntu Maverick alpha 2, then installed the 2010-07-02-maverick linux-*2.6.35-999.201007021009_* debs. The display now lights up. The built-in keyboard and trackpad are not responsive, but a USB mouse and keyboard work. (The built-in keyboard did work in alpha-2's console before installing the 20100702 debs, but does not work now.)

Glen Ditchfield (gjditchfield) wrote :

Alpha

Geir Ove Myhr (gomyhr) wrote :

Good that the display now lights up. If I understand you correctly you have a working computer if you use an external mouse and keyboard. The mouse/keyboard problem is probably unrelated to the original problem. It may be related to using a daily build (it is possible that the mainline build of -rc4 is better) or that there are some out-of-tree drivers in the Ubuntu kernel that is not in the mainline kernel. Anyway, the Maverick kernel will be rebased to include all patches from 2.6.35-rc4 soon. At that point this bug should be fixed in Ubuntu. You can see when the ubuntu kernel was last updated at https://launchpad.net/ubuntu/+source/linux .

If the next Ubuntu Maverick kernel breaks your keyboard and trackpad, please file a new bug report at that point.

Geir Ove Myhr (gomyhr) wrote :

The newest Ubuntu kernels (2.6.35-7) are based on -rc4 and therefore include the eDP patch. Could you verify that the display problem is gone with this kernel? If this kernel introduces the keyboard and trackpad problem, please file a new bug report for that.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Glen Ditchfield (gjditchfield) wrote :

I installed kubuntu alpha-2 maveric-desktop-i386.iso, booted with nomodeset in the kernel boot options to get a command line, apt-get upgraded, and apt-get dist-upgraded to get the 2.6.35-7 kernel.

The display is working well. KWin reports that it could not activate Blur, Cover Switch, Desktop Cube, and Wobbly Windows, but other effects are active. gltron's frame rate is over 50 fps.

The built-in keyboard and trackpad work, too.

Should have been fixed by
https://patchwork.kernel.org/patch/108727/
which is in drm-intel-next now

(In reply to comment #8)
> Should have been fixed by
> https://patchwork.kernel.org/patch/108727/
> which is in drm-intel-next now

Indeed. It is even in -rc4. Glen just tested an -rc4 based Ubuntu kernel and reports the problem is resolved.

Geir Ove Myhr (gomyhr) wrote :

I take it that the original problem is now fixed, and I therefore close this bug report.

The missing effects in KWin may be a bug in KWin, mesa, and others and you may file a new bug report for that.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Incomplete → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium

Nadezhda 25 yo - I search for Real boyfriend

Hello! I am Nadezhda, 25 yo.
I search for Real boyfriend.
Are you ready for relations?
please check my profile here:

http://brides-hot.ru

Note!
New free service! check info at the site!
( to unsubscribe -click link and enter e-mail address.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.