[gm45] Backlight sometimes stays off

Bug #580225 reported by Roland Dreier on 2010-05-13
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

On my Lenovo X200 notebook (GM45 graphics), the backlight sometimes (not always -- maybe one fifth of the time or so) stays off after a suspend/resume cycle. In other words, the system resumes properly except that the backlight does not turn on (screen contents are dimly visible, unlocking the screen, typing, etc work fine). Doing "xset dpms force on" or "xset dpms force off" or pressing any of the brightness function keys has no effect.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-video-intel 2:2.9.1-3ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
Date: Thu May 13 14:41:22 2010
DkmsStatus: Error: [Errno 2] No such file or directory
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: LENOVO 7458B18
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=2430964c-21ce-442f-819c-e1fc1596711f ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
dmi.bios.date: 03/10/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6DET63WW (3.13 )
dmi.board.name: 7458B18
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6DET63WW(3.13):bd03/10/2010:svnLENOVO:pn7458B18:pvrThinkPadX200:rvnLENOVO:rn7458B18:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7458B18
dmi.product.version: ThinkPad X200
dmi.sys.vendor: LENOVO
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
     Subsystem: Lenovo Device [17aa:20e4]

Roland Dreier (roland.dreier) wrote :
Bryce Harrington (bryce) on 2010-05-14
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Geir Ove Myhr (gomyhr) on 2010-05-16
tags: added: backlight resume suspend
tags: added: gm45
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Felix Yan (felixonmars) wrote :

Exactly the same bug here, but I also affected the bug in Windows 7(tested for many many times).

Tiago Neiva (tneiva) wrote :

I have the same issue on a Compaq mini 110 with Lucid.
Fresh install of lucid, all updates.
I have seen this issue reported on the foruns and some different bug reports. different versions, different computers with different video adapters.
A workaround is to change the brightness using the keyboard, but the bug should be found.
I have to see how to do a propper bug report.

lcampagn (luke-campagnola) wrote :

Same problem, on Lenovo X60 laptop. This problem is new for me as of 10.04--I did not have this problem for any other version of ubuntu back to about 7.04. changing the brightness via keyboard does not work, nor does "xset dpms force on". The only option I've found is to reboot.

Same problem here, Lenovo X200 with Intel 4500HD graphics.
Any workarounds for this issue?

Setting SAVE_VIDEO_PCI_STATE=true in /etc/default/acpi-support did note solve the problem - it happened again today.
Once the screen goes buggy after resume, I can't do anything to turn the light back on.

I tried all pm-suspend quirks.
Hibernating brings the screen back on during boot-up, but as soon as I get to the resumed desktop it's off again.
Switching to console (Ctrl+Alt+F1) and back doesn't bring the light on at any moment.

The only way to get the light back on is with a full reboot.
Must be a bug with the Intel driver then...?

Maybe I should turn off kernel-mode setting and try the console-switch method next time it happens?

If anyone knows anything I can try, please let me know.

Timo Kluck (tkluck) wrote :

I have the same bug on a HP TouchSmart tm2, with the added bonus that the backlight problems also happen at startup every now and then.

The easiest way I have found to trigger this situation is to set brightness to 0 on a terminal (as root)

echo 0 > /sys/class/backlight/acpi_video0/brightness

Any other brightness set in this way is applied correctly. However, after setting 0, the backlight never comes back on.

A workaround I use is to change screen orientation. For some reason, the command

xrandr -o right

(followed by xrandr -o normal to get it back to normal) changes so many things in the display settings that the backlight comes back on. I have now assigned hotkeys to these commands, so that I can log in blindly, then press the hotkeys, and have a working backlight.

I should also note that this problem does not occur after switching to ATI graphics with the vga_switcheroo kernel module.

rockachu2 (rockachu2) wrote :

same problem with thinkpad t42p, except it happened after the screen was turned off.

ubuntu 10.10 beta
full reboot fixed the problem.

The backlight was stuck off, so I used a bright flashlight to see what was on the screen to save my work and reboot.

this is a pain in the ass and should be fixed ASAP

tags: added: maverick
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
rockachu2 (rockachu2) on 2010-10-05
summary: - [gm45] Backlight sometimes stays off after resume on Lenovo X200
+ Backlight sometimes stays off

see discussion in https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/685727?comments=all for similar backlight off problem in 10.10 kernel 2.6.35-24 for Gateway NV79. Issue did NOT occur for Lucid 10.04 kernel 2.6.32.27.

bugbot (bugbot) wrote :

Hey Roland,

Thanks for testing maverick during its development period. Unfortunately it looks like this bug report didn't get attention during the maverick development period. But I see there's not been more comments on the bug since the release, which makes me wonder if this is still an issue for you?

If you've not seen this issue since maverick's release yourself, it may have been solved by kernel or X or other updates that occurred late in the release; if so, would you mind please closing the bug for us? Go to the URL mentioned in this bug report, click the yellow icon(s) in the status column and set to 'Fix Released'.

If you no longer have the hardware needed to reproduce the problem, or otherwise feel the bug no longer needs tracked in Launchpad, you can set the status to 'Invalid'.

If you are the original reporter and still have this issue, just reply to this email saying so. (Or set the bug status to Confirmed.) If you are able to re-test this against 11.04 Natty Narwhal (our current development focus) and find the issue still affects Natty, please also run 'apport-collect <bug-number>' while running natty, which will add fresh logs and debug data, and flag it for the Ubuntu-X development team to look at.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
Doug Holton (edtechdev) wrote :

I can confirm issue still exists with both 10.10, 10.10 updated to the latest drivers, and 11.04 alpha 3.

Like others mentioned, this wasn't a problem in 10.04.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Expired → Confirmed
bugbot (bugbot) on 2011-04-27
description: updated
bugbot (bugbot) on 2011-04-28
summary: - Backlight sometimes stays off
+ [gm45] Backlight sometimes stays off
Stefan Hammer (j-4) wrote :

Hi!
This is still a severe problem using Ubuntu 10.04, kernel 2.6.32-32 on my Thinkpad x200.
Backlight won't turn on after suspend to ram. Intel 4500HD graphics.
The issue seems to come up more often since the last few kernel-updates. Maybe there is a related patch included which causes this problem?!
Are there any known fixes or workarounds?

Thanks,
Jango

Simon K (octav14n) wrote :

This Bug still exists with Ubuntu 12.10 alpha.
I'm using a HP-Touchsmart 2 (tm2).

madbiologist (me-again) wrote :

Official support for Ubuntu 10.10 "Maverick Meerkat" ended on April 10, 2012. Official support for Ubuntu 11.04 "Natty Narwhal" ended on October 28, 2012. Official support for Ubuntu 10.04 LTS "Lucid Lynx" desktop edition and Ubuntu 11.10 "Oneiric Ocelot" ended on May 9, 2013.

Simon K and anyone still experiencing this bug on a supported version of Ubuntu - please file a new bug report so that we can get a fresh set of logs. Also, please file different bugs for different hardware models.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Invalid
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers